source: projects/specs/trunk/f/freetype/freetype-vl.spec @ 521

Revision 521, 7.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2Summary: A free and portable TrueType font rendering engine.
3Name: freetype
4Version: 1.3.1
5Release: 6%{?_dist_release}
6License: BSD-like
7Group: System Environment/Libraries
8URL: http://www.freetype.org
9Source: freetype-%{version}.tar.gz
10Source1: ttmkfdir.tar.gz
11Patch0: freetype-1.2-fixpath.patch
12Patch1: freetype-1.3.1-foundrynames.patch
13Patch2: freetype-1.3.1-ftdump-gcc3.patch
14Patch3: freetype-1.3.1-config.sub-x86_64.patch
15Patch4: freetype-1.3.1-ltconfig-compat32.patch
16
17Buildroot: %{_tmppath}/%{name}-%{version}-root
18Obsoletes: freetype-utils
19
20%description
21The FreeType engine is a free and portable TrueType font rendering
22engine, developed to provide TrueType support for a variety of
23platforms and environments. FreeType is a library which can open and
24manages font files as well as efficiently load, hint and render
25individual glyphs. FreeType is not a font server or a complete
26text-rendering library.
27
28%package utils
29Summary: Several utilities to manipulate and examine TrueType fonts.
30Group: Applications/Publishing
31
32%description utils
33This package contains several utilities which allow you to view and
34manipulate TrueType fonts.  They are mainly useful for debugging and
35testing purposes, and are not required for using the FreeType
36library.
37
38%package devel
39Summary: Header files and static library for development with FreeType.
40Group: Development/Libraries
41
42%description devel
43The freetype-devel package contains the header files and static
44library needed to develop or compile applications which use the
45FreeType TrueType font rendering library.
46
47Install freetype-devel if you want to develop FreeType
48applications. If you simply want to run existing applications, you
49won't need this package.
50
51## to build compat32 for x86_64 architecture support
52%package -n compat32-%{name}
53Summary: A free and portable TrueType font rendering engine.
54Group: System Environment/Libraries
55%description -n compat32-%{name}
56The FreeType engine is a free and portable TrueType font rendering
57engine, developed to provide TrueType support for a variety of
58platforms and environments. FreeType is a library which can open and
59manages font files as well as efficiently load, hint and render
60individual glyphs. FreeType is not a font server or a complete
61text-rendering library.
62
63%package -n compat32-%{name}-devel
64Summary: Header files and static library for development with FreeType.
65Group: Development/Libraries
66Requires: compat32-%{name} = %{version}
67%description -n compat32-%{name}-devel
68The freetype-devel package contains the header files and static
69library needed to develop or compile applications which use the
70FreeType TrueType font rendering library.
71
72Install freetype-devel if you want to develop FreeType
73applications. If you simply want to run existing applications, you
74won't need this package.
75
76%prep
77%setup -q
78mkdir ttmkfdir
79tar xz -C ttmkfdir -f %{SOURCE1}
80%patch0 -p1 -b .fixpath
81%patch1 -p1 -b .foundrynames
82%patch2 -p1 -b .ftdump-gcc3
83%patch3 -p1 -b .config.sub-x86_64
84%if %{build_compat32}
85%patch4 -p1 -b .ltconfig-compat32
86%endif
87
88%build
89%if %{build_compat32}
90export CC='gcc -m32'
91%endif
92##libtoolize --copy --force
93./configure --prefix=%{_prefix} \
94        --with-cflags="$RPM_OPT_FLAGS" \
95        --disable-debug \
96        --enable-static --enable-shared \
97        --with-locale-dir=%{_localedir} \
98        --libdir=%{_libdir} \
99        --x-libraries=%{_prefix}/X11R6/%{_lib} \
100        --target=%{_target_platform}
101
102make
103
104%if 0
105make -C ttmkfdir CC="gcc $RPM_OPT_FLAGS"
106
107(cd contrib/ttf2pk
108./configure --prefix=%{_prefix} \
109        --mandir=%{_mandir} \
110        --with-cflags="$RPM_OPT_FLAGS"
111make
112)
113%endif
114
115#       --libdir=$RPM_BUILD_ROOT%{_libdir} \
116%install
117rm -rf $RPM_BUILD_ROOT
118make prefix=$RPM_BUILD_ROOT%{_prefix} \
119        libdir=$RPM_BUILD_ROOT%{_libdir} \
120        install \
121        gnulocaledir=$RPM_BUILD_ROOT%{_localedir}
122%if 0
123install -m 755 ttmkfdir/ttmkfdir $RPM_BUILD_ROOT%{_bindir}
124%endif
125
126(cd $RPM_BUILD_ROOT%{_includedir}
127for i in freetype/*.h
128do
129    ln -sf $i .
130done
131)
132
133%if 0
134(cd contrib/ttf2pk
135make prefix=$RPM_BUILD_ROOT%{_prefix} \
136        mandir=$RPM_BUILD_ROOT%{_mandir} \
137        install
138mkdir -p $RPM_BUILD_ROOT%{_datadir}/ttf2pk
139cp data/* $RPM_BUILD_ROOT%{_datadir}/ttf2pk
140)
141%endif
142
143# remove unpackaged files
144rm -rf $RPM_BUILD_ROOT%{_bindir}
145
146%post -p /sbin/ldconfig
147
148%postun -p /sbin/ldconfig
149
150%if %{build_compat32}
151%post -n compat32-%{name} -p /sbin/ldconfig
152%postun -n compat32-%{name} -p /sbin/ldconfig
153%endif
154
155%clean
156rm -rf $RPM_BUILD_ROOT
157
158%if !%{build_compat32}
159%files
160%defattr(-,root,root)
161%{_libdir}/libttf.la
162%{_libdir}/libttf.so.*
163%{_datadir}/locale/*/LC_MESSAGES/*
164%doc README  announce docs
165
166%if 0
167%files utils
168%defattr(-,root,root)
169%{_bindir}/*
170%{_mandir}/man1/*
171%{_datadir}/ttf2pk/
172%endif
173
174%files devel
175%defattr(-,root,root)
176%{_includedir}/*
177%{_libdir}/libttf.so
178%{_libdir}/libttf.a
179%endif
180
181## to build compat32 for x86_64 architecture support
182%if %{build_compat32}
183%files -n compat32-%{name}
184%defattr(-,root,root)
185%{_libdir}/libttf.la
186%{_libdir}/libttf.so.*
187
188%files -n compat32-%{name}-devel
189%defattr(-,root,root)
190%{_libdir}/libttf.so
191%{_libdir}/libttf.a
192%endif
193
194%changelog
195* Wed Mar 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.1-6
196- obsolete freetype-utils
197
198* Thu Feb 23 2006 Shu KONNO <owa@bg.wakwak.com> 1.3.1-5vl5
199- fixed libdir to configure and to make install
200
201* Mon Feb 13 2006 Shu KONNO <owa@bg.wakwak.com> 1.3.1-5vl4
202- dropt libtoolize
203- added freetype-1.3.1-ftdump-gcc3.patch
204- added freetype-1.3.1-config.sub-x86_64.patch
205- added freetype-1.3.1-ltconfig-compat32.patch
206- added options --libdir, --x-libraries, --target to configure
207- added URL
208- changed Copyright to License
209- changed direct path strings to macros
210
211* Sat Mar 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.1-5vl3
212- rebuilt with new toolchains
213
214* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
215- 1.3.1-5vl2
216- rebuilt with new %%{_mandir} for VineSeed
217
218* Wed Aug  2 2000 Jun Nishii <jun@vinelinux.org>
219- 1.3.1-5vl1
220- follow RHL62
221
222* Sat Jan 22 2000 Jun Nishii <jun@vinelinux.org>
223- added %defattr
224
225* Tue Jan 11 2000 Jun Nishii <jun@vinelinux.org>
226- added bins from contrib/ttf2pk
227
228* Tue Nov 23 1999 Norihito Ohmori <ohmori@flatout.org>
229- modified for Vine Linux
230
231* Wed Nov 10 1999 Norihito Ohmori <nono@kondara.org>
232- add /usr/bin/{ftmetric,ftsbit,ftstrtto} to freetype-utils (jitterbug #88)
233
234* Mon Nov 8 1999 Toru Hoshina <t@kondara.org>
235- be a NoSrc :-P
236
237* Wed Oct 14 1999 Norihito Ohmori <nono@kondara.org>
238- freetype-current dated Oct 12 1999.
239
240* Sat Oct 9 1999 Toru Hoshina <t@kondara.org>
241- freetype-current dated Oct 3 1999.
242
243* Thu Aug 19 1999 Preston Brown <pbrown@redhat.com>
244- newer ttmkfdir that works better, moved ttmkfdir to /usr/bin from /usr/sbin
245- freetype utilities moved to subpkg, X dependency removed from main pkg
246- libttf.so symlink moved to devel pkg
247
248* Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
249- strip binaries
250
251* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
252- auto rebuild in the new build environment (release 5)
253
254* Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
255- fixed the %doc file list
256
257* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
258- Injected new description and group.
259
260* Mon Feb 15 1999 Preston Brown <pbrown@redhat.com>
261- added ttmkfdir
262
263* Tue Feb 02 1999 Preston Brown <pbrown@redhat.com>
264- update to 1.2
265
266* Thu Jan 07 1999 Cristian Gafton <gafton@redhat.com>
267- call libtoolize to sanitize config.sub and get ARM support
268- dispoze of the patch (not necessary anymore)
269
270* Wed Oct 21 1998 Preston Brown <pbrown@redhat.com>
271- post/postun sections for ldconfig action.
272
273* Tue Oct 20 1998 Preston Brown <pbrown@redhat.com>
274- initial RPM, includes normal and development packages.
Note: See TracBrowser for help on using the repository browser.