source: projects/specs/tags/6_0_REL/f/f-spot/f-spot-vl.spec @ 2387

Revision 2387, 14.1 KB checked in by Takemikaduchi, 13 years ago (diff)

new upstream release

Line 
1Name:           f-spot
2Version:        0.8.2
3Release:        1%{?_dist_release}
4Summary:        Photo management application
5Summary(ja):    写真管理アプリケーション
6
7Group:          Applications/Multimedia
8License:        GPLv2+ and LGPLv2+ and CPL and MIT
9URL:            http://f-spot.org/
10Source0:        http://ftp.gnome.org/pub/gnome/sources/f-spot/0.8/f-spot-%{version}.tar.bz2
11Patch1:         f-spot-0.7.1-build-fixes.patch
12# unmount cameras before importing
13Patch3:         0002-enhance-the-f-spot-import-script.patch
14
15# Patch from fedora
16# two upstream patches to fix compile issue with Mono 2.8:
17# http://git.gnome.org/browse/f-spot/commit/?id=9d6e8052b188c2b1cb310ef05842da74a730a39f
18Patch13:         0001-PixbufLoader-from-gtk-sharp-master-does-not-have-a-C.patch
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21
22BuildRequires:  mono-devel mono-web mono-data mono-data-sqlite lcms-devel
23BuildRequires:  libexif-devel gphoto2-devel >= 2.1.4
24BuildRequires:  gtk-sharp2 libgnome-devel libgnomeui-devel
25BuildRequires:  gtk2-devel mono-devel libjpeg-devel sqlite3-devel
26BuildRequires:  gnome-sharp2 gnome-desktop-sharp2 gtk-sharp2-gapi
27BuildRequires:  gconf-sharp2
28BuildRequires:  gettext
29BuildRequires:  autoconf, automake, libtool, intltool
30BuildRequires:  perl-XML-Parser
31BuildRequires:  gnome-doc-utils
32BuildRequires:  ndesk-dbus-glib
33BuildRequires:  mono-addins
34BuildRequires:  desktop-file-utils
35BuildRequires:  gnome-keyring-sharp-devel
36BuildRequires:  unique-devel
37BuildRequires:  flickrnet-devel
38BuildRequires:  libSM-devel
39Requires:       sqlite3
40Requires:       lcms
41Requires:       dcraw
42Requires:       hicolor-icon-theme
43Requires:       yelp
44Requires(post): desktop-file-utils
45Requires(postun): desktop-file-utils
46
47# no mono available
48ExcludeArch: sparc64
49
50# Some compiler segfault on ia64:
51ExcludeArch: ia64
52
53# No libgphoto etc on s390
54ExcludeArch: s390
55
56%description
57F-Spot is an application designed to provide personal photo management
58to the GNOME desktop. Features include import, export, printing and advanced
59sorting and tagging of digital images.
60
61%package screensaver
62Summary: F-Spot gnome-screensaver plugin
63Summary(ja): F-Spot gnome-screensaver plugin
64Group: Applications/Multimedia
65Requires: %{name} = %{version}-%{release}
66Requires: gnome-screensaver
67Obsoletes: f-spot < 0.6.1.1
68
69%description screensaver
70F-Spot provides a plugin for gnome-screensaver which displays parts of the
71photo collection in a slideshow as a screensaver.
72
73%prep
74%setup -q
75#%patch1 -p1 -b .buildfix
76%patch3 -p1 -b .gvfs-gphoto
77%patch13 -p1 -b mono28-compile-fix
78
79
80%build
81intltoolize --force --copy
82libtoolize --force --copy --automake
83aclocal -I build/m4/f-spot -I build/m4/shamrock -I build/m4/shave
84autoconf
85autoheader
86test -f config.h.in && touch config.h.in
87automake --gnu --add-missing --force --copy -Wno-portability
88
89export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
90%configure --disable-scrollkeeper
91make %{?_smp_mflags}
92
93
94%install
95rm -rf $RPM_BUILD_ROOT
96export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
97make install DESTDIR=$RPM_BUILD_ROOT
98
99rm $RPM_BUILD_ROOT%{_libdir}/%{name}/*.a
100rm $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
101rm $RPM_BUILD_ROOT%{_libdir}/pkgconfig/f-spot.pc
102
103# only files marked executable are used to auto-generate the
104# requires/provides of the package
105find $RPM_BUILD_ROOT \( -name '*.exe' -or -name '*.dll' \) \
106     -exec chmod a+x {} \;
107
108for file in $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
109do
110   desktop-file-validate $file
111done
112
113%find_lang %name
114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%pre
119if [ "$1" -gt 1 ]; then
120  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
121  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/f-spot.schemas > /dev/null || :
122fi
123
124%post
125update-desktop-database &> /dev/null ||:
126touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
127export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
128gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/f-spot.schemas > /dev/null || :
129
130%preun
131if [ "$1" -eq 0 ]; then
132  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
133  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/f-spot.schemas > /dev/null || :
134fi
135
136%postun
137update-desktop-database &> /dev/null ||:
138if [ $1 -eq 0 ] ; then
139    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
140    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
141fi
142
143%posttrans
144gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
145
146%files -f %{name}.lang
147%defattr(-,root,root,-)
148%doc AUTHORS COPYING README NEWS
149%{_sysconfdir}/gconf/schemas/*
150%{_datadir}/applications/*.desktop
151%{_datadir}/gnome/help/f-spot/
152%{_datadir}/icons/hicolor/*/*/*.png
153%{_datadir}/f-spot/
154%dir %{_libdir}/f-spot/
155%{_libdir}/f-spot/*.dll
156%{_libdir}/f-spot/*.exe
157%{_libdir}/f-spot/*.addins
158%{_libdir}/f-spot/*.config
159%{_libdir}/f-spot/*.mdb
160%{_libdir}/f-spot/*.so
161%{_libdir}/f-spot/*.so.*
162%exclude %{_libdir}/f-spot/Extensions/FSpot.Tools.ScreensaverConfig.dll*
163%{_libdir}/f-spot/Extensions/
164%{_bindir}/f-spot
165%{_bindir}/f-spot-import
166%{_bindir}/f-spot-sqlite-upgrade
167
168%files screensaver
169%defattr(-,root,root,-)
170%{_libdir}/f-spot/Extensions/FSpot.Tools.ScreensaverConfig.dll
171%{_prefix}/libexec/gnome-screensaver/f-spot-screensaver
172%{_datadir}/applications/screensavers/f-spot-screensaver.desktop
173
174%changelog
175* Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.2-1
176- new upstream release
177- delete Patch11,12
178
179* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
180- new upstream release
181- drop Patch1
182- add Patch11,12,13 from fedora
183- add BuildRequires: libSM-devel
184
185* Thu Aug 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.1-1
186- new upstream release
187- add patch1 to support parallel builds
188- add BR: unique-devel, flickrnet-devel
189
190* Sun May 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.1.5-1
191- initial build for Vine Linux
192
193* Mon Dec 14 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.5-2
194- Corrected the permission fix for all .exe and .dll files in order
195  to generate the dependencies correctly (BZ 547063)
196
197* Sun Nov 08 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.5-1
198- Update to 0.6.1.5 (BZ 531955)
199- Build f-spot against system gnome-keyring-sharp library (BZ 442343)
200- Make all .dll and .exe files executable so that they are respected
201  by the find-requires/find-provides scripts
202- Remove upstreamed patch
203
204* Mon Oct 26 2009 Dennis Gilmore <dennis@ausil.us> - 0.6.1.3-2
205- ExcludeArch sparc64
206
207* Sun Oct 04 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.3-1
208- Update to 0.6.1.3 (BZ 526217)
209- Remove two upstreamed patches
210- Use a slightly different fix for the cairo-devel dependency
211  (suggested by upstream)
212
213* Wed Sep 30 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.2-3
214- Add patch to fix f-spot crash when using "soft focus" and cairo-devel
215  was not installed (BZ 526563)
216- Minor spec file beautification
217
218* Tue Sep 22 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.2-2
219- Add upstream patches (
220  commit b87604bc9782bf92f053aaf3ceb739a32f44ea13
221  commit 807dab4344ecdadc7e46793369821de8b49692e5 )
222  to fix crash in facebook exporter (BZ 524860)
223
224* Thu Sep 17 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.2-1
225- Update to 0.6.1.2 (BZ 519290)
226
227* Fri Aug 28 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.1-2
228- Move the screensaver plugin into a sub-package (BZ 519640)
229- Let f-spot-screensaver obsolete older f-spot version so that it
230  is pulled in during update (fresh installations of f-spot will not
231  pull in gnome-screensaver)
232
233* Wed Aug 26 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.1-1
234- Update to 0.6.1.1
235- Remove upstreamed patch
236- Updated use-system-Mono.Addins-if-available patch
237- Add a patch to enable parallel build
238
239* Sun Aug 09 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.0.0-3
240- Build arch ppc64.
241
242* Sun Aug 09 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.0.0-2
243- Fix Icon Cache script in %%post section
244
245* Sun Aug 09 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.0.0-1
246- Update to new upstream version 0.6.0.0
247- Cleanup spec file
248
249* Sat Jul 25 2009 Christian Krause <chkr@fedoraproject.org> - 0.5.0.3-9
250- Avoid showing f-spot twice for photo imports
251- Make f-spot-import work with gvfs
252- Minor indentation fix
253
254* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.0.3-8
255- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
256
257* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.0.3-7
258- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
259
260* Sun Feb  8 2009 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.5.0.3-6
261- Rebuild against new mono stack to fix broken deps
262
263* Thu Dec  4 2008 Matthias Clasen <mclasen@redhat.com> - 0.5.0.3-5
264- Update to 0.5.0.3
265
266* Fri Nov 21 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.4-8
267- Better URL
268- Tweak %%description
269
270* Tue Oct 28 2008 Orion Poplawski <orion@cora.nwra.com.com> - 0.4.4-7
271- Run desktop-file-validate against desktop files
272
273* Mon Oct 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4.4-6
274- rebuild against new gnome-sharp
275
276* Thu Oct  2 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.4-5
277- Use a standard icon name instead of a non-existing one
278
279* Mon Jul 14 2008 Nigel Jones <dev@nigelj.com> - 0.4.4-4
280- Remove Tom's patch in -2, there is a gtk-sharp 2.12.1, just nobody bothered
281  packaging it.
282- Patch Makefile{.in,am} to use DESTDIR for the gio-sharp.dll, this is
283  effectively a backport of r4010 Upstream.
284- Patch libfspot/Makefile{.in,am} to remove -DGTK_DISABLE_DEPRECATED per
285  recommendation of upstream.
286- Re-add patch to use system mono-addins
287- Include GIO stuff for now (until it appears in gtk-sharp)
288
289* Wed Jul  5 2008 Alex Lancaster <alexlan[AT] fedoraproject org> - 0.4.4-3
290- gtkhtml dependency now provided by gnome-desktop-sharp-devel
291  rather than gnome-sharp-devel, so add as BuildRequires
292
293* Wed Jun  4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4.4-2
294- Fix it to not look for non-existant glib-sharp-2.12.1
295
296* Wed Jun  4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4.4-1
297- update to 0.4.4
298- fix license tag
299
300* Tue May 13 2008 Matthias Clasen <mclasne@redhat.com> - 0.4.3.1-1
301- Update to 0.4.3.1
302
303* Tue Apr 15 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.4.2-5
304- Add patch from Debian to use system mono-addins (from #442343)
305
306* Sat Mar  1 2008 Christopher Aillon <caillon@redhat.com> - 0.4.2-4
307- Require dcraw
308
309* Fri Feb 29 2008 Christopher Aillon <caillon@redhat.com> - 0.4.2-3
310- Fix the build
311
312* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
313- Autorebuild for GCC 4.3
314
315* Thu Feb 14 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.2-1
316- Update to 0.4.2
317
318* Fri Jan 18 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.1-2
319- Add support for content-types
320
321* Thu Dec  6 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.1-1
322- Update to 0.4.1
323
324* Sat Nov 17 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-4
325- Remove comments from ExclusiveArch line (#388581)
326
327* Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-3
328- Add alpha to ExclusiveArch
329
330* Fri Aug 24 2007 Adam Jackson <ajax@redhat.com> - 0.4.0-2
331- Rebuild for build ID
332
333* Sat Aug  4 2007 Matthis Clasen <mclasen@redhat.com> - 0.4.0-1
334- Update to 0.4.0
335
336* Mon Jul  2 2007 Christopher Aillon <caillon@redhat.com> - 0.3.5-3
337- Hack to get screensavers to work again (#221546)
338
339* Fri Apr 13 2007 Christopher Aillon <caillon@redhat.com> - 0.3.5-2
340- Now with validated desktop files!
341
342* Wed Mar  7 2007 Christopher Aillon <caillon@redhat.com> - 0.3.5-1
343- Update to 0.3.5
344
345* Wed Feb 28 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.4-1
346- Update to 0.3.4
347
348* Tue Feb 13 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.3-1
349- Update to 0.3.3
350
351* Tue Jan 23 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
352- Update to 0.3.2
353
354* Fri Oct 20 2006 Christopher Aillon <caillon@redhat.com> - 0.2.2-1
355- Update to 0.2.2
356
357* Mon Oct 16 2006 Matthias Clasen <mclasen@redhat.com> - 0.2.1-2
358- Fix a directory ownership issue (#211009)
359
360* Wed Sep 13 2006 Christopher Aillon <caillon@redhat.com> - 0.2.1-1
361- Update to 0.2.1
362
363* Tue Sep 12 2006 Matthias Clasen <mclasen@redhat.com> - 0.2.0-2
364- Add libgphoto2_port version to dll config (#205302)
365
366* Mon Sep  4 2006 Christopher Aillon <caillon@redhat.com> - 0.2.0-1
367- Update to 0.2.0
368
369* Fri Aug 18 2006 Alexander Larsson <alexl@redhat.com> - 0.1.11-5
370- Rebuild with new mono and gtk-sharp2
371
372* Thu Jul 27 2006 Matthias Clasen <mclasen@redhat.com> - 0.1.11-4
373- Fix dbus-sharp BR
374
375* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.1.11-3.1
376- rebuild
377
378* Sun Jun 24 2006 Jesse Keating <jkeating@redhat.com> 0.1.11-3
379- Add missing BR gettext
380
381* Wed May 31 2006 Alexander Larsson <alexl@redhat.com> 0.1.11-2
382- Rebuild for gmime update
383
384* Fri Mar 17 2006 Christopher Aillon <caillon@redhat.com> 0.1.11-1
385- Update to 0.1.11
386
387* Fri Feb 24 2006 Christopher Aillon <caillon@redhat.com> 0.1.10-1
388- Update to 0.1.10
389
390* Tue Feb 21 2006 Karsten Hopp <karsten@redhat.de> 0.1.9-2
391- add BuildRequires  libgnome-devel libgnomeui-devel
392  gtk2-devel mono-devel libjpeg-devel sqlite-devel
393
394* Fri Feb 17 2006 Christopher Aillon <caillon@redhat.com> - 0.1.9-1
395- Update to 0.1.9
396
397* Sun Feb 12 2006 Christopher Aillon <caillon@redhat.com> - 0.1.8-3
398- Rebuild
399
400* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.1.8-2.1
401- rebuilt for new gcc4.1 snapshot and glibc changes
402
403* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> - 0.1.8-2
404- Add sqlite3.patch to ensure that sqlite3 is used if both
405  sqlite2 and sqlite3 are installed.
406
407* Tue Jan 31 2006 Christopher Aillon <caillon@redhat.com> - 0.1.8-1
408- Update to 0.1.8
409- Use sqlite3 instead of sqlite2
410
411* Tue Jan 31 2006 Ray Strode <rstrode@redhat.com> - 0.1.5-3
412- don't blindly run f-spot from current working directory
413  (bug 177407)
414
415* Tue Jan 10 2006 Alexander Larsson <alexl@redhat.com> - 0.1.5-2
416- Add lcms depencency
417
418* Mon Jan  9 2006 Alexander Larsson <alexl@redhat.com> - 0.1.5-1
419- Update to 0.1.5
420
421* Thu Dec  8 2005 Alexander Larsson <alexl@redhat.com> 0.1.3-3
422- Use sqlite2 to avoid problems with beagle
423
424* Fri Nov 18 2005 Alexander Larsson <alexl@redhat.com> 0.1.3-2
425- Make exes and dlls executable to pick up dependencies
426- Remove .a and .la files
427
428* Wed Nov 16 2005 Alexander Larsson <alexl@redhat.com> - 0.1.3-1
429- Initial version
430
Note: See TracBrowser for help on using the repository browser.