source: projects/specs/tags/6_0_REL/b/bison/bison-vl.spec @ 2388

Revision 2388, 6.2 KB checked in by Takemikaduchi, 13 years ago (diff)

new upstream release

Line 
1Summary: A GNU general-purpose parser generator.
2Summary(ja): GNU 汎用構文解析器生成プログラム
3Name: bison
4Version: 2.4.3
5Release: 1%{?_dist_release}
6License: GPL
7Group: Development/Tools
8Source: http://ftp.gnu.org/gnu/bison/bison-%{version}.tar.bz2
9URL: http://www.gnu.org/software/bison/
10
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12Requires: m4 >= 1.4
13Requires(post): install-info
14Requires(preun): install-info
15
16Vendor:        Project Vine
17Distribution:  Vine Linux
18
19%description
20Bison is a general purpose parser generator which converts a grammar
21description for an LALR(1) context-free grammar into a C program to parse
22that grammar.  Bison can be used to develop a wide range of language
23parsers, from ones used in simple desk calculators to complex programming
24languages.  Bison is upwardly compatible with Yacc, so any correctly
25written Yacc grammar should work with Bison without any changes.  If
26you know Yacc, you shouldn't have any trouble using Bison. You do need
27to be very proficient in C programming to be able to use Bison).  Bison
28is only needed on systems that are used for development.
29
30If your system will be used for C development, you should install Bison
31since it is used to build many C programs.
32
33#'
34%description -l ja
35bison は汎用構文解析器を生成するプログラムで,LALR(1) 文脈自由文法で
36書かれた文法記述を元に,その記述を解析する C プログラムを生成します.
37bison は簡単な電卓から複雑なプログラミング言語まで,幅広い種類の
38言語解析器を開発するのに使うことが出来ます.
39bison は yacc の上位互換ですので,yacc で書かれた文法を修正すること
40なしに解析することが出来ます.yacc を知っているのであれば,bison を
41使って困ることは何もないでしょう.bison を使うには C プログラミングの
42豊富な知識が必要となります.bison は開発を行うシステム以外では特に
43必要にならないでしょう.
44
45C 言語による開発を行う場合は,多くの C プログラムの作成に使われるので
46bison をインストールして下さい.
47
48
49%prep
50%setup -q
51
52
53%build
54%configure
55make
56make check
57
58
59%install
60rm -rf $RPM_BUILD_ROOT
61%makeinstall
62
63# Remove unpackaged files.
64rm -f $RPM_BUILD_ROOT/%{_bindir}/yacc
65rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
66rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/yacc*
67
68%find_lang %{name}
69
70
71%clean
72rm -rf $RPM_BUILD_ROOT
73
74
75%post
76/sbin/install-info %{_infodir}/bison.info.gz %{_infodir}/dir \
77    --entry="* bison: (bison).                        The GNU parser generator."
78
79%preun
80if [ $1 = 0 ]; then
81  /sbin/install-info --delete %{_infodir}/bison.info.gz %{_infodir}/dir \
82      --entry="* bison: (bison).                        The GNU parser generator."
83fi
84
85
86%files -f %{name}.lang
87%defattr(-,root,root)
88%doc AUTHORS COPYING ChangeLog NEWS OChangeLog README THANKS TODO
89%{_bindir}/bison
90%{_libdir}/liby.a
91%{_datadir}/bison
92%{_datadir}/aclocal/*.m4
93%{_datadir}/locale/*/LC_MESSAGES/%{name}-runtime.mo
94%{_mandir}/*/bison*
95%{_infodir}/bison.info*
96
97
98%changelog
99* Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.3-1
100- new upstream release
101- delete Patch1
102
103* Wed Feb 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.1-2
104- rebuilt with new toolchain
105
106* Tue Feb  3 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.1-1
107- new upstream release
108- import Patch1 from Fedora
109
110* Sat Nov  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4-1
111- new upstream release
112- spec in UTF-8
113
114* Sun Apr 13 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.3-1
115- rebuild with new toolchain.
116- apply new versioning policy.
117
118* Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3-0vl1
119- new upstream release
120
121* Tue Mar 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1-0vl1
122- new upstream release
123
124* Thu Jun 09 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0-6vl1
125- new upstream release
126- dropped Patch1
127- added %doc files
128- updated URL
129
130* Sun Feb 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.875-6vl1
131- add Patch1 from fedora
132- add Requires: m4
133  * Thu Oct 30 2003 Roland McGrath <roland@redhat.com> 1.875-6
134  - add dependency on m4 (bug #108655)
135  * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 1.875-5
136  - remove problematic __attribute__ use for label (bug #105034)
137
138* Sun Jul  6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.875-3vl1
139- based on Rawhide 1.875-3
140- s/Copyright/License/
141
142* Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.75-2vl1
143  - new upstream release
144  - merged with rawhide release
145    * Thu Nov 21 2002 Tim Waugh <twaugh@redhat.com> 1.75-2
146    - Run 'make check'.
147    - Apply patch from bison-patches to fix bash compilation.
148    * Thu Oct 17 2002 Florian La Roche <Florian.LaRoche@redhat.de>
149    - update to 1.75
150
151* Fri May 31 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
152- 1.35-2vl1: synced with rawhide
153
154* Thu Dec 28 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
155- 1.28-5vl1
156- rebuilt with new %%{_mandir} definition
157- added Japanese summary and description
158
159* Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 1.28-5vl1
160- build on Vine Linux with gcc-2.95.3
161
162* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
163- automatic rebuild
164
165* Sun Jun 18 2000 Than Ngo <than@redhat.de>
166- rebuilt in the new build environment
167- FHS packaging
168
169* Sat May 27 2000 Ngo Than <than@redhat.de>
170- rebuild for 7.0
171- put man pages and info files to correct place
172
173* Thu Feb 03 2000 Preston Brown <pbrown@redhat.com>
174- rebuild to gzip man page.
175
176* Fri Jul 16 1999 Jeff Johnson <jbj@redhat.com>
177- update to 1.28.
178
179* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
180- auto rebuild in the new build environment (release 3)
181
182* Mon Mar  8 1999 Jeff Johnson <jbj@redhat.com>
183- configure with datadir=/usr/lib (#1386).
184
185* Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
186- updated text in spec file.
187- update to 1.27
188
189* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
190- build for glibc 2.1
191
192* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
193- translations modified for de, fr, tr
194
195* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
196- built for Manhattan
197- added build root
198
199* Wed Oct 15 1997 Donnie Barnes <djb@redhat.com>
200- various spec file cleanups
201
202* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
203- built against glibc
204
Note: See TracBrowser for help on using the repository browser.