source: projects/specs/branches/6/z/zsh/zsh-vl.spec @ 2425

Revision 2425, 14.0 KB checked in by iwaim, 13 years ago (diff)

zsh 4.3.11-1

Line 
1# -*- Mode: rpm-spec -*-
2
3%define name zsh
4%define version 4.3.11
5%define rversion %{version}
6%define dversion %{version}
7%define release 1%{?_dist_release}
8%define url ftp://ftp.zsh.org/pub/
9## %define _sysconfdir /etc
10
11Summary: A shell with lots of features.
12Summary(ja): 多機能シェル
13Name: %{name}
14Version: %{version}
15Release: %{release}
16License: distributable (see LICENCE file)
17Group: System Environment/Shells
18Url: http://www.zsh.org
19Source0: %{url}/%{name}-%{rversion}.tar.bz2
20Source1: zcfg-vine.tar.bz2
21Source3: http://www.pwstephenson.fsnet.co.uk/computing/zshguide.tar.bz2
22# fixed that _apt fail  completions rpm package name.
23Patch0: zsh-4.3.4-apt4rpm.patch
24Patch1: zsh-4.3.4-sshcomp.patch
25Patch2: zsh-4.2.0-completion_tar_archive.patch
26Patch3: zsh-4.3.10-fixpath.patch
27Requires(post,preun): /sbin/install-info
28Requires(post,postun): grep
29BuildRoot: %{_tmppath}/%{name}-buildroot
30BuildRequires: texinfo, ncurses-devel
31BuildRequires: findutils grep
32
33Vendor: Project Vine
34Distribution: Vine Linux
35Packager: iwaim
36Epoch: 1
37
38%description
39Zsh is a UNIX command interpreter (shell) usable as an
40interactive login shell and as a shell script command
41processor. Of the standard shells, zsh most closely resembles
42ksh but includes many enhancements. Zsh has command-line editing,
43built-in spelling correction, programmable command completion,
44shell functions (with autoloading), a history mechanism, and a
45lots of other features
46
47Install the zsh package if you'd like to try out a different shell.
48
49%description -l ja
50Zsh 対話的に使える コマンドラインインタプリタ(シェル)です。
51規格上Zsh はksh ににているが多くの拡張がされている。
52スペルコレクション,プログラマブル補完,
53シェルファンクションズ(オートロード),等の多くの機能がある。
54
55%prep
56%setup -q -a 1 -n %{name}-%{rversion}
57#%patch0 -p1
58#%patch1 -p1
59#%patch2 -p1
60%patch3 -p1
61
62# remove temporary files
63find|grep '~$'|xargs rm -f
64
65%build
66
67%ifnarch sparc
68%configure \
69           --enable-etcdir=%{_sysconfdir} \
70           --enable-fndir=%{_datadir}/zsh/functions \
71           --enable-site-fndir=%{_datadir}/zsh/site-functions \
72           --enable-function-subdirs \
73           --enable-scriptdir=%{_datadir}/zsh/scripts \
74           --enable-site-scriptdir=%{_datadir}/zsh/site-scripts \
75           --with-tcsetpgrp
76%else
77%configure \
78           --enable-etcdir=%{_sysconfdir} \
79           --enable-fndir=%{_datadir}/zsh/functions \
80           --enable-site-fndir=%{_datadir}/zsh/site-functions \
81           --enable-function-subdirs \
82           --enable-scriptdir=%{_datadir}/zsh/scripts \
83           --enable-site-scriptdir=%{_datadir}/zsh/site-scripts
84           --disable-lfs
85%endif
86make
87
88%install
89rm -rf $RPM_BUILD_ROOT
90%makeinstall fndir=%{buildroot}%{_datadir}/zsh/functions sitefndir=%{buildroot}%{_datadir}/zsh/site-functions scriptdir=%{buildroot}%{_datadir}/zsh/scripts sitescriptdir=%{buildroot}%{_datadir}/zsh/site-scripts
91
92make install.info DESTDIR=$RPM_BUILD_ROOT
93
94mkdir -p %{buildroot}%{_sysbindir}
95pushd %{buildroot}%{_sysbindir} && {
96    ln -s ..%{_bindir}/zsh ./zsh
97} && popd
98
99# copy Mandrake Configuration files.
100mkdir -p %{buildroot}%{_sysconfdir}
101cp -a zcfg/* %{buildroot}%{_sysconfdir}
102
103# Copy documentation.
104#rm -rf docroot
105mkdir -p docroot/{Info_html,Examples,Documentation}/
106cp -a README docroot/
107cp -a Functions/Misc/* Misc/* Util/* docroot/Examples/
108cp -a INSTALL ChangeLog* docroot/Documentation
109cp -a StartupFiles docroot/
110cp -a Etc/* docroot/Documentation
111cp -a NEWS docroot/
112#cp -a Doc/*html docroot/Info_html/
113
114mkdir -p docroot/Zsh_Guide
115bzcat %{SOURCE3}|tar xf - -C docroot/Zsh_Guide
116mv docroot/Zsh_Guide/zshguide/*html docroot/Zsh_Guide/
117rmdir docroot/Zsh_Guide/zshguide
118
119find docroot/ -type f|xargs perl -p -i -e 's|^#!%{prefix}/local/bin/zsh|#!%{_bi
120ndir}/zsh|'
121find docroot/ -type f|xargs perl -p -i -e 's|^#!%{prefix}/local/bin/perl|#!%{_b
122indir}/perl|'
123
124rm -f docroot/StartupFiles/.distfiles
125rm -f docroot/Examples/{Makefile*,*.yo}
126rm -f docroot/Documentation/{Makefile*,*.yo}
127mv docroot/Examples/compctl-examples docroot/StartupFiles
128
129#Build Helpdir
130mkdir -p %{buildroot}%{_datadir}/zsh/
131
132rm -rf help && mkdir help/ && pushd help && {
133    echo "Build Documentation"
134    make -C ../Doc/ zshbuiltins.1
135    man ../Doc/zshbuiltins.1|colcrt -|perl ../Util/helpfiles
136} && popd
137
138mv help %{buildroot}%{_datadir}/zsh
139
140find docroot/ -name 'Makefile*' -o -name '.yo'|xargs rm -f
141
142%clean
143rm -rf %{buildroot}
144
145%post
146if [ ! -f %{_sysconfdir}/shells ]; then
147        echo "/bin/zsh" > %{_sysconfdir}/shells
148else
149        grep '^/bin/zsh' %{_sysconfdir}/shells > /dev/null || echo "/bin/zsh" >> /etc/shells
150fi
151/sbin/install-info %{_infodir}/zsh.info.gz %{_infodir}/dir
152
153%preun
154if [ "$1" = 0 ]; then
155    /sbin/install-info --delete %{_infodir}/zsh.info.gz %{_infodir}/dir
156fi
157
158%postun
159if [ ! -x /bin/zsh ]; then
160        grep -v '^/bin/zsh$' %{_sysconfdir}/shells | grep -v '^/bin/zsh$'> /etc/shells.rpm
161        mv %{_sysconfdir}/shells.rpm /etc/shells
162fi
163
164%files
165%defattr(-,root,root,0755)
166%doc LICENCE
167%doc docroot/README docroot/NEWS
168%doc docroot/Documentation/ docroot/Examples/ docroot/Info_html/ docroot/StartupFiles/
169%doc docroot/Zsh_Guide
170%config %{_sysconfdir}/z*
171%{_sysbindir}/zsh
172%{_bindir}/zsh*
173%{_libdir}/zsh
174%{_infodir}/*.info*
175%exclude %{_infodir}/dir*
176%{_mandir}/man*/*
177%{_datadir}/zsh
178
179%changelog
180* Tue Dec 21 2010 IWAI, Masaharu <iwai@alib.jp> 4.3.11-1
181- new upstream release
182
183* Sun Aug 15 2010 IWAI, Masaharu <iwai@alib.jp> 4.3.10-2
184- rebuild with new toolchain
185
186* Tue Feb 23 2010 IWAI, Masaharu <iwai@alib.jp> 4.3.10-1
187- new upstream release
188- update fixpath patch (Patch3)
189- drop unnecessary patch: fix subversion completion patch (Patch4)
190- fix '--with-tcsetpgrp' option: apply besides SPARC arch
191- add LICENCE file in %%doc directory: fixed typo
192- exclude %%{_infodir}/dir* in %%files section
193- drop Prefix tag
194- replace Prereq to Requires(*)
195- BuildRequires: findutils grep
196
197* Wed Jan 27 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.3.4-4
198- fix files error (LICENSE is no longer exist)
199
200* Wed Jan 27 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.3.4-3
201- add --with-tcsetpgrp into configure section
202- add BR: texinfo, ncurses-devel
203
204* Thu Jan  7 2010 IWAI, Masaharu <iwai@alib.jp> 4.3.4-2
205- add fix subversion completion patch (Patch4): <BTS:VineLinux:869>
206  - see http://svn.haxx.se/users/archive-2008-06/0095.shtml
207- add Packager tag
208- add LICENSE file in %%doc directory
209- fix License tag's value
210
211* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 4.3.4-1vl5
212- applied new versioning policy, spec in utf-8
213
214* Wed Oct 31 2007 IWAI, Masaharu <iwai@alib.jp> 4.3.4-0vl1
215- new upstream release
216- update apt4rpm patch ( Patch0 )
217- update sshcomp patch ( Patch1 )
218- add fixpath patch ( Patch3 )
219- update %%build and %%install section
220
221* Tue Apr 12 2005 IWAI, Masaharu <iwai@alib.jp> 4.2.5-0vl1
222- new upstream release
223
224* Tue Mar  8 2005 IWAI, Masaharu <iwai@alib.jp> 4.2.4-0vl1
225- new upstream release
226
227* Sat Aug 14 2004 IWAI, Masaharu <iwai@alib.jp> 4.2.1-0vl1
228- new upstream release
229- update apt4rpm patch ( Patch0 )
230- drop unnecessary patch for fixed upstream: job_table_full patch ( Patch3 )
231- update 'Copy documentation' script: moved NEWS document in upstream archive
232
233* Sat Jul 7 2004 HAYASHI Kentarou <linjian@gigo-ice.org> 4.2.0-0vl2
234- add job_table_full.patch (Patch3)
235  see Zsh Mailing List 2004/msg00488.html
236
237* Mon Mar 29 2004 IWAI, Masaharu <iwai@alib.jp> 4.2.0-0vl1
238- new upstream release
239- update completion tar archive patch (Patch2)
240- update file list: include directories in %%{_libdir} and %%{_datadir}
241
242* Sun Dec 28 2003 IWAI, Masaharu <iwai@alib.jp> 4.0.9-0vl1
243- upstream update
244- update apt4rpm.patch (Patch0)
245
246* Fri Jun 20 2003 IWAI Masaharu <iwai@alib.jp> 4.0.7-0vl1
247- upstream update
248- update apt4rpm.patch(Patch0)
249
250* Sat May  3 2003 IWAI Masaharu <iwai@alib.jp> 4.0.6-0vl3
251- add completion_tar_archive.patch (Patch2)
252  for tar's "z" option to accept bz2 tarball with zsh completion.
253
254* Mon Dec  2 2002 IWAI Masaharu <iwai@alib.jp> 4.0.6-0vl2
255- add apt-cache showsrc option in apt4rpm patch (Patch0)
256
257* Thu Aug 15 2002 IWAI Masaharu <iwai@alib.jp> 4.0.6-0vl1
258- upstream update
259
260* Sun Aug 11 2002 IWAI Masaharu <iwai@alib.jp> 4.0.5-0vl1
261- upstream update
262- apt-cache showsrc option changed unavailable in apt4rpm patch (Patch0)
263
264* Tue Dec  4 2001 Kazuhisa TAKEI <takei@vinelinux.org> 4.0.4-0vl1
265- loading vine specific profile scripts moved from zshrc to zprofile
266- fixed other bug($PATH,zmodload)
267
268
269* Mon Aug 27 2001 Shoji Matsumoto <shom@vinelinux.org> 4.0.2-0vl3
270- rebuilding current Seed
271- change ssh completion (Patch1)
272
273* Thu Aug 16 2001 Kazuhisa TAKEI <takei@vinelinux.org> 4.0.2-0vl2
274- fixed bug rpm package name completions in _apt
275
276* Thu Jul 19 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.2-0vl1
277- 4.0.2
278
279* Sun Jun  3 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.1-0vl1
280- upstream 4.0.1 release
281- fixed bug zshrc( add /usr/X11R6/bin $PATH)
282- fixed lack 'Epoch:'
283
284* Thu Apr 26 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.1-0vl0.4.pre.3
285- fixed version number invalid
286
287* Fri Apr 20 2001 <sagami@vinelinux.org>
288- 4.0.1-0vl0.3.pre.4
289- install infopage/manpage and added PreReq = /sbin/install-info
290- fixed/added scripts in post/postun/preun for install-info
291
292* Fri Apr 13 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.1-0vl0.3.pre.3
293- upstream update
294- fixed /etc/zshrc bugs
295
296* Tue Apr  3 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.1-0vl0.0.pre.2
297- upstream update
298- remove all patches
299
300* Tue Oct  3 2000 Kazuhisa TAKEI<takei@vinelinux.org> 3.1.9-4vl1
301- can read /etc/profile.d/*.sh
302
303* Wed Sep 13 2000 Kazuhisa TAKEI<takei@vinelinux.org>
304- 3.1.9-4vl0
305- convert from Mandrake Linux to Vine Linux
306- add Japanise Summary and description
307
308* Sat Aug 26 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.9-4mdk
309- Set some %config file to (noreplace).
310- Make -A to complete spec file for _rpm.
311
312* Thu Jul 20 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.9-3mdk
313- Get /usr/share/man also in the completion for perl manpages.
314- BM.
315
316* Wed Jul  5 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.9-2mdk
317- Fix buildroot hardcoded in binary.
318
319* Wed Jun 21 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.9-1mdk
320- Use makeinstall macros (not easy this one :\).
321- 3.1.9.
322
323* Mon Jun  5 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.8-1mdk
324- 3.1.8.
325
326* Sun May 28 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev22-3mdk
327- Fix path (%{prefix}/ucb -> %{_bindir}/X11)
328- Fix keys (home-end-suppr-delete) directly in the zsh binary.
329
330* Sun Apr 16 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev22-2mdk
331- Remove doble .so in %{_libdir}/zsh/*.
332
333* Thu Apr 13 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev22-1mdk
334- 3.1.6dev22.
335
336* Fri Mar 31 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev20-3mdk
337- Fix completion of rpm with -qp*.
338
339* Mon Mar 27 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev20-2mdk
340- Upgrade zshguide.
341
342* Sat Mar 25 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev20-1mdk
343- 3.1.6-dev20
344
345* Wed Mar 22 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev19-3mdk
346- Move global configuration here.
347- Adjust groups.
348
349* Tue Feb 22 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev19-2mdk
350- Add new zshguide from pws.
351- Separate the doc to the doc package
352
353* Sun Feb 20 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev19-1mdk
354- Clean Up spec (thanks specs-helper).
355- Remove all our patchs (now all is commited to upstream main).
356- 3.1.6dev19.
357
358* Fri Feb 18 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev18-3mdk
359- Recompile with glibc2.1.3 (first one).
360
361* Thu Feb 17 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev18-2mdk
362- Add --freshen completion.
363
364* Tue Feb 15 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev18-1mdk
365- Fix descriptions and summary.
366- 3.1.6dev18.
367
368* Thu Feb 10 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev17-2mdk
369- Remove Makefile in %doc.
370- BuildRequires: autoconf tetex.
371- Lot of modications in the default config as suggested by Bart
372  Schaefer <schaefer@zsh.org>.
373- 3.1.6dev17.
374
375* Mon Jan 24 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev16-1mdk
376- dev16.
377- Redo the tar_archive patchs.
378
379* Tue Jan 18 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev15-1mdk
380- dev15.
381- Fix doc generation with dev15.
382- remove META-FAQ.
383- disable lfs on sparc.
384
385* Thu Jan  6 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev14-1mdk
386- dev14 (note the name change).
387
388* Mon Jan  3 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6pws13-3mdk
389- Remove temporary files.
390
391* Fri Dec 31 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
392- 3.1.6pws13 (mainly bug fixes).
393- fix %post.
394- fix rpm completion
395
396* Thu Dec 09 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
397- 3.1.6pws11 (mainly bug fixes).
398
399* Tue Dec  7 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
400- Add run-help and perl-build the documentation.
401
402* Tue Nov 30 1999 Francis Galiegue <francis@mandrakesoft.com>
403
404- Completion machine patch - we use GNU make and GNU tar
405- Small fix to %post script
406
407* Tue Nov 30 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
408- 3.1.6pws10
409- Fix zprofile.
410- Clean-up Franciseries.
411- Clean-up specs.
412
413* Mon Nov 29 1999 Francis Galiegue <francis@mandrakesoft.com>
414- Grrr... Rebuilt on kenobi, toy ain't a cooker
415
416* Mon Nov 29 1999 Francis Galiegue <francis@mandrakesoft.com>
417
418- Completion system now handles bzip2'ed manpages and tarballs
419- Some cool options
420
421* Wed Nov 10 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
422- Add zshguide.txt to documentation.
423
424* Thu Oct 07 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
425
426- Fix bug in %{_sysconfdir}/zsh use USERNAME instead of USER.
427- Improve %{_sysconfdir}/z* to source the /etc/profile.d/ files.
428
429* Mon Oct 04 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
430
431- 3.1.6-pws6
432- Fix bad link.
433- Fix bad manpages.
434
435* Tue Aug 17 1999 Thierry Vignaud <tvignaud@mandrakesoft.com>
436- fix typo in examples directory name
437
438* Sun Aug  8 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
439
440- Copy documentation (yes a lot).
441- Remove the completion machine and put them in [[ {etc,root}(skel|files) ]] package.
442
443* Sat Aug  7 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
444
445- By defaut we launch the completion machine.
446- Put zsh in %{_bindir}/
447- Rewrite of Spec file for this new major version.
448
449# end of file
Note: See TracBrowser for help on using the repository browser.