source: projects/specs/trunk/z/zsh/zsh-vl.spec @ 1579

Revision 1579, 13.9 KB checked in by iwaim, 14 years ago (diff)

zsh 4.3.10-2

Line 
1# -*- Mode: rpm-spec -*-
2
3%define name zsh
4%define version 4.3.10
5%define rversion %{version}
6%define dversion %{version}
7%define release 2%{?_dist_release}
8%define url ftp://ftp.zsh.org/pub/
9## %define _sysconfdir /etc
10
11Summary: A shell with lots of features.
12Summary(ja): 多機能シェル
13Name: %{name}
14Version: %{version}
15Release: %{release}
16License: distributable (see LICENCE file)
17Group: System Environment/Shells
18Url: http://www.zsh.org
19Source0: %{url}/%{name}-%{rversion}.tar.bz2
20Source1: zcfg-vine.tar.bz2
21Source3: http://www.pwstephenson.fsnet.co.uk/computing/zshguide.tar.bz2
22# fixed that _apt fail  completions rpm package name.
23Patch0: zsh-4.3.4-apt4rpm.patch
24Patch1: zsh-4.3.4-sshcomp.patch
25Patch2: zsh-4.2.0-completion_tar_archive.patch
26Patch3: zsh-4.3.10-fixpath.patch
27Requires(post,preun): /sbin/install-info
28Requires(post,postun): grep
29BuildRoot: %{_tmppath}/%{name}-buildroot
30BuildRequires: texinfo, ncurses-devel
31BuildRequires: findutils grep
32
33Vendor: Project Vine
34Distribution: Vine Linux
35Packager: iwaim
36Epoch: 1
37
38%description
39Zsh is a UNIX command interpreter (shell) usable as an
40interactive login shell and as a shell script command
41processor. Of the standard shells, zsh most closely resembles
42ksh but includes many enhancements. Zsh has command-line editing,
43built-in spelling correction, programmable command completion,
44shell functions (with autoloading), a history mechanism, and a
45lots of other features
46
47Install the zsh package if you'd like to try out a different shell.
48
49%description -l ja
50Zsh 対話的に使える コマンドラインインタプリタ(シェル)です。
51規格上Zsh はksh ににているが多くの拡張がされている。
52スペルコレクション,プログラマブル補完,
53シェルファンクションズ(オートロード),等の多くの機能がある。
54
55%prep
56%setup -q -a 1 -n %{name}-%{rversion}
57#%patch0 -p1
58#%patch1 -p1
59#%patch2 -p1
60%patch3 -p1
61
62# remove temporary files
63find|grep '~$'|xargs rm -f
64
65%build
66
67%ifnarch sparc
68%configure \
69           --enable-etcdir=%{_sysconfdir} \
70           --enable-fndir=%{_datadir}/zsh/functions \
71           --enable-site-fndir=%{_datadir}/zsh/site-functions \
72           --enable-function-subdirs \
73           --enable-scriptdir=%{_datadir}/zsh/scripts \
74           --enable-site-scriptdir=%{_datadir}/zsh/site-scripts \
75           --with-tcsetpgrp
76%else
77%configure \
78           --enable-etcdir=%{_sysconfdir} \
79           --enable-fndir=%{_datadir}/zsh/functions \
80           --enable-site-fndir=%{_datadir}/zsh/site-functions \
81           --enable-function-subdirs \
82           --enable-scriptdir=%{_datadir}/zsh/scripts \
83           --enable-site-scriptdir=%{_datadir}/zsh/site-scripts
84           --disable-lfs
85%endif
86make
87
88%install
89rm -rf $RPM_BUILD_ROOT
90%makeinstall fndir=%{buildroot}%{_datadir}/zsh/functions sitefndir=%{buildroot}%{_datadir}/zsh/site-functions scriptdir=%{buildroot}%{_datadir}/zsh/scripts sitescriptdir=%{buildroot}%{_datadir}/zsh/site-scripts
91
92make install.info DESTDIR=$RPM_BUILD_ROOT
93
94mkdir -p %{buildroot}%{_sysbindir}
95pushd %{buildroot}%{_sysbindir} && {
96    ln -s ..%{_bindir}/zsh ./zsh
97} && popd
98
99# copy Mandrake Configuration files.
100mkdir -p %{buildroot}%{_sysconfdir}
101cp -a zcfg/* %{buildroot}%{_sysconfdir}
102
103# Copy documentation.
104#rm -rf docroot
105mkdir -p docroot/{Info_html,Examples,Documentation}/
106cp -a README docroot/
107cp -a Functions/Misc/* Misc/* Util/* docroot/Examples/
108cp -a INSTALL ChangeLog* docroot/Documentation
109cp -a StartupFiles docroot/
110cp -a Etc/* docroot/Documentation
111cp -a NEWS docroot/
112#cp -a Doc/*html docroot/Info_html/
113
114mkdir -p docroot/Zsh_Guide
115bzcat %{SOURCE3}|tar xf - -C docroot/Zsh_Guide
116mv docroot/Zsh_Guide/zshguide/*html docroot/Zsh_Guide/
117rmdir docroot/Zsh_Guide/zshguide
118
119find docroot/ -type f|xargs perl -p -i -e 's|^#!%{prefix}/local/bin/zsh|#!%{_bi
120ndir}/zsh|'
121find docroot/ -type f|xargs perl -p -i -e 's|^#!%{prefix}/local/bin/perl|#!%{_b
122indir}/perl|'
123
124rm -f docroot/StartupFiles/.distfiles
125rm -f docroot/Examples/{Makefile*,*.yo}
126rm -f docroot/Documentation/{Makefile*,*.yo}
127mv docroot/Examples/compctl-examples docroot/StartupFiles
128
129#Build Helpdir
130mkdir -p %{buildroot}%{_datadir}/zsh/
131
132rm -rf help && mkdir help/ && pushd help && {
133    echo "Build Documentation"
134    make -C ../Doc/ zshbuiltins.1
135    man ../Doc/zshbuiltins.1|colcrt -|perl ../Util/helpfiles
136} && popd
137
138mv help %{buildroot}%{_datadir}/zsh
139
140find docroot/ -name 'Makefile*' -o -name '.yo'|xargs rm -f
141
142%clean
143rm -rf %{buildroot}
144
145%post
146if [ ! -f %{_sysconfdir}/shells ]; then
147        echo "/bin/zsh" > %{_sysconfdir}/shells
148else
149        grep '^/bin/zsh' %{_sysconfdir}/shells > /dev/null || echo "/bin/zsh" >> /etc/shells
150fi
151/sbin/install-info %{_infodir}/zsh.info.gz %{_infodir}/dir
152
153%preun
154if [ "$1" = 0 ]; then
155    /sbin/install-info --delete %{_infodir}/zsh.info.gz %{_infodir}/dir
156fi
157
158%postun
159if [ ! -x /bin/zsh ]; then
160        grep -v '^/bin/zsh$' %{_sysconfdir}/shells | grep -v '^/bin/zsh$'> /etc/shells.rpm
161        mv %{_sysconfdir}/shells.rpm /etc/shells
162fi
163
164%files
165%defattr(-,root,root,0755)
166%doc LICENCE
167%doc docroot/README docroot/NEWS
168%doc docroot/Documentation/ docroot/Examples/ docroot/Info_html/ docroot/StartupFiles/
169%doc docroot/Zsh_Guide
170%config %{_sysconfdir}/z*
171%{_sysbindir}/zsh
172%{_bindir}/zsh*
173%{_libdir}/zsh
174%{_infodir}/*.info*
175%exclude %{_infodir}/dir*
176%{_mandir}/man*/*
177%{_datadir}/zsh
178
179%changelog
180* Sun Aug 15 2010 IWAI, Masaharu <iwai@alib.jp> 4.3.10-2
181- rebuild with new toolchain
182
183* Tue Feb 23 2010 IWAI, Masaharu <iwai@alib.jp> 4.3.10-1
184- new upstream release
185- update fixpath patch (Patch3)
186- drop unnecessary patch: fix subversion completion patch (Patch4)
187- fix '--with-tcsetpgrp' option: apply besides SPARC arch
188- add LICENCE file in %%doc directory: fixed typo
189- exclude %%{_infodir}/dir* in %%files section
190- drop Prefix tag
191- replace Prereq to Requires(*)
192- BuildRequires: findutils grep
193
194* Wed Jan 27 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.3.4-4
195- fix files error (LICENSE is no longer exist)
196
197* Wed Jan 27 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.3.4-3
198- add --with-tcsetpgrp into configure section
199- add BR: texinfo, ncurses-devel
200
201* Thu Jan  7 2010 IWAI, Masaharu <iwai@alib.jp> 4.3.4-2
202- add fix subversion completion patch (Patch4): <BTS:VineLinux:869>
203  - see http://svn.haxx.se/users/archive-2008-06/0095.shtml
204- add Packager tag
205- add LICENSE file in %%doc directory
206- fix License tag's value
207
208* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 4.3.4-1vl5
209- applied new versioning policy, spec in utf-8
210
211* Wed Oct 31 2007 IWAI, Masaharu <iwai@alib.jp> 4.3.4-0vl1
212- new upstream release
213- update apt4rpm patch ( Patch0 )
214- update sshcomp patch ( Patch1 )
215- add fixpath patch ( Patch3 )
216- update %%build and %%install section
217
218* Tue Apr 12 2005 IWAI, Masaharu <iwai@alib.jp> 4.2.5-0vl1
219- new upstream release
220
221* Tue Mar  8 2005 IWAI, Masaharu <iwai@alib.jp> 4.2.4-0vl1
222- new upstream release
223
224* Sat Aug 14 2004 IWAI, Masaharu <iwai@alib.jp> 4.2.1-0vl1
225- new upstream release
226- update apt4rpm patch ( Patch0 )
227- drop unnecessary patch for fixed upstream: job_table_full patch ( Patch3 )
228- update 'Copy documentation' script: moved NEWS document in upstream archive
229
230* Sat Jul 7 2004 HAYASHI Kentarou <linjian@gigo-ice.org> 4.2.0-0vl2
231- add job_table_full.patch (Patch3)
232  see Zsh Mailing List 2004/msg00488.html
233
234* Mon Mar 29 2004 IWAI, Masaharu <iwai@alib.jp> 4.2.0-0vl1
235- new upstream release
236- update completion tar archive patch (Patch2)
237- update file list: include directories in %%{_libdir} and %%{_datadir}
238
239* Sun Dec 28 2003 IWAI, Masaharu <iwai@alib.jp> 4.0.9-0vl1
240- upstream update
241- update apt4rpm.patch (Patch0)
242
243* Fri Jun 20 2003 IWAI Masaharu <iwai@alib.jp> 4.0.7-0vl1
244- upstream update
245- update apt4rpm.patch(Patch0)
246
247* Sat May  3 2003 IWAI Masaharu <iwai@alib.jp> 4.0.6-0vl3
248- add completion_tar_archive.patch (Patch2)
249  for tar's "z" option to accept bz2 tarball with zsh completion.
250
251* Mon Dec  2 2002 IWAI Masaharu <iwai@alib.jp> 4.0.6-0vl2
252- add apt-cache showsrc option in apt4rpm patch (Patch0)
253
254* Thu Aug 15 2002 IWAI Masaharu <iwai@alib.jp> 4.0.6-0vl1
255- upstream update
256
257* Sun Aug 11 2002 IWAI Masaharu <iwai@alib.jp> 4.0.5-0vl1
258- upstream update
259- apt-cache showsrc option changed unavailable in apt4rpm patch (Patch0)
260
261* Tue Dec  4 2001 Kazuhisa TAKEI <takei@vinelinux.org> 4.0.4-0vl1
262- loading vine specific profile scripts moved from zshrc to zprofile
263- fixed other bug($PATH,zmodload)
264
265
266* Mon Aug 27 2001 Shoji Matsumoto <shom@vinelinux.org> 4.0.2-0vl3
267- rebuilding current Seed
268- change ssh completion (Patch1)
269
270* Thu Aug 16 2001 Kazuhisa TAKEI <takei@vinelinux.org> 4.0.2-0vl2
271- fixed bug rpm package name completions in _apt
272
273* Thu Jul 19 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.2-0vl1
274- 4.0.2
275
276* Sun Jun  3 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.1-0vl1
277- upstream 4.0.1 release
278- fixed bug zshrc( add /usr/X11R6/bin $PATH)
279- fixed lack 'Epoch:'
280
281* Thu Apr 26 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.1-0vl0.4.pre.3
282- fixed version number invalid
283
284* Fri Apr 20 2001 <sagami@vinelinux.org>
285- 4.0.1-0vl0.3.pre.4
286- install infopage/manpage and added PreReq = /sbin/install-info
287- fixed/added scripts in post/postun/preun for install-info
288
289* Fri Apr 13 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.1-0vl0.3.pre.3
290- upstream update
291- fixed /etc/zshrc bugs
292
293* Tue Apr  3 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.1-0vl0.0.pre.2
294- upstream update
295- remove all patches
296
297* Tue Oct  3 2000 Kazuhisa TAKEI<takei@vinelinux.org> 3.1.9-4vl1
298- can read /etc/profile.d/*.sh
299
300* Wed Sep 13 2000 Kazuhisa TAKEI<takei@vinelinux.org>
301- 3.1.9-4vl0
302- convert from Mandrake Linux to Vine Linux
303- add Japanise Summary and description
304
305* Sat Aug 26 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.9-4mdk
306- Set some %config file to (noreplace).
307- Make -A to complete spec file for _rpm.
308
309* Thu Jul 20 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.9-3mdk
310- Get /usr/share/man also in the completion for perl manpages.
311- BM.
312
313* Wed Jul  5 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.9-2mdk
314- Fix buildroot hardcoded in binary.
315
316* Wed Jun 21 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.9-1mdk
317- Use makeinstall macros (not easy this one :\).
318- 3.1.9.
319
320* Mon Jun  5 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.8-1mdk
321- 3.1.8.
322
323* Sun May 28 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev22-3mdk
324- Fix path (%{prefix}/ucb -> %{_bindir}/X11)
325- Fix keys (home-end-suppr-delete) directly in the zsh binary.
326
327* Sun Apr 16 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev22-2mdk
328- Remove doble .so in %{_libdir}/zsh/*.
329
330* Thu Apr 13 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev22-1mdk
331- 3.1.6dev22.
332
333* Fri Mar 31 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev20-3mdk
334- Fix completion of rpm with -qp*.
335
336* Mon Mar 27 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev20-2mdk
337- Upgrade zshguide.
338
339* Sat Mar 25 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev20-1mdk
340- 3.1.6-dev20
341
342* Wed Mar 22 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev19-3mdk
343- Move global configuration here.
344- Adjust groups.
345
346* Tue Feb 22 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev19-2mdk
347- Add new zshguide from pws.
348- Separate the doc to the doc package
349
350* Sun Feb 20 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev19-1mdk
351- Clean Up spec (thanks specs-helper).
352- Remove all our patchs (now all is commited to upstream main).
353- 3.1.6dev19.
354
355* Fri Feb 18 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev18-3mdk
356- Recompile with glibc2.1.3 (first one).
357
358* Thu Feb 17 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev18-2mdk
359- Add --freshen completion.
360
361* Tue Feb 15 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev18-1mdk
362- Fix descriptions and summary.
363- 3.1.6dev18.
364
365* Thu Feb 10 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev17-2mdk
366- Remove Makefile in %doc.
367- BuildRequires: autoconf tetex.
368- Lot of modications in the default config as suggested by Bart
369  Schaefer <schaefer@zsh.org>.
370- 3.1.6dev17.
371
372* Mon Jan 24 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev16-1mdk
373- dev16.
374- Redo the tar_archive patchs.
375
376* Tue Jan 18 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev15-1mdk
377- dev15.
378- Fix doc generation with dev15.
379- remove META-FAQ.
380- disable lfs on sparc.
381
382* Thu Jan  6 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev14-1mdk
383- dev14 (note the name change).
384
385* Mon Jan  3 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6pws13-3mdk
386- Remove temporary files.
387
388* Fri Dec 31 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
389- 3.1.6pws13 (mainly bug fixes).
390- fix %post.
391- fix rpm completion
392
393* Thu Dec 09 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
394- 3.1.6pws11 (mainly bug fixes).
395
396* Tue Dec  7 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
397- Add run-help and perl-build the documentation.
398
399* Tue Nov 30 1999 Francis Galiegue <francis@mandrakesoft.com>
400
401- Completion machine patch - we use GNU make and GNU tar
402- Small fix to %post script
403
404* Tue Nov 30 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
405- 3.1.6pws10
406- Fix zprofile.
407- Clean-up Franciseries.
408- Clean-up specs.
409
410* Mon Nov 29 1999 Francis Galiegue <francis@mandrakesoft.com>
411- Grrr... Rebuilt on kenobi, toy ain't a cooker
412
413* Mon Nov 29 1999 Francis Galiegue <francis@mandrakesoft.com>
414
415- Completion system now handles bzip2'ed manpages and tarballs
416- Some cool options
417
418* Wed Nov 10 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
419- Add zshguide.txt to documentation.
420
421* Thu Oct 07 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
422
423- Fix bug in %{_sysconfdir}/zsh use USERNAME instead of USER.
424- Improve %{_sysconfdir}/z* to source the /etc/profile.d/ files.
425
426* Mon Oct 04 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
427
428- 3.1.6-pws6
429- Fix bad link.
430- Fix bad manpages.
431
432* Tue Aug 17 1999 Thierry Vignaud <tvignaud@mandrakesoft.com>
433- fix typo in examples directory name
434
435* Sun Aug  8 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
436
437- Copy documentation (yes a lot).
438- Remove the completion machine and put them in [[ {etc,root}(skel|files) ]] package.
439
440* Sat Aug  7 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
441
442- By defaut we launch the completion machine.
443- Put zsh in %{_bindir}/
444- Rewrite of Spec file for this new major version.
445
446# end of file
Note: See TracBrowser for help on using the repository browser.