source: projects/specs/branches/6/z/zint/zint-vl.spec @ 3809

Revision 3809, 4.5 KB checked in by owa, 13 years ago (diff)

update:zint

Line 
1Summary: A barcode generator and library
2Summary(ja): Zintバーコード作成プログラム
3Name: zint
4Version: 2.4.2
5Release: 1%{?_dist_release}
6License: GPLv3+
7URL: http://www.zint.org.uk
8Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
9Patch0: zint-2.4.0-qr-kanji.patch
10Patch1: %{name}-rpath.patch
11Group: Applications/Engineering
12BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
13BuildRequires: cmake
14BuildRequires: libpng-devel
15BuildRequires: zlib-devel
16BuildRequires: qt4-devel
17BuildRequires: desktop-file-utils
18Distribution: Vine Linux
19Vendor: Project Vine
20Packager: owa
21
22%description
23Zint is a C library for encoding data in several barcode variants. The
24bundled command-line utility provides a simple interface to the library.
25Features of the library:
26- Over 50 symbologies including all ISO/IEC standards, like QR codes.
27- Unicode translation for symbologies which support Latin-1 and
28  Kanji character sets.
29- Full GS1 support including data verification and automated insertion of
30  FNC1 characters.
31- Support for encoding binary data including NULL (ASCII 0) characters.
32- Health Industry Barcode (HIBC) encoding capabilities.
33- Output in PNG, EPS and SVG formats with user adjustable sizes and colors.
34- Verification stage for SBN, ISBN and ISBN-13 data.
35
36%package devel
37Summary: Library and header files for %{name}
38Summary(ja): Zintバーコードの開発用ライブラリとヘッダファイル
39Group: Development/Libraries
40Requires: %{name} = %{version}-%{release}
41
42%description devel
43C library and header files needed to develop applications using %{name}.
44The API documentation can be found ont the project website:
45http://www.zint.org.uk/zintSite/Manual.aspx
46
47%package qt
48Summary: Zint Barcode Studio GUI and library
49Summary(ja): Zintバーコード作成GUI(QT)とライブラリ
50Group: Applications/Engineering
51Requires: %{name} = %{version}-%{release}
52BuildRequires: qt4-devel >= 4.4
53BuildRequires: desktop-file-utils
54
55%description qt
56Zint Barcode Studio is a Qt-based GUI which allows desktop users to generate
57barcodes which can then be embedded in documents or HTML pages, and a library
58which can be used to incorporate barcode generation functionality into other
59software.
60
61%package qt-devel
62Summary: Library and header files for %{name}-qt
63Summary(ja): ZintバーコードのGUI(QT)開発用ライブラリとヘッダファイル
64Group: Development/Libraries
65Requires: %{name}-devel = %{version}-%{release}
66Requires: %{name}-qt = %{version}-%{release}
67
68%description qt-devel
69C library and header files needed to develop applications using %{name}-qt.
70
71
72%prep
73%setup -q
74%patch0 -p 1 -b .qr-kanji
75%patch1 -p 1 -b .rpath
76
77# remove BSD-licensed file required for Windows only
78# (just to ensure that this package is plain GPLv3+)
79rm -f backend/ms_stdint.h
80# remove bundled getopt sources (we use the corresponding Fedora package instead)
81rm -f frontend/getopt*.*
82
83
84%build
85%cmake CMakeLists.txt
86make VERBOSE=1 %{?_smp_mflags}
87
88
89%install
90rm -rf $RPM_BUILD_ROOT
91make install DESTDIR=$RPM_BUILD_ROOT
92
93rm -rf $RPM_BUILD_ROOT/%{_datadir}/cmake
94
95cat <<EOF >%{name}-qt.desktop
96[Desktop Entry]
97Encoding=UTF-8
98Name=Zint Barcode Studio
99Name[ja]=Zintバーコードスタジオ
100Comment=Zint Barcode Studio
101Comment[ja]=バーコードを作成するツールです
102GenericName=Zint Barcode Studio
103Exec=zint-qt
104Icon=zint
105Terminal=false
106Type=Application
107Categories=Utility;
108EOF
109
110install -D -p -m 644 %{name}.png %{buildroot}/usr/share/pixmaps/%{name}.png
111install -D -p -m 644 %{name}-qt.desktop %{buildroot}%{_datadir}/applications/%{name}-qt.desktop
112desktop-file-validate %{buildroot}%{_datadir}/applications/%{name}-qt.desktop
113
114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%post -p /sbin/ldconfig
119%postun -p /sbin/ldconfig
120%post qt -p /sbin/ldconfig
121%postun qt -p /sbin/ldconfig
122%files
123%defattr(-,root,root,-)
124%doc COPYING readme
125%{_bindir}/%{name}
126%{_libdir}/libzint.so.*
127
128%files devel
129%defattr(-,root,root,-)
130%{_includedir}/%{name}.h
131%{_libdir}/libzint.so
132
133%files qt
134%defattr(-,root,root,-)
135%{_bindir}/%{name}-qt
136%{_libdir}/libQZint.so.*
137%{_datadir}/applications/%{name}-qt.desktop
138%{_datadir}/pixmaps/%{name}.png
139
140%files qt-devel
141%defattr(-,root,root,-)
142%{_includedir}/qzint.h
143%{_libdir}/libQZint.so
144
145
146%changelog
147* Sat May 07 2011 Shu KONNO <owa@bg.wakwak.com> 2.4.2-1
148- updated zint to 2.4.2
149- added %{name}-rpath.patch
150- added BR: qt4-devel, desktop-file-utils
151
152* Sat Nov 06 2010 Shu KONNO <owa@bg.wakwak.com> 2.4.0-2
153- added zint-2.4.0-qr-kanji.patch (BTS:1062)
154- install %{name}.png
155
156* Thu Oct 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.4.0-1
157- initial build for Vine
158
Note: See TracBrowser for help on using the repository browser.