source: projects/specs/trunk/z/zint/zint-vl.spec @ 2145

Revision 2145, 4.0 KB checked in by owa, 14 years ago (diff)

新規 zint

Line 
1Summary: A barcode generator and library
2Summary(ja): Zintバーコード作成プログラム
3Name: zint
4Version: 2.4.0
5Release: 1%{?_dist_release}
6License: GPLv3+
7URL: http://www.zint.org.uk
8Source: http://downloads.sourceforge.net/project/%{name}/%{name}/%{version}/%{name}-%{version}.src.tar.gz
9Group: Applications/Engineering
10BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
11BuildRequires: cmake
12BuildRequires: libpng-devel
13BuildRequires: zlib-devel
14Packager: owa
15
16%description
17Zint is a C library for encoding data in several barcode variants. The
18bundled command-line utility provides a simple interface to the library.
19Features of the library:
20- Over 50 symbologies including all ISO/IEC standards, like QR codes.
21- Unicode translation for symbologies which support Latin-1 and
22  Kanji character sets.
23- Full GS1 support including data verification and automated insertion of
24  FNC1 characters.
25- Support for encoding binary data including NULL (ASCII 0) characters.
26- Health Industry Barcode (HIBC) encoding capabilities.
27- Output in PNG, EPS and SVG formats with user adjustable sizes and colors.
28- Verification stage for SBN, ISBN and ISBN-13 data.
29
30%package devel
31Summary: Library and header files for %{name}
32Summary(ja): Zintバーコードの開発用ライブラリとヘッダファイル
33Group: Development/Libraries
34Requires: %{name} = %{version}-%{release}
35
36%description devel
37C library and header files needed to develop applications using %{name}.
38The API documentation can be found ont the project website:
39http://www.zint.org.uk/zintSite/Manual.aspx
40
41%package qt
42Summary: Zint Barcode Studio GUI and library
43Summary(ja): Zintバーコード作成GUI(QT)とライブラリ
44Group: Applications/Engineering
45Requires: %{name} = %{version}-%{release}
46BuildRequires: qt4-devel >= 4.4
47BuildRequires: desktop-file-utils
48
49%description qt
50Zint Barcode Studio is a Qt-based GUI which allows desktop users to generate
51barcodes which can then be embedded in documents or HTML pages, and a library
52which can be used to incorporate barcode generation functionality into other
53software.
54
55%package qt-devel
56Summary: Library and header files for %{name}-qt
57Summary(ja): ZintバーコードのGUI(QT)開発用ライブラリとヘッダファイル
58Group: Development/Libraries
59Requires: %{name}-devel = %{version}-%{release}
60Requires: %{name}-qt = %{version}-%{release}
61
62%description qt-devel
63C library and header files needed to develop applications using %{name}-qt.
64
65
66%prep
67%setup -q
68
69# remove BSD-licensed file required for Windows only (just to ensure that this package is plain GPLv3+)
70rm -f backend/ms_stdint.h
71# remove bundled getopt sources (we use the corresponding Fedora package instead)
72rm -f frontend/getopt*.*
73
74
75%build
76%cmake CMakeLists.txt
77make VERBOSE=1 %{?_smp_mflags}
78
79cat <<EOF >zint-qt.desktop
80[Desktop Entry]
81Encoding=UTF-8
82Name=Zint Barcode Studio
83Name[ja]=Zintバーコードスタジオ
84Comment=Zint Barcode Studio
85Comment[ja]=バーコードを作成するツールです
86GenericName=Zint Barcode Studio
87Exec=zint-qt
88Icon=zint
89Terminal=false
90Type=Application
91Categories=Utility;
92EOF
93
94
95%install
96rm -rf $RPM_BUILD_ROOT
97make install DESTDIR=$RPM_BUILD_ROOT
98
99rm -rf $RPM_BUILD_ROOT/%{_datadir}/cmake
100install -D -p -m 644 %{name}-qt.desktop %{buildroot}%{_datadir}/applications/%{name}-qt.desktop
101desktop-file-validate %{buildroot}%{_datadir}/applications/%{name}-qt.desktop
102
103
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107%post -p /sbin/ldconfig
108%postun -p /sbin/ldconfig
109%post -n %{name}-qt -p /sbin/ldconfig
110%postun -n %{name}-qt -p /sbin/ldconfig
111%files
112%defattr(-,root,root,-)
113%doc COPYING readme
114%{_bindir}/%{name}
115%{_libdir}/libzint.so.*
116
117%files devel
118%defattr(-,root,root,-)
119%{_includedir}/%{name}.h
120%{_libdir}/libzint.so
121
122%files qt
123%defattr(-,root,root,-)
124%{_bindir}/%{name}-qt
125%{_libdir}/libQZint.so.*
126%{_datadir}/applications/%{name}-qt.desktop
127
128%files qt-devel
129%defattr(-,root,root,-)
130%{_includedir}/qzint.h
131%{_libdir}/libQZint.so
132
133
134%changelog
135* Thu Oct 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.4.0-1
136- initial build for Vine
137
Note: See TracBrowser for help on using the repository browser.