source: projects/specs/branches/6/y/yelp/yelp-vl.spec @ 3357

Revision 3357, 11.4 KB checked in by Takemikaduchi, 13 years ago (diff)

WebKit?: new upstream release, yelp: bug fix

Line 
1%define glib2_version 2.26.0
2%define pango_version 1.28.3
3%define gtk2_version 2.22.0
4%define desktop_file_utils_version 0.17
5%define gnome_doc_utils_version 0.20.0
6%define rarian_version 0.7.0
7%define xulrunner_version 2.0
8%define gnome_common_version 2.28.0
9
10Summary: A system documentation reader from the Gnome project.
11Summary(ja): GNOME プロジェクトのシステムドキュメントリーダ
12Name: yelp
13Version: 2.30.2
14Release: 3%{?_dist_release}
15
16URL: http://live.gnome.org/Yelp
17Source0: %{name}-%{version}.tar.bz2
18Source10: man-convert-helper
19# http://bugzilla.gnome.org/show_bug.cgi?id=319096
20Patch1: yelp-2.15.5-fedora-docs.patch
21Patch2: yelp-2.30.2-add-mime-handling.patch
22Patch3: yelp-2.15.91-use-pango.patch
23# http://bugzilla.gnome.org/show_bug.cgi?id=497559
24Patch6: hp.patch
25Patch7: yelp-libxul.patch
26
27Patch10: yelp-2.26.0-convert-euc-manpages.patch
28
29Patch11: yelp-2.30.2-xul20.patch
30
31License: GPL
32Group: User Interface/Desktops
33BuildRoot: %{_tmppath}/%{name}-%{version}-root
34Requires: gtk2 >= %{gtk2_version}
35Requires: gnome-doc-utils >= %{gnome_doc_utils_version}
36Requires: xulrunner >= %{xulrunner_version}
37Requires: nkf
38BuildRequires: glib2-devel >= %{glib2_version}
39BuildRequires: pango-devel >= %{pango_version}
40BuildRequires: gtk2-devel >= %{gtk2_version}
41BuildRequires: GConf2-devel
42BuildRequires: libxml2-devel >= 2.6.5
43BuildRequires: libxslt-devel >= 1.1.4
44BuildRequires: zlib-devel
45BuildRequires: lzma-devel
46BuildRequires: bzip2-devel
47BuildRequires: startup-notification-devel >= 0.8
48BuildRequires: dbus-glib-devel
49BuildRequires: rarian-devel >= %{rarian_version}
50BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
51BuildRequires: xulrunner-devel >= %{xulrunner_version}
52BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
53BuildRequires: gnome-common >= %{gnome_common_version}
54
55%description
56Yelp is the Gnome 2 help/documentation browser. It is designed
57to help you browse all the documentation on your system in
58one central tool.
59
60%description -l ja
61Yelp は Gnome 2 のヘルプ/ドキュメントブラウザです。このツール
62によってシステム内の全てのドキュメントを参照できることを目標に
63作られています。
64
65%prep
66%setup -q
67%patch1 -p1 -b .fedora-docs
68%patch2 -p1 -b .add-mime-handling
69%patch3 -p1 -b .use-pango
70%patch6 -p1 -b .hp
71%patch7 -p1 -b .libxul
72%patch10 -p1 -b .convert
73%patch11 -p1 -b .xul20
74
75autoreconf -f -i
76
77%build
78%configure \
79    --with-gecko=libxul-embedding \
80    --with-search=basic \
81    --disable-schemas-install
82make
83
84%install
85rm -rf $RPM_BUILD_ROOT
86export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
87%makeinstall
88unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
89
90desktop-file-install --vendor=gnome --delete-original       \
91  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
92  --add-only-show-in GNOME                                  \
93  $RPM_BUILD_ROOT%{_datadir}/applications/*
94
95mkdir -p -m 755 $RPM_BUILD_ROOT/%{_datadir}/gnome/help
96
97install -m755 %{SOURCE10} $RPM_BUILD_ROOT%{_datadir}/yelp/
98
99%find_lang %{name}
100
101%clean
102rm -rf $RPM_BUILD_ROOT
103
104%post
105export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
106gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/yelp.schemas > /dev/null
107update-desktop-database %{_datadir}/applications >& /dev/null ||:
108update-mime-database %{_datadir}/mime >& /dev/null ||:
109
110touch %{_datadir}/icons/hicolor
111if [ -x /usr/bin/gtk-update-icon-cache ]; then
112  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
113fi
114
115%pre
116if [ "$1" -eq 0 ]; then
117  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
118  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/yelp.schemas >& /dev/null || :
119fi
120
121%preun
122if [ "$1" -eq 0 ]; then
123  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
124  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/yelp.schemas >& /dev/null || :
125fi
126
127%postun
128update-desktop-database %{_datadir}/applications >& /dev/null ||:
129update-mime-database %{_datadir}/mime >& /dev/null ||:
130
131%files -f %{name}.lang
132%defattr(-,root,root)
133%{_sysconfdir}/gconf/schemas/yelp.schemas
134%{_bindir}/*
135%{_datadir}/applications/*
136%dir %{_datadir}/gnome/help
137%{_datadir}/icons/hicolor/*
138%{_datadir}/yelp
139
140
141%changelog
142* Sat Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-3
143- update Patch2: yelp-2.30.2-add-mime-handling.patch
144
145* Wed Mar 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.2-2
146- rebuild with xulrunner-2.0
147- add Patch11 to build with xulrunner-2.0
148
149* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
150- new upstream release
151
152* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
153- new upstream release
154
155* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
156- new upstream release
157- change Requires: gecko-libs -> xulrunner
158- change BuildRequires: gecko-devel -> xulrunner-devel
159- drop Patch11
160
161* Mon Mar 01 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.1-1
162- new upstream release
163- build with xulrunner-1.9.2 (gecko-1.9.2)
164  - BR: gecko-devel instead of gecko-unstable-devel
165  - add patch11 to fix xulrunner-1.9.2 problem
166    - https://bugzilla.gnome.org/show_bug.cgi?id=603561
167    - http://git.gnome.org/browse/yelp/commit/?id=a5588114ed94d00ca64913aa5b248e09a5e13edc
168
169* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
170- new upstream release
171
172* Tue Aug 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
173- convert manpages from euc to utf8
174
175* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
176- rebuild with gecko-1.9.1
177
178* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
179- new upstream release
180- remove BR: libgnomeprintui-devel
181
182* Mon Jun 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.1-2
183- use xulrunner-1.9 for gecko libs instead of firefox
184- add Patch7,8,9 to build with xulrunner-1.9
185
186* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
187- new upstream release
188
189* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
190- new upstream release
191- added Patches from Fedora Core
192  * Mon Mar 31 2008 Jon McCann <jmccann@redhat.com> - 2.22.0-4
193  - Disallow launchers when running under GDM.
194  * Thu Mar 13 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2
195  - Add patch for RH bug #437328 (searching with Beagle broken).
196  * Fri Nov 16 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-7
197  - Handle .HP tags in man pages
198  * Wed Sep  6 2006 Matthias Clasen  <mclasen@redhat.com> - 2.16.0-2.fc6
199  - Actually apply the Pango patch
200  * Thu Dec 15 2005 David Malcolm <dmalcolm@redhat.com> - 2.13.2-2
201  - Patched to include DocBook mimetype in desktop file, and added preun and
202    post hooks to update-desktop-database (#175880)
203  - Patched to ensure that Yelp recognizes that it can handle the mimetype of
204    the documentation as reported by gnomevfs (also #175880)
205
206* Sat Jan 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
207- new upstream release
208- added BuildRequires: rarian-devel
209
210* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
211- rebuild with new environment/toolchain
212
213* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
214- new upstream release
215- drop Patch20
216
217* Thu Nov 16 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.3-0vl3
218- added Patch20 (<BTS:0314>)
219- add BuildRequires: libgnomeprintui-devel
220
221* Wed Oct 25 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
222- rebuild with firefox-2.0
223
224* Sun Oct 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
225- updated to 2.14.3
226- changed Group to User Interface/Desktops
227
228* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl2
229- add Patch10 to fix corruption of help option message.
230- add Japanese summary and description
231
232* Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
233- new upstream release
234
235* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
236- rebuild with firefox-1.5.0.2-0vl4
237
238* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
239- new upstream release
240- build with firefox-1.5.0.2
241
242* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
243- run gtk-update-icon-cache in %%post script.
244
245* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
246- new upstream release
247
248* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.6-0vl1
249- new upstream release
250
251* Thu Feb 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl2
252- rebuild with firefox-1.5.0.1
253
254* Fri Dec 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
255- new upstream release
256- build with firefox-1.5
257
258* Sat Sep 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
259- new upstream release
260- build with mozilla-1.7.12
261
262* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
263- new upstream release
264
265* Sat Aug 20 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.0-0vl4
266- rebuilt with mozilla-1.7.11 (doh! 0vl3 had stupid mistake in the changelog)
267
268* Fri May 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
269- rebuild with mozilla-1.7.8
270
271* Mon May 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
272- new upstream release
273
274* Sun Apr 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl4
275- rebuild with mozilla-1.7.7
276
277* Thu Apr 14 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl3
278- add Requires/BuildRequires to gnome-doc-utils
279
280* Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl2
281- include yelp.schemas
282- add versioned requires to mozilla
283
284* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl1
285- new upstream version
286- use mozilla's gecko engine, add Requires: mozilla
287
288* Mon Nov 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
289- new upstream release
290
291* Mon Dec 22 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
292- new upstream release
293- rebuild with new toolchains
294
295* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
296- new upstream release
297
298* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
299- new upstream release
300
301* Thu May 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0-0vl1
302- new upstream release
303
304* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
305- new upstream release
306
307* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
308- new upstream release
309- build for Vine Linux
310
311* Mon Nov 18 2002 Tim Powers <timp@redhat.com>
312- rebuild for all arches
313
314* Mon Aug 12 2002 Alexander Larsson <alexl@redhat.com>
315- Remove the strange copyright on the start page. Fixes #69106
316
317* Thu Aug  8 2002 Havoc Pennington <hp@redhat.com>
318- 1.0.2
319- include libexecdir stuff
320
321* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
322- rebuild with new gail
323- 1.0.1
324
325* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
326- automated rebuild
327
328* Tue Jun 18 2002 Havoc Pennington <hp@redhat.com>
329- put all the binaries in the file list... why is this package so hard?
330
331* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
332- put images in file list, this thing will be non-ugly yet
333
334* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
335- 1.0
336- use desktop-file-install to install/munge .desktop files
337- put the sgml stuff in file list
338
339* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
340- rebuild in different environment
341
342* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
343- 0.10
344
345* Sun May 26 2002 Tim Powers <timp@redhat.com>
346- automated rebuild
347
348* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
349- rebuild in different environment
350
351* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
352- 0.8
353
354* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
355- 0.6.1
356
357* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
358- 0.6
359
360* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
361- Rebuild for new gnome2 libraries
362
363* Mon Jan 28 2002 Alex Larsson <alexl@redhat.com>
364- Initial build.
Note: See TracBrowser for help on using the repository browser.