source: projects/specs/branches/6/y/yatex/yatex-vl.spec @ 6272

Revision 6272, 10.4 KB checked in by munepi, 12 years ago (diff)

new upstream release

RevLine 
[521]1%define _noVersionedDependencies        1
[6272]2#% define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
[521]3
[6272]4%if %{?_dist_release} <= "vl5"
5exit 1
6%endif
7
[521]8Name:          yatex
[6272]9Version:       1.76
10Release:       2%{?_dist_release}
[521]11License:       Distributable
12Source0:       http://www.yatex.org/yatex%{version}.tar.gz
[6272]13#Source0:       http://www.gentei.org/~yuuji/tmp/yatex11205111805.tar.gz
[521]14Source1:       %{name}-install.sh
15Source2:       %{name}-remove.sh
16Source3:       %{name}-init.el
17Source4:       vine-default-%{name}.el
[2599]18Source5:       vine-default-yahtml.el
[521]19
20## Vine Patch(es)
21Patch1:        yatexhlp-emacs.diff
22Patch2:        yatex-make.diff
23# based on a patch at http://www.nekolinux.2y.net/nekomemo/yahtml01.html
24# and modified to suit 1.70 release
25Patch3:        yahtml-1.70-timestamp.patch
26
[6272]27Patch10:       yatex-1.76-vine-vl7.patch
28Patch11:       yatex-1.76-vine-vl6.patch
29
[521]30URL:           http://www.yatex.org/
31Group:         Applications/Editors/Emacs
32BuildRoot:     %{_tmppath}/%{name}-%{version}-root
33Summary:       YaTeX - Yet Another TeX mode for Emacs
34Summary(ja):   野鳥(YaTeX) - Yet Another TeX mode for Emacs
35BuildArch:     noarch
36
[6272]37Requires(post): emacsen
38Requires(post): emacsen-common
[5643]39Requires(post): make
[521]40BuildRequires: emacsen-common
[6272]41BuildRequires: nkf perl
[521]42Obsoletes:     yatex-xemacs
43
44Distribution:  Vine Linux
45Vendor:        Project Vine
[6272]46Packager:      munepi
[521]47
48%description
49YaTeX is an intelligent, acquisitive and integrated package which reduces
50your efforts of composing LaTeX source on GNU Emacs.
51
[2750]52
53If you are YaTeX user and you install both yatex and auctex on your system,
54you may add the following configure in your emacs init file
55~/.emacs.d/emacsXX-vine-default.el (XX: emacs major version):
56
[6272]57;; I am a YaTeX user!!!
[2750]58(setq vine-default-auctex nil
59      vine-default-preview-latex nil)
60
61
[521]62%description -l ja
63YaTeX(野鳥)とは、EmacsでLaTeXソースを書くときに生ずる手間を軽減
64してくれる、LaTeX 入力支援環境です。
65
66
[2750]67yatex と auctex パッケージの両方をインストールする場合、
68~/.emacs.d/emacsXX-vine-default.el (XX: emacs のメジャーバージョン)
69に以下の設定を追加するとよいでしょう。
70
71;; YaTeX ユーザです!!!
72(setq vine-default-auctex nil
73      vine-default-preview-latex nil)
74
75
[521]76%prep
77%setup -n yatex%{version}
78%patch1 -p1
79%patch2 -p1
80%patch3 -p1
81
[6272]82%if %{?_dist_release} == "vl7"
83%patch10 -p1 -b .vine
84%elseif %{?_dist_release} == "vl6"
85%patch11 -p1 -b .vine
86%endif
[521]87
[2599]88(cd docs
[6272]89    # change permissions
[2599]90    chmod 644 *
[6272]91
92    # encode as utf-8 (LF)
93    # NOTE: This changes needs to entry info files to Info DIR
94    for i in yatexj yatexe yahtmlj yahtmle; do nkf --unix -w --overwrite $i; done
[521]95)
96
97
[6272]98%build
99
100
[521]101%install
102
[2599]103[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
[521]104
[2599]105%__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
106%__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
107%__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
108%__mkdir_p ${RPM_BUILD_ROOT}%{_infodir}
[521]109
110
111#
112# install el files
113#
114
[2599]115%__cp -a *.el makefile help \
116      ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}
117%__cp -a %{SOURCE3} %{SOURCE4} %{SOURCE5} \
118      ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
[521]119
120#
121# install info files
122#
123
[2599]124%__install -m 644 docs/{yahtmle,yahtmlj,yatexe,yatexj} \
[521]125   ${RPM_BUILD_ROOT}%{_infodir}
126
127
128#
129# install script (bytecompile el and install elc, remove)
130#
131
132%_installemacsenscript %{name} %{SOURCE1}
133
134%_removeemacsenscript  %{name} %{SOURCE2}
135
136
137%clean
[2599]138[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
[521]139
140
141%post
142#
143# bytecompile and install
144#
145
146if [ "$1" = 2 ] ; then
147
148%_emacsenPackageRemove %{name}
149
150fi
151
152%_addemacsenlist %{name}
153
154%_emacsenPackageInstall %{name}
155
[6272]156for i in yatexe yatexj yahtmle yahtmlj; do
157    /sbin/install-info --dir-file %{_infodir}/dir --section="Emacs" \
158                       %{_infodir}/${i}.gz
159done
[521]160
161
162%preun
163
164if [ "$1" = 0 ]; then
165
166%_emacsenPackageRemove %{name}
167
168%_removeemacsenlist %{name}
169
[6272]170for i in yatexe yatexj yahtmle yahtmlj; do
171    /sbin/install-info --delete --dir-file %{_infodir}/dir --section="Emacs" \
172                       %{_infodir}/${i}.gz
173done
[521]174
175fi
176
177
178%files
179%defattr(-,root,root)
180%doc 00readme install manifest yatex.new
181%doc docs
182
183%{_datadir}/emacs/site-lisp/yatex/
[6272]184%{_infodir}/yahtmle*
185%{_infodir}/yahtmlj*
186%{_infodir}/yatexe*
187%{_infodir}/yatexj*
[521]188%{emacsen_pkgdir}/install/%{name}
189%{emacsen_pkgdir}/remove/%{name}
190
191
[5643]192%changelog
[6272]193* Tue May 22 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.76-2
194- new upstream release
195- updated yatex-1.76-vine-vl{6,7}.patch
196
197* Sat May 12 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.76-1.20120511
198- source snapshot 20120511: testing version 1.76 development
199- dropped obsoleted/upstreamed patches
200- applied yatex-1.76-vine-vl{6,7}.patch
201
202* Fri May 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.75-3
203- added BuildRequires: nkf perl
204- updated yatex-1.74-vine.patch as yatex-1.75-vine-vl{6,7}.patch
205- dropped pre-formatted info files
206- use original info files
207  - encode info files as utf-8
208  - add INFO-DIR-ENTRY
209
210* Thu May 10 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.75-2
211- fixed vine-default-yatex.el
212- applied yatex-1.74-vine.patch for vl6
213- updated yatex-1.74-vine.patch: support some extensions for \includegraphics
214
215* Thu Feb  9 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.75-1
216- new upstream release
217- updated vine-default-yatex.el
218
219* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-9
220- support TeX Live 2011
221- applied yatex-1.74-vine-vl7.patch
222- updated vine-default-yatex.el
223
224* Thu Aug 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-8
[5643]225- added Requires(post): make
[6272]226
[3482]227* Sat Apr 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-7
228- updated vine-default-yatex.el
229  - check 'YaTeX-inhibit-prefix-letter
230  - used "pbibtex -kanji=utf8" as default bibtex-command
231  - used "mendex -U" as default makeindex-command
232
[3080]233* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-6
234- updated vine-default-{yatex,yahtml}.el
235  - revived auto-fill-mode on {yatex,yahtml}-mode
236
[2750]237* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-5
238- updated yatex-init.el
239  - dropped all pathes of auctex and preview-latex from load-path
240
[2599]241* Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-4
242- updated vine-default-yatex.el
243  - added (setq YaTeX-inhibit-prefix-letter t) [yatex:04567]
244  - supported TeX Live
245    - used "eplatex", "pxdvi", "pdvips" as default commands
246- updated yatex-init.el
247  - output "Loading vine-default-yatex ..." to the buffer *Messages*
248  - defined vine-default-yahtml
249- added vine-default-yahtml.el
250
[2443]251* Tue Jan 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-3
252- updated vine-default-yatex.el
253  - added bbl extension in auto-mode-alist to run yatex-mode
254
255* Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-2
256- updated vine-default-yatex.el
257  - supported new vine-default
258
[521]259* Mon Jan 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-1
260- new upstream release
261
262* Sun Oct 18 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.73-7
263- updated vine-default-yatex.el
264  - dropped (setq YaTeX-no-begend-shortcut t)
265- use %{emacsen_pkgdir}
266
267* Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-6
268- updated vine-default-yatex.el
269  - (setq tex-command "platex -kanji=utf8 -src-specials") [VineSeed:17572]
270
271* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-5
272- updated yatex-install.sh
273  - *-init.el: changed from hard copy to symbolic link
274    on /etc/emacs-XX.YY/site-start.d
275
276* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-4
277- fixed yatex-init.el
278
279* Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-3
280- added yatex-init.el, vine-default-yatex.el
281- updated yatex-install.sh, yatex-remove.sh for vine-default-yatex.el
282
283* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-2
284- spec in utf8
285
286* Sat Jun 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.73-1
287- applied new versioning policy
288
289* Wed Aug 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.73-0vl1
290- new upstream release
291
292* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.72-0vl2
293- s/Copyright/License/
294- changed Group to Applications/Editors/Emacs <BTS:VineLinux:163>
295
296* Sun Feb 01 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.72-0vl1
297- update yatex-1.72
298
299* Wed May 07 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.71-0vl1
300- update yatex-1.71
301
302* Fri Jul 17 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.70-0vl2
303- added Patch3 to add hhmts timestamp feature
304
305* Tue May 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.70-0vl1
306- update yatex-1.70
307
308* Tue May 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.69-0vl0.1
309- update yatex10203151806
310
311* Wed Mar 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.68-0vl4
312- fixed: bytecompile yatex19
313
314* Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.68-0vl3
315- now emacsen-common aware
316- FIXME: newer upstream 1.69.2 do not work fine with xemacs-21.1.14
317
318* Wed Oct 11 2000 Jun Nishii <jun@vinelinux.org>
319- 1.68-0vl2
320- no kanji code conversion of documents
321
322* Tue Sep 19 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
323- 1.68-0vl1
324- update to 1.68
325
326* Wed Jul 05 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
327- 1.67-6vl5
328- YATEXHLP.{jp,eng} moved to appropriate dir
329
330* Thu Jun 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
331- 1.67-6vl3
332- rebuilt for emacs-20.7
333
334* Thu May 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
335- 1.67-6vl2
336- oops ... fixed target dir for help files
337
338* Tue May 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
339- 1.67-6vl1
340- rebuilt for emacs-20.6
341
342* Tue Jan 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
343- 1.67-6
344- included forgotten info file for YaHTML
345
346* Fri Jan 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
347- 1.67-5
348- updated for emacs-20.5a release
349
350* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
351- 1.67-4
352- change Group to Applications/Editors/EmacsLisp
353
354* Sun Nov 28 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
355- 1.67-3
356- %post and %preun section modified
357
358* Thu Sep 23 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
359- 1.67-2
360- fixed minor problem in the %files section
361
362* Sat Sep 18 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
363- 1.67-1
364- updated to 1.67 release
365- rebuilt for emacs-20.4 on Vine Linux 1.9
366- updated URL for the new web site of YaTeX
367- some typo fix
368
369* Tue May  4 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
370- Initial Release
Note: See TracBrowser for help on using the repository browser.