source: projects/specs/branches/6/y/yatex/yatex-vl.spec @ 5643

Revision 5643, 9.4 KB checked in by munepi, 12 years ago (diff)

updated yatex

Line 
1%define _noVersionedDependencies        1
2%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3
4Name:          yatex
5Version:       1.74
6Release:       8%{?_dist_release}
7License:       Distributable
8Source0:       http://www.yatex.org/yatex%{version}.tar.gz
9#Source0:       http://www.yatex.org/yatex10203151806.tar.gz
10Source1:       %{name}-install.sh
11Source2:       %{name}-remove.sh
12Source3:       %{name}-init.el
13Source4:       vine-default-%{name}.el
14Source5:       vine-default-yahtml.el
15
16## pre-formatted info files here
17Source10:      yatexe
18Source11:      yatexj
19Source12:      yahtmle
20Source13:      yahtmlj
21
22## Vine Patch(es)
23Patch0:        yatex-info.diff
24Patch1:        yatexhlp-emacs.diff
25Patch2:        yatex-make.diff
26# based on a patch at http://www.nekolinux.2y.net/nekomemo/yahtml01.html
27# and modified to suit 1.70 release
28Patch3:        yahtml-1.70-timestamp.patch
29
30URL:           http://www.yatex.org/
31Group:         Applications/Editors/Emacs
32BuildRoot:     %{_tmppath}/%{name}-%{version}-root
33Summary:       YaTeX - Yet Another TeX mode for Emacs
34Summary(ja):   野鳥(YaTeX) - Yet Another TeX mode for Emacs
35BuildArch:     noarch
36
37PreReq:        emacsen
38%prereq_ge     emacsen-common
39Requires(post): make
40BuildRequires: emacsen-common
41Obsoletes:     yatex-xemacs
42
43Distribution:  Vine Linux
44Vendor:        Project Vine
45
46
47%description
48YaTeX is an intelligent, acquisitive and integrated package which reduces
49your efforts of composing LaTeX source on GNU Emacs.
50
51
52If you are YaTeX user and you install both yatex and auctex on your system,
53you may add the following configure in your emacs init file
54%if %{?_dist_release} == "vl5"
55~/.emacs.el:
56%else
57~/.emacs.d/emacsXX-vine-default.el (XX: emacs major version):
58%endif
59
60;; I am YaTeX user!!!
61(setq vine-default-auctex nil
62      vine-default-preview-latex nil)
63
64
65%description -l ja
66YaTeX(野鳥)とは、EmacsでLaTeXソースを書くときに生ずる手間を軽減
67してくれる、LaTeX 入力支援環境です。
68
69
70yatex と auctex パッケージの両方をインストールする場合、
71%if %{?_dist_release} == "vl5"
72~/.emacs.el:
73%else
74~/.emacs.d/emacsXX-vine-default.el (XX: emacs のメジャーバージョン)
75%endif
76に以下の設定を追加するとよいでしょう。
77
78;; YaTeX ユーザです!!!
79(setq vine-default-auctex nil
80      vine-default-preview-latex nil)
81
82
83%prep
84%setup -n yatex%{version}
85%patch0 -p1
86%patch1 -p1
87%patch2 -p1
88%patch3 -p1
89
90
91%build
92
93(cd docs
94    chmod 644 *
95    %__install -v -m 644 %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} .
96)
97
98
99%install
100
101[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
102
103%__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
104%__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
105%__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
106%__mkdir_p ${RPM_BUILD_ROOT}%{_infodir}
107
108
109#
110# install el files
111#
112
113%__cp -a *.el makefile help \
114      ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}
115%__cp -a %{SOURCE3} %{SOURCE4} %{SOURCE5} \
116      ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
117
118#
119# install info files
120#
121
122%__install -m 644 docs/{yahtmle,yahtmlj,yatexe,yatexj} \
123   ${RPM_BUILD_ROOT}%{_infodir}
124
125
126#
127# install script (bytecompile el and install elc, remove)
128#
129
130%_installemacsenscript %{name} %{SOURCE1}
131
132%_removeemacsenscript  %{name} %{SOURCE2}
133
134
135%clean
136[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
137
138
139%post
140#
141# bytecompile and install
142#
143
144if [ "$1" = 2 ] ; then
145
146%_emacsenPackageRemove %{name}
147
148fi
149
150%_addemacsenlist %{name}
151
152%_emacsenPackageInstall %{name}
153
154
155/sbin/install-info %{_infodir}/yatexe.gz %{_infodir}/dir \
156  --section="Emacs"
157/sbin/install-info %{_infodir}/yatexj.gz %{_infodir}/dir \
158  --section="Emacs"
159/sbin/install-info %{_infodir}/yahtmle.gz %{_infodir}/dir \
160  --section="Emacs"
161/sbin/install-info %{_infodir}/yahtmlj.gz %{_infodir}/dir \
162  --section="Emacs"
163
164
165%preun
166
167if [ "$1" = 0 ]; then
168
169%_emacsenPackageRemove %{name}
170
171%_removeemacsenlist %{name}
172
173/sbin/install-info --delete %{_infodir}/yatexe.gz %{_infodir}/dir \
174  --section="Emacs"
175/sbin/install-info --delete %{_infodir}/yatexj.gz %{_infodir}/dir \
176  --section="Emacs"
177/sbin/install-info --delete %{_infodir}/yahtmle.gz %{_infodir}/dir \
178  --section="Emacs"
179/sbin/install-info --delete %{_infodir}/yahtmlj.gz %{_infodir}/dir \
180  --section="Emacs"
181
182fi
183
184
185%files
186%defattr(-,root,root)
187%doc 00readme install manifest yatex.new
188%doc docs
189
190%{_datadir}/emacs/site-lisp/yatex/
191%{_infodir}/*
192%{emacsen_pkgdir}/install/%{name}
193%{emacsen_pkgdir}/remove/%{name}
194
195
196%changelog
197* Tue Feb 14 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-8
198- added Requires(post): make
199 
200* Sat Apr 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-7
201- updated vine-default-yatex.el
202  - check 'YaTeX-inhibit-prefix-letter
203  - used "pbibtex -kanji=utf8" as default bibtex-command
204  - used "mendex -U" as default makeindex-command
205
206* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-6
207- updated vine-default-{yatex,yahtml}.el
208  - revived auto-fill-mode on {yatex,yahtml}-mode
209
210* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-5
211- updated yatex-init.el
212  - dropped all pathes of auctex and preview-latex from load-path
213
214* Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-4
215- updated vine-default-yatex.el
216  - added (setq YaTeX-inhibit-prefix-letter t) [yatex:04567]
217  - supported TeX Live
218    - used "eplatex", "pxdvi", "pdvips" as default commands
219- updated yatex-init.el
220  - output "Loading vine-default-yatex ..." to the buffer *Messages*
221  - defined vine-default-yahtml
222- added vine-default-yahtml.el
223
224* Tue Jan 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-3
225- updated vine-default-yatex.el
226  - added bbl extension in auto-mode-alist to run yatex-mode
227
228* Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-2
229- updated vine-default-yatex.el
230  - supported new vine-default
231
232* Mon Jan 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-1
233- new upstream release
234
235* Sun Oct 18 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.73-7
236- updated vine-default-yatex.el
237  - dropped (setq YaTeX-no-begend-shortcut t)
238- use %{emacsen_pkgdir}
239
240* Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-6
241- updated vine-default-yatex.el
242  - (setq tex-command "platex -kanji=utf8 -src-specials") [VineSeed:17572]
243
244* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-5
245- updated yatex-install.sh
246  - *-init.el: changed from hard copy to symbolic link
247    on /etc/emacs-XX.YY/site-start.d
248
249* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-4
250- fixed yatex-init.el
251
252* Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-3
253- added yatex-init.el, vine-default-yatex.el
254- updated yatex-install.sh, yatex-remove.sh for vine-default-yatex.el
255
256* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-2
257- spec in utf8
258
259* Sat Jun 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.73-1
260- applied new versioning policy
261
262* Wed Aug 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.73-0vl1
263- new upstream release
264
265* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.72-0vl2
266- s/Copyright/License/
267- changed Group to Applications/Editors/Emacs <BTS:VineLinux:163>
268
269* Sun Feb 01 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.72-0vl1
270- update yatex-1.72
271
272* Wed May 07 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.71-0vl1
273- update yatex-1.71
274
275* Fri Jul 17 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.70-0vl2
276- added Patch3 to add hhmts timestamp feature
277
278* Tue May 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.70-0vl1
279- update yatex-1.70
280
281* Tue May 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.69-0vl0.1
282- update yatex10203151806
283
284* Wed Mar 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.68-0vl4
285- fixed: bytecompile yatex19
286
287* Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.68-0vl3
288- now emacsen-common aware
289- FIXME: newer upstream 1.69.2 do not work fine with xemacs-21.1.14
290
291* Wed Oct 11 2000 Jun Nishii <jun@vinelinux.org>
292- 1.68-0vl2
293- no kanji code conversion of documents
294
295* Tue Sep 19 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
296- 1.68-0vl1
297- update to 1.68
298
299* Wed Jul 05 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
300- 1.67-6vl5
301- YATEXHLP.{jp,eng} moved to appropriate dir
302
303* Thu Jun 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
304- 1.67-6vl3
305- rebuilt for emacs-20.7
306
307* Thu May 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
308- 1.67-6vl2
309- oops ... fixed target dir for help files
310
311* Tue May 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
312- 1.67-6vl1
313- rebuilt for emacs-20.6
314
315* Tue Jan 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
316- 1.67-6
317- included forgotten info file for YaHTML
318
319* Fri Jan 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
320- 1.67-5
321- updated for emacs-20.5a release
322
323* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
324- 1.67-4
325- change Group to Applications/Editors/EmacsLisp
326
327* Sun Nov 28 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
328- 1.67-3
329- %post and %preun section modified
330
331* Thu Sep 23 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
332- 1.67-2
333- fixed minor problem in the %files section
334
335* Sat Sep 18 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
336- 1.67-1
337- updated to 1.67 release
338- rebuilt for emacs-20.4 on Vine Linux 1.9
339- updated URL for the new web site of YaTeX
340- some typo fix
341
342* Tue May  4 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
343- Initial Release
Note: See TracBrowser for help on using the repository browser.