source: projects/specs/branches/6/x/xorg-x11-drv-intel/xorg-x11-drv-intel-vl.spec @ 6591

Revision 6591, 20.3 KB checked in by daisuke, 12 years ago (diff)

disable dri on sandybridge

Line 
1%define moduledir %(pkg-config xorg-server --variable=moduledir )
2%define driverdir       %{moduledir}/drivers
3%define gputoolsdate 20100625
4
5Summary:   Xorg X11 Intel video driver
6Summary(ja):   Xorg X11 Intel ビデオドライバ
7Name:      xorg-x11-drv-intel
8Epoch:     1
9Version:   2.17.0
10Release:   7%{?_dist_release}
11URL:       http://intellinuxgraphics.org/
12License:   MIT
13Group:     User Interface/X Hardware Support
14
15Source0:   http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
16Source2:   intel.xinf
17Source3:   intel-gpu-tools-%{gputoolsdate}.tar.bz2
18
19# Clamp VGA pixel clock to 250MHz,
20# anything higher's going to look awful anyway. (#559426)
21Patch10: intel-2.11.0-vga-clock-max.patch
22
23# import from ubuntu/debian package
24Patch101: 101_copy-fb.patch
25Patch103: 103_fix_uxa_fill_spans.patch
26Patch104: 104_uxa_fix_gtt_mapping_limits.patch
27
28# vine patch
29Patch200: intel-2.17.0-dri2proto26.patch
30Patch210: intel-2.17.0-ivybridge-disable-dri.patch
31Patch220: intel-2.17.0-ivybridge-disable-accell.patch
32
33ExclusiveArch: %{ix86} x86_64 ia64
34BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
35BuildRequires: autoconf, automake, libtool
36BuildRequires: xorg-x11-server-sdk >= 1.7.99
37BuildRequires: libXvMC-devel
38BuildRequires: libGL-devel >= 7.10
39BuildRequires: libdrm-devel >= 2.4.25
40BuildRequires: kernel-headers >= 2.6.33
41BuildRequires: libudev-devel
42BuildRequires: libxcb-devel >= 1.5
43BuildRequires: xcb-util-devel
44
45Requires:  hwdata
46Requires:  xorg-x11-server-Xorg
47Requires:  xcb-util
48
49Obsoletes: xorg-x11-drv-i810
50Provides: xorg-x11-drv-i810
51
52#Conflicts:  kudzu < 1.2.42-1
53
54Vendor: Project Vine
55Distribution: Vine Linux
56
57%description
58X.Org X11 Intel video driver.
59
60%package devel
61Summary:   Xorg X11 Intel video driver XvMC development package
62Summary(ja):   Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
63Group:     Development/System
64Requires:  %{name} = %{epoch}:%{version}-%{release}
65Provides:  xorg-x11-drv-intel-devel = %{version}-%{release}
66
67%description devel
68X.Org X11 Intel video driver XvMC development package.
69
70%package -n intel-gpu-tools
71Summary:    Debugging tools for Intel graphics chips
72Group:      Development/Tools
73
74%description -n intel-gpu-tools
75Debugging tools for Intel graphics chips
76
77
78%prep
79%setup -q -n xf86-video-intel-%{version} -b3
80
81%patch10 -p1 -b .vga-clock
82
83%patch101 -p1 -b .copy-fb
84%patch103 -p1 -b .fix_uxa_fill_spans
85%patch104 -p1 -b .uxa_fix_gtt_mapping_limits.patch
86
87%patch200 -p1 -b .dri2proto
88%patch210 -p1 -b .ivybridge-disable-dri
89%patch220 -p1 -b .ivybridge-disable-accel
90
91%build
92autoreconf -vi
93
94%configure \
95  --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
96  --enable-dri --enable-xvmc
97make
98
99pushd ../intel-gpu-tools-%{gputoolsdate}
100autoreconf -v --install
101%configure
102make
103popd
104
105
106%install
107rm -rf $RPM_BUILD_ROOT
108
109make install DESTDIR=$RPM_BUILD_ROOT
110mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
111install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
112
113pushd ../intel-gpu-tools-%{gputoolsdate}
114make install DESTDIR=$RPM_BUILD_ROOT
115popd
116
117
118find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
119
120%clean
121rm -rf $RPM_BUILD_ROOT
122
123%triggerpostun -- XOrg < 7.0
124if (grep -q i810 /etc/X11/xorg.conf)
125then
126  cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
127  sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
128fi ||:
129
130%files
131%defattr(-,root,root,-)
132%{driverdir}/intel_drv.so
133%{_datadir}/hwdata/videoaliases/intel.xinf
134%{_libdir}/libI810XvMC.so.*
135%{_libdir}/libIntelXvMC.so.*
136%{_mandir}/man4/i*
137
138%files devel
139%defattr(-,root,root,-)
140%{_libdir}/libI810XvMC.so
141%{_libdir}/libIntelXvMC.so
142
143%files -n intel-gpu-tools
144%defattr(-,root,root,-)
145%{_bindir}/intel_*
146%{_mandir}/man1/intel_*.1*
147
148
149%changelog
150* Wed Jul 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-7
151- disable dri on sandybridge again.
152
153* Mon Jul 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-6
154- rebuild with libdrm-2.4.33
155
156* Wed Jul 04 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-5
157- add patch220 to disable some acceleration on IvyBridge.
158
159* Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-4
160- import patch103,104 from ubuntu (cherry picked upstream patch)
161- add patch210 to disable dri on IvyBridge
162
163* Mon Feb 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-3
164- add patch200 to build with dri2proto < 2.6 (for Vine6)
165
166* Sat Nov 26 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-2
167- disable sna/vmap
168
169* Fri Nov 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
170- new upstram release
171- disable copy-fb patch
172
173* Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-3
174- rebuild with xserver-1.11.1.902
175
176* Wed Aug 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-2
177- add --enable-sna --enable-vmap
178
179* Wed Aug 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
180- new upstream release
181
182* Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.15.0-6
183- rebuild with xcb-util-0.3.8
184- drop Patch200
185
186* Tue Jul 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-5
187- update to disable copy_fb on sandybridge/ivybridge
188
189* Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
190- update intel.xinf
191- add patch10 from fedora
192  - Clamp VGA pixel clock to 250MHz,
193    anything higher's going to look awful anyway. (#559426)
194
195* Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
196- drop patch1-3 and replaced with new patch1 from git master
197- add Patch200 to disable DRI on SandyBridge/IvyBridge
198- update intel-gpu-tools
199
200* Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
201- add Patch1-3 from upstream
202
203* Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
204- new upstream release
205- drop upstream patches: 107-115
206- temporary disabled patch101
207- BR: libdrm >= 2.4.25
208
209* Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
210- add Patch101-115 from ubuntu/debian package
211  - Patch101: Plymouth integration patch
212  - Patch107: Check null return from uxa_acquire_solid()
213  - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
214  - Patch109: Fix font corruption (missing glyphs) on rotated screens.
215  - Patch110,114: Cherry picks to fix a large number of build warnings.
216  - Patch111: Fix clipped window plane offset
217  - Patch112: Fix issue where vertical green line and strange colors
218              shows up when playing gstreamer with certain videos,
219              when dragged.  (LP 460677)
220  - Patch113: Fixes GPU lockup during login with
221              "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
222              error messages listed in the gpu dump text. (LP 710321)
223  - Patch115: Don't fill up Xorg.0.log with
224              "get vblank counter failed: Invalid argument" warnings.
225   
226* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
227- rebuild with xserver-1.10.0
228
229* Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
230- new upstream release
231
232* Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
233- new upstream release
234
235* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
236- rebuild with xserver-1.9.2
237
238* Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
239- new upstream release
240- add Patch40: fix uxa planemask (backported)
241- add Patch61: add support for backlight on macbooks
242- add Patch62: disable page flipping for stability
243
244* Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
245- new upstream release
246- drop patch70
247
248* Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
249- rebuild again with xserver-1.8rc
250
251* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
252- add intel-gpu-tools as sub-package
253- rebuild with libdrm-2.4.18
254
255* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
256- new upstream release
257- import Patch1,2,60,70 from fedora
258- add BR: kernel-headers >= 2.6.33 (new drm header required)
259- add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
260- add BR; libudev-devel and autoreconf for Patch60
261
262* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
263- rebuild with libdrm-2.4.17
264
265* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
266- new upstream release
267
268* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
269- new upstream release (hopefully fixes severe issues w/ efifb)
270- drop all patches already upstreamed; import Patch20/21 from Fedora
271
272* Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
273- import Patch121,122 from ubuntu
274- build with libdrm-2.4.12 which fixes vt switch crash
275
276* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
277- apply patch114 to fix Xv with non-GEM kernel
278
279* Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
280- update to 2.6.3
281- add patch106,107,115,118,119,120 from ubuntu
282  - add Patch106: remove triple buffering
283  - add Patch107: remove page flipping
284  - add Patch115: fix crash Xv overlay
285  - add Patch118: drop legacy3d
286  - add Patch119: fix crashes in drm bo
287  - add Patch120: fix vt switch
288- add patch130-134 from upstream git
289  - add Patch130: fix another vt switch leak
290  - add Patch131: Create known output configuration at EnterVT time
291  - add Patch132: fix leak of some 965 render state on VT switch
292  - add Patch133: fix crash with fake bufmgr and UXA
293  - add Patch134: fix EnterVT/LeaveVT
294  - add Patch135: add new chip supoprt
295
296
297* Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
298- revert to 2.6.1, add Epoch
299- add Patch103-121 from ubuntu
300
301* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
302- new upstream release
303
304* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
305- new upstream release
306
307* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
308- new upstream release
309
310* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
311- add Patch5 - Dont die on irq handler failure
312
313* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
314- new upstream release
315- add BR: libdrm-devel >= 2.4.0-3
316
317* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
318- import Patch10,11,12 from ubuntu
319
320* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
321- new upstream release
322- add triggerpostun script to replace i810 driver to intel driver
323
324* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
325- new upstream release
326
327* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
328- new upstream release
329- rename i810.xinf to intel.xinf
330- update intel.xinf (add Intel 4 series)
331
332* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
333- rebuild with new xserver
334
335* Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
336- new upstream release
337
338* Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
339- new upstream release
340
341* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
342- new upstream release
343
344* Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
345- initial build for Vine Linux
346
347* Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
348- Rebuild for new server ABI.
349- intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
350
351* Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
352- hook up ch7017 (bz#408471)
353
354* Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
355- xf86-video-intel 2.2.0
356
357* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
358- xf86-video-intel 2.1.99.
359- Drop the i810 driver.  Time to move on.
360- Require xserver 1.4.99.1
361
362* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
363- intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
364
365* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
366- intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
367  for textured Xv to use as an offscreen pixmap so xv actually works under
368  compiz - granted it may be unusably slow but at least stuff shows up.
369
370* Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
371- intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
372- intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
373
374* Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
375- intel-2.1.1-quirk-update.patch - update quirks from master
376
377* Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
378- i810.xinf: Flip everything over to -intel by default now.  Still install
379  i810 driver just in case.
380
381* Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
382- intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
383
384* Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
385- xf86-video-intel 2.1.1.
386
387* Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
388- xf86-video-intel 2.1.0.
389
390* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
391- Update Requires and BuildRequires.
392
393* Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
394- Update to git master.  Many Xv and DVO fixes.  Adds support for 945GME,
395  965GME, G33, Q33, and Q35 chips.
396
397* Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
398- intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
399  DRI clients are active, for better battery life.
400
401* Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
402- Rebuild for final RANDR 1.2 ABI.  Fixes segfault at startup. (#238575)
403
404* Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
405- xf86-video-intel 2.0.0.  Change the version number to match, why not.
406- Add a Virtual provides for xorg-x11-drv-intel, since we should probably
407  rename this at some point.
408
409* Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
410- i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
411  915GM.
412
413* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
414- i810.xinf: More intel whitelisting (#214011, #234877)
415
416* Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
417- xf86-video-intel-1.9.94 (RC4).  Adds support for 965GM.
418- i810.xinf: Point 965GM support at the intel driver since it's not present
419  in old i810.
420
421* Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
422- xf86-video-intel-1.9.93 (RC3).
423
424* Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
425- fix typo with 945GM pci id from my laptop
426
427* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
428- xf86-video-intel 1.9.92 (RC2).
429
430* Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
431- Updated modesetting driver to one that will actually work with a 1.3 server.
432
433* Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
434- Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
435- Remove ivch and ch7017 from the install since they aren't hooked up to the
436  code anywhere
437- Disown the module
438
439* Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
440- update modesetting driver to git snapshot from today
441
442* Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
443- i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
444
445* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
446- rebuilt for unwind info generation, broken in gcc-4.1.1-21
447
448* Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
449- Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
450  actually require kudzu to run.
451
452* Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
453- i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
454
455* Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
456- i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
457- i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
458  driver match the corresponding terrible heuristic in the server.
459
460* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
461- intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
462  correctly distinguish between Mac Mini and Macbook Pro.
463
464* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
465- i810.xinf: PCI IDs for i965.
466
467* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
468- i810.xinf: Uppercase PCI IDs.
469
470* Fri Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
471- Update i810 to 1.6.5, should fix DRI.
472- Add kuzdu requires.
473- i810.xinf: Start whitelisting devices over to intel.
474
475* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
476- intel-driver-rename.patch: Fix the driver name in more places so it'll,
477  you know, load.
478
479* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
480- intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
481  LFP special casing in favor of the blacklist.
482
483* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
484- Admit defeat, kinda.  Package both i810 stable and modesetting drivers.
485  The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
486  and is selected with Driver "intel" in xorg.conf.  Individual devices will
487  whitelist over to "intel" until that branch gets merged into head.
488- Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
489- intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
490  the BIOS is known to lie.
491
492* Tue Aug  8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
493- Today's snapshot: I2C bus creation fix.
494
495* Wed Aug  2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
496- intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
497  clock when computing the modes list.
498- intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
499  in centimeters as the size of the display in pixels.
500
501* Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
502- Disable spread-spectrum LVDS, various crash and hang fixes, saner output
503  probing.
504
505* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
506- Update again for a mode comparison bugfix.
507
508* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
509- Update to today's git; crash fixes, better pre-915 support, slightly better
510  autoconfigurability.
511
512* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
513- rebuild
514
515* Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
516- Fix Revision number to match naming policy.
517
518* Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
519- Add back modesetting changes.
520
521* Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
522- Roll back modesetting changes and build for fc5 aiglx repo.
523
524* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
525- Snapshot of the git modesetting branch.
526
527* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
528- Update i810.xinf to include entries for E7221 and 945GM.
529
530* Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
531- Add with_dri macro to spec file, and conditionalize build time DRI support
532
533* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
534- Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
535  to pick up proto-devel as well.
536
537* Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
538- Rebuild for 7.1 ABI fix.
539
540* Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
541- Bump for fc5-bling build.
542
543* Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
544- Update to 1.6.0 from 7.1RC1.
545
546* Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
547- Add patch to add missing #include's, specifically assert.h.
548
549* Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
550- Update to CVS snapshot of 20060322.
551
552* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
553- rebuilt for new gcc4.1 snapshot and glibc changes
554
555* Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
556- Added 8086:2772 mapping to i810.xinf for bug (#178451)
557
558* Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
559- Added 8086:2592 mapping to i810.xinf for bug (#172884)
560
561* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
562- Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
563
564* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
565- Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
566- Removed 'x' suffix from manpage dirs to match RC4 upstream.
567
568* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
569- Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
570
571* Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
572- Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
573- Fix *.la file removal.
574- Added 'devel' subpackage for XvMC .so
575- Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
576
577* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
578- Update BuildRoot to use Fedora Packaging Guidelines.
579- Deglob file manifest.
580- Limit "ExclusiveArch" to x86, x86_64, ia64
581
582* Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
583- Initial spec file for i810 video driver generated automatically
584  by my xorg-driverspecgen script.
Note: See TracBrowser for help on using the repository browser.