source: projects/specs/branches/6/x/xorg-x11-drv-intel/xorg-x11-drv-intel-vl.spec @ 6605

Revision 6605, 20.5 KB checked in by daisuke, 12 years ago (diff)

enable dri on sandybridge again

Line 
1%define moduledir %(pkg-config xorg-server --variable=moduledir )
2%define driverdir       %{moduledir}/drivers
3%define gputoolsdate 20100625
4
5Summary:   Xorg X11 Intel video driver
6Summary(ja):   Xorg X11 Intel ビデオドライバ
7Name:      xorg-x11-drv-intel
8Epoch:     1
9Version:   2.17.0
10Release:   8%{?_dist_release}
11URL:       http://intellinuxgraphics.org/
12License:   MIT
13Group:     User Interface/X Hardware Support
14
15Source0:   http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
16Source2:   intel.xinf
17Source3:   intel-gpu-tools-%{gputoolsdate}.tar.bz2
18
19# Clamp VGA pixel clock to 250MHz,
20# anything higher's going to look awful anyway. (#559426)
21Patch10: intel-2.11.0-vga-clock-max.patch
22
23# import from ubuntu/debian package
24Patch101: 101_copy-fb.patch
25Patch103: 103_fix_uxa_fill_spans.patch
26Patch104: 104_uxa_fix_gtt_mapping_limits.patch
27
28# vine patch
29Patch200: intel-2.17.0-dri2proto26.patch
30Patch210: intel-2.17.0-ivybridge-disable-dri.patch
31Patch220: intel-2.17.0-ivybridge-disable-accell.patch
32
33ExclusiveArch: %{ix86} x86_64 ia64
34BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
35BuildRequires: autoconf, automake, libtool
36BuildRequires: xorg-x11-server-sdk >= 1.7.99
37BuildRequires: libXvMC-devel
38BuildRequires: libGL-devel >= 7.10
39BuildRequires: libdrm-devel >= 2.4.25
40BuildRequires: kernel-headers >= 2.6.33
41BuildRequires: libudev-devel
42BuildRequires: libxcb-devel >= 1.5
43BuildRequires: xcb-util-devel
44
45Requires:  hwdata
46Requires:  xorg-x11-server-Xorg
47Requires:  xcb-util
48
49Obsoletes: xorg-x11-drv-i810
50Provides: xorg-x11-drv-i810
51
52#Conflicts:  kudzu < 1.2.42-1
53
54Vendor: Project Vine
55Distribution: Vine Linux
56
57%description
58X.Org X11 Intel video driver.
59
60%package devel
61Summary:   Xorg X11 Intel video driver XvMC development package
62Summary(ja):   Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
63Group:     Development/System
64Requires:  %{name} = %{epoch}:%{version}-%{release}
65Provides:  xorg-x11-drv-intel-devel = %{version}-%{release}
66
67%description devel
68X.Org X11 Intel video driver XvMC development package.
69
70%package -n intel-gpu-tools
71Summary:    Debugging tools for Intel graphics chips
72Group:      Development/Tools
73
74%description -n intel-gpu-tools
75Debugging tools for Intel graphics chips
76
77
78%prep
79%setup -q -n xf86-video-intel-%{version} -b3
80
81%patch10 -p1 -b .vga-clock
82
83%patch101 -p1 -b .copy-fb
84%patch103 -p1 -b .fix_uxa_fill_spans
85%patch104 -p1 -b .uxa_fix_gtt_mapping_limits.patch
86
87%patch200 -p1 -b .dri2proto
88%patch210 -p1 -b .ivybridge-disable-dri
89%patch220 -p1 -b .ivybridge-disable-accel
90
91%build
92autoreconf -vi
93
94%configure \
95  --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
96  --enable-dri --enable-xvmc
97make
98
99pushd ../intel-gpu-tools-%{gputoolsdate}
100autoreconf -v --install
101%configure
102make
103popd
104
105
106%install
107rm -rf $RPM_BUILD_ROOT
108
109make install DESTDIR=$RPM_BUILD_ROOT
110mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
111install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
112
113pushd ../intel-gpu-tools-%{gputoolsdate}
114make install DESTDIR=$RPM_BUILD_ROOT
115popd
116
117
118find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
119
120%clean
121rm -rf $RPM_BUILD_ROOT
122
123%triggerpostun -- XOrg < 7.0
124if (grep -q i810 /etc/X11/xorg.conf)
125then
126  cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
127  sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
128fi ||:
129
130%files
131%defattr(-,root,root,-)
132%{driverdir}/intel_drv.so
133%{_datadir}/hwdata/videoaliases/intel.xinf
134%{_libdir}/libI810XvMC.so.*
135%{_libdir}/libIntelXvMC.so.*
136%{_mandir}/man4/i*
137
138%files devel
139%defattr(-,root,root,-)
140%{_libdir}/libI810XvMC.so
141%{_libdir}/libIntelXvMC.so
142
143%files -n intel-gpu-tools
144%defattr(-,root,root,-)
145%{_bindir}/intel_*
146%{_mandir}/man1/intel_*.1*
147
148
149%changelog
150* Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-8
151- enable dri on sandybridge again...
152  (KNOWN PROBLEM: compiz does not work correctly)
153
154* Wed Jul 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-7
155- disable dri on sandybridge again.
156
157* Mon Jul 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-6
158- rebuild with libdrm-2.4.33
159
160* Wed Jul 04 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-5
161- add patch220 to disable some acceleration on IvyBridge.
162
163* Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-4
164- import patch103,104 from ubuntu (cherry picked upstream patch)
165- add patch210 to disable dri on IvyBridge
166
167* Mon Feb 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-3
168- add patch200 to build with dri2proto < 2.6 (for Vine6)
169
170* Sat Nov 26 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-2
171- disable sna/vmap
172
173* Fri Nov 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
174- new upstram release
175- disable copy-fb patch
176
177* Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-3
178- rebuild with xserver-1.11.1.902
179
180* Wed Aug 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-2
181- add --enable-sna --enable-vmap
182
183* Wed Aug 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
184- new upstream release
185
186* Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.15.0-6
187- rebuild with xcb-util-0.3.8
188- drop Patch200
189
190* Tue Jul 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-5
191- update to disable copy_fb on sandybridge/ivybridge
192
193* Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
194- update intel.xinf
195- add patch10 from fedora
196  - Clamp VGA pixel clock to 250MHz,
197    anything higher's going to look awful anyway. (#559426)
198
199* Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
200- drop patch1-3 and replaced with new patch1 from git master
201- add Patch200 to disable DRI on SandyBridge/IvyBridge
202- update intel-gpu-tools
203
204* Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
205- add Patch1-3 from upstream
206
207* Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
208- new upstream release
209- drop upstream patches: 107-115
210- temporary disabled patch101
211- BR: libdrm >= 2.4.25
212
213* Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
214- add Patch101-115 from ubuntu/debian package
215  - Patch101: Plymouth integration patch
216  - Patch107: Check null return from uxa_acquire_solid()
217  - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
218  - Patch109: Fix font corruption (missing glyphs) on rotated screens.
219  - Patch110,114: Cherry picks to fix a large number of build warnings.
220  - Patch111: Fix clipped window plane offset
221  - Patch112: Fix issue where vertical green line and strange colors
222              shows up when playing gstreamer with certain videos,
223              when dragged.  (LP 460677)
224  - Patch113: Fixes GPU lockup during login with
225              "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
226              error messages listed in the gpu dump text. (LP 710321)
227  - Patch115: Don't fill up Xorg.0.log with
228              "get vblank counter failed: Invalid argument" warnings.
229   
230* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
231- rebuild with xserver-1.10.0
232
233* Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
234- new upstream release
235
236* Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
237- new upstream release
238
239* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
240- rebuild with xserver-1.9.2
241
242* Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
243- new upstream release
244- add Patch40: fix uxa planemask (backported)
245- add Patch61: add support for backlight on macbooks
246- add Patch62: disable page flipping for stability
247
248* Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
249- new upstream release
250- drop patch70
251
252* Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
253- rebuild again with xserver-1.8rc
254
255* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
256- add intel-gpu-tools as sub-package
257- rebuild with libdrm-2.4.18
258
259* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
260- new upstream release
261- import Patch1,2,60,70 from fedora
262- add BR: kernel-headers >= 2.6.33 (new drm header required)
263- add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
264- add BR; libudev-devel and autoreconf for Patch60
265
266* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
267- rebuild with libdrm-2.4.17
268
269* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
270- new upstream release
271
272* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
273- new upstream release (hopefully fixes severe issues w/ efifb)
274- drop all patches already upstreamed; import Patch20/21 from Fedora
275
276* Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
277- import Patch121,122 from ubuntu
278- build with libdrm-2.4.12 which fixes vt switch crash
279
280* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
281- apply patch114 to fix Xv with non-GEM kernel
282
283* Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
284- update to 2.6.3
285- add patch106,107,115,118,119,120 from ubuntu
286  - add Patch106: remove triple buffering
287  - add Patch107: remove page flipping
288  - add Patch115: fix crash Xv overlay
289  - add Patch118: drop legacy3d
290  - add Patch119: fix crashes in drm bo
291  - add Patch120: fix vt switch
292- add patch130-134 from upstream git
293  - add Patch130: fix another vt switch leak
294  - add Patch131: Create known output configuration at EnterVT time
295  - add Patch132: fix leak of some 965 render state on VT switch
296  - add Patch133: fix crash with fake bufmgr and UXA
297  - add Patch134: fix EnterVT/LeaveVT
298  - add Patch135: add new chip supoprt
299
300
301* Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
302- revert to 2.6.1, add Epoch
303- add Patch103-121 from ubuntu
304
305* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
306- new upstream release
307
308* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
309- new upstream release
310
311* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
312- new upstream release
313
314* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
315- add Patch5 - Dont die on irq handler failure
316
317* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
318- new upstream release
319- add BR: libdrm-devel >= 2.4.0-3
320
321* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
322- import Patch10,11,12 from ubuntu
323
324* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
325- new upstream release
326- add triggerpostun script to replace i810 driver to intel driver
327
328* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
329- new upstream release
330
331* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
332- new upstream release
333- rename i810.xinf to intel.xinf
334- update intel.xinf (add Intel 4 series)
335
336* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
337- rebuild with new xserver
338
339* Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
340- new upstream release
341
342* Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
343- new upstream release
344
345* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
346- new upstream release
347
348* Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
349- initial build for Vine Linux
350
351* Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
352- Rebuild for new server ABI.
353- intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
354
355* Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
356- hook up ch7017 (bz#408471)
357
358* Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
359- xf86-video-intel 2.2.0
360
361* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
362- xf86-video-intel 2.1.99.
363- Drop the i810 driver.  Time to move on.
364- Require xserver 1.4.99.1
365
366* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
367- intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
368
369* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
370- intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
371  for textured Xv to use as an offscreen pixmap so xv actually works under
372  compiz - granted it may be unusably slow but at least stuff shows up.
373
374* Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
375- intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
376- intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
377
378* Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
379- intel-2.1.1-quirk-update.patch - update quirks from master
380
381* Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
382- i810.xinf: Flip everything over to -intel by default now.  Still install
383  i810 driver just in case.
384
385* Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
386- intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
387
388* Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
389- xf86-video-intel 2.1.1.
390
391* Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
392- xf86-video-intel 2.1.0.
393
394* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
395- Update Requires and BuildRequires.
396
397* Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
398- Update to git master.  Many Xv and DVO fixes.  Adds support for 945GME,
399  965GME, G33, Q33, and Q35 chips.
400
401* Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
402- intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
403  DRI clients are active, for better battery life.
404
405* Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
406- Rebuild for final RANDR 1.2 ABI.  Fixes segfault at startup. (#238575)
407
408* Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
409- xf86-video-intel 2.0.0.  Change the version number to match, why not.
410- Add a Virtual provides for xorg-x11-drv-intel, since we should probably
411  rename this at some point.
412
413* Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
414- i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
415  915GM.
416
417* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
418- i810.xinf: More intel whitelisting (#214011, #234877)
419
420* Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
421- xf86-video-intel-1.9.94 (RC4).  Adds support for 965GM.
422- i810.xinf: Point 965GM support at the intel driver since it's not present
423  in old i810.
424
425* Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
426- xf86-video-intel-1.9.93 (RC3).
427
428* Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
429- fix typo with 945GM pci id from my laptop
430
431* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
432- xf86-video-intel 1.9.92 (RC2).
433
434* Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
435- Updated modesetting driver to one that will actually work with a 1.3 server.
436
437* Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
438- Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
439- Remove ivch and ch7017 from the install since they aren't hooked up to the
440  code anywhere
441- Disown the module
442
443* Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
444- update modesetting driver to git snapshot from today
445
446* Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
447- i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
448
449* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
450- rebuilt for unwind info generation, broken in gcc-4.1.1-21
451
452* Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
453- Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
454  actually require kudzu to run.
455
456* Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
457- i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
458
459* Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
460- i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
461- i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
462  driver match the corresponding terrible heuristic in the server.
463
464* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
465- intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
466  correctly distinguish between Mac Mini and Macbook Pro.
467
468* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
469- i810.xinf: PCI IDs for i965.
470
471* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
472- i810.xinf: Uppercase PCI IDs.
473
474* Fri Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
475- Update i810 to 1.6.5, should fix DRI.
476- Add kuzdu requires.
477- i810.xinf: Start whitelisting devices over to intel.
478
479* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
480- intel-driver-rename.patch: Fix the driver name in more places so it'll,
481  you know, load.
482
483* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
484- intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
485  LFP special casing in favor of the blacklist.
486
487* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
488- Admit defeat, kinda.  Package both i810 stable and modesetting drivers.
489  The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
490  and is selected with Driver "intel" in xorg.conf.  Individual devices will
491  whitelist over to "intel" until that branch gets merged into head.
492- Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
493- intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
494  the BIOS is known to lie.
495
496* Tue Aug  8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
497- Today's snapshot: I2C bus creation fix.
498
499* Wed Aug  2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
500- intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
501  clock when computing the modes list.
502- intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
503  in centimeters as the size of the display in pixels.
504
505* Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
506- Disable spread-spectrum LVDS, various crash and hang fixes, saner output
507  probing.
508
509* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
510- Update again for a mode comparison bugfix.
511
512* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
513- Update to today's git; crash fixes, better pre-915 support, slightly better
514  autoconfigurability.
515
516* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
517- rebuild
518
519* Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
520- Fix Revision number to match naming policy.
521
522* Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
523- Add back modesetting changes.
524
525* Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
526- Roll back modesetting changes and build for fc5 aiglx repo.
527
528* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
529- Snapshot of the git modesetting branch.
530
531* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
532- Update i810.xinf to include entries for E7221 and 945GM.
533
534* Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
535- Add with_dri macro to spec file, and conditionalize build time DRI support
536
537* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
538- Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
539  to pick up proto-devel as well.
540
541* Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
542- Rebuild for 7.1 ABI fix.
543
544* Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
545- Bump for fc5-bling build.
546
547* Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
548- Update to 1.6.0 from 7.1RC1.
549
550* Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
551- Add patch to add missing #include's, specifically assert.h.
552
553* Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
554- Update to CVS snapshot of 20060322.
555
556* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
557- rebuilt for new gcc4.1 snapshot and glibc changes
558
559* Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
560- Added 8086:2772 mapping to i810.xinf for bug (#178451)
561
562* Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
563- Added 8086:2592 mapping to i810.xinf for bug (#172884)
564
565* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
566- Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
567
568* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
569- Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
570- Removed 'x' suffix from manpage dirs to match RC4 upstream.
571
572* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
573- Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
574
575* Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
576- Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
577- Fix *.la file removal.
578- Added 'devel' subpackage for XvMC .so
579- Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
580
581* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
582- Update BuildRoot to use Fedora Packaging Guidelines.
583- Deglob file manifest.
584- Limit "ExclusiveArch" to x86, x86_64, ia64
585
586* Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
587- Initial spec file for i810 video driver generated automatically
588  by my xorg-driverspecgen script.
Note: See TracBrowser for help on using the repository browser.