source: projects/specs/branches/6/x/xorg-x11-drv-intel/xorg-x11-drv-intel-vl.spec @ 6423

Revision 6423, 19.5 KB checked in by daisuke, 12 years ago (diff)

import 2.17.0-3 to 6.x branch

Line 
1%define moduledir %(pkg-config xorg-server --variable=moduledir )
2%define driverdir       %{moduledir}/drivers
3%define gputoolsdate 20100625
4
5Summary:   Xorg X11 Intel video driver
6Summary(ja):   Xorg X11 Intel ビデオドライバ
7Name:      xorg-x11-drv-intel
8Epoch:     1
9Version:   2.17.0
10Release:   3%{?_dist_release}
11URL:       http://intellinuxgraphics.org/
12License:   MIT
13Group:     User Interface/X Hardware Support
14
15Source0:   http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
16Source2:   intel.xinf
17Source3:   intel-gpu-tools-%{gputoolsdate}.tar.bz2
18
19# Clamp VGA pixel clock to 250MHz,
20# anything higher's going to look awful anyway. (#559426)
21Patch10: intel-2.11.0-vga-clock-max.patch
22
23# import from ubuntu/debian package
24Patch101: intel-2.15.0-copy-fb.patch
25
26# vine patch
27Patch200: intel-2.17.0-dri2proto26.patch
28
29ExclusiveArch: %{ix86} x86_64 ia64
30BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
31BuildRequires: autoconf, automake, libtool
32BuildRequires: xorg-x11-server-sdk >= 1.7.99
33BuildRequires: libXvMC-devel
34BuildRequires: libGL-devel >= 7.10
35BuildRequires: libdrm-devel >= 2.4.25
36BuildRequires: kernel-headers >= 2.6.33
37BuildRequires: libudev-devel
38BuildRequires: libxcb-devel >= 1.5
39BuildRequires: xcb-util-devel
40
41Requires:  hwdata
42Requires:  xorg-x11-server-Xorg
43Requires:  xcb-util
44
45Obsoletes: xorg-x11-drv-i810
46Provides: xorg-x11-drv-i810
47
48#Conflicts:  kudzu < 1.2.42-1
49
50Vendor: Project Vine
51Distribution: Vine Linux
52
53%description
54X.Org X11 Intel video driver.
55
56%package devel
57Summary:   Xorg X11 Intel video driver XvMC development package
58Summary(ja):   Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
59Group:     Development/System
60Requires:  %{name} = %{epoch}:%{version}-%{release}
61Provides:  xorg-x11-drv-intel-devel = %{version}-%{release}
62
63%description devel
64X.Org X11 Intel video driver XvMC development package.
65
66%package -n intel-gpu-tools
67Summary:    Debugging tools for Intel graphics chips
68Group:      Development/Tools
69
70%description -n intel-gpu-tools
71Debugging tools for Intel graphics chips
72
73
74%prep
75%setup -q -n xf86-video-intel-%{version} -b3
76
77%patch10 -p1 -b .vga-clock
78
79#%patch101 -p1 -b .copy-fb
80
81%patch200 -p1 -b .dri2proto
82
83%build
84autoreconf -vi
85
86%configure \
87  --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
88  --enable-dri --enable-xvmc
89  # --enable-sna --enable-vmap
90make
91
92pushd ../intel-gpu-tools-%{gputoolsdate}
93autoreconf -v --install
94%configure
95make
96popd
97
98
99%install
100rm -rf $RPM_BUILD_ROOT
101
102make install DESTDIR=$RPM_BUILD_ROOT
103mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
104install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
105
106pushd ../intel-gpu-tools-%{gputoolsdate}
107make install DESTDIR=$RPM_BUILD_ROOT
108popd
109
110
111find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
112
113%clean
114rm -rf $RPM_BUILD_ROOT
115
116%triggerpostun -- XOrg < 7.0
117if (grep -q i810 /etc/X11/xorg.conf)
118then
119  cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
120  sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
121fi ||:
122
123%files
124%defattr(-,root,root,-)
125%{driverdir}/intel_drv.so
126%{_datadir}/hwdata/videoaliases/intel.xinf
127%{_libdir}/libI810XvMC.so.*
128%{_libdir}/libIntelXvMC.so.*
129%{_mandir}/man4/i*
130
131%files devel
132%defattr(-,root,root,-)
133%{_libdir}/libI810XvMC.so
134%{_libdir}/libIntelXvMC.so
135
136%files -n intel-gpu-tools
137%defattr(-,root,root,-)
138%{_bindir}/intel_*
139%{_mandir}/man1/intel_*.1*
140
141
142%changelog
143* Mon Feb 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-3
144- add patch200 to build with dri2proto < 2.6 (for Vine6)
145
146* Sat Nov 26 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-2
147- disable sna/vmap
148
149* Fri Nov 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
150- new upstram release
151- disable copy-fb patch
152
153* Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-3
154- rebuild with xserver-1.11.1.902
155
156* Wed Aug 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-2
157- add --enable-sna --enable-vmap
158
159* Wed Aug 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
160- new upstream release
161
162* Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.15.0-6
163- rebuild with xcb-util-0.3.8
164- drop Patch200
165
166* Tue Jul 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-5
167- update to disable copy_fb on sandybridge/ivybridge
168
169* Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
170- update intel.xinf
171- add patch10 from fedora
172  - Clamp VGA pixel clock to 250MHz,
173    anything higher's going to look awful anyway. (#559426)
174
175* Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
176- drop patch1-3 and replaced with new patch1 from git master
177- add Patch200 to disable DRI on SandyBridge/IvyBridge
178- update intel-gpu-tools
179
180* Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
181- add Patch1-3 from upstream
182
183* Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
184- new upstream release
185- drop upstream patches: 107-115
186- temporary disabled patch101
187- BR: libdrm >= 2.4.25
188
189* Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
190- add Patch101-115 from ubuntu/debian package
191  - Patch101: Plymouth integration patch
192  - Patch107: Check null return from uxa_acquire_solid()
193  - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
194  - Patch109: Fix font corruption (missing glyphs) on rotated screens.
195  - Patch110,114: Cherry picks to fix a large number of build warnings.
196  - Patch111: Fix clipped window plane offset
197  - Patch112: Fix issue where vertical green line and strange colors
198              shows up when playing gstreamer with certain videos,
199              when dragged.  (LP 460677)
200  - Patch113: Fixes GPU lockup during login with
201              "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
202              error messages listed in the gpu dump text. (LP 710321)
203  - Patch115: Don't fill up Xorg.0.log with
204              "get vblank counter failed: Invalid argument" warnings.
205   
206* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
207- rebuild with xserver-1.10.0
208
209* Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
210- new upstream release
211
212* Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
213- new upstream release
214
215* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
216- rebuild with xserver-1.9.2
217
218* Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
219- new upstream release
220- add Patch40: fix uxa planemask (backported)
221- add Patch61: add support for backlight on macbooks
222- add Patch62: disable page flipping for stability
223
224* Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
225- new upstream release
226- drop patch70
227
228* Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
229- rebuild again with xserver-1.8rc
230
231* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
232- add intel-gpu-tools as sub-package
233- rebuild with libdrm-2.4.18
234
235* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
236- new upstream release
237- import Patch1,2,60,70 from fedora
238- add BR: kernel-headers >= 2.6.33 (new drm header required)
239- add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
240- add BR; libudev-devel and autoreconf for Patch60
241
242* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
243- rebuild with libdrm-2.4.17
244
245* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
246- new upstream release
247
248* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
249- new upstream release (hopefully fixes severe issues w/ efifb)
250- drop all patches already upstreamed; import Patch20/21 from Fedora
251
252* Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
253- import Patch121,122 from ubuntu
254- build with libdrm-2.4.12 which fixes vt switch crash
255
256* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
257- apply patch114 to fix Xv with non-GEM kernel
258
259* Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
260- update to 2.6.3
261- add patch106,107,115,118,119,120 from ubuntu
262  - add Patch106: remove triple buffering
263  - add Patch107: remove page flipping
264  - add Patch115: fix crash Xv overlay
265  - add Patch118: drop legacy3d
266  - add Patch119: fix crashes in drm bo
267  - add Patch120: fix vt switch
268- add patch130-134 from upstream git
269  - add Patch130: fix another vt switch leak
270  - add Patch131: Create known output configuration at EnterVT time
271  - add Patch132: fix leak of some 965 render state on VT switch
272  - add Patch133: fix crash with fake bufmgr and UXA
273  - add Patch134: fix EnterVT/LeaveVT
274  - add Patch135: add new chip supoprt
275
276
277* Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
278- revert to 2.6.1, add Epoch
279- add Patch103-121 from ubuntu
280
281* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
282- new upstream release
283
284* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
285- new upstream release
286
287* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
288- new upstream release
289
290* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
291- add Patch5 - Dont die on irq handler failure
292
293* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
294- new upstream release
295- add BR: libdrm-devel >= 2.4.0-3
296
297* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
298- import Patch10,11,12 from ubuntu
299
300* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
301- new upstream release
302- add triggerpostun script to replace i810 driver to intel driver
303
304* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
305- new upstream release
306
307* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
308- new upstream release
309- rename i810.xinf to intel.xinf
310- update intel.xinf (add Intel 4 series)
311
312* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
313- rebuild with new xserver
314
315* Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
316- new upstream release
317
318* Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
319- new upstream release
320
321* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
322- new upstream release
323
324* Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
325- initial build for Vine Linux
326
327* Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
328- Rebuild for new server ABI.
329- intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
330
331* Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
332- hook up ch7017 (bz#408471)
333
334* Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
335- xf86-video-intel 2.2.0
336
337* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
338- xf86-video-intel 2.1.99.
339- Drop the i810 driver.  Time to move on.
340- Require xserver 1.4.99.1
341
342* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
343- intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
344
345* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
346- intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
347  for textured Xv to use as an offscreen pixmap so xv actually works under
348  compiz - granted it may be unusably slow but at least stuff shows up.
349
350* Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
351- intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
352- intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
353
354* Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
355- intel-2.1.1-quirk-update.patch - update quirks from master
356
357* Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
358- i810.xinf: Flip everything over to -intel by default now.  Still install
359  i810 driver just in case.
360
361* Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
362- intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
363
364* Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
365- xf86-video-intel 2.1.1.
366
367* Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
368- xf86-video-intel 2.1.0.
369
370* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
371- Update Requires and BuildRequires.
372
373* Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
374- Update to git master.  Many Xv and DVO fixes.  Adds support for 945GME,
375  965GME, G33, Q33, and Q35 chips.
376
377* Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
378- intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
379  DRI clients are active, for better battery life.
380
381* Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
382- Rebuild for final RANDR 1.2 ABI.  Fixes segfault at startup. (#238575)
383
384* Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
385- xf86-video-intel 2.0.0.  Change the version number to match, why not.
386- Add a Virtual provides for xorg-x11-drv-intel, since we should probably
387  rename this at some point.
388
389* Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
390- i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
391  915GM.
392
393* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
394- i810.xinf: More intel whitelisting (#214011, #234877)
395
396* Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
397- xf86-video-intel-1.9.94 (RC4).  Adds support for 965GM.
398- i810.xinf: Point 965GM support at the intel driver since it's not present
399  in old i810.
400
401* Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
402- xf86-video-intel-1.9.93 (RC3).
403
404* Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
405- fix typo with 945GM pci id from my laptop
406
407* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
408- xf86-video-intel 1.9.92 (RC2).
409
410* Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
411- Updated modesetting driver to one that will actually work with a 1.3 server.
412
413* Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
414- Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
415- Remove ivch and ch7017 from the install since they aren't hooked up to the
416  code anywhere
417- Disown the module
418
419* Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
420- update modesetting driver to git snapshot from today
421
422* Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
423- i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
424
425* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
426- rebuilt for unwind info generation, broken in gcc-4.1.1-21
427
428* Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
429- Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
430  actually require kudzu to run.
431
432* Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
433- i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
434
435* Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
436- i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
437- i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
438  driver match the corresponding terrible heuristic in the server.
439
440* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
441- intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
442  correctly distinguish between Mac Mini and Macbook Pro.
443
444* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
445- i810.xinf: PCI IDs for i965.
446
447* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
448- i810.xinf: Uppercase PCI IDs.
449
450* Fri Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
451- Update i810 to 1.6.5, should fix DRI.
452- Add kuzdu requires.
453- i810.xinf: Start whitelisting devices over to intel.
454
455* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
456- intel-driver-rename.patch: Fix the driver name in more places so it'll,
457  you know, load.
458
459* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
460- intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
461  LFP special casing in favor of the blacklist.
462
463* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
464- Admit defeat, kinda.  Package both i810 stable and modesetting drivers.
465  The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
466  and is selected with Driver "intel" in xorg.conf.  Individual devices will
467  whitelist over to "intel" until that branch gets merged into head.
468- Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
469- intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
470  the BIOS is known to lie.
471
472* Tue Aug  8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
473- Today's snapshot: I2C bus creation fix.
474
475* Wed Aug  2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
476- intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
477  clock when computing the modes list.
478- intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
479  in centimeters as the size of the display in pixels.
480
481* Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
482- Disable spread-spectrum LVDS, various crash and hang fixes, saner output
483  probing.
484
485* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
486- Update again for a mode comparison bugfix.
487
488* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
489- Update to today's git; crash fixes, better pre-915 support, slightly better
490  autoconfigurability.
491
492* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
493- rebuild
494
495* Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
496- Fix Revision number to match naming policy.
497
498* Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
499- Add back modesetting changes.
500
501* Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
502- Roll back modesetting changes and build for fc5 aiglx repo.
503
504* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
505- Snapshot of the git modesetting branch.
506
507* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
508- Update i810.xinf to include entries for E7221 and 945GM.
509
510* Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
511- Add with_dri macro to spec file, and conditionalize build time DRI support
512
513* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
514- Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
515  to pick up proto-devel as well.
516
517* Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
518- Rebuild for 7.1 ABI fix.
519
520* Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
521- Bump for fc5-bling build.
522
523* Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
524- Update to 1.6.0 from 7.1RC1.
525
526* Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
527- Add patch to add missing #include's, specifically assert.h.
528
529* Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
530- Update to CVS snapshot of 20060322.
531
532* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
533- rebuilt for new gcc4.1 snapshot and glibc changes
534
535* Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
536- Added 8086:2772 mapping to i810.xinf for bug (#178451)
537
538* Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
539- Added 8086:2592 mapping to i810.xinf for bug (#172884)
540
541* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
542- Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
543
544* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
545- Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
546- Removed 'x' suffix from manpage dirs to match RC4 upstream.
547
548* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
549- Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
550
551* Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
552- Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
553- Fix *.la file removal.
554- Added 'devel' subpackage for XvMC .so
555- Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
556
557* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
558- Update BuildRoot to use Fedora Packaging Guidelines.
559- Deglob file manifest.
560- Limit "ExclusiveArch" to x86, x86_64, ia64
561
562* Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
563- Initial spec file for i810 video driver generated automatically
564  by my xorg-driverspecgen script.
Note: See TracBrowser for help on using the repository browser.