source: projects/specs/branches/6/x/xcb-util/xcb-util-vl.spec @ 2352

Revision 2352, 5.4 KB checked in by Takemikaduchi, 13 years ago (diff)

pulseaudio: add BuildRequires?, others: create compat32- sub package

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name:           xcb-util
4Version:        0.3.6
5Release:        3%{?_dist_release}
6Summary:        Convenience libraries sitting on top of libxcb
7
8Group:          System Environment/Libraries
9License:        MIT
10URL:            http://xcb.freedesktop.org
11Source0:        http://xcb.freedesktop.org/dist/%{name}-%{version}.tar.bz2
12BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
13BuildRequires:  gperf, pkgconfig, libxcb-devel >= 1.4, m4, xorg-x11-proto-devel
14BuildRequires:  chrpath
15
16
17%description
18The xcb-util module provides a number of libraries which sit on top of
19libxcb, the core X protocol library, and some of the extension
20libraries. These experimental libraries provide convenience functions
21and interfaces which make the raw X protocol more usable. Some of the
22libraries also provide client-side code which is not strictly part of
23the X protocol but which have traditionally been provided by Xlib.
24
25
26%package        devel
27Summary:        Development and header files for xcb-util
28Group:          System Environment/Libraries
29Requires:       %{name} = %{version}-%{release}, pkgconfig
30
31%description    devel
32Development files for xcb-util.
33
34
35# compat32
36%package -n compat32-%{name}
37Summary: Convenience libraries sitting on top of libxcb
38Group: System Environment/Libraries
39Requires: %{name} = %{version}-%{release}
40
41%description -n compat32-%{name}
42The xcb-util module provides a number of libraries which sit on top of
43libxcb, the core X protocol library, and some of the extension
44libraries. These experimental libraries provide convenience functions
45and interfaces which make the raw X protocol more usable. Some of the
46libraries also provide client-side code which is not strictly part of
47the X protocol but which have traditionally been provided by Xlib.
48
49
50%package -n compat32-%{name}-devel
51Summary:        Development and header files for xcb-util
52Group:          System Environment/Libraries
53Requires:       compat32-%{name} = %{version}-%{release}
54Requires:       %{name}-devel = %{version}-%{release}
55
56%description -n compat32-%{name}-devel
57Development files for xcb-util.
58
59
60%prep
61%setup -q
62
63
64%build
65%configure --with-pic --disable-static
66
67make %{?_smp_mflags}
68
69
70%check
71
72make check
73
74
75%install
76rm -rf %{buildroot}
77
78make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
79
80# remove RPATH
81chrpath --delete $RPM_BUILD_ROOT%{_prefix}/%{_lib}/libxcb-*.so.*
82
83rm %{buildroot}%{_libdir}/*.la
84
85
86%post -p /sbin/ldconfig
87
88
89%postun -p /sbin/ldconfig
90
91
92%post -n compat32-%{name} -p /sbin/ldconfig
93%postun -n compat32-%{name} -p /sbin/ldconfig
94
95
96%clean
97rm -rf %{buildroot}
98
99
100%files
101%defattr(-,root,root,-)
102%doc README
103%{_libdir}/libxcb-atom.so.1*
104%{_libdir}/libxcb-aux.so.0*
105%{_libdir}/libxcb-event.so.1*
106%{_libdir}/libxcb-icccm.so.1*
107%{_libdir}/libxcb-image.so.0*
108%{_libdir}/libxcb-keysyms.so.1*
109%{_libdir}/libxcb-property.so.1*
110%{_libdir}/libxcb-render-util.so.0*
111%{_libdir}/libxcb-reply.so.1*
112
113%files devel
114%defattr(-,root,root,-)
115%{_libdir}/pkgconfig/*.pc
116%{_libdir}/*.so
117%{_includedir}/xcb/*.h
118
119# compat32
120%if %{build_compat32}
121%files -n compat32-%{name}
122%defattr(-,root,root,-)
123%{_libdir}/libxcb-atom.so.1*
124%{_libdir}/libxcb-aux.so.0*
125%{_libdir}/libxcb-event.so.1*
126%{_libdir}/libxcb-icccm.so.1*
127%{_libdir}/libxcb-image.so.0*
128%{_libdir}/libxcb-keysyms.so.1*
129%{_libdir}/libxcb-property.so.1*
130%{_libdir}/libxcb-render-util.so.0*
131%{_libdir}/libxcb-reply.so.1*
132
133%files -n compat32-%{name}-devel
134%defattr(-,root,root,-)
135%{_libdir}/pkgconfig/*.pc
136%{_libdir}/*.so
137%endif
138
139
140%changelog
141* Wed Dec 15 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.6-3
142- create compat32-xcb-util sub package
143
144* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.6-2
145- rebuild with rpm-4.8.1 for pkg-config file
146
147* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp>  0.3.6-1
148- initial build for Vine Linux
149
150* Fri Aug 28 2009 Michal Nowak <mnowak@redhat.com> - 0.3.6-1
151- 0.3.6
152
153* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.5-2
154- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
155
156* Mon Jul 13 2009 Adam Jackson <ajax@redhat.com> 0.3.5-1
157- xcb-util 0.3.5
158
159* Mon Jul 06 2009 Adam Jackson <ajax@redhat.com> 0.3.4-2
160- Explicitly list DSOs so we're notified of version changes.
161
162* Sat Jun 13 2009 Michal Nowak <mnowak@redhat.com> - 0.3.4-1
163- 0.3.4; needed for Awesome 3.3
164
165* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.3-2
166- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
167
168* Fri Feb 20 2009 Michal Nowak <mnowak@redhat.com> - 0.3.3-1
169- 0.3.3
170- removed patches already in git (and 0.3.3)
171
172* Fri Dec 19 2008 Michal Nowak <mnowak@redhat.com> - 0.3.2-2
173- hack the sed lines after %%configure out and hack chrpath in
174- make check is running again
175
176* Thu Dec 18 2008 Michal Nowak <mnowak@redhat.com> - 0.3.2-1
177- 0.3.2
178- remove rpath (x86-64)
179- xcb_keysyms: remove xcb_lookup_t
180- Revert "keysyms: use xcb_key_lookup_t type for col paramter"
181- temporary disabled %%check due to RPATH regression
182
183* Thu Dec  4 2008 Michal Nowak <mnowak@redhat.com> - 0.3.1-2
184- patch for exit() in aux library (Peter Harris)
185- slight changes in spec file
186
187* Mon Nov 24 2008 Michal Nowak <mnowak@redhat.com> - 0.3.1-1
188- 0.3.1
189- fix license issue (Jonathan Landis)
190
191* Fri Sep 19 2008 Michal Nowak <mnowak@redhat.com> - 0.3.0-1
192- bump to 0.3.0
193
194* Sun Aug 17 2008 Michal Nowak <mnowak@redhat.com> - 0.2.1-2
195- new build deps: gperf, pkgconfig, libxcb, m4, xorg-x11-proto-devel
196- not installing *.a files anymore
197- configure with --with-pic
198
199* Mon Aug 04 2008 Michal Nowak <mnowak@redhat.com> - 0.2.1-1
200- initial package
201
Note: See TracBrowser for help on using the repository browser.