source: projects/specs/trunk/x/xcb-util/xcb-util-vl.spec @ 4616

Revision 4616, 5.0 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name:           xcb-util
4Version:        0.3.8
5Release:        1%{?_dist_release}
6Summary:        Convenience libraries sitting on top of libxcb
7
8Group:          System Environment/Libraries
9License:        MIT
10URL:            http://xcb.freedesktop.org
11Source0:        http://xcb.freedesktop.org/dist/%{name}-%{version}.tar.bz2
12BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
13BuildRequires:  gperf, pkgconfig, libxcb-devel >= 1.4, m4, xorg-x11-proto-devel
14BuildRequires:  xorg-x11-util-macros
15BuildRequires:  chrpath
16
17Vendor: Project Vine
18Distribution: Vine Linux
19
20%description
21The xcb-util module provides a number of libraries which sit on top of
22libxcb, the core X protocol library, and some of the extension
23libraries. These experimental libraries provide convenience functions
24and interfaces which make the raw X protocol more usable. Some of the
25libraries also provide client-side code which is not strictly part of
26the X protocol but which have traditionally been provided by Xlib.
27
28
29%package        devel
30Summary:        Development and header files for xcb-util
31Group:          System Environment/Libraries
32Requires:       %{name} = %{version}-%{release}, pkgconfig
33
34%description    devel
35Development files for xcb-util.
36
37
38# compat32
39%package -n compat32-%{name}
40Summary: Convenience libraries sitting on top of libxcb
41Group: System Environment/Libraries
42Requires: %{name} = %{version}-%{release}
43
44%description -n compat32-%{name}
45The xcb-util module provides a number of libraries which sit on top of
46libxcb, the core X protocol library, and some of the extension
47libraries. These experimental libraries provide convenience functions
48and interfaces which make the raw X protocol more usable. Some of the
49libraries also provide client-side code which is not strictly part of
50the X protocol but which have traditionally been provided by Xlib.
51
52
53%package -n compat32-%{name}-devel
54Summary:        Development and header files for xcb-util
55Group:          System Environment/Libraries
56Requires:       %{name}-devel = %{version}-%{release}
57
58%description -n compat32-%{name}-devel
59Development files for xcb-util.
60
61
62%prep
63%setup -q
64
65
66%build
67%configure --with-pic --disable-static
68
69make %{?_smp_mflags}
70
71
72%check
73
74make check
75
76
77%install
78rm -rf %{buildroot}
79
80make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
81
82# remove RPATH
83chrpath --delete $RPM_BUILD_ROOT%{_prefix}/%{_lib}/libxcb-*.so.*
84
85rm %{buildroot}%{_libdir}/*.la
86
87
88%post -p /sbin/ldconfig
89
90
91%postun -p /sbin/ldconfig
92
93
94%post -n compat32-%{name} -p /sbin/ldconfig
95%postun -n compat32-%{name} -p /sbin/ldconfig
96
97
98%clean
99rm -rf %{buildroot}
100
101
102%files
103%defattr(-,root,root,-)
104%doc README
105%{_libdir}/libxcb-util.so.*
106
107%files devel
108%defattr(-,root,root,-)
109%{_libdir}/pkgconfig/*.pc
110%{_libdir}/libxcb-util.so
111%{_includedir}/xcb/*.h
112
113# compat32
114%if %{build_compat32}
115%files -n compat32-%{name}
116%defattr(-,root,root,-)
117%{_libdir}/libxcb-util.so.*
118
119%files -n compat32-%{name}-devel
120%defattr(-,root,root,-)
121%{_libdir}/pkgconfig/*.pc
122%{_libdir}/libxcb-util.so
123%endif
124
125
126%changelog
127* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.8-1
128- new upstream release
129- add BuildRequires: xorg-x11-util-macros
130
131* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.6-2
132- rebuild with rpm-4.8.1 for pkg-config file
133
134* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp>  0.3.6-1
135- initial build for Vine Linux
136
137* Fri Aug 28 2009 Michal Nowak <mnowak@redhat.com> - 0.3.6-1
138- 0.3.6
139
140* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.5-2
141- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
142
143* Mon Jul 13 2009 Adam Jackson <ajax@redhat.com> 0.3.5-1
144- xcb-util 0.3.5
145
146* Mon Jul 06 2009 Adam Jackson <ajax@redhat.com> 0.3.4-2
147- Explicitly list DSOs so we're notified of version changes.
148
149* Sat Jun 13 2009 Michal Nowak <mnowak@redhat.com> - 0.3.4-1
150- 0.3.4; needed for Awesome 3.3
151
152* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.3-2
153- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
154
155* Fri Feb 20 2009 Michal Nowak <mnowak@redhat.com> - 0.3.3-1
156- 0.3.3
157- removed patches already in git (and 0.3.3)
158
159* Fri Dec 19 2008 Michal Nowak <mnowak@redhat.com> - 0.3.2-2
160- hack the sed lines after %%configure out and hack chrpath in
161- make check is running again
162
163* Thu Dec 18 2008 Michal Nowak <mnowak@redhat.com> - 0.3.2-1
164- 0.3.2
165- remove rpath (x86-64)
166- xcb_keysyms: remove xcb_lookup_t
167- Revert "keysyms: use xcb_key_lookup_t type for col paramter"
168- temporary disabled %%check due to RPATH regression
169
170* Thu Dec  4 2008 Michal Nowak <mnowak@redhat.com> - 0.3.1-2
171- patch for exit() in aux library (Peter Harris)
172- slight changes in spec file
173
174* Mon Nov 24 2008 Michal Nowak <mnowak@redhat.com> - 0.3.1-1
175- 0.3.1
176- fix license issue (Jonathan Landis)
177
178* Fri Sep 19 2008 Michal Nowak <mnowak@redhat.com> - 0.3.0-1
179- bump to 0.3.0
180
181* Sun Aug 17 2008 Michal Nowak <mnowak@redhat.com> - 0.2.1-2
182- new build deps: gperf, pkgconfig, libxcb, m4, xorg-x11-proto-devel
183- not installing *.a files anymore
184- configure with --with-pic
185
186* Mon Aug 04 2008 Michal Nowak <mnowak@redhat.com> - 0.2.1-1
187- initial package
188
Note: See TracBrowser for help on using the repository browser.