source: projects/specs/branches/6/w/wireshark/wireshark-vl.spec @ 5129

Revision 5129, 11.6 KB checked in by Takemikaduchi, 13 years ago (diff)

new upstream release

Line 
1%define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
2
3Summary:        Network traffic analyzer
4Summary(ja):    ネットワークトラフィック解析プログラム
5Name:           wireshark
6Version:        1.6.3
7Release:        1%{_dist_release}
8License:        GPLv2
9Group:          Applications/System
10Source0:        http://www.wireshark.org/download/src/%{name}-%{version}.tar.bz2
11Source1:        wireshark.pam
12Source2:        wireshark.console
13Source3:        wireshark.desktop
14Patch1:         wireshark-0.99.7-pie.patch
15Patch3:         wireshark-nfsv4-opts.patch
16Patch4:         wireshark-0.99.7-path.patch
17Patch5:         wireshark-1.4.0-lua-vine.patch
18URL:            http://www.wireshark.org/
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21BuildRequires:  libcap-devel
22BuildRequires:  net-snmp-devel >= 5.0
23BuildRequires:  net-snmp-utils >= 5.0
24BuildRequires:  zlib-devel, bzip2-devel
25BuildRequires:  openssl-devel
26BuildRequires:  glib2-devel, gtk2-devel
27BuildRequires:  libelf-devel
28BuildRequires:  python, pcre-devel
29BuildRequires:  gnutls-devel
30BuildRequires:  desktop-file-utils, automake, libtool
31BuildRequires:  bison, flex
32%if %{?_dist_release} != "vl4"
33BuildRequires:  krb5-devel
34BuildRequires:  libpcap-devel
35BuildRequires:  lua-devel
36%else
37BuildRequires:  libpcap
38%endif
39Requires:       usermode >= 1.37
40Requires(post): desktop-file-utils
41Requires(postun): desktop-file-utils
42
43Obsoletes:      ethereal
44Obsoletes:      ethereal-base ethereal-gnome ethereal-gtk+
45Obsoletes:      ethereal-kde ethereal-usermode
46Provides:       ethereal ethereal-gnome
47
48Vendor:         Project Vine
49Distribution:   Vine Linux
50Packager: inagaki, Takemikaduchi
51
52%description
53Wireshark is a network traffic analyzer for Unix-ish operating systems.
54
55This package lays base for libpcap, a packet capture and filtering
56library, contains command-line utilities, contains plugins and
57documentation for wireshark. A graphical user interface is also
58included with this package.
59
60%description -l ja
61Wireshark は,UNIX 系 OS 用のネットワークトラフィック解析プログラムです.
62
63このパッケージは,パケットキャプチャ/フィルタリングライブラリである
64libpcap を使ったコマンドラインツールと,プラグイン,ドキュメント等が
65収められています.GUI もこのパッケージに収められています.
66
67%prep
68%setup -q -n %{name}-%{version}
69#patch1 -p1 -b .pie
70%patch3 -p1
71%patch4 -p1
72%patch5 -p1 -b .lua-vine
73
74%build
75%ifarch s390 s390x
76export PIECFLAGS="-fPIE"
77%else
78export PIECFLAGS="-fpie"
79%endif
80# FC5+ automatic -fstack-protector-all switch
81export RPM_OPT_FLAGS=${RPM_OPT_FLAGS//-fstack-protector/-fstack-protector-all}
82## export CFLAGS="$RPM_OPT_FLAGS $CPPFLAGS -I%{_includedir}/pcap -I%{_includedir}/pcre"
83export CFLAGS="$RPM_OPT_FLAGS $CPPFLAGS -I%{_includedir}/pcre"
84export CXXFLAGS="$RPM_OPT_FLAGS $CPPFLAGS"
85export LDFLAGS="$LDFLAGS -lm -lcrypto"
86export PATH="$PATH:/usr/kerberos/bin"
87./autogen.sh
88# --disable-warning-as-erros needs for compiling with glib 2.14.0
89%configure \
90   --bindir=%{_sbindir} \
91   --enable-ipv6 \
92   --with-gnu-ld \
93   --disable-static \
94   --disable-usr-local \
95   --enable-wireshark \
96   --with-pic \
97   --with-ssl \
98   --with-pcap \
99   --with-pcre \
100%if %{?_dist_release} != "vl4"
101   --with-krb5 \
102%else
103   --without-krb5 \
104%endif
105   --with-plugins=%{_libdir}/%{name}/plugins/%{version} \
106   --disable-warnings-as-errors
107time make %{?_smp_mflags}
108
109%install
110rm -rf $RPM_BUILD_ROOT
111
112# The evil plugins hack
113perl -pi -e 's|-L../../epan|-L../../epan/.libs|' plugins/*/*.la
114
115make DESTDIR=$RPM_BUILD_ROOT install
116
117#symlink tshark to tethereal
118ln -s tshark $RPM_BUILD_ROOT%{_sbindir}/tethereal
119
120#empty?!
121rm -f $RPM_BUILD_ROOT%{_sbindir}/idl2wrs
122
123# install support files for usermode, gnome and kde
124mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/pam.d
125install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/pam.d/wireshark
126mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/security/console.apps
127install -m 644 %{SOURCE2} $RPM_BUILD_ROOT/%{_sysconfdir}/security/console.apps/wireshark
128mkdir -p $RPM_BUILD_ROOT/%{_bindir}
129ln -s consolehelper $RPM_BUILD_ROOT/%{_bindir}/wireshark
130
131# install man
132## mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
133## install -m 644 *.1 $RPM_BUILD_ROOT/%{_mandir}/man1
134
135# Install python stuff.
136mkdir -p $RPM_BUILD_ROOT%{python_sitelib}
137install -m 644 tools/wireshark_be.py tools/wireshark_gen.py  $RPM_BUILD_ROOT%{python_sitelib}
138
139desktop-file-install --vendor=                             \
140        --dir ${RPM_BUILD_ROOT}%{_datadir}/applications    \
141        %{SOURCE3}
142
143mkdir -p $RPM_BUILD_ROOT/%{_datadir}/pixmaps
144install -m 644 image/wsicon48.png $RPM_BUILD_ROOT/%{_datadir}/pixmaps/wireshark.png
145
146
147# Remove .la files
148rm -f $RPM_BUILD_ROOT/%{_libdir}/%{name}/plugins/%{version}/*.la
149
150# Remove .la files in libdir
151rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
152
153%clean
154rm -rf $RPM_BUILD_ROOT
155
156%post
157/sbin/ldconfig
158update-desktop-database -q
159
160%postun
161/sbin/ldconfig
162update-desktop-database -q
163
164%files
165%defattr(-,root,root)
166%doc AUTHORS COPYING ChangeLog INSTALL NEWS README*
167%{_sbindir}/editcap
168#%{_sbindir}/idl2wrs
169%{_sbindir}/tshark
170%{_sbindir}/mergecap
171%{_sbindir}/text2pcap
172%{_sbindir}/dftest
173%{_sbindir}/capinfos
174%{_sbindir}/randpkt
175%{_sbindir}/dumpcap
176%{_sbindir}/tethereal
177%{_sbindir}/rawshark
178%{python_sitelib}/*
179%{_libdir}/lib*
180%{_mandir}/man1/editcap.*
181%{_mandir}/man1/tshark.*
182%{_mandir}/man1/idl2wrs.*
183%{_mandir}/man1/mergecap.*
184%{_mandir}/man1/text2pcap.*
185%{_mandir}/man1/capinfos.*
186%{_mandir}/man1/dumpcap.*
187%{_mandir}/man4/wireshark-filter.*
188%{_libdir}/wireshark
189%config(noreplace) %{_sysconfdir}/pam.d/wireshark
190%config(noreplace) %{_sysconfdir}/security/console.apps/wireshark
191%{_datadir}/wireshark
192
193%{_datadir}/applications/*.desktop
194%{_datadir}/pixmaps/wireshark.png
195%{_bindir}/wireshark
196%{_sbindir}/wireshark
197%{_mandir}/man1/wireshark.*
198%{_mandir}/man1/rawshark.*
199%{_mandir}/man1/dftest.*
200%{_mandir}/man1/randpkt.*
201
202
203%changelog
204* Sat Nov 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.3-1
205- new upstream release
206
207* Thu Sep 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
208- new upstream release
209
210* Sun Jul 31 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
211- new upstream release
212
213* Sun Jun 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.7-1
214- new upstream release
215  (including security fix for CVE-2011-1957,1958,1959,2174,7175)
216
217* Sun Apr 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.6-1
218- new upstream release
219
220* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-2
221- rebuild with krb5-libs-1.8.2
222
223* Wed Mar 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-1
224- new upstream release
225  (including security fix for CVE-2011-0538 and CVE-2011-0713)
226
227* Sat Jan 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
228- new upstream release
229  (including security fix for CVE-2010-4538)
230
231* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-2
232- rebuild with openssl-1.0.0c
233
234* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
235- new upstream release
236
237* Sat Oct 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
238- new upstream release
239  (including security fix for CVE-2010-3445)
240
241* Sun Sep 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
242- new upstream release
243- add Patch5 (wireshark-1.4.0-lua-vine.patch)
244
245* Mon Aug 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-1
246- new upstream release
247  (including security fix for CVE-2010-2287 and CVE-2010-2284)
248
249* Wed Jul 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.9-1
250- new upstream release
251
252* Tue May 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.8-2
253- rebuilt with libpcap-1.1.1
254
255* Sat May 08 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
256- new upstream release
257  (including security fix for CVE-2010-1455)
258
259* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.7-1
260- new upstream release
261
262* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.2.5-3
263- rebuilt with python-2.6.4
264
265* Sun Dec 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-2
266- added --enable-wireshark instead of --enable-gtk2
267- added BR: bison, flex
268
269* Sat Dec 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.5-1
270- new upstream release with security fixes (SNA/SMB/IPMI issues)
271
272* Fri Oct 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-1
273- new upstream release
274  (includeing security fix for CVE-2009-3549,3550 and 3551)
275
276* Wed Sep 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.2-2
277- add BR: lua-devel (Vine 5.0 and later)
278
279* Sat Sep 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-1
280- new upstream release
281
282* Tue Jul 21 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
283- new upstream release
284
285* Mon Jul 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-1
286- new upstream release
287
288* Sat May 23 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.8-1
289- new upstream release
290
291* Fri Apr 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.7-1
292- new upstream release
293
294* Sun Feb  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.6-1
295- new upstream release
296- used more macros
297
298* Sat Jan 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-1
299- new upstream release
300
301* Sun Nov 09 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.4-2vl5
302- rebuilt
303
304* Mon Oct 27 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.4-1
305- new upstream release with security fix
306- add BuildRequires krb5-devel
307- SPEC in UTF-8
308
309* Fri Sep 05 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.3-1
310- new upstream release with security update
311
312* Wed Apr 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0-1
313- new upstream release with security update
314- add Vendor/Distribution tag
315- add BuildRequires: libcap-devel
316- new versioning policy
317
318* Tue Jan  8 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.99.7-0vl2
319- modified Source3 because of desktop-file-install error, like this:
320    /var/tmp/wireshark-0.99.7-root/usr/share/applications/wireshark.desktop:
321    error: value "wireshark.png" for key "Icon" in group "Desktop Entry" is
322    an icon name with an extension, but there should be no extension as
323    described in the Icon Theme Specification if the value is not an
324    absolute path
325  this warning/error occurs with desktop-file-utils >= 0.14
326
327* Wed Jan 2 2008 Satoshi MACHINO <machino@vinelinux.org> 0.99.7-0vl1
328- new upstream release
329- imported patch4 from fc9
330
331* Sun Sep  2 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.6-0vl2
332- rebuilt with libpcap-0.9.7
333- added --disable-warning-as-errors to %%configure for glib-2.14.0
334
335* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.6-0vl1
336- new upstream release
337- rebuilt with libpcap-0.9.6
338- added --with-pcap, --with-pcre
339
340* Fri Jun  1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.5-0vl2
341- rebuilt with new toolchain and environment
342
343* Thu Feb  8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.5-0vl1
344- new upstream release
345
346* Mon Nov 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.4-0vl1
347- new upstream release
348
349* Wed Oct  4 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.3-0vl1
350- initial built for Vine Linux based on Fedora
351- Obsoletes: ethereal, Provides: ethereal
352
353* Fri Aug 25 2006 Radek Vokal <rvokal@redhat.com> 0.99.3-fc5.1
354- upgrade to 0.99.3-1
355- CVE-2006-4330 Wireshark security issues (CVE-2006-4333 CVE-2006-4332 CVE-2006-4331)
356
357* Wed Jul 26 2006 Radek Vokal <rvokal@redhat.com> 0.99.2-fc5.2
358- fix BuildRequires
359
360* Tue Jul 25 2006 Radek Vokal <rvokal@redhat.com> 0.99.2-fc5.1
361- build for FC5
362
363* Tue Jul 18 2006 Radek Vok叩l <rvokal@redhat.com> 0.99.2-1
364- upgrade to 0.99.2
365
366* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.99.2-0.pre1.1
367- rebuild
368
369* Tue Jul 11 2006 Radek Vok叩l <rvokal@redhat.com> 0.99.2-0.pre1
370- upgrade to 0.99.2pre1, fixes (#198242)
371
372* Tue Jun 13 2006 Radek Vokal <rvokal@redhat.com> 0.99.1-0.pre1
373- spec file changes
374
375* Fri Jun  9 2006 Radek Vokal <rvokal@redhat.com> 0.99.1pre1-1
376- initial build for Fedora Core
Note: See TracBrowser for help on using the repository browser.