source: projects/specs/branches/6/w/wireshark/wireshark-vl.spec @ 10718

Revision 10718, 15.6 KB checked in by Takemikaduchi, 8 years ago (diff)

new upstream release

Line 
1%define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
2
3Summary:        Network traffic analyzer
4Summary(ja):    ネットワークトラフィック解析プログラム
5Name:           wireshark
6Version:        2.0.5
7Release:        1%{_dist_release}
8License:        GPLv2
9Group:          Applications/System
10Source0:        http://www.wireshark.org/download/src/%{name}-%{version}.tar.bz2
11Source1:        wireshark.pam
12Source2:        wireshark.console
13Source3:        wireshark.desktop
14Patch4:         wireshark-2.0.5-path.patch
15Patch5:         wireshark-1.10.0-lua-vine.patch
16URL:            http://www.wireshark.org/
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19
20BuildRequires:  libcap-devel
21BuildRequires:  net-snmp-devel >= 5.0
22BuildRequires:  net-snmp-utils >= 5.0
23BuildRequires:  zlib-devel, bzip2-devel
24BuildRequires:  openssl-devel
25BuildRequires:  glib2-devel, gtk2-devel
26BuildRequires:  libelf-devel
27BuildRequires:  python, pcre-devel
28BuildRequires:  gnutls-devel
29BuildRequires:  desktop-file-utils, automake, libtool
30BuildRequires:  bison, flex
31BuildRequires:  krb5-devel
32BuildRequires:  libpcap-devel
33BuildRequires:  lua-devel
34
35Requires:       usermode >= 1.37
36Requires(post): desktop-file-utils
37Requires(postun): desktop-file-utils
38
39Obsoletes:      ethereal
40Obsoletes:      ethereal-base ethereal-gnome ethereal-gtk+
41Obsoletes:      ethereal-kde ethereal-usermode
42Provides:       ethereal ethereal-gnome
43
44Vendor:         Project Vine
45Distribution:   Vine Linux
46Packager: inagaki, Takemikaduchi
47
48%description
49Wireshark is a network traffic analyzer for Unix-ish operating systems.
50
51This package lays base for libpcap, a packet capture and filtering
52library, contains command-line utilities, contains plugins and
53documentation for wireshark. A graphical user interface is also
54included with this package.
55
56%description -l ja
57Wireshark は,UNIX 系 OS 用のネットワークトラフィック解析プログラムです.
58
59このパッケージは,パケットキャプチャ/フィルタリングライブラリである
60libpcap を使ったコマンドラインツールと,プラグイン,ドキュメント等が
61収められています.GUI もこのパッケージに収められています.
62
63%prep
64%setup -q -n %{name}-%{version}
65%patch4 -p1
66%patch5 -p1 -b .lua-vine
67
68%build
69%ifarch s390 s390x
70export PIECFLAGS="-fPIE"
71%else
72export PIECFLAGS="-fpie"
73%endif
74# FC5+ automatic -fstack-protector-all switch
75export RPM_OPT_FLAGS=${RPM_OPT_FLAGS//-fstack-protector/-fstack-protector-all}
76## export CFLAGS="$RPM_OPT_FLAGS $CPPFLAGS -I%{_includedir}/pcap -I%{_includedir}/pcre"
77export CFLAGS="$RPM_OPT_FLAGS $CPPFLAGS -I%{_includedir}/pcre"
78export CXXFLAGS="$RPM_OPT_FLAGS $CPPFLAGS"
79export LDFLAGS="$LDFLAGS -lm -lcrypto"
80export PATH="$PATH:/usr/kerberos/bin"
81
82./autogen.sh
83# --disable-warning-as-erros needs for compiling with glib 2.14.0
84%configure \
85   --bindir=%{_sbindir} \
86   --enable-ipv6 \
87   --with-gnu-ld \
88   --disable-static \
89   --disable-usr-local \
90   --enable-wireshark \
91   --with-pic \
92   --with-ssl \
93   --with-pcap \
94   --with-pcre \
95%if %{?_dist_release} != "vl4"
96   --with-krb5 \
97%else
98   --without-krb5 \
99%endif
100   --with-plugins=%{_libdir}/%{name}/plugins/%{version} \
101   --disable-warnings-as-errors \
102   --without-qt \
103   --with-gtk2=yes \
104   --with-gtk3=no
105time make %{?_smp_mflags}
106
107%install
108rm -rf $RPM_BUILD_ROOT
109
110# The evil plugins hack
111perl -pi -e 's|-L../../epan|-L../../epan/.libs|' plugins/*/*.la
112
113make DESTDIR=$RPM_BUILD_ROOT install
114
115#symlink tshark to tethereal
116ln -s tshark $RPM_BUILD_ROOT%{_sbindir}/tethereal
117
118#empty?!
119rm -f $RPM_BUILD_ROOT%{_sbindir}/idl2wrs
120
121# install support files for usermode, gnome and kde
122mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/pam.d
123install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/pam.d/wireshark
124mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/security/console.apps
125install -m 644 %{SOURCE2} $RPM_BUILD_ROOT/%{_sysconfdir}/security/console.apps/wireshark
126mkdir -p $RPM_BUILD_ROOT/%{_bindir}
127ln -s consolehelper $RPM_BUILD_ROOT/%{_bindir}/wireshark
128
129mv $RPM_BUILD_ROOT/%{_sbindir}/wireshark-gtk $RPM_BUILD_ROOT/%{_sbindir}/wireshark
130
131# install man
132## mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
133## install -m 644 *.1 $RPM_BUILD_ROOT/%{_mandir}/man1
134
135# Install python stuff.
136mkdir -p $RPM_BUILD_ROOT%{python_sitelib}
137install -m 644 tools/wireshark_be.py tools/wireshark_gen.py  $RPM_BUILD_ROOT%{python_sitelib}
138
139desktop-file-install --vendor=                             \
140        --dir ${RPM_BUILD_ROOT}%{_datadir}/applications    \
141        %{SOURCE3}
142
143mkdir -p $RPM_BUILD_ROOT/%{_datadir}/pixmaps
144install -m 644 image/wsicon48.png $RPM_BUILD_ROOT/%{_datadir}/pixmaps/wireshark.png
145
146
147# Remove .la files
148rm -f $RPM_BUILD_ROOT/%{_libdir}/%{name}/plugins/%{version}/*.la
149
150# Remove .la files in libdir
151rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
152
153%clean
154rm -rf $RPM_BUILD_ROOT
155
156%post
157/sbin/ldconfig
158update-desktop-database -q
159
160%postun
161/sbin/ldconfig
162update-desktop-database -q
163
164%files
165%defattr(-,root,root)
166%doc AUTHORS COPYING ChangeLog INSTALL NEWS README*
167%{_sbindir}/androiddump
168%{_sbindir}/editcap
169%{_sbindir}/tshark
170%{_sbindir}/mergecap
171%{_sbindir}/text2pcap
172%{_sbindir}/dftest
173%{_sbindir}/capinfos
174%{_sbindir}/captype
175%{_sbindir}/randpkt
176%{_sbindir}/dumpcap
177%{_sbindir}/tethereal
178%{_sbindir}/rawshark
179%{_sbindir}/reordercap
180%{python_sitelib}/*
181%{_libdir}/lib*
182%{_mandir}/man1/androiddump.*
183%{_mandir}/man1/editcap.*
184%{_mandir}/man1/tshark.*
185%{_mandir}/man1/mergecap.*
186%{_mandir}/man1/text2pcap.*
187%{_mandir}/man1/capinfos.*
188%{_mandir}/man1/dumpcap.*
189%{_mandir}/man1/reordercap.*
190%{_mandir}/man4/wireshark-filter.*
191%{_mandir}/man1/rawshark.*
192%{_mandir}/man1/dftest.*
193%{_mandir}/man1/randpkt.*
194%{_libdir}/wireshark
195%config(noreplace) %{_sysconfdir}/pam.d/wireshark
196%config(noreplace) %{_sysconfdir}/security/console.apps/wireshark
197
198%config(noreplace) %{_datadir}/%{name}/init.lua
199%{_datadir}/%{name}/AUTHORS-SHORT
200%{_datadir}/%{name}/COPYING
201%{_datadir}/%{name}/*.html
202%{_datadir}/%{name}/*.css
203%{_datadir}/%{name}/cfilters
204%{_datadir}/%{name}/colorfilters
205%{_datadir}/%{name}/console.lua
206%{_datadir}/%{name}/dfilters
207%{_datadir}/%{name}/diameter
208%{_datadir}/%{name}/dtd_gen.lua
209%{_datadir}/%{name}/dtds
210%{_datadir}/%{name}/help
211%{_datadir}/%{name}/manuf
212%{_datadir}/%{name}/pdml2html.xsl
213%{_datadir}/%{name}/profiles
214%{_datadir}/%{name}/radius
215%{_datadir}/%{name}/services
216%{_datadir}/%{name}/smi_modules
217%{_datadir}/%{name}/tpncp
218%{_datadir}/%{name}/wimaxasncp
219
220%{_datadir}/icons/hicolor/*/*/*
221
222%{_datadir}/applications/*.desktop
223%{_datadir}/appdata/wireshark.appdata.xml
224%{_datadir}/mime/packages/wireshark.xml
225%{_datadir}/pixmaps/wireshark.png
226%{_bindir}/wireshark
227%{_sbindir}/wireshark
228%{_mandir}/man1/wireshark.*
229
230
231%changelog
232* Sun Jul 31 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.5-1
233- new upstream release
234- update Patch4 (wireshark-2.0.5-path.patch)
235
236* Thu May 05 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.11-1
237- new upstream release
238  (including security fix for CVE-2016-2521,2523,2530,2531,2532)
239
240* Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.9-1
241- new upstream release
242
243* Thu Oct 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.8-1
244- new upstream release (including security fix for CVE-2015-7830)
245
246* Sun Aug 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.7-1
247- new upstream release
248
249* Thu Jun 18 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.6-1
250- new upstream release
251
252* Wed May 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.14-1
253- new upstream release
254  (including security fix for CVE-2015-3811,3812,3814)
255
256* Sun Mar 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.13-1
257- new upstream release
258  (including security fix for CVE-2015-2188,2189,2190)
259
260* Sat Jan 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.12-1
261- new upstream release
262  (including security fix for CVE-2015-0562,0563,0564)
263
264* Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.11-1
265- new upstream release
266  (including security fix for CVE-2014-8710,8711,8712,8713,8714)
267
268* Wed Sep 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.10-1
269- new upstream release
270
271* Tue Aug  5 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.10.9-1
272- new upstream release with security fixes
273
274* Fri Jun 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
275- new upstream release
276- update Patch5 (wireshark-1.10.0-lua-vine.patch)
277- remove Patch3 (wireshark-nfsv4-opts.patch)
278
279* Tue Mar 11 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.8.13-1
280- new upstream release with security fixes
281
282* Fri Dec 20 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.8.12-1
283- new upstream release with security fixes 
284
285* Tue Nov  5 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.8.11-1
286- new upstream release with security fixes
287
288* Mon Sep 16 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.10-1
289- new upstream release
290
291* Sun Jul 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.9-1
292- new upstream release
293  (including security fix for CVE-2013-4927,4929,4930,4931,4932,4944,4934,4935)
294
295* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.15-1
296- new upstream release
297
298* Sun Mar 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
299- new upstream release
300  (including security fix for CVE-2013-2475 - 2488)
301
302* Wed Jan 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.13-1
303- new upstream release
304
305* Thu Nov 29 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.12-1
306- new upstream release with security fixes
307
308* Wed Oct 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.11-1
309- new upstream release
310 (including security fix for CVE-2012-5239)
311
312* Thu Aug 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-1
313- new upstream release
314 (including security fix for CVE-2012-4285 - 4298)
315
316* Wed May 23 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
317- new upstream release
318
319* Sun Apr 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.7-1
320- new upstream release
321
322* Thu Jan 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.5-1
323- new upstream release
324
325* Tue Nov 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
326- new upstream release
327
328* Sat Nov 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.3-1
329- new upstream release
330
331* Thu Sep 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
332- new upstream release
333
334* Sun Jul 31 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
335- new upstream release
336
337* Sun Jun 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.7-1
338- new upstream release
339  (including security fix for CVE-2011-1957,1958,1959,2174,7175)
340
341* Sun Apr 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.6-1
342- new upstream release
343
344* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-2
345- rebuild with krb5-libs-1.8.2
346
347* Wed Mar 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-1
348- new upstream release
349  (including security fix for CVE-2011-0538 and CVE-2011-0713)
350
351* Sat Jan 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
352- new upstream release
353  (including security fix for CVE-2010-4538)
354
355* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-2
356- rebuild with openssl-1.0.0c
357
358* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
359- new upstream release
360
361* Sat Oct 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
362- new upstream release
363  (including security fix for CVE-2010-3445)
364
365* Sun Sep 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
366- new upstream release
367- add Patch5 (wireshark-1.4.0-lua-vine.patch)
368
369* Mon Aug 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-1
370- new upstream release
371  (including security fix for CVE-2010-2287 and CVE-2010-2284)
372
373* Wed Jul 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.9-1
374- new upstream release
375
376* Tue May 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.8-2
377- rebuilt with libpcap-1.1.1
378
379* Sat May 08 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
380- new upstream release
381  (including security fix for CVE-2010-1455)
382
383* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.7-1
384- new upstream release
385
386* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.2.5-3
387- rebuilt with python-2.6.4
388
389* Sun Dec 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-2
390- added --enable-wireshark instead of --enable-gtk2
391- added BR: bison, flex
392
393* Sat Dec 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.5-1
394- new upstream release with security fixes (SNA/SMB/IPMI issues)
395
396* Fri Oct 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-1
397- new upstream release
398  (includeing security fix for CVE-2009-3549,3550 and 3551)
399
400* Wed Sep 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.2-2
401- add BR: lua-devel (Vine 5.0 and later)
402
403* Sat Sep 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-1
404- new upstream release
405
406* Tue Jul 21 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
407- new upstream release
408
409* Mon Jul 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-1
410- new upstream release
411
412* Sat May 23 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.8-1
413- new upstream release
414
415* Fri Apr 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.7-1
416- new upstream release
417
418* Sun Feb  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.6-1
419- new upstream release
420- used more macros
421
422* Sat Jan 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-1
423- new upstream release
424
425* Sun Nov 09 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.4-2vl5
426- rebuilt
427
428* Mon Oct 27 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.4-1
429- new upstream release with security fix
430- add BuildRequires krb5-devel
431- SPEC in UTF-8
432
433* Fri Sep 05 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.3-1
434- new upstream release with security update
435
436* Wed Apr 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0-1
437- new upstream release with security update
438- add Vendor/Distribution tag
439- add BuildRequires: libcap-devel
440- new versioning policy
441
442* Tue Jan  8 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.99.7-0vl2
443- modified Source3 because of desktop-file-install error, like this:
444    /var/tmp/wireshark-0.99.7-root/usr/share/applications/wireshark.desktop:
445    error: value "wireshark.png" for key "Icon" in group "Desktop Entry" is
446    an icon name with an extension, but there should be no extension as
447    described in the Icon Theme Specification if the value is not an
448    absolute path
449  this warning/error occurs with desktop-file-utils >= 0.14
450
451* Wed Jan 2 2008 Satoshi MACHINO <machino@vinelinux.org> 0.99.7-0vl1
452- new upstream release
453- imported patch4 from fc9
454
455* Sun Sep  2 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.6-0vl2
456- rebuilt with libpcap-0.9.7
457- added --disable-warning-as-errors to %%configure for glib-2.14.0
458
459* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.6-0vl1
460- new upstream release
461- rebuilt with libpcap-0.9.6
462- added --with-pcap, --with-pcre
463
464* Fri Jun  1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.5-0vl2
465- rebuilt with new toolchain and environment
466
467* Thu Feb  8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.5-0vl1
468- new upstream release
469
470* Mon Nov 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.4-0vl1
471- new upstream release
472
473* Wed Oct  4 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.3-0vl1
474- initial built for Vine Linux based on Fedora
475- Obsoletes: ethereal, Provides: ethereal
476
477* Fri Aug 25 2006 Radek Vokal <rvokal@redhat.com> 0.99.3-fc5.1
478- upgrade to 0.99.3-1
479- CVE-2006-4330 Wireshark security issues (CVE-2006-4333 CVE-2006-4332 CVE-2006-4331)
480
481* Wed Jul 26 2006 Radek Vokal <rvokal@redhat.com> 0.99.2-fc5.2
482- fix BuildRequires
483
484* Tue Jul 25 2006 Radek Vokal <rvokal@redhat.com> 0.99.2-fc5.1
485- build for FC5
486
487* Tue Jul 18 2006 Radek Vok叩l <rvokal@redhat.com> 0.99.2-1
488- upgrade to 0.99.2
489
490* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.99.2-0.pre1.1
491- rebuild
492
493* Tue Jul 11 2006 Radek Vok叩l <rvokal@redhat.com> 0.99.2-0.pre1
494- upgrade to 0.99.2pre1, fixes (#198242)
495
496* Tue Jun 13 2006 Radek Vokal <rvokal@redhat.com> 0.99.1-0.pre1
497- spec file changes
498
499* Fri Jun  9 2006 Radek Vokal <rvokal@redhat.com> 0.99.1pre1-1
500- initial build for Fedora Core
Note: See TracBrowser for help on using the repository browser.