source: projects/specs/branches/6/w/wireshark/wireshark-vl.spec @ 9920

Revision 9920, 14.6 KB checked in by Takemikaduchi, 8 years ago (diff)

new upstream release

Line 
1%define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
2
3Summary:        Network traffic analyzer
4Summary(ja):    ネットワークトラフィック解析プログラム
5Name:           wireshark
6Version:        1.12.9
7Release:        1%{_dist_release}
8License:        GPLv2
9Group:          Applications/System
10Source0:        http://www.wireshark.org/download/src/%{name}-%{version}.tar.bz2
11Source1:        wireshark.pam
12Source2:        wireshark.console
13Source3:        wireshark.desktop
14Patch4:         wireshark-0.99.7-path.patch
15Patch5:         wireshark-1.10.0-lua-vine.patch
16URL:            http://www.wireshark.org/
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19BuildRequires:  libcap-devel
20BuildRequires:  net-snmp-devel >= 5.0
21BuildRequires:  net-snmp-utils >= 5.0
22BuildRequires:  zlib-devel, bzip2-devel
23BuildRequires:  openssl-devel
24BuildRequires:  glib2-devel, gtk2-devel
25BuildRequires:  libelf-devel
26BuildRequires:  python, pcre-devel
27BuildRequires:  gnutls-devel
28BuildRequires:  desktop-file-utils, automake, libtool
29BuildRequires:  bison, flex
30%if %{?_dist_release} != "vl4"
31BuildRequires:  krb5-devel
32BuildRequires:  libpcap-devel
33BuildRequires:  lua-devel
34%else
35BuildRequires:  libpcap
36%endif
37Requires:       usermode >= 1.37
38Requires(post): desktop-file-utils
39Requires(postun): desktop-file-utils
40
41Obsoletes:      ethereal
42Obsoletes:      ethereal-base ethereal-gnome ethereal-gtk+
43Obsoletes:      ethereal-kde ethereal-usermode
44Provides:       ethereal ethereal-gnome
45
46Vendor:         Project Vine
47Distribution:   Vine Linux
48Packager: inagaki, Takemikaduchi
49
50%description
51Wireshark is a network traffic analyzer for Unix-ish operating systems.
52
53This package lays base for libpcap, a packet capture and filtering
54library, contains command-line utilities, contains plugins and
55documentation for wireshark. A graphical user interface is also
56included with this package.
57
58%description -l ja
59Wireshark は,UNIX 系 OS 用のネットワークトラフィック解析プログラムです.
60
61このパッケージは,パケットキャプチャ/フィルタリングライブラリである
62libpcap を使ったコマンドラインツールと,プラグイン,ドキュメント等が
63収められています.GUI もこのパッケージに収められています.
64
65%prep
66%setup -q -n %{name}-%{version}
67%patch4 -p1
68%patch5 -p1 -b .lua-vine
69
70%build
71%ifarch s390 s390x
72export PIECFLAGS="-fPIE"
73%else
74export PIECFLAGS="-fpie"
75%endif
76# FC5+ automatic -fstack-protector-all switch
77export RPM_OPT_FLAGS=${RPM_OPT_FLAGS//-fstack-protector/-fstack-protector-all}
78## export CFLAGS="$RPM_OPT_FLAGS $CPPFLAGS -I%{_includedir}/pcap -I%{_includedir}/pcre"
79export CFLAGS="$RPM_OPT_FLAGS $CPPFLAGS -I%{_includedir}/pcre"
80export CXXFLAGS="$RPM_OPT_FLAGS $CPPFLAGS"
81export LDFLAGS="$LDFLAGS -lm -lcrypto"
82export PATH="$PATH:/usr/kerberos/bin"
83./autogen.sh
84# --disable-warning-as-erros needs for compiling with glib 2.14.0
85%configure \
86   --bindir=%{_sbindir} \
87   --enable-ipv6 \
88   --with-gnu-ld \
89   --disable-static \
90   --disable-usr-local \
91   --enable-wireshark \
92   --with-pic \
93   --with-ssl \
94   --with-pcap \
95   --with-pcre \
96%if %{?_dist_release} != "vl4"
97   --with-krb5 \
98%else
99   --without-krb5 \
100%endif
101   --with-plugins=%{_libdir}/%{name}/plugins/%{version} \
102   --disable-warnings-as-errors \
103   --without-qt \
104   --with-gtk2=yes \
105   --with-gtk3=no
106time make %{?_smp_mflags}
107
108%install
109rm -rf $RPM_BUILD_ROOT
110
111# The evil plugins hack
112perl -pi -e 's|-L../../epan|-L../../epan/.libs|' plugins/*/*.la
113
114make DESTDIR=$RPM_BUILD_ROOT install
115
116#symlink tshark to tethereal
117ln -s tshark $RPM_BUILD_ROOT%{_sbindir}/tethereal
118
119#empty?!
120rm -f $RPM_BUILD_ROOT%{_sbindir}/idl2wrs
121
122# install support files for usermode, gnome and kde
123mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/pam.d
124install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/pam.d/wireshark
125mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/security/console.apps
126install -m 644 %{SOURCE2} $RPM_BUILD_ROOT/%{_sysconfdir}/security/console.apps/wireshark
127mkdir -p $RPM_BUILD_ROOT/%{_bindir}
128ln -s consolehelper $RPM_BUILD_ROOT/%{_bindir}/wireshark
129
130# install man
131## mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
132## install -m 644 *.1 $RPM_BUILD_ROOT/%{_mandir}/man1
133
134# Install python stuff.
135mkdir -p $RPM_BUILD_ROOT%{python_sitelib}
136install -m 644 tools/wireshark_be.py tools/wireshark_gen.py  $RPM_BUILD_ROOT%{python_sitelib}
137
138desktop-file-install --vendor=                             \
139        --dir ${RPM_BUILD_ROOT}%{_datadir}/applications    \
140        %{SOURCE3}
141
142mkdir -p $RPM_BUILD_ROOT/%{_datadir}/pixmaps
143install -m 644 image/wsicon48.png $RPM_BUILD_ROOT/%{_datadir}/pixmaps/wireshark.png
144
145
146# Remove .la files
147rm -f $RPM_BUILD_ROOT/%{_libdir}/%{name}/plugins/%{version}/*.la
148
149# Remove .la files in libdir
150rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
151
152%clean
153rm -rf $RPM_BUILD_ROOT
154
155%post
156/sbin/ldconfig
157update-desktop-database -q
158
159%postun
160/sbin/ldconfig
161update-desktop-database -q
162
163%files
164%defattr(-,root,root)
165%doc AUTHORS COPYING ChangeLog INSTALL NEWS README*
166%{_sbindir}/editcap
167#%{_sbindir}/idl2wrs
168%{_sbindir}/tshark
169%{_sbindir}/mergecap
170%{_sbindir}/text2pcap
171%{_sbindir}/dftest
172%{_sbindir}/capinfos
173%{_sbindir}/captype
174%{_sbindir}/randpkt
175%{_sbindir}/dumpcap
176%{_sbindir}/tethereal
177%{_sbindir}/rawshark
178%{_sbindir}/reordercap
179%{python_sitelib}/*
180%{_libdir}/lib*
181%{_mandir}/man1/editcap.*
182%{_mandir}/man1/tshark.*
183%{_mandir}/man1/mergecap.*
184%{_mandir}/man1/text2pcap.*
185%{_mandir}/man1/capinfos.*
186%{_mandir}/man1/dumpcap.*
187%{_mandir}/man1/reordercap.*
188%{_mandir}/man4/wireshark-filter.*
189%{_libdir}/wireshark
190%config(noreplace) %{_sysconfdir}/pam.d/wireshark
191%config(noreplace) %{_sysconfdir}/security/console.apps/wireshark
192%{_datadir}/wireshark
193
194%{_datadir}/applications/*.desktop
195%{_datadir}/pixmaps/wireshark.png
196%{_bindir}/wireshark
197%{_sbindir}/wireshark
198%{_mandir}/man1/wireshark.*
199%{_mandir}/man1/rawshark.*
200%{_mandir}/man1/dftest.*
201%{_mandir}/man1/randpkt.*
202
203
204%changelog
205* Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.9-1
206- new upstream release
207
208* Thu Oct 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.8-1
209- new upstream release (including security fix for CVE-2015-7830)
210
211* Sun Aug 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.7-1
212- new upstream release
213
214* Thu Jun 18 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.6-1
215- new upstream release
216
217* Wed May 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.14-1
218- new upstream release
219  (including security fix for CVE-2015-3811,3812,3814)
220
221* Sun Mar 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.13-1
222- new upstream release
223  (including security fix for CVE-2015-2188,2189,2190)
224
225* Sat Jan 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.12-1
226- new upstream release
227  (including security fix for CVE-2015-0562,0563,0564)
228
229* Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.11-1
230- new upstream release
231  (including security fix for CVE-2014-8710,8711,8712,8713,8714)
232
233* Wed Sep 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.10-1
234- new upstream release
235
236* Tue Aug  5 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.10.9-1
237- new upstream release with security fixes
238
239* Fri Jun 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
240- new upstream release
241- update Patch5 (wireshark-1.10.0-lua-vine.patch)
242- remove Patch3 (wireshark-nfsv4-opts.patch)
243
244* Tue Mar 11 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.8.13-1
245- new upstream release with security fixes
246
247* Fri Dec 20 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.8.12-1
248- new upstream release with security fixes 
249
250* Tue Nov  5 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.8.11-1
251- new upstream release with security fixes
252
253* Mon Sep 16 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.10-1
254- new upstream release
255
256* Sun Jul 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.9-1
257- new upstream release
258  (including security fix for CVE-2013-4927,4929,4930,4931,4932,4944,4934,4935)
259
260* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.15-1
261- new upstream release
262
263* Sun Mar 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
264- new upstream release
265  (including security fix for CVE-2013-2475 - 2488)
266
267* Wed Jan 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.13-1
268- new upstream release
269
270* Thu Nov 29 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.12-1
271- new upstream release with security fixes
272
273* Wed Oct 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.11-1
274- new upstream release
275 (including security fix for CVE-2012-5239)
276
277* Thu Aug 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-1
278- new upstream release
279 (including security fix for CVE-2012-4285 - 4298)
280
281* Wed May 23 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
282- new upstream release
283
284* Sun Apr 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.7-1
285- new upstream release
286
287* Thu Jan 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.5-1
288- new upstream release
289
290* Tue Nov 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
291- new upstream release
292
293* Sat Nov 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.3-1
294- new upstream release
295
296* Thu Sep 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
297- new upstream release
298
299* Sun Jul 31 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
300- new upstream release
301
302* Sun Jun 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.7-1
303- new upstream release
304  (including security fix for CVE-2011-1957,1958,1959,2174,7175)
305
306* Sun Apr 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.6-1
307- new upstream release
308
309* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-2
310- rebuild with krb5-libs-1.8.2
311
312* Wed Mar 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-1
313- new upstream release
314  (including security fix for CVE-2011-0538 and CVE-2011-0713)
315
316* Sat Jan 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
317- new upstream release
318  (including security fix for CVE-2010-4538)
319
320* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-2
321- rebuild with openssl-1.0.0c
322
323* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
324- new upstream release
325
326* Sat Oct 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
327- new upstream release
328  (including security fix for CVE-2010-3445)
329
330* Sun Sep 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
331- new upstream release
332- add Patch5 (wireshark-1.4.0-lua-vine.patch)
333
334* Mon Aug 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-1
335- new upstream release
336  (including security fix for CVE-2010-2287 and CVE-2010-2284)
337
338* Wed Jul 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.9-1
339- new upstream release
340
341* Tue May 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.8-2
342- rebuilt with libpcap-1.1.1
343
344* Sat May 08 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
345- new upstream release
346  (including security fix for CVE-2010-1455)
347
348* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.7-1
349- new upstream release
350
351* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.2.5-3
352- rebuilt with python-2.6.4
353
354* Sun Dec 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-2
355- added --enable-wireshark instead of --enable-gtk2
356- added BR: bison, flex
357
358* Sat Dec 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.5-1
359- new upstream release with security fixes (SNA/SMB/IPMI issues)
360
361* Fri Oct 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-1
362- new upstream release
363  (includeing security fix for CVE-2009-3549,3550 and 3551)
364
365* Wed Sep 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.2-2
366- add BR: lua-devel (Vine 5.0 and later)
367
368* Sat Sep 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-1
369- new upstream release
370
371* Tue Jul 21 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
372- new upstream release
373
374* Mon Jul 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-1
375- new upstream release
376
377* Sat May 23 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.8-1
378- new upstream release
379
380* Fri Apr 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.7-1
381- new upstream release
382
383* Sun Feb  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.6-1
384- new upstream release
385- used more macros
386
387* Sat Jan 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-1
388- new upstream release
389
390* Sun Nov 09 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.4-2vl5
391- rebuilt
392
393* Mon Oct 27 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.4-1
394- new upstream release with security fix
395- add BuildRequires krb5-devel
396- SPEC in UTF-8
397
398* Fri Sep 05 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.3-1
399- new upstream release with security update
400
401* Wed Apr 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0-1
402- new upstream release with security update
403- add Vendor/Distribution tag
404- add BuildRequires: libcap-devel
405- new versioning policy
406
407* Tue Jan  8 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.99.7-0vl2
408- modified Source3 because of desktop-file-install error, like this:
409    /var/tmp/wireshark-0.99.7-root/usr/share/applications/wireshark.desktop:
410    error: value "wireshark.png" for key "Icon" in group "Desktop Entry" is
411    an icon name with an extension, but there should be no extension as
412    described in the Icon Theme Specification if the value is not an
413    absolute path
414  this warning/error occurs with desktop-file-utils >= 0.14
415
416* Wed Jan 2 2008 Satoshi MACHINO <machino@vinelinux.org> 0.99.7-0vl1
417- new upstream release
418- imported patch4 from fc9
419
420* Sun Sep  2 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.6-0vl2
421- rebuilt with libpcap-0.9.7
422- added --disable-warning-as-errors to %%configure for glib-2.14.0
423
424* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.6-0vl1
425- new upstream release
426- rebuilt with libpcap-0.9.6
427- added --with-pcap, --with-pcre
428
429* Fri Jun  1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.5-0vl2
430- rebuilt with new toolchain and environment
431
432* Thu Feb  8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.5-0vl1
433- new upstream release
434
435* Mon Nov 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.4-0vl1
436- new upstream release
437
438* Wed Oct  4 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.3-0vl1
439- initial built for Vine Linux based on Fedora
440- Obsoletes: ethereal, Provides: ethereal
441
442* Fri Aug 25 2006 Radek Vokal <rvokal@redhat.com> 0.99.3-fc5.1
443- upgrade to 0.99.3-1
444- CVE-2006-4330 Wireshark security issues (CVE-2006-4333 CVE-2006-4332 CVE-2006-4331)
445
446* Wed Jul 26 2006 Radek Vokal <rvokal@redhat.com> 0.99.2-fc5.2
447- fix BuildRequires
448
449* Tue Jul 25 2006 Radek Vokal <rvokal@redhat.com> 0.99.2-fc5.1
450- build for FC5
451
452* Tue Jul 18 2006 Radek Vok叩l <rvokal@redhat.com> 0.99.2-1
453- upgrade to 0.99.2
454
455* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.99.2-0.pre1.1
456- rebuild
457
458* Tue Jul 11 2006 Radek Vok叩l <rvokal@redhat.com> 0.99.2-0.pre1
459- upgrade to 0.99.2pre1, fixes (#198242)
460
461* Tue Jun 13 2006 Radek Vokal <rvokal@redhat.com> 0.99.1-0.pre1
462- spec file changes
463
464* Fri Jun  9 2006 Radek Vokal <rvokal@redhat.com> 0.99.1pre1-1
465- initial build for Fedora Core
Note: See TracBrowser for help on using the repository browser.