source: projects/specs/branches/6/u/unzip/unzip-vl.spec @ 9307

Revision 9307, 8.8 KB checked in by iwamoto, 9 years ago (diff)

unzip: update to 6.0 + fc22 patches + security patches

Line 
1%define src_file unzip60
2
3Summary: A utility for unpacking zip files.
4Summary(ja): zip ファイルを展開するユーティリティ
5Name: unzip
6Version: 6.0
7Release: 3%{?_dist_release}
8License: BSD
9Group: Applications/Archiving
10URL: http://www.info-zip.org/UnZip.html
11
12Source: http://downloads.sourceforge.net/infozip/%{src_file}.tar.gz
13
14# Not sent to upstream.
15Patch1: unzip-6.0-bzip2-configure.patch
16# Upstream plans to do this in zip (hopefully also in unzip).
17Patch2: unzip-6.0-exec-shield.patch
18# Upstream plans to do similar thing.
19Patch3: unzip-6.0-close.patch
20# Details in rhbz#532380.
21# Reported to upstream: http://www.info-zip.org/board/board.pl?m-1259575993/
22Patch4: unzip-6.0-attribs-overflow.patch
23# Not sent to upstream, as it's Fedora/RHEL specific.
24# Modify the configure script not to request the strip of binaries.
25Patch5: unzip-6.0-nostrip.patch
26Patch6: unzip-6.0-manpage-fix.patch
27# Update match.c with recmatch() from zip 3.0's util.c
28# This also resolves the license issue in that old function.
29# Original came from here: https://projects.parabolagnulinux.org/abslibre.git/plain/libre/unzip-libre/match.patch
30Patch7: unzip-6.0-fix-recmatch.patch
31# Update process.c
32Patch8: unzip-6.0-symlink.patch
33# change using of macro "case_map" by "to_up"
34Patch9: unzip-6.0-caseinsensitive.patch
35# downstream fix for "-Werror=format-security"
36# upstream doesn't want hear about this option again
37Patch10: unzip-6.0-format-secure.patch
38Patch11: unzip-6.0-valgrind.patch
39Patch12: unzip-6.0-x-option.patch
40
41# security
42Patch100: unzip-6.0-CVE-2014-8139.patch
43Patch110: unzip-6.0-CVE-2014-8140.patch
44Patch120: unzip-6.0-CVE-2014-8141.patch
45
46# japanese charset support
47# https://gist.github.com/hamano/573753
48Patch200: unzip-6.0-japanese_charset.patch
49# just ignore -E option, older nls patch use this.
50Patch201: unzip-6.0-ignore-E-option.patch
51# support ja_JP.utf8 locale
52Patch202: unzip-6.0-japanese_charset-utf8.patch
53
54BuildRoot: %{_tmppath}/%{name}-%{version}-root
55
56Vendor: Project Vine
57Distribution: Vine Linux
58Packager: daisuke
59
60%description
61The unzip utility is used to list, test, or extract files from a zip
62archive.  Zip archives are commonly found on MS-DOS systems.  The zip
63utility, included in the zip package, creates zip archives.  Zip and
64unzip are both compatible with archives created by PKWARE(R)'s PKZIP
65for MS-DOS, but the programs' options and default behaviors do differ
66in some respects.
67
68Install the unzip package if you need to list, test or extract files from
69a zip archive.
70
71%description -l ja
72unzip ユーティリティは,zip アーカイブ内のファイルを一覧表示したり,
73テスト/展開する為に使うユーティリティです.zip アーカイブは MS-DOS
74システムで一般的に使われます.
75zip パッケージに含まれる zip プログラムは zip アーカイブを
76作成するのに使います.
77zip と unzip は PKWARE(R) の MS-DOS 用 PKZIP で作成された zip アーカイブに
78対応していますが,デフォルトの動作やプログラムオプション等一部が
79異なります.
80
81
82%prep
83%setup -q -n %{src_file}
84%patch1 -p1 -b .bzip2-configure
85%patch2 -p1 -b .exec-shield
86%patch3 -p1 -b .close
87%patch4 -p1 -b .attribs-overflow
88%patch5 -p1 -b .nostrip
89%patch6 -p1 -b .manpage-fix
90%patch7 -p1 -b .recmatch
91%patch8 -p1 -b .symlink
92%patch9 -p1 -b .caseinsensitive
93%patch10 -p1 -b .format-secure
94%patch11 -p1 -b .valgrind
95%patch12 -p1 -b .x-option
96
97# security
98%patch100 -p1 -b .CVE-2014-8139
99%patch110 -p1 -b .CVE-2014-8140
100%patch120 -p1 -b .CVE-2014-8141
101
102%patch200 -p1 -b .jp
103%patch201 -p1 -b .ignore-E
104%patch202 -p1 -b .utf8
105
106ln -s unix/Makefile Makefile
107
108%build
109make LOCAL_UNZIP="-D_FILE_OFFSET_BITS=64 -DNO_LCHMOD -D_MBCS -DNO_WORKING_ISPRINT" linux_noasm
110
111%install
112[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
113
114make prefix=$RPM_BUILD_ROOT%{_prefix} MANDIR=$RPM_BUILD_ROOT/%{_mandir}/man1 install LF2=""
115
116
117%clean
118[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
119
120
121%files
122%defattr(-,root,root)
123%doc README BUGS LICENSE INSTALL
124%{_bindir}/*
125%{_mandir}/*/*
126
127
128%changelog
129* Sun Jan 18 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>  6.0-3
130- add Patch100 for fix CVE-2014-8139 (crc-overflow)
131- add Patch110 for fix CVE-2014-8140 (test-compr-eb)
132- add Patch120 for fix CVE-2014-8141 (getzip64data)
133- add Patch9-12 from fc22
134
135* Thu Jul 03 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 6.0-2
136- add patch202 to support ja_JP.utf8
137
138* Thu May 22 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 6.0-1
139- update to 6.0
140- replace nls patch.
141
142* Tue Apr  5 2011 IWAI, Masaharu <iwai@alib.jp> 5.52-3vl6
143- build on current VineSeed
144
145* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.52-2
146- spec in utf-8
147- add NLS patch
148
149* Wed Apr 09 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.52-1
150- new upstream release
151- add patch13 from fc8
152- update patches to fit new release & drop old patches
153- with new versioning polity
154
155* Wed Apr 09 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.51-11vl4
156- fix changelog typo
157
158* Wed Apr 09 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.51-10vl4
159- update patch100 to fix ppc issue (it was patch5, from rhel4)
160- renumber patchs
161- add patch 2,3 to support big archive (from rhel4)
162- with new versioning polity
163
164* Fri Mar 21 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.51-9vl1.1
165- add patch5 for fix CVE-2005-4667
166- add patch6 for fix CVE-2008-0888
167- add Vendor/Distribution tag
168
169* Tue May 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.51-9vl1
170- new upstream release
171- based on 5.51-9 Fedora development
172  * Thu Feb 10 2005 Ivana Varekova <varekova@redhat.com> 5.51-9
173  - fix the other problem with unpacking zipfiles containing symlinks
174    (bug #134073)
175  * Thu Feb 03 2005 Ivana Varekova <varekova@redhat.com> 5.51-8
176  - fix segfault with unpacking of zipfiles containing dangling symlinks
177    (bug #134073)
178  * Thu Dec 02 2004 Lon Hohberger <lhh@redhat.com> 5.51-5
179  - Fix segfault on extraction of symlinks
180  * Mon Jun 21 2004 Lon Hohberger <lhh@redhat.com> 5.51-4
181  - Extend max file/archive size to 2^32-8193 (4294959103) bytes
182  * Tue Jun 08 2004 Lon Hohberger <lhh@redhat.com> 5.51-1.1
183  - Update to 5.51; remove dotdot patch.
184
185* Tue Sep 23 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.50-5vl2
186- merged patch1 from Vine Linux 2.6 updates
187  - Thu Aug 28 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.50-4vl3
188  - replace patch1 from RedHat (RHSA-2003:199-02).
189
190  - Fri Jul 18 2003 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 5.50-4vl2
191  - added patch1 from Redhat (RHSA-2003:199-01)
192
193
194* Sun Dec  1 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.50-5vl1
195- modified changelog section :-P (merge rawhidee changelogs)
196
197  - Sun Dec  1 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.50-4vl2
198  - rebuild with new toolchains
199
200  - Sun May 26 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.50-4vl1
201  - based on 5.50-4 from Rawhide
202  - previous Vine version was 5.41-3vl1:
203
204  - Tue Dec 26 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
205  - 5.41-3vl1
206  - based on 5.41-3 from Rawhide
207  - added Japanese summary and description
208  - use better macros
209
210* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
211- automated rebuild
212
213* Thu May 23 2002 Tim Powers <timp@redhat.com>
214- automated rebuild
215
216* Thu Apr 25 2002 Trond Eivind Glomsr︰ <teg@redhat.com> 5.50-3
217- Rebuild
218
219* Tue Apr  2 2002 Trond Eivind Glomsr︰ <teg@redhat.com> 5.50-2
220- Make it not strip
221
222* Wed Mar 13 2002 Trond Eivind Glomsr︰ <teg@redhat.com> 5.50-1
223- 5.50
224
225* Thu Feb 21 2002 Trond Eivind Glomsr︰ <teg@redhat.com> 5.42-3
226- Rebuild
227
228* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
229- automated rebuild
230
231* Mon May 21 2001 Trond Eivind Glomsr︰ <teg@redhat.com>
232- 5.42
233- Don't strip binaries explicitly
234- build without assembly, it doesn't seem to increase performance
235- make it respect RPM_OPT_FLAGS, define _GNU_SOURCE
236- use %%{_tmppath}
237- "License:" replaces "Copyright:"
238- Update URL
239- include zipgrep
240- COPYING doesn't exist anymore, include LICENSE instead
241
242* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
243- automatic rebuild
244
245* Sun Jun 11 2000 BIll Nottingham <notting@redhat.com>
246- rebuild in new env.; FHS fixes.
247
248* Tue Apr 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
249- 4.51 (an acceptable license at last...)
250
251* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
252- handle compressed man pages
253
254* Fri Jul 30 1999 Bill Nottingham <notting@redhat.com>
255- update to 5.40
256
257* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
258- auto rebuild in the new build environment (release 5)
259
260* Thu Dec 17 1998 Michael Maher <mike@redhat.com>
261- built for 6.0
262
263* Tue Aug 11 1998 Jeff Johnson <jbj@redhat.com>
264- build root
265
266* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
267- translations modified for de, fr, tr
268
269* Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
270- builds on non i386 platforms
271
272* Mon Oct 20 1997 Otto Hammersmith <otto@redhat.com>
273- updated the version
274
275* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
276- built against glibc
277
Note: See TracBrowser for help on using the repository browser.