source: projects/specs/branches/6/u/unzip/unzip-vl.spec @ 9802

Revision 9802, 9.5 KB checked in by iwamoto, 8 years ago (diff)

unzip: fix CVE-2015-7696, CVE-2015-7697.

Line 
1%define src_file unzip60
2
3Summary: A utility for unpacking zip files.
4Summary(ja): zip ファイルを展開するユーティリティ
5Name: unzip
6Version: 6.0
7Release: 5%{?_dist_release}
8License: BSD
9Group: Applications/Archiving
10URL: http://www.info-zip.org/UnZip.html
11
12Source: http://downloads.sourceforge.net/infozip/%{src_file}.tar.gz
13
14# Not sent to upstream.
15Patch1: unzip-6.0-bzip2-configure.patch
16# Upstream plans to do this in zip (hopefully also in unzip).
17Patch2: unzip-6.0-exec-shield.patch
18# Upstream plans to do similar thing.
19Patch3: unzip-6.0-close.patch
20# Details in rhbz#532380.
21# Reported to upstream: http://www.info-zip.org/board/board.pl?m-1259575993/
22Patch4: unzip-6.0-attribs-overflow.patch
23# Not sent to upstream, as it's Fedora/RHEL specific.
24# Modify the configure script not to request the strip of binaries.
25Patch5: unzip-6.0-nostrip.patch
26Patch6: unzip-6.0-manpage-fix.patch
27# Update match.c with recmatch() from zip 3.0's util.c
28# This also resolves the license issue in that old function.
29# Original came from here: https://projects.parabolagnulinux.org/abslibre.git/plain/libre/unzip-libre/match.patch
30Patch7: unzip-6.0-fix-recmatch.patch
31# Update process.c
32Patch8: unzip-6.0-symlink.patch
33# change using of macro "case_map" by "to_up"
34Patch9: unzip-6.0-caseinsensitive.patch
35# downstream fix for "-Werror=format-security"
36# upstream doesn't want hear about this option again
37Patch10: unzip-6.0-format-secure.patch
38Patch11: unzip-6.0-valgrind.patch
39Patch12: unzip-6.0-x-option.patch
40
41# security
42Patch100: unzip-6.0-CVE-2014-8139.patch
43Patch110: unzip-6.0-CVE-2014-8140.patch
44Patch120: unzip-6.0-CVE-2014-8141.patch
45## http://www.openwall.com/lists/oss-security/2014/11/03/10
46Patch130: unzip-6.0-CVE-2014-9636.patch
47Patch140: unzip-6.0_CVE-2015-7696.patch
48Patch150: unzip-6.0-CVE-2015-7697.patch
49Patch160: unzip-6.0-fix-integer-underflow-csiz-decrypted.patch
50
51# japanese charset support
52# https://gist.github.com/hamano/573753
53Patch200: unzip-6.0-japanese_charset.patch
54# just ignore -E option, older nls patch use this.
55Patch201: unzip-6.0-ignore-E-option.patch
56# support ja_JP.utf8 locale
57Patch202: unzip-6.0-japanese_charset-utf8.patch
58
59BuildRoot: %{_tmppath}/%{name}-%{version}-root
60
61Vendor: Project Vine
62Distribution: Vine Linux
63Packager: daisuke
64
65%description
66The unzip utility is used to list, test, or extract files from a zip
67archive.  Zip archives are commonly found on MS-DOS systems.  The zip
68utility, included in the zip package, creates zip archives.  Zip and
69unzip are both compatible with archives created by PKWARE(R)'s PKZIP
70for MS-DOS, but the programs' options and default behaviors do differ
71in some respects.
72
73Install the unzip package if you need to list, test or extract files from
74a zip archive.
75
76%description -l ja
77unzip ユーティリティは,zip アーカイブ内のファイルを一覧表示したり,
78テスト/展開する為に使うユーティリティです.zip アーカイブは MS-DOS
79システムで一般的に使われます.
80zip パッケージに含まれる zip プログラムは zip アーカイブを
81作成するのに使います.
82zip と unzip は PKWARE(R) の MS-DOS 用 PKZIP で作成された zip アーカイブに
83対応していますが,デフォルトの動作やプログラムオプション等一部が
84異なります.
85
86
87%prep
88%setup -q -n %{src_file}
89%patch1 -p1 -b .bzip2-configure
90%patch2 -p1 -b .exec-shield
91%patch3 -p1 -b .close
92%patch4 -p1 -b .attribs-overflow
93%patch5 -p1 -b .nostrip
94%patch6 -p1 -b .manpage-fix
95%patch7 -p1 -b .recmatch
96%patch8 -p1 -b .symlink
97%patch9 -p1 -b .caseinsensitive
98%patch10 -p1 -b .format-secure
99%patch11 -p1 -b .valgrind
100%patch12 -p1 -b .x-option
101
102# security
103%patch100 -p1 -b .CVE-2014-8139
104%patch110 -p1 -b .CVE-2014-8140
105%patch120 -p1 -b .CVE-2014-8141
106%patch130 -p1 -b .CVE-2014-9636
107%patch140 -p0 -b .CVE-2015-7696
108%patch150 -p1 -b .CVE-2015-7697
109%patch160 -p1 -b .fix-integer-underflow-csiz-decrypted
110
111%patch200 -p1 -b .jp
112%patch201 -p1 -b .ignore-E
113%patch202 -p1 -b .utf8
114
115ln -s unix/Makefile Makefile
116
117%build
118make LOCAL_UNZIP="-D_FILE_OFFSET_BITS=64 -DNO_LCHMOD -D_MBCS -DNO_WORKING_ISPRINT" linux_noasm
119
120%install
121[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
122
123make prefix=$RPM_BUILD_ROOT%{_prefix} MANDIR=$RPM_BUILD_ROOT/%{_mandir}/man1 install LF2=""
124
125
126%clean
127[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
128
129
130%files
131%defattr(-,root,root)
132%doc README BUGS LICENSE INSTALL
133%{_bindir}/*
134%{_mandir}/*/*
135
136
137%changelog
138* Wed Nov 11 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.0-5
139- add patch140,150.160 for fix CVE-2015-7696,7697
140  These patches are from debian, Thanks.
141
142* Sun Feb  8 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 6.0-4
143- add Patch130 for CVE-2014-9636 (heap overflow)
144
145* Sun Jan 18 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>  6.0-3
146- add Patch100 for fix CVE-2014-8139 (crc-overflow)
147- add Patch110 for fix CVE-2014-8140 (test-compr-eb)
148- add Patch120 for fix CVE-2014-8141 (getzip64data)
149- add Patch9-12 from fc22
150
151* Thu Jul 03 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 6.0-2
152- add patch202 to support ja_JP.utf8
153
154* Thu May 22 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 6.0-1
155- update to 6.0
156- replace nls patch.
157
158* Tue Apr  5 2011 IWAI, Masaharu <iwai@alib.jp> 5.52-3vl6
159- build on current VineSeed
160
161* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.52-2
162- spec in utf-8
163- add NLS patch
164
165* Wed Apr 09 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.52-1
166- new upstream release
167- add patch13 from fc8
168- update patches to fit new release & drop old patches
169- with new versioning polity
170
171* Wed Apr 09 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.51-11vl4
172- fix changelog typo
173
174* Wed Apr 09 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.51-10vl4
175- update patch100 to fix ppc issue (it was patch5, from rhel4)
176- renumber patchs
177- add patch 2,3 to support big archive (from rhel4)
178- with new versioning polity
179
180* Fri Mar 21 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.51-9vl1.1
181- add patch5 for fix CVE-2005-4667
182- add patch6 for fix CVE-2008-0888
183- add Vendor/Distribution tag
184
185* Tue May 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.51-9vl1
186- new upstream release
187- based on 5.51-9 Fedora development
188  * Thu Feb 10 2005 Ivana Varekova <varekova@redhat.com> 5.51-9
189  - fix the other problem with unpacking zipfiles containing symlinks
190    (bug #134073)
191  * Thu Feb 03 2005 Ivana Varekova <varekova@redhat.com> 5.51-8
192  - fix segfault with unpacking of zipfiles containing dangling symlinks
193    (bug #134073)
194  * Thu Dec 02 2004 Lon Hohberger <lhh@redhat.com> 5.51-5
195  - Fix segfault on extraction of symlinks
196  * Mon Jun 21 2004 Lon Hohberger <lhh@redhat.com> 5.51-4
197  - Extend max file/archive size to 2^32-8193 (4294959103) bytes
198  * Tue Jun 08 2004 Lon Hohberger <lhh@redhat.com> 5.51-1.1
199  - Update to 5.51; remove dotdot patch.
200
201* Tue Sep 23 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.50-5vl2
202- merged patch1 from Vine Linux 2.6 updates
203  - Thu Aug 28 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.50-4vl3
204  - replace patch1 from RedHat (RHSA-2003:199-02).
205
206  - Fri Jul 18 2003 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 5.50-4vl2
207  - added patch1 from Redhat (RHSA-2003:199-01)
208
209
210* Sun Dec  1 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.50-5vl1
211- modified changelog section :-P (merge rawhidee changelogs)
212
213  - Sun Dec  1 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.50-4vl2
214  - rebuild with new toolchains
215
216  - Sun May 26 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.50-4vl1
217  - based on 5.50-4 from Rawhide
218  - previous Vine version was 5.41-3vl1:
219
220  - Tue Dec 26 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
221  - 5.41-3vl1
222  - based on 5.41-3 from Rawhide
223  - added Japanese summary and description
224  - use better macros
225
226* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
227- automated rebuild
228
229* Thu May 23 2002 Tim Powers <timp@redhat.com>
230- automated rebuild
231
232* Thu Apr 25 2002 Trond Eivind Glomsr︰ <teg@redhat.com> 5.50-3
233- Rebuild
234
235* Tue Apr  2 2002 Trond Eivind Glomsr︰ <teg@redhat.com> 5.50-2
236- Make it not strip
237
238* Wed Mar 13 2002 Trond Eivind Glomsr︰ <teg@redhat.com> 5.50-1
239- 5.50
240
241* Thu Feb 21 2002 Trond Eivind Glomsr︰ <teg@redhat.com> 5.42-3
242- Rebuild
243
244* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
245- automated rebuild
246
247* Mon May 21 2001 Trond Eivind Glomsr︰ <teg@redhat.com>
248- 5.42
249- Don't strip binaries explicitly
250- build without assembly, it doesn't seem to increase performance
251- make it respect RPM_OPT_FLAGS, define _GNU_SOURCE
252- use %%{_tmppath}
253- "License:" replaces "Copyright:"
254- Update URL
255- include zipgrep
256- COPYING doesn't exist anymore, include LICENSE instead
257
258* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
259- automatic rebuild
260
261* Sun Jun 11 2000 BIll Nottingham <notting@redhat.com>
262- rebuild in new env.; FHS fixes.
263
264* Tue Apr 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
265- 4.51 (an acceptable license at last...)
266
267* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
268- handle compressed man pages
269
270* Fri Jul 30 1999 Bill Nottingham <notting@redhat.com>
271- update to 5.40
272
273* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
274- auto rebuild in the new build environment (release 5)
275
276* Thu Dec 17 1998 Michael Maher <mike@redhat.com>
277- built for 6.0
278
279* Tue Aug 11 1998 Jeff Johnson <jbj@redhat.com>
280- build root
281
282* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
283- translations modified for de, fr, tr
284
285* Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
286- builds on non i386 platforms
287
288* Mon Oct 20 1997 Otto Hammersmith <otto@redhat.com>
289- updated the version
290
291* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
292- built against glibc
293
Note: See TracBrowser for help on using the repository browser.