source: projects/specs/branches/6/t/tinyxml/tinyxml-vl.spec @ 4126

Revision 4126, 3.5 KB checked in by kudoh, 13 years ago (diff)
Line 
1%define underscore_version 2_6_2
2
3Name:           tinyxml
4Version:        2.6.2
5Release:        1%{?_dist_release}
6Summary:        A simple, small, C++ XML parser
7Summary(ja):    シンプルで小さな C++ XML パーサー
8Group:          System Environment/Libraries
9License:        zlib
10URL:            http://www.grinninglizard.com/tinyxml/
11Source0:        http://downloads.sourceforge.net/%{name}/%{name}_%{underscore_version}.tar.gz
12Patch0:         tinyxml-2.5.3-stl.patch
13Patch1:         entity.patch
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15
16BuildRequires: gcc-c++
17
18%description
19TinyXML is a simple, small, C++ XML parser that can be easily integrating
20into other programs. Have you ever found yourself writing a text file parser
21every time you needed to save human readable data or serialize objects?
22TinyXML solves the text I/O file once and for all.
23(Or, as a friend said, ends the Just Another Text File Parser problem.)
24
25
26%package        devel
27Summary:        Development files for %{name}
28Summary(ja):    %{name} の開発ファイル
29Group:          Development/Libraries
30Requires:       %{name} = %{version}-%{release}
31
32%description    devel
33The %{name}-devel package contains libraries and header files for
34developing applications that use %{name}.
35
36
37%prep
38%setup -q -n %{name}
39%patch0 -p1 -b .stl
40%patch1
41touch -r tinyxml.h.stl tinyxml.h
42
43
44%build
45# Not really designed to be build as lib, DYI
46for i in tinyxml.cpp tinystr.cpp tinyxmlerror.cpp tinyxmlparser.cpp; do
47  g++ $RPM_OPT_FLAGS -fPIC -o $i.o -c $i
48done
49g++ $RPM_OPT_FLAGS -shared -o lib%{name}.so.0.%{version} \
50   -Wl,-soname,lib%{name}.so.0 *.cpp.o
51
52
53%install
54rm -rf $RPM_BUILD_ROOT
55# Not really designed to be build as lib, DYI
56mkdir -p $RPM_BUILD_ROOT%{_libdir}
57mkdir -p $RPM_BUILD_ROOT%{_includedir}
58install -m 755 lib%{name}.so.0.%{version} $RPM_BUILD_ROOT%{_libdir}
59ln -s lib%{name}.so.0.%{version} $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so.0
60ln -s lib%{name}.so.0.%{version} $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
61install -p -m 644 %{name}.h $RPM_BUILD_ROOT%{_includedir}
62
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67
68%post -p /sbin/ldconfig
69
70%postun -p /sbin/ldconfig
71
72
73%files
74%defattr(-,root,root,-)
75%doc changes.txt readme.txt
76%{_libdir}/*.so.*
77
78%files devel
79%defattr(-,root,root,-)
80%doc docs/*
81%{_includedir}/*
82%{_libdir}/*.so
83
84
85%changelog
86* Sun Jun 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.6.2-1
87- new upstream release
88- added BuildRequires: gcc-c++
89
90* Wed Sep 29 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.6.1-3
91- rebuilt with rpm-4.8.1 for pkg-config
92
93* Sun Aug 15 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.6.1-2
94- added patch1 to fix incorrect entity encoding from upstream BTS
95
96* Tue Mar 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.6.1-1
97- new upstream release
98
99* Mon Mar 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.6.0-1
100- new upstream release
101- applied new naming policy to spec
102- added summary(ja)
103
104* Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.5.3-3
105- rebuilt with new toolchain
106
107* Sat May 9 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.5.3-2vl5
108- fixed %BuildRoot
109- spec in UTF-8
110
111* Wed Jan 21 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.5.3-1vl5
112- initial build for VineSeed
113- import Fedora's 2.5.3-3
114
115* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.5.3-3
116- Autorebuild for GCC 4.3
117
118* Fri Dec 14 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 2.5.3-2
119- Various improvements from review (bz 407571)
120
121* Fri Nov 30 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 2.5.3-1
122- Initial Fedora Package
Note: See TracBrowser for help on using the repository browser.