source: projects/specs/trunk/t/tinyxml/tinyxml-vl.spec @ 1948

Revision 1948, 3.3 KB checked in by kudoh, 14 years ago (diff)
Line 
1%define underscore_version 2_6_1
2
3Name:           tinyxml
4Version:        2.6.1
5Release:        3%{?_dist_release}
6Summary:        A simple, small, C++ XML parser
7Summary(ja):    シンプルで小さな C++ XML パーサー
8Group:          System Environment/Libraries
9License:        zlib
10URL:            http://www.grinninglizard.com/tinyxml/
11Source0:        http://downloads.sourceforge.net/%{name}/%{name}_%{underscore_version}.tar.gz
12Patch0:         tinyxml-2.5.3-stl.patch
13Patch1:         entity.patch
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15
16%description
17TinyXML is a simple, small, C++ XML parser that can be easily integrating
18into other programs. Have you ever found yourself writing a text file parser
19every time you needed to save human readable data or serialize objects?
20TinyXML solves the text I/O file once and for all.
21(Or, as a friend said, ends the Just Another Text File Parser problem.)
22
23
24%package        devel
25Summary:        Development files for %{name}
26Summary(ja):    %{name} の開発ファイル
27Group:          Development/Libraries
28Requires:       %{name} = %{version}-%{release}
29
30%description    devel
31The %{name}-devel package contains libraries and header files for
32developing applications that use %{name}.
33
34
35%prep
36%setup -q -n %{name}
37%patch0 -p1 -b .stl
38%patch1
39touch -r tinyxml.h.stl tinyxml.h
40
41
42%build
43# Not really designed to be build as lib, DYI
44for i in tinyxml.cpp tinystr.cpp tinyxmlerror.cpp tinyxmlparser.cpp; do
45  g++ $RPM_OPT_FLAGS -fPIC -o $i.o -c $i
46done
47g++ $RPM_OPT_FLAGS -shared -o lib%{name}.so.0.%{version} \
48   -Wl,-soname,lib%{name}.so.0 *.cpp.o
49
50
51%install
52rm -rf $RPM_BUILD_ROOT
53# Not really designed to be build as lib, DYI
54mkdir -p $RPM_BUILD_ROOT%{_libdir}
55mkdir -p $RPM_BUILD_ROOT%{_includedir}
56install -m 755 lib%{name}.so.0.%{version} $RPM_BUILD_ROOT%{_libdir}
57ln -s lib%{name}.so.0.%{version} $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so.0
58ln -s lib%{name}.so.0.%{version} $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
59install -p -m 644 %{name}.h $RPM_BUILD_ROOT%{_includedir}
60
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65
66%post -p /sbin/ldconfig
67
68%postun -p /sbin/ldconfig
69
70
71%files
72%defattr(-,root,root,-)
73%doc changes.txt readme.txt
74%{_libdir}/*.so.*
75
76%files devel
77%defattr(-,root,root,-)
78%doc docs/*
79%{_includedir}/*
80%{_libdir}/*.so
81
82
83%changelog
84* Wed Sep 29 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.6.1-3
85- rebuilt with rpm-4.8.1 for pkg-config
86
87* Sun Aug 15 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.6.1-2
88- added patch1 to fix incorrect entity encoding from upstream BTS
89
90* Tue Mar 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.6.1-1
91- new upstream release
92
93* Mon Mar 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.6.0-1
94- new upstream release
95- applied new naming policy to spec
96- added summary(ja)
97
98* Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.5.3-3
99- rebuilt with new toolchain
100
101* Sat May 9 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.5.3-2vl5
102- fixed %BuildRoot
103- spec in UTF-8
104
105* Wed Jan 21 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.5.3-1vl5
106- initial build for VineSeed
107- import Fedora's 2.5.3-3
108
109* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.5.3-3
110- Autorebuild for GCC 4.3
111
112* Fri Dec 14 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 2.5.3-2
113- Various improvements from review (bz 407571)
114
115* Fri Nov 30 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 2.5.3-1
116- Initial Fedora Package
Note: See TracBrowser for help on using the repository browser.