source: projects/specs/branches/6/t/texlive-macros/texlive-macros-vl.spec @ 2503

Revision 2503, 12.1 KB checked in by munepi, 13 years ago (diff)

updated texlive packages: supported VinePlus?/5, more; improved some %%post scripts

Line 
1## -*- coding: utf-8-unix -*-
2%define tex_destdir     %{_datadir}
3%define texmf           %{_prefix}/share/texmf
4%define texlive_src     %{tex_destdir}/texlive-sources
5%define build_tex_destdir       %{buildroot}%{tex_destdir}
6%define build_texmf     %{buildroot}%{texmf}
7%define build_texlive_src       %{buildroot}%{tex_destdir}-sources
8
9%define knjfonts        kanjifonts-3.1
10%define jsclasses_ver   100314
11%define jlisting_ver    0.2
12%define bkmk2uni        convert-bkmk2uni
13
14%define exec_texhash    [ -x %{_bindir}/texhash ] && %{_bindir}/env - %{_bindir}/texhash 2> /dev/null
15%define exec_updmap     [ -x %{_bindir}/updmap-sys ] && %{_bindir}/env - %{_bindir}/updmap-sys --nostop 2> /dev/null
16
17%define list_macros \
18        jsclasses-%{jsclasses_ver} \
19        jlisting-%{jlisting_ver}
20
21
22Summary:        A collection of useful macro packages for texlive package
23Summary(ja):    texlive パッケージで使うマクロパッケージ集
24Name:           texlive-macros
25Version:        2009
26Release:        3%{?_dist_release}
27License:        distributable
28Group:          Applications/Publishing
29
30## Vine Linux
31Source0:        %{knjfonts}.tar.bz2
32Source1:        sample.tex
33
34## jsclasses
35Source10:       http://oku.edu.mie-u.ac.jp/~okumura/jsclasses/jsclasses-%{jsclasses_ver}.zip
36Source11:       http://oku.edu.mie-u.ac.jp/~okumura/jsclasses/index.html
37
38## jlisting
39Source20:       http://prdownloads.sourceforge.jp/mytexpert/26068/jlisting.sty.bz2
40
41
42Requires:       perl
43Requires:       texlive = %{version}
44BuildRequires:  texlive = %{version}
45BuildRequires:  nkf unzip
46
47Buildroot: %{_tmppath}/%{name}-%{version}-root
48BuildArch: noarch
49
50%if %{?_dist_release} == "vl6"
51Obsoletes:      tetex-macros <= 3.0
52%endif
53%if %{?_dist_release} == "vl5"
54Conflicts:      tetex-macros
55%endif
56Obsoletes:      pLaTeX2e_Macros
57
58Distribution:   Vine Linux
59Vendor:         Project Vine
60Packager:       munepi
61
62
63%description
64A collection of useful macro packages for texlive package, including
65        kanjifonts-3.1 (for Ricoh Fonts/DynaLab Fonts and JIS font metric)
66%{list_macros}
67
68# This package contained a perl script
69#   http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
70
71%description -l ja
72texlive パッケージで使うマクロパッケージ集です。
73以下のマクロを収録しています。
74        kanjifonts-3.1 (Vine Linux 3.1R 付属のリコーフォント/ダイナフォントやJISフォントメトリックを使う)
75%{list_macros}
76
77# このパッケージには prosper, powerdot 用に
78# PDF ブックマークの文字化けを修正するための perl スクリプト
79#   http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
80# を同梱しています.
81
82%prep
83[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && %__rm -rf $RPM_BUILD_ROOT
84%setup -q -c -n %{name}-%{version}
85
86%__mkdir_p jsclasses
87(cd jsclasses
88    %__mkdir_p jsclasses
89    %__unzip -a -qq %{SOURCE10}
90    %__cp -p %{SOURCE11} ./jsclasses/README.html
91)
92
93# get rid of unwanted files
94find . -type d -name CVS | xargs -r %__rm -frv
95find . -type f -name .cvsignore | xargs -r %__rm -fv
96
97(cd jsclasses
98    %__mkdir_p tmp
99    for i in *.*; do nkf $i > tmp/$i; done
100    %__mv tmp/* .
101    %__rm -rf tmp
102)
103
104
105%build
106
107(cd jsclasses
108    for i in jsclasses okumacro okuverb morisawa; do
109        platex ${i}.dtx && platex ${i}.dtx || exit 1
110    done
111    for i in jsclasses okumacro okuverb; do
112        dvipdfmx $i || exit 1
113    done
114    %__cp *.dvi *.pdf jsclasses
115)
116
117%install
118%__rm -rf %{buildroot}
119
120# InstallClass(){
121# target=$1; shift
122# (cd $target
123# bzip2 -dc ${RPM_SOURCE_DIR}/$target.tar.bz2 | tar xf - -C %{build_texmf}/packages/
124# rm %{build_texmf}/packages/$target/*.{ins,def,bst,rtx,sty,cls,ltx,fnt,cyr,fdd} || :
125
126# if [ -f src/$target.ins ]; then
127#     cp src/* .
128# fi
129# latex $target.ins
130# mkdir -p %{build_texmf}/tex/latex/$target
131# cp *.{ldf,sty,def,cls,rtx} %{build_texmf}/tex/latex/$target || :
132# if [ ! -z "$*" ]; then
133#     cp -d $* %{build_texmf}/tex/latex/$target || :
134# fi
135# if [ -n "`ls *.bst`" ]; then
136#     mkdir -p %{build_texmf}/bibtex/bst/$target
137#     cp *.bst %{build_texmf}/bibtex/bst/$target || :
138# fi
139# )
140# }
141
142%__mkdir_p %{build_texmf}/packages/
143#InstallClass geometry
144
145## install kanjifonts
146%__mkdir_p %{build_texmf}/ptex/platex/generic
147%__mv %{knjfonts}/*.sty %{build_texmf}/ptex/platex/generic
148%__mv %{knjfonts}/*.def %{build_texmf}/ptex/platex/generic
149
150# nkf --utf8 %{SOURCE25} | \
151#     sed -e "s@^#!/usr/local/bin/perl5 -w@#!/usr/bin/perl -w@" > \
152#     %{buildroot}%{_bindir}/%{bkmk2uni}
153# chmod 755 %{buildroot}%{_bindir}/%{bkmk2uni}
154
155## install jsclasses
156(cd jsclasses
157    %__mkdir_p %{build_texmf}/ptex/platex/js
158    %__cp -fp *.dtx *.ins *.cls *.sty %{build_texmf}/ptex/platex/js/
159)
160
161## install jlisting
162%__mkdir_p %{build_texmf}/ptex/platex/jlisting
163%__install -m 644 %{SOURCE20} %{build_texmf}/ptex/platex/jlisting/
164bunzip2 %{build_texmf}/ptex/platex/jlisting/jlisting.sty.bz2
165
166
167# ## install MORISAWA basic 5 fonts
168# #mkdir -p %{build_texmf}/dvips/config/extmap
169# %__mkdir_p %{build_texmf}/fonts/tfm/ptex
170# %__mkdir_p %{build_texmf}/fonts/tfm/dvips
171# %__mkdir_p %{build_texmf}/fonts/vf/ptex
172# #mv morisawa/morisawa.map %{build_texmf}/dvips/config/extmap/
173# %__mv morisawa/tfm/ptex/* %{build_texmf}/fonts/tfm/ptex/
174# %__mv morisawa/tfm/dvips/* %{build_texmf}/fonts/tfm/dvips/
175# %__mv morisawa/vf/* %{build_texmf}/fonts/vf/ptex/
176
177
178%post
179%{exec_texhash}
180# %{exec_updmap}
181exit 0
182
183
184%postun
185if [ "$1" = 0 ]; then
186    %{exec_texhash}
187    # %{exec_updmap}
188fi
189exit 0
190
191
192%clean
193%__rm -rf $RPM_BUILD_ROOT
194
195
196%files
197%defattr(-,root,root)
198%doc %{knjfonts}
199%doc jsclasses/jsclasses
200#%{_bindir}/%{bkmk2uni}
201%{texmf}/ptex/platex/generic/kanjifonts.sty
202%{texmf}/ptex/platex/generic/*.def
203%{texmf}/ptex/platex/js
204%{texmf}/ptex/platex/jlisting
205
206
207%changelog
208* Fri Dec 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
209- dropped BuildRequires: jvf
210- for vl5, added Conflicts: tetex-macros
211
212* Tue Aug 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
213- removed %%{exec_updmap} in %%post and %%postun
214
215* Tue May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
216- ported from tetex-macros-3.0-7
217- TeX Live 2009
218
219* Mon Oct 12 2009 Munehiro Yamamoto <munepi@vinelinux.org> 3.0-7
220- added BuildRequires: unzip
221- updated jsclasses to 090826
222- updated pict2e to 0.2x
223
224* Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-6
225- dropped epsbox.sty, eclepsf.sty
226  (bacause there style files for platex209 are obsolete)
227
228* Fri May 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-5
229- added jlisting v0.2
230- defined list_macros
231  - used %%{list_macros} in %%description and %%description -l ja
232
233* Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-4
234- dropped convert-euc.txt
235
236* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-3
237- updated prosper
238  - added some contrib themes from CTAN
239  - added prosper.cls v1.6 from CVS HEAD
240  - added a perl script: convert-euc.txt
241- added powerdot v1.3
242  - added xkeyval v2.5d
243- added beamer v3.07
244  - added pgf v2.00
245- added pict2e v0.2w
246
247* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-2
248- updated jsclasses to 20090222
249- updated jsclasses/index.html to 2009-02-22
250- removed /usr/share/texmf/dvips/config/extmap/morisawa.map (See [BTS:524])
251
252* Wed Sep 03 2008 Shu KONNO <owa@bg.wakwak.com> 3.0-1vl5
253- applied new versioning policy, spec in utf-8
254
255* Mon Oct 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl3
256- update jsclasses/index.html to 2006-11-06.
257
258* Fri May 19 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl2
259- update jsclasses/index.html to 2006-02-12.
260
261* Sun Nov 06 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl1
262- update jsclasses/index.html to 2005-10-26.
263
264* Sat Jun 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl0.1
265- update jsclasses/index.html to 2005-4-30.
266- added breqn
267
268* Tue Jan 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl7
269- update jsclasses/index.html to 2004-12-29.
270
271* Mon Jan 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
272- add missing files in kanjifonts-3.0
273
274* Sun Jan 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
275- update to kanjifonts.sty-3.0.
276
277* Mon Nov 29 2004 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl4
278- update jsclasses/index.html to 2004-11-03.
279
280* Sat Oct 16 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl3
281- update jsclasses/index.html to 2004-09-27.
282
283* Sat Apr 17 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl2
284- update jsclasses/index.html to 2004-02-25.
285- added eclepsf.sty.
286- removed epsf.sty (symlink to epsbox.sty).
287- removed geometry, which is in tetex-2.0.
288
289* Fri Apr 18 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl1
290- update jsclasses/index.html to 2003-04-18.
291- added morisawa.dvi.
292
293* Fri Mar 14 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t2
294- update jsclasses/index.html to 2003-03-06
295
296* Mon Feb  3 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t1
297- remove natbib, which is in tetex-2.0
298- let version number same as tetex
299- added Requires: tetex
300
301* Sat Jan 18 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl9
302- update jsclasses/index.html to 2003-01-16
303
304* Mon Jan 13 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl8
305- update jsclasses to 2003-01-05
306- update index.html to 2003-01-12
307
308* Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl7
309- update jsclasses and index.html to 2002-11-27
310
311* Sun Nov 03 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl6
312- update jsclasses and index.html to 2002-11-01
313
314* Thu Oct 17 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl5
315- oops, packager was incorrect
316
317* Mon Jul 15 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl4
318- update jsclasses to 2002-06-29
319- update index.html to 2002-07-03
320
321* Sun Apr 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl3
322- update jsclasses to 2002-04-21
323- update index.html to 2002-04-09
324
325* Tue Apr 16 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.1-0vl2
326- added MORISAWA basic 5 fonts
327
328* Mon Mar 25 2002 Jun Nishii <jun@vinelinux.org> 1.1-0vl1
329- update to kanjifonts-1.1
330
331* Thu Feb 07 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl11
332- update jsclasses and index.html to 2002-02-07
333
334* Tue Jan 31 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl10
335- update jsclasses and index.html to 2002-01-27
336- fix typo in changelog
337
338* Fri Jan 25 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl9
339- update jsclasses and index.html to 2002-01-18
340
341* Tue Dec 18 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl8
342- update index.html (jsclasses)
343
344* Sat Dec 15 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl7
345- update jsclasses to 2001-11-29
346
347* Sun Sep 16 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.0-0vl6
348- fixed spec file for Prosper and jsclasses
349- use RPM macro in %files
350- added BuildPrereq: jvf
351
352* Mon Sep 10 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl5
353- move revtex4 to texmacro-aps package
354
355* Sun Sep  9 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl4
356- added prosper jsclasses
357
358* Mon Sep  6 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl3
359- added revtex4 natbib
360
361* Mon Sep  3 2001 Jun Nishii <jun@vinelinux.org> 1.0-0vl2
362- remove prereq tetex to avoid dependency-loop
363
364* Wed Aug  1 2001 Jun Nishii <jun@vinelinux.org>
365- tetex-macros-1.0-0vl1
366
367* Fri Jan 21 2000 Jun Nishii <jun@vinelinux.org>
368- 2.0-2
369- added kanjifonts-1.0 and removed jisfontsmetric
370
371* Sun Jan  9 2000 Jun Nishii <jun@vinelinux.org>
372- 2.0-1
373- install ldf in babel
374
375* Sat Jan  8 2000 Jun Nishii <jun@vinelinux.org>
376- added jisfontmetric.tex
377
378* Fri Oct 29 1999 Norihito Ohmori <ohmori@flatout.org>
379- change group.
380
381* Sun Oct 17 1999 Jun Nishii <jun@flatout.org>
382- added babel
383
384* Fri Aug 27 1999 Jun Nishii <jun@flatout.org>
385- added hoekwater
386
387* Mon Aug 3 1999 Jun Nishii <jun@flatout.org>
388- added psfrag
389
390* Mon Jun 21 1999 Jun Nishii <jun@flatout.org>
391- added psnfss
392- Change directory tree according to the suggestion by Dr.Okumura.
393- remove many files from packages directory except documentations
394- disable mktexlsr and erase ls-R
395
396* Tue Feb 16 1999 Jun Nishii <jun@flatout.org>
397- added url.sty
398
399* Thu Dec 3 1998 Jun Nishii <jun@flatout.org>
400- pLaTeX2e_Macros-1-2
401- added fancyhdr.sty, boxedminipage.sty
402- added graphics.cfg, color.cfg (use dvips as default)
403- symlink from epsbox to epsf
404
405* Mon Nov 9 1998 Jun Nishii <jun@flatout.org>
406- pLaTeX2e_Macros-1-1
407  (rename as pLaTeX2e_Macros from pLaTeX-Classes)
408- added def files of graphics
409- added tools and hyperref
410- check the existence of mktexlsr
411
412* Tue Oct 5 1998 Jun Nishii <jun@flatout.org>
413- buildarch: noarch
414- added requires
415
416* Tue Sep 29 1998 Jun Nishii <jun@flatout.org>
417- tiny bug fix and add %defattr
418
419* Wed Sep 23 1998 Jun Nishii <jun@flatout.org>
420- first version fo platex-19980901
Note: See TracBrowser for help on using the repository browser.