source: projects/specs/trunk/t/texlive-macros/texlive-macros-vl.spec @ 5207

Revision 5207, 11.0 KB checked in by munepi, 12 years ago (diff)

upgrade to TeX Live 2011

Line 
1## -*- coding: utf-8-unix -*-
2%define tex_destdir     %{_datadir}
3%define texmf           %{_prefix}/share/texmf
4%define texlive_src     %{tex_destdir}/texlive-sources
5%define build_tex_destdir       %{buildroot}%{tex_destdir}
6%define build_texmf     %{buildroot}%{texmf}
7%define build_texlive_src       %{buildroot}%{tex_destdir}-sources
8
9%define knjfonts        kanjifonts-3.1
10%define jsclasses_ver   100314
11%define jlisting_ver    0.2
12%define bkmk2uni        convert-bkmk2uni
13
14%define exec_texhash    [ -x %{_bindir}/texhash ] && %{_bindir}/env - %{_bindir}/texhash 2> /dev/null
15%define exec_updmap     [ -x %{_bindir}/updmap-sys ] && %{_bindir}/env - %{_bindir}/updmap-sys 2> /dev/null
16
17%define list_macros \
18        jsclasses-%{jsclasses_ver} \
19        jlisting-%{jlisting_ver}
20
21
22Summary:        A collection of useful macro packages for texlive package
23Summary(ja):    texlive パッケージで使うマクロパッケージ集
24Name:           texlive-macros
25Version:        2011
26Release:        1%{?_dist_release}
27License:        distributable
28Group:          Applications/Publishing
29
30## Vine Linux
31Source0:        %{knjfonts}.tar.bz2
32Source1:        sample.tex
33
34## jsclasses
35Source10:       http://oku.edu.mie-u.ac.jp/~okumura/jsclasses/jsclasses-%{jsclasses_ver}.zip
36Source11:       http://oku.edu.mie-u.ac.jp/~okumura/jsclasses/index.html
37
38## jlisting
39Source20:       http://prdownloads.sourceforge.jp/mytexpert/26068/jlisting.sty.bz2
40
41
42Requires:       perl
43Requires:       texlive-common = %{version}
44BuildRequires:  texlive-common = %{version}
45BuildRequires:  nkf unzip
46
47Buildroot: %{_tmppath}/%{name}-%{version}-root
48BuildArch: noarch
49
50Obsoletes:      tetex-macros
51Obsoletes:      pLaTeX2e_Macros
52
53Distribution:   Vine Linux
54Vendor:         Project Vine
55Packager:       munepi
56
57
58%description
59A collection of useful macro packages for texlive package, including
60        kanjifonts-3.1 (for Ricoh Fonts/DynaLab Fonts and JIS font metric)
61%{list_macros}
62
63# This package contained a perl script
64#   http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
65
66%description -l ja
67texlive パッケージで使うマクロパッケージ集です。
68以下のマクロを収録しています。
69        kanjifonts-3.1 (Vine Linux 3.1R 付属のリコーフォント/ダイナフォントやJISフォントメトリックを使う)
70%{list_macros}
71
72# このパッケージには prosper, powerdot 用に
73# PDF ブックマークの文字化けを修正するための perl スクリプト
74#   http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
75# を同梱しています.
76
77%prep
78[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && %__rm -rf $RPM_BUILD_ROOT
79%setup -q -c -n %{name}-%{version}
80
81%__mkdir_p jsclasses
82(cd jsclasses
83    %__mkdir_p jsclasses
84    %__unzip -a -qq %{SOURCE10}
85    %__cp -p %{SOURCE11} ./jsclasses/README.html
86)
87
88# get rid of unwanted files
89find . -type d -name CVS | xargs -r %__rm -frv
90find . -type f -name .cvsignore | xargs -r %__rm -fv
91
92(cd jsclasses
93    %__mkdir_p tmp
94    for i in *.*; do nkf $i > tmp/$i; done
95    %__mv tmp/* .
96    %__rm -rf tmp
97)
98
99
100%build
101
102(cd jsclasses
103    for i in jsclasses okumacro okuverb morisawa; do
104        platex ${i}.dtx && platex ${i}.dtx || exit 1
105    done
106    for i in jsclasses okumacro okuverb; do
107        dvipdfmx $i || exit 1
108    done
109    %__cp *.dvi *.pdf jsclasses
110)
111
112%install
113%__rm -rf %{buildroot}
114
115%__mkdir_p %{build_texmf}/packages/
116
117## install kanjifonts
118%__mkdir_p %{build_texmf}/tex/platex/kanjifonts
119%__mv %{knjfonts}/*.sty %{build_texmf}/tex/platex/kanjifonts
120%__mv %{knjfonts}/*.def %{build_texmf}/tex/platex/kanjifonts
121
122# nkf --utf8 %{SOURCE25} | \
123#     sed -e "s@^#!/usr/local/bin/perl5 -w@#!/usr/bin/perl -w@" > \
124#     %{buildroot}%{_bindir}/%{bkmk2uni}
125# chmod 755 %{buildroot}%{_bindir}/%{bkmk2uni}
126
127## install jsclasses
128(cd jsclasses
129    %__mkdir_p %{build_texmf}/tex/platex/jsclasses
130    %__cp -fp *.dtx *.ins *.cls *.sty %{build_texmf}/tex/platex/jsclasses/
131)
132
133## install jlisting
134%__mkdir_p %{build_texmf}/tex/platex/jlisting
135%__install -m 644 %{SOURCE20} %{build_texmf}/tex/platex/jlisting/
136bunzip2 %{build_texmf}/tex/platex/jlisting/jlisting.sty.bz2
137
138
139%post
140%{exec_texhash}
141# %{exec_updmap}
142exit 0
143
144
145%postun
146if [ "$1" = 0 ]; then
147    %{exec_texhash}
148    # %{exec_updmap}
149fi
150exit 0
151
152
153%clean
154%__rm -rf $RPM_BUILD_ROOT
155
156
157%files
158%defattr(-,root,root)
159%doc %{knjfonts}
160%doc jsclasses/jsclasses
161#%{_bindir}/%{bkmk2uni}
162%{texmf}/tex/platex/kanjifonts/kanjifonts.sty
163%{texmf}/tex/platex/kanjifonts/*.def
164%{texmf}/tex/platex/jsclasses
165%{texmf}/tex/platex/jlisting
166
167
168%changelog
169* Sun Nov 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011
170- TeX Live 2011
171- updated jsclasses to 110510
172
173* Fri Dec 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
174- dropped BuildRequires: jvf
175- for vl5, added Conflicts: tetex-macros
176
177* Tue Aug 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
178- removed %%{exec_updmap} in %%post and %%postun
179
180* Tue May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
181- ported from tetex-macros-3.0-7
182- TeX Live 2009
183
184* Mon Oct 12 2009 Munehiro Yamamoto <munepi@vinelinux.org> 3.0-7
185- added BuildRequires: unzip
186- updated jsclasses to 090826
187- updated pict2e to 0.2x
188
189* Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-6
190- dropped epsbox.sty, eclepsf.sty
191  (bacause there style files for platex209 are obsolete)
192
193* Fri May 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-5
194- added jlisting v0.2
195- defined list_macros
196  - used %%{list_macros} in %%description and %%description -l ja
197
198* Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-4
199- dropped convert-euc.txt
200
201* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-3
202- updated prosper
203  - added some contrib themes from CTAN
204  - added prosper.cls v1.6 from CVS HEAD
205  - added a perl script: convert-euc.txt
206- added powerdot v1.3
207  - added xkeyval v2.5d
208- added beamer v3.07
209  - added pgf v2.00
210- added pict2e v0.2w
211
212* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-2
213- updated jsclasses to 20090222
214- updated jsclasses/index.html to 2009-02-22
215- removed /usr/share/texmf/dvips/config/extmap/morisawa.map (See [BTS:524])
216
217* Wed Sep 03 2008 Shu KONNO <owa@bg.wakwak.com> 3.0-1vl5
218- applied new versioning policy, spec in utf-8
219
220* Mon Oct 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl3
221- update jsclasses/index.html to 2006-11-06.
222
223* Fri May 19 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl2
224- update jsclasses/index.html to 2006-02-12.
225
226* Sun Nov 06 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl1
227- update jsclasses/index.html to 2005-10-26.
228
229* Sat Jun 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl0.1
230- update jsclasses/index.html to 2005-4-30.
231- added breqn
232
233* Tue Jan 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl7
234- update jsclasses/index.html to 2004-12-29.
235
236* Mon Jan 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
237- add missing files in kanjifonts-3.0
238
239* Sun Jan 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
240- update to kanjifonts.sty-3.0.
241
242* Mon Nov 29 2004 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl4
243- update jsclasses/index.html to 2004-11-03.
244
245* Sat Oct 16 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl3
246- update jsclasses/index.html to 2004-09-27.
247
248* Sat Apr 17 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl2
249- update jsclasses/index.html to 2004-02-25.
250- added eclepsf.sty.
251- removed epsf.sty (symlink to epsbox.sty).
252- removed geometry, which is in tetex-2.0.
253
254* Fri Apr 18 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl1
255- update jsclasses/index.html to 2003-04-18.
256- added morisawa.dvi.
257
258* Fri Mar 14 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t2
259- update jsclasses/index.html to 2003-03-06
260
261* Mon Feb  3 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t1
262- remove natbib, which is in tetex-2.0
263- let version number same as tetex
264- added Requires: tetex
265
266* Sat Jan 18 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl9
267- update jsclasses/index.html to 2003-01-16
268
269* Mon Jan 13 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl8
270- update jsclasses to 2003-01-05
271- update index.html to 2003-01-12
272
273* Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl7
274- update jsclasses and index.html to 2002-11-27
275
276* Sun Nov 03 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl6
277- update jsclasses and index.html to 2002-11-01
278
279* Thu Oct 17 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl5
280- oops, packager was incorrect
281
282* Mon Jul 15 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl4
283- update jsclasses to 2002-06-29
284- update index.html to 2002-07-03
285
286* Sun Apr 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl3
287- update jsclasses to 2002-04-21
288- update index.html to 2002-04-09
289
290* Tue Apr 16 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.1-0vl2
291- added MORISAWA basic 5 fonts
292
293* Mon Mar 25 2002 Jun Nishii <jun@vinelinux.org> 1.1-0vl1
294- update to kanjifonts-1.1
295
296* Thu Feb 07 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl11
297- update jsclasses and index.html to 2002-02-07
298
299* Tue Jan 31 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl10
300- update jsclasses and index.html to 2002-01-27
301- fix typo in changelog
302
303* Fri Jan 25 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl9
304- update jsclasses and index.html to 2002-01-18
305
306* Tue Dec 18 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl8
307- update index.html (jsclasses)
308
309* Sat Dec 15 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl7
310- update jsclasses to 2001-11-29
311
312* Sun Sep 16 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.0-0vl6
313- fixed spec file for Prosper and jsclasses
314- use RPM macro in %files
315- added BuildPrereq: jvf
316
317* Mon Sep 10 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl5
318- move revtex4 to texmacro-aps package
319
320* Sun Sep  9 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl4
321- added prosper jsclasses
322
323* Mon Sep  6 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl3
324- added revtex4 natbib
325
326* Mon Sep  3 2001 Jun Nishii <jun@vinelinux.org> 1.0-0vl2
327- remove prereq tetex to avoid dependency-loop
328
329* Wed Aug  1 2001 Jun Nishii <jun@vinelinux.org>
330- tetex-macros-1.0-0vl1
331
332* Fri Jan 21 2000 Jun Nishii <jun@vinelinux.org>
333- 2.0-2
334- added kanjifonts-1.0 and removed jisfontsmetric
335
336* Sun Jan  9 2000 Jun Nishii <jun@vinelinux.org>
337- 2.0-1
338- install ldf in babel
339
340* Sat Jan  8 2000 Jun Nishii <jun@vinelinux.org>
341- added jisfontmetric.tex
342
343* Fri Oct 29 1999 Norihito Ohmori <ohmori@flatout.org>
344- change group.
345
346* Sun Oct 17 1999 Jun Nishii <jun@flatout.org>
347- added babel
348
349* Fri Aug 27 1999 Jun Nishii <jun@flatout.org>
350- added hoekwater
351
352* Mon Aug 3 1999 Jun Nishii <jun@flatout.org>
353- added psfrag
354
355* Mon Jun 21 1999 Jun Nishii <jun@flatout.org>
356- added psnfss
357- Change directory tree according to the suggestion by Dr.Okumura.
358- remove many files from packages directory except documentations
359- disable mktexlsr and erase ls-R
360
361* Tue Feb 16 1999 Jun Nishii <jun@flatout.org>
362- added url.sty
363
364* Thu Dec 3 1998 Jun Nishii <jun@flatout.org>
365- pLaTeX2e_Macros-1-2
366- added fancyhdr.sty, boxedminipage.sty
367- added graphics.cfg, color.cfg (use dvips as default)
368- symlink from epsbox to epsf
369
370* Mon Nov 9 1998 Jun Nishii <jun@flatout.org>
371- pLaTeX2e_Macros-1-1
372  (rename as pLaTeX2e_Macros from pLaTeX-Classes)
373- added def files of graphics
374- added tools and hyperref
375- check the existence of mktexlsr
376
377* Tue Oct 5 1998 Jun Nishii <jun@flatout.org>
378- buildarch: noarch
379- added requires
380
381* Tue Sep 29 1998 Jun Nishii <jun@flatout.org>
382- tiny bug fix and add %defattr
383
384* Wed Sep 23 1998 Jun Nishii <jun@flatout.org>
385- first version fo platex-19980901
Note: See TracBrowser for help on using the repository browser.