source: projects/specs/branches/6/s/subversion/subversion-vl.spec @ 8314

Revision 8314, 16.5 KB checked in by iwamoto, 10 years ago (diff)

subversion: fix CVE-2014-0032

Line 
1%define neon_version 0.25.5
2%define swig_version 1.3.29
3%define apache_dir /usr
4
5%define db_version 4.3.29
6
7%define swigdirs swig_pydir=%{python_sitearch}/libsvn swig_pydir_extra=%{python_sitearch}/svn
8
9# set to zero to avoid running test suite
10%define make_check 0
11
12Summary: Modern Version Control System
13Summary(ja): モダンなバージョン管理システム
14Name: subversion
15Version: 1.6.23
16Release: 2%{?_dist_release}
17License: ASL 1.1
18Group: Development/Tools
19URL: http://subversion.apache.org/
20
21Packager: iwaim
22Vendor: Project Vine
23Distribution: Vine Linux
24
25SOURCE0: subversion-%{version}.tar.bz2
26SOURCE1: subversion.conf
27SOURCE2: httpd.davcheck.conf
28SOURCE3: filter-requires.sh
29Patch1: subversion-1.6.0-deplibs.patch
30Patch3: subversion-1.6.1-rpath.patch
31Patch11: subversion-1.6.23_fix_detect_apache.patch
32#security
33Patch100: subversion-1.6.11-CVE-2014-0032.patch
34
35Requires: db4 >= %{db_version}
36Requires: expat
37Requires: neon >= %{neon_version}
38BuildRequires: apache2-devel
39BuildRequires: apr-devel, apr-util-devel
40BuildRequires: autoconf >= 2.53
41BuildRequires: db4-devel >= %{db_version}
42BuildRequires: expat-devel
43BuildRequires: gdbm-devel
44BuildRequires: libtool >= 1.4.2
45BuildRequires: neon-devel >= %{neon_version}
46BuildRequires: openssl-devel
47BuildRequires: python
48BuildRequires: python-devel
49BuildRequires: swig >= %{swig_version}
50BuildRequires: texinfo
51BuildRequires: zlib-devel
52BuildRequires: openldap-devel
53BuildRequires: ruby >= 1.8.2
54BuildRequires: ruby-devel >= 1.8.2
55BuildRequires: perl >= 5.8.0
56BuildRequires: sqlite3-devel
57BuildRequires: krb5-devel
58BuildRequires: keyutils-libs-devel
59BuildRequires: dbus-devel
60BuildRequires: libgnome-keyring-devel
61BuildRoot: %{_tmppath}/%{name}-%{version}-root
62
63%define __perl_requires %{SOURCE3}
64
65%description
66Subversion is a concurrent version control system which enables one
67or more users to collaborate in developing and maintaining a
68hierarchy of files and directories while keeping a history of all
69changes.  Subversion only stores the differences between versions,
70instead of every complete file.  Subversion is intended to be a
71compelling replacement for CVS.
72
73%package devel
74Group: Development/Libraries
75Summary: Development package for Subversion developers.
76Requires: subversion = %{version}-%{release}
77Requires: apr-devel, apr-util-devel
78%description devel
79The subversion-devel package includes the static libraries and include files
80for developers interacting with the subversion package.
81
82%package mod_dav_svn
83Group: System Environment/Daemons
84Summary: Apache server module for Subversion server.
85Requires: httpd >= %{apache_version}
86Requires: subversion = %{version}-%{release}
87%description mod_dav_svn
88The subversion-mod_dav_svn package adds the Subversion server Apache module to
89the Apache directories and configuration.
90
91%package tools
92Group: Development/Tools
93Summary: Tools for Subversion
94BuildRequires: perl >= 5.8.0
95Requires: perl >= 5.8.0
96Requires: subversion = %{version}-%{release}
97
98%description tools
99Tools for Subversion.
100
101%package perl
102Group: Development/Libraries
103Summary: Perl bindings to the Subversion libraries
104Requires: subversion = %{version}-%{release}
105Requires: perl >= 5.8.0
106Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
107
108%description perl
109This package includes the Perl bindings to the Subversion libraries.
110
111%package ruby
112Group: Development/Libraries
113Summary: Ruby bindings to the Subversion libraries
114Requires: subversion = %{version}-%{release}
115Requires: ruby >= 1.8.2
116
117%description ruby
118This package includes the Ruby bindings to the Subversion libraries.
119
120%package python
121Group: Development/Libraries
122Summary: Python bindings to the Subversion libraries
123Requires: subversion = %{version}-%{release}, python
124
125%description python
126This package includes the Python bindings to the Subversion libraries.
127
128%prep
129%setup -q
130%patch1 -p1 -b .deplibs
131%patch3 -p1 -b .rpath
132%patch11 -p1 -b .fix_detect_apache
133#security
134%patch100 -p1 -b .CVE-2014-0032
135
136rm -rf neon apr apr-util db4
137
138%build
139./autogen.sh
140
141# fix shebang lines, #111498
142perl -pi -e 's|/usr/bin/env perl -w|/usr/bin/perl -w|' tools/hook-scripts/*.pl.in
143
144# override weird -shrext from ruby
145export svn_cv_ruby_link="%{__cc} -shared"
146export svn_cv_ruby_sitedir_libsuffix=""
147export svn_cv_ruby_sitedir_archsuffix=""
148
149export CC=gcc CXX=g++ JAVA_HOME=%{jdk_path}
150export CPPFLAGS="-DSVN_NEON_0_26 -DSVN_NEON_0_25"
151%configure --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
152        --with-swig --with-neon=%{_prefix} \
153        --with-ruby-sitedir=%{rarchdir} \
154        --with-apxs=%{_bindir}/apxs \
155        --with-gnome-keyring \
156        --disable-mod-activation \
157        --disable-static \
158        --disable-neon-version-check
159# 1.3.0 tarball ships with generated swig sources
160make extraclean-swig-headers
161make %{?_smp_mflags} all
162make swig-py swig-py-lib %{swigdirs}
163make swig-pl swig-pl-lib swig-rb swig-rb-lib
164
165
166%install
167echo %{rarchdir}
168rm -rf $RPM_BUILD_ROOT
169make install \
170        install-swig-py \
171        install-swig-pl-lib \
172        install-swig-rb \
173        DESTDIR=$RPM_BUILD_ROOT %{swigdirs}
174
175make pure_vendor_install -C subversion/bindings/swig/perl/native \
176        PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
177install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/subversion
178
179# Add subversion.conf configuration file into httpd/conf.d directory.
180install -m 755 -d $RPM_BUILD_ROOT/etc/apache2/conf.d
181install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/apache2/conf.d
182
183# Set up tools package files.
184mkdir -p $RPM_BUILD_ROOT/usr/lib/subversion
185cp -r tools $RPM_BUILD_ROOT/usr/lib/subversion
186
187# Remove unpackaged files
188rm -rf $RPM_BUILD_ROOT%{_includedir}/subversion-*/*.txt \
189       $RPM_BUILD_ROOT%{python_sitearch}/*/*.{a,la} \
190       $RPM_BUILD_ROOT%{_libdir}/*.la
191       
192# remove stuff produced with Perl modules
193find $RPM_BUILD_ROOT -type f \
194     -a \( -name .packlist -o \( -name '*.bs' -a -empty \) \) \
195     -print0 | xargs -0 rm -f
196
197# make Perl modules writable so they get stripped
198find $RPM_BUILD_ROOT%{_libdir}/perl5 -type f -perm 555 -print0 |
199     xargs -0 chmod 755
200
201# unnecessary libraries for swig bindings
202rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig_*.{so,la,a}
203
204# Remove unnecessary ruby libraries
205rm -f $RPM_BUILD_ROOT%{rarchdir}/svn/ext/*.*a
206
207# Trim what goes in docdir
208rm -rf tools/*/*.in tools/test-scripts
209                       
210# Rename authz_svn INSTALL doc for docdir
211ln -f subversion/mod_authz_svn/INSTALL mod_authz_svn-INSTALL
212
213%clean
214rm -rf $RPM_BUILD_ROOT
215
216%post -p /sbin/ldconfig
217
218%postun -p /sbin/ldconfig
219
220%post tools -p /sbin/ldconfig
221
222%postun tools -p /sbin/ldconfig
223
224
225%files
226%defattr(-,root,root)
227%doc BUGS CHANGES COMMITTERS COPYING HACKING INSTALL README
228%doc subversion/LICENSE
229%{_bindir}/*
230%{_libdir}/libsvn_*.so.*
231%{_localedir}/*/*/subversion.mo
232%{_mandir}/man*/*
233%dir %{_sysconfdir}/subversion
234%exclude %{_mandir}/man*/*::*
235%exclude %{_libdir}/libsvn_swig_perl*.so.*
236%exclude %{_libdir}/libsvn_swig_py*.so.*
237%exclude %{_libdir}/libsvn_swig_ruby*.so.*
238
239%files devel
240%defattr(-,root,root)
241%{_includedir}/subversion-1
242%{_libdir}/libsvn*.so
243%exclude %{_libdir}/libsvn_swig_perl*.so.*
244%exclude %{_libdir}/libsvn_swig_py*.so.*
245%exclude %{_libdir}/libsvn_swig_ruby*.so.*
246
247%files mod_dav_svn
248%defattr(-,root,root)
249%config(noreplace) /etc/apache2/conf.d/subversion.conf
250%{apache_dir}/%{_lib}/apache2/modules/mod_*.*
251
252%files tools
253%defattr(-,root,root)
254%{_prefix}/lib/subversion/tools
255
256%files perl
257%defattr(-,root,root,-)
258%{perl_vendorarch}/auto/SVN
259%{perl_vendorarch}/SVN
260%{_libdir}/libsvn_swig_perl*
261%{_mandir}/man*/*::*
262
263%files ruby
264%defattr(-,root,root,-)
265%{_libdir}/libsvn_swig_ruby*
266%{rarchdir}/svn
267
268%files python
269%defattr(-,root,root,-)
270%{_libdir}/libsvn_swig_py*
271%{python_sitearch}/libsvn
272%{python_sitearch}/svn
273
274
275%changelog
276* Fri Mar 21 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.23-2
277- add patch100 for fix CVE-2014-0032 (from rhel5, thanks)
278- add patch11 to fix apache version detect error
279- drop old patch files from srpm
280
281* Sun Jun  2 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.23-1
282- new upstream release with security fixes (CVE-2013-1968,2088,2112)
283
284* Mon Apr 29 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.21-1
285- new upstream release with security fixes (CVE-2013-1845,46,47,49)
286- fix changelog typo
287
288* Fri Jun  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.17-1
289- new upstream release with security fix (CVE-2011-1752, 1783, 1921)
290- add configure option with-gnome-keyring
291- add BR: keyutils-libs-devel, dbus-devel, libgnome-keyring-devel
292- fix Packager name
293
294* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.16-2
295- build with perl 5.12.3
296- add Requires: perl(:MODULE_COMPAT_...)
297
298* Sat Mar  5 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.16-1
299- new upstream release with security fix
300- add Vendor/Distri tags
301
302* Mon Nov 29 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.15-1
303- new upstream release
304
305* Tue Mar  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-2
306- fix <BTS:VineLinux:941>
307  - using rpm macro: rarchdir
308  - export svn_cv_ruby_sitedir_libsuffix and svn_cv_ruby_sitedir_archsuffix
309- using rpm macros: perl_vendorarch and python_sitearch
310- add BuildRequires: sqlite3-devel krb5-devel
311
312* Thu Feb 18 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
313- new upstream release
314- update URL
315- update deplibs patch (Patch1) from Fedora 1.6.9-2.fc13
316- update rpath patch (Patch3) from Fedora 1.6.9-2.fc13
317- stop applying pia patch (Patch6): sync Fedora 1.6.9-2.fc13
318- stop applying update-neon-m4 patch (Patch10): sync Fedora 1.6.9-2.fc13
319
320* Wed Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.7-1
321- new upstream release
322
323* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.2-1
324- new upstream release
325
326* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.6-2vl5
327- rebuilt with python-2.5.2
328
329* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.6-1vl5
330- new upstream release
331- rebuild with neon-0.28.2
332- dropped old-Patch10 by adding --disable-neon-version-check to %%configure
333- added Patch6, 8, 9, 10 from Fedora Core
334  * Thu Feb 21 2008 Lubomir Kundrak <lkundrak@redhat.com> 1.4.6-5
335  - Correct install location of java stuff (#433295)
336  * Wed Aug  8 2007 Joe Orton <jorton@redhat.com> 1.4.4-3
337  - fix build with new glibc open()-as-macro
338  - build all swig code in %%build, not %%install
339  * Fri May 21 2004 Joe Orton <jorton@redhat.com> 1.0.3-2
340  - build /usr/bin/* as PIEs
341
342* Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl2
343- rebuild with expat-2.0.1
344
345* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.3-0vl1
346- new upstream release
347- add Patch10 to build with neon.
348  1.3.2-0vl5 does not support neon..
349
350* Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl4
351- rebuild with new neon
352
353* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.2-0vl3
354- rebuilt with new toolchain and db4-4.3.x
355
356* Sat Mar 31 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.2-0vl2
357- modified %%files section for lib64 architecture
358
359* Tue Aug 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl1
360- new upstream release
361- rebuild with new openldap-2.3.24
362
363* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.1-0vl1
364- new upstream release
365- change Group to Develoment/Tools
366- build with apr-1.2.7/apr-util-1.2.7
367  - require apr/apr-util instead of apache2-apr
368- build with swig-1.3.29
369- split {perl,python,ruby} related files to subpackage.
370
371* Tue Oct 18 2005 IWAI, Masaharu <iwai@alib.jp> 1.2.3-0vl1
372- new upstream release
373- add noreplace option for config file
374
375* Sun Jan 30 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl3
376- fix Requires and BuildPreReq.
377
378* Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl2
379- new upstream release.
380- add swig-runtime to 'BuildPreReq:'.
381- fix %%files.
382
383* Sun Oct 17 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.0.6-0vl1.1
384- require neon version 0.24.7 for ra_dav
385- add BuildPreReq: openldap-devel
386- replace BuildPreReq: httpd to BuildPreReq: apache2
387- replace tools Requires: perl(:MODULE_COMPAT_version) to perl >= 5.8.0
388
389* Wed Jul 21 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.6-0vl1
390- new upstream release
391
392* Tue Jun 22 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.5-0vl1
393- new upstream release
394
395* Fri Jun  4 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.4-0vl1
396- new upstream release
397- clean up specfile.
398
399* Tue Nov 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.32.1-0vl1
400- new upstream release
401- build with apache2-2.0.47
402
403* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.20.0-0vl1
404- build Vine Linux
405
406* Sat Mar 01 2003 David Summers <david@summersoft.fay.ar.us> 0.18.1-5173
407- Enabled RA_DAV checking.
408  Now requires httpd package to build because of RA_DAV tests.
409
410* Sat Jan 18 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4433
411- Created tools package to hold the tools.
412
413* Thu Jan 16 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4405
414- Now requires httpd >= 2.0.44-0.1 (APACHE_2_0_BRANCH) which contains the new
415  version of APR/APR-UTILS as of 2003.01.15.
416- Added svnversion command.
417
418* Tue Dec 31 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4218
419- Create a svnadmin.static which is copied to svnadmin-version-release
420  when the package is erased, so users can still dump/load their repositories
421  even after they have upgraded the RPM package.
422
423* Sat Dec 14 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4128
424- SWIG now builds so we can use cvs2svn.
425
426* Fri Oct 04 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3280
427- Made cvs2svn conditional (at least until we can get it to build consistently
428  and work).
429
430* Sat Sep 21 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3205
431- Added SWIG dependencies to add cvs2svn capabilities.
432
433* Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2984
434- Now requires neon-0.22.0.
435
436* Thu Aug 15 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2978
437- Took out loading mod_dav_svn from subversion.spec file and put it in
438  subversion.conf file which goes into the apache conf directory.
439- Simplify what gets put into httpd.conf to only the include for the
440  subversion.conf file.
441  (Thanks to Scott Harrison <sharrison@users.sourceforge.net> for prompting
442  me to do this).
443
444* Thu Aug 08 2002 David Summers <david@summersoft.fay.ar.us> 0.14.0-2919
445- Updated to APR/APR-UTIL 2002-08-08.
446
447* Tue Jun 25 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2332
448- Updated to APACHE/APR/APR-UTIL 2002-06-25.
449- Previous version had a few problems because of missing apache error/ files.
450
451* Sun Jun 23 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2318
452- Updated to apache-2.0.40-0.3.
453- Updated to subversion-0.13.1-2318.
454
455* Tue Jun 18 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2277
456- Updated for RedHat 7.3 (autoconf253).
457- Added a bunch of pre-requisites I didn't know were needed because I built a
458  new machine that didn't have them already installed.
459- Fixed installation of man and info documentation pages.
460
461* Wed Mar 06 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1447
462- Back to apache-libapr* stuff, hopefully to stay.
463
464* Sun Feb 24 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1373
465- Fixed expat.patch to not have to make so many changes by writing a small
466  shell script that changes libexpat to -lexpat.
467
468* Fri Feb 22 2002 Blair Zajac <blair@orcaware.com> 0.9.0-1364
469- Updated to neon-0.19.2.
470
471* Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1250
472- Back to using apr and apr-util separately from apache.
473
474* Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1232
475- Updated to APR and APR-UTIL 2002.02.11.
476- Updated to apache-2.0.32-0.2. (Requires apache-libapr and apache-libapr-util).
477- Took out a (now non-existant) documentation file.
478- Moved SPEC file changelog to after all package definitions.
479 
480* Sun Feb 03 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1153
481- Updated to neon-0.18.5.
482- Broke up apache and apache-devel into apache-apr, apache-apr-devel,
483  apache-apr-utils, and apache-apr-utils-devel.
484- Updated apache to APR and APR-UTILS to 2002.02.03 version.
485
486* Sat Feb 02 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1147
487- Now builds without the separate APR package as it is built into and
488  "exported" from apache-2.0.31-0.3.
489
490* Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1132
491- Took out patches to install procedure now not required because of fixes
492  in rev 1130.
493
494* Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1129
495- Added requirement for APR 0.2002.01.19 rev 2 where the /usr/bin/apr-config
496  program was added.
497
498* Sun Oct 28 2001 David Summers <david@summersoft.fay.ar.us>
499- Release M5-r340: Added the subversion-server package.
500
501* Fri Oct 26 2001 David Summers <david@summersoft.fay.ar.us>
502- Release M5-r327: No longer need expat-lite. We can use the normal expat.
503
504* Thu Sep 27 2001 David Summers <david@summersoft.fay.ar.us>
505- Release M3-r117: Initial Version.
506
Note: See TracBrowser for help on using the repository browser.