source: projects/specs/branches/6/s/subversion/subversion-vl.spec @ 10682

Revision 10682, 17.1 KB checked in by tomop, 8 years ago (diff)

subversion-1.6.23-3

Line 
1%define neon_version 0.25.5
2%define swig_version 1.3.29
3%define apache_dir /usr
4
5%define db_version 4.3.29
6
7%define swigdirs swig_pydir=%{python_sitearch}/libsvn swig_pydir_extra=%{python_sitearch}/svn
8
9# set to zero to avoid running test suite
10%define make_check 0
11
12Summary: Modern Version Control System
13Summary(ja): モダンなバージョン管理システム
14Name: subversion
15Version: 1.6.23
16Release: 3%{?_dist_release}
17License: ASL 1.1
18Group: Development/Tools
19URL: http://subversion.apache.org/
20
21Packager: iwaim
22Vendor: Project Vine
23Distribution: Vine Linux
24
25SOURCE0: subversion-%{version}.tar.bz2
26SOURCE1: subversion.conf
27SOURCE2: httpd.davcheck.conf
28SOURCE3: filter-requires.sh
29Patch1: subversion-1.6.0-deplibs.patch
30Patch3: subversion-1.6.1-rpath.patch
31Patch11: subversion-1.6.23_fix_detect_apache.patch
32#security
33Patch100: subversion-1.6.11-CVE-2014-0032.patch
34Patch101: CVE-2014-3522.patch
35Patch102: CVE-2014-3528.patch
36Patch103: CVE-2014-3580.patch
37Patch104: CVE-2015-0248.patch
38Patch105: CVE-2015-0251.patch
39Patch106: CVE-2015-3187.patch
40
41Requires: db4 >= %{db_version}
42Requires: expat
43Requires: neon >= %{neon_version}
44BuildRequires: apache2-devel
45BuildRequires: apr-devel, apr-util-devel
46BuildRequires: autoconf >= 2.53
47BuildRequires: db4-devel >= %{db_version}
48BuildRequires: expat-devel
49BuildRequires: gdbm-devel
50BuildRequires: libtool >= 1.4.2
51BuildRequires: neon-devel >= %{neon_version}
52BuildRequires: openssl-devel
53BuildRequires: python
54BuildRequires: python-devel
55BuildRequires: swig >= %{swig_version}
56BuildRequires: texinfo
57BuildRequires: zlib-devel
58BuildRequires: openldap-devel
59BuildRequires: ruby >= 1.8.2
60BuildRequires: ruby-devel >= 1.8.2
61BuildRequires: perl >= 5.8.0
62BuildRequires: sqlite3-devel
63BuildRequires: krb5-devel
64BuildRequires: keyutils-libs-devel
65BuildRequires: dbus-devel
66BuildRequires: libgnome-keyring-devel
67BuildRoot: %{_tmppath}/%{name}-%{version}-root
68
69%define __perl_requires %{SOURCE3}
70
71%description
72Subversion is a concurrent version control system which enables one
73or more users to collaborate in developing and maintaining a
74hierarchy of files and directories while keeping a history of all
75changes.  Subversion only stores the differences between versions,
76instead of every complete file.  Subversion is intended to be a
77compelling replacement for CVS.
78
79%package devel
80Group: Development/Libraries
81Summary: Development package for Subversion developers.
82Requires: subversion = %{version}-%{release}
83Requires: apr-devel, apr-util-devel
84%description devel
85The subversion-devel package includes the static libraries and include files
86for developers interacting with the subversion package.
87
88%package mod_dav_svn
89Group: System Environment/Daemons
90Summary: Apache server module for Subversion server.
91Requires: httpd >= %{apache_version}
92Requires: subversion = %{version}-%{release}
93%description mod_dav_svn
94The subversion-mod_dav_svn package adds the Subversion server Apache module to
95the Apache directories and configuration.
96
97%package tools
98Group: Development/Tools
99Summary: Tools for Subversion
100BuildRequires: perl >= 5.8.0
101Requires: perl >= 5.8.0
102Requires: subversion = %{version}-%{release}
103
104%description tools
105Tools for Subversion.
106
107%package perl
108Group: Development/Libraries
109Summary: Perl bindings to the Subversion libraries
110Requires: subversion = %{version}-%{release}
111Requires: perl >= 5.8.0
112Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
113
114%description perl
115This package includes the Perl bindings to the Subversion libraries.
116
117%package ruby
118Group: Development/Libraries
119Summary: Ruby bindings to the Subversion libraries
120Requires: subversion = %{version}-%{release}
121Requires: ruby >= 1.8.2
122
123%description ruby
124This package includes the Ruby bindings to the Subversion libraries.
125
126%package python
127Group: Development/Libraries
128Summary: Python bindings to the Subversion libraries
129Requires: subversion = %{version}-%{release}, python
130
131%description python
132This package includes the Python bindings to the Subversion libraries.
133
134%prep
135%setup -q
136%patch1 -p1 -b .deplibs
137%patch3 -p1 -b .rpath
138%patch11 -p1 -b .fix_detect_apache
139#security
140%patch100 -p1 -b .CVE-2014-0032
141%patch101 -p1 -b .CVE-2014-3522
142%patch102 -p1 -b .CVE-2014-3528
143%patch103 -p1 -b .CVE-2014-3580
144%patch104 -p1 -b .CVE-2015-0248
145%patch105 -p1 -b .CVE-2015-0251
146%patch106 -p1 -b .CVE-2015-3187
147
148rm -rf neon apr apr-util db4
149
150sed -i -e 's|libtool/config|libtool/build-aux|' autogen.sh
151
152%build
153./autogen.sh
154
155# fix shebang lines, #111498
156perl -pi -e 's|/usr/bin/env perl -w|/usr/bin/perl -w|' tools/hook-scripts/*.pl.in
157
158# override weird -shrext from ruby
159export svn_cv_ruby_link="%{__cc} -shared"
160export svn_cv_ruby_sitedir_libsuffix=""
161export svn_cv_ruby_sitedir_archsuffix=""
162
163export CC=gcc CXX=g++ JAVA_HOME=%{jdk_path}
164export CPPFLAGS="-DSVN_NEON_0_26 -DSVN_NEON_0_25"
165%configure --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
166        --with-swig --with-neon=%{_prefix} \
167        --with-ruby-sitedir=%{rarchdir} \
168        --with-apxs=%{_bindir}/apxs \
169        --with-gnome-keyring \
170        --disable-mod-activation \
171        --disable-static \
172        --disable-neon-version-check
173# 1.3.0 tarball ships with generated swig sources
174make extraclean-swig-headers
175make %{?_smp_mflags} all
176make swig-py swig-py-lib %{swigdirs}
177make swig-pl swig-pl-lib swig-rb swig-rb-lib
178
179
180%install
181echo %{rarchdir}
182rm -rf $RPM_BUILD_ROOT
183make install \
184        install-swig-py \
185        install-swig-pl-lib \
186        install-swig-rb \
187        DESTDIR=$RPM_BUILD_ROOT %{swigdirs}
188
189make pure_vendor_install -C subversion/bindings/swig/perl/native \
190        PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
191install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/subversion
192
193# Add subversion.conf configuration file into httpd/conf.d directory.
194install -m 755 -d $RPM_BUILD_ROOT/etc/apache2/conf.d
195install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/apache2/conf.d
196
197# Set up tools package files.
198mkdir -p $RPM_BUILD_ROOT/usr/lib/subversion
199cp -r tools $RPM_BUILD_ROOT/usr/lib/subversion
200
201# Remove unpackaged files
202rm -rf $RPM_BUILD_ROOT%{_includedir}/subversion-*/*.txt \
203       $RPM_BUILD_ROOT%{python_sitearch}/*/*.{a,la} \
204       $RPM_BUILD_ROOT%{_libdir}/*.la
205       
206# remove stuff produced with Perl modules
207find $RPM_BUILD_ROOT -type f \
208     -a \( -name .packlist -o \( -name '*.bs' -a -empty \) \) \
209     -print0 | xargs -0 rm -f
210
211# make Perl modules writable so they get stripped
212find $RPM_BUILD_ROOT%{_libdir}/perl5 -type f -perm 555 -print0 |
213     xargs -0 chmod 755
214
215# unnecessary libraries for swig bindings
216rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig_*.{so,la,a}
217
218# Remove unnecessary ruby libraries
219rm -f $RPM_BUILD_ROOT%{rarchdir}/svn/ext/*.*a
220
221# Trim what goes in docdir
222rm -rf tools/*/*.in tools/test-scripts
223                       
224# Rename authz_svn INSTALL doc for docdir
225ln -f subversion/mod_authz_svn/INSTALL mod_authz_svn-INSTALL
226
227%clean
228rm -rf $RPM_BUILD_ROOT
229
230%post -p /sbin/ldconfig
231
232%postun -p /sbin/ldconfig
233
234%post tools -p /sbin/ldconfig
235
236%postun tools -p /sbin/ldconfig
237
238
239%files
240%defattr(-,root,root)
241%doc BUGS CHANGES COMMITTERS COPYING HACKING INSTALL README
242%doc subversion/LICENSE
243%{_bindir}/*
244%{_libdir}/libsvn_*.so.*
245%{_localedir}/*/*/subversion.mo
246%{_mandir}/man*/*
247%dir %{_sysconfdir}/subversion
248%exclude %{_mandir}/man*/*::*
249%exclude %{_libdir}/libsvn_swig_perl*.so.*
250%exclude %{_libdir}/libsvn_swig_py*.so.*
251%exclude %{_libdir}/libsvn_swig_ruby*.so.*
252
253%files devel
254%defattr(-,root,root)
255%{_includedir}/subversion-1
256%{_libdir}/libsvn*.so
257%exclude %{_libdir}/libsvn_swig_perl*.so.*
258%exclude %{_libdir}/libsvn_swig_py*.so.*
259%exclude %{_libdir}/libsvn_swig_ruby*.so.*
260
261%files mod_dav_svn
262%defattr(-,root,root)
263%config(noreplace) /etc/apache2/conf.d/subversion.conf
264%{apache_dir}/%{_lib}/apache2/modules/mod_*.*
265
266%files tools
267%defattr(-,root,root)
268%{_prefix}/lib/subversion/tools
269
270%files perl
271%defattr(-,root,root,-)
272%{perl_vendorarch}/auto/SVN
273%{perl_vendorarch}/SVN
274%{_libdir}/libsvn_swig_perl*
275%{_mandir}/man*/*::*
276
277%files ruby
278%defattr(-,root,root,-)
279%{_libdir}/libsvn_swig_ruby*
280%{rarchdir}/svn
281
282%files python
283%defattr(-,root,root,-)
284%{_libdir}/libsvn_swig_py*
285%{python_sitearch}/libsvn
286%{python_sitearch}/svn
287
288
289%changelog
290* Sun Jul 24 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.23-3
291- added Patch101-106 to fix vulnerabilities.
292  - CVE-2014-3522
293  - CVE-2014-3528
294  - CVE-2014-3580
295  - CVE-2015-0248
296  - CVE-2015-0251
297  - CVE-2015-3187
298
299* Fri Mar 21 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.23-2
300- add patch100 for fix CVE-2014-0032 (from rhel5, thanks)
301- add patch11 to fix apache version detect error
302- drop old patch files from srpm
303
304* Sun Jun  2 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.23-1
305- new upstream release with security fixes (CVE-2013-1968,2088,2112)
306
307* Mon Apr 29 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.21-1
308- new upstream release with security fixes (CVE-2013-1845,46,47,49)
309- fix changelog typo
310
311* Fri Jun  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.17-1
312- new upstream release with security fix (CVE-2011-1752, 1783, 1921)
313- add configure option with-gnome-keyring
314- add BR: keyutils-libs-devel, dbus-devel, libgnome-keyring-devel
315- fix Packager name
316
317* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.16-2
318- build with perl 5.12.3
319- add Requires: perl(:MODULE_COMPAT_...)
320
321* Sat Mar  5 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.16-1
322- new upstream release with security fix
323- add Vendor/Distri tags
324
325* Mon Nov 29 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.15-1
326- new upstream release
327
328* Tue Mar  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-2
329- fix <BTS:VineLinux:941>
330  - using rpm macro: rarchdir
331  - export svn_cv_ruby_sitedir_libsuffix and svn_cv_ruby_sitedir_archsuffix
332- using rpm macros: perl_vendorarch and python_sitearch
333- add BuildRequires: sqlite3-devel krb5-devel
334
335* Thu Feb 18 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
336- new upstream release
337- update URL
338- update deplibs patch (Patch1) from Fedora 1.6.9-2.fc13
339- update rpath patch (Patch3) from Fedora 1.6.9-2.fc13
340- stop applying pia patch (Patch6): sync Fedora 1.6.9-2.fc13
341- stop applying update-neon-m4 patch (Patch10): sync Fedora 1.6.9-2.fc13
342
343* Wed Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.7-1
344- new upstream release
345
346* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.2-1
347- new upstream release
348
349* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.6-2vl5
350- rebuilt with python-2.5.2
351
352* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.6-1vl5
353- new upstream release
354- rebuild with neon-0.28.2
355- dropped old-Patch10 by adding --disable-neon-version-check to %%configure
356- added Patch6, 8, 9, 10 from Fedora Core
357  * Thu Feb 21 2008 Lubomir Kundrak <lkundrak@redhat.com> 1.4.6-5
358  - Correct install location of java stuff (#433295)
359  * Wed Aug  8 2007 Joe Orton <jorton@redhat.com> 1.4.4-3
360  - fix build with new glibc open()-as-macro
361  - build all swig code in %%build, not %%install
362  * Fri May 21 2004 Joe Orton <jorton@redhat.com> 1.0.3-2
363  - build /usr/bin/* as PIEs
364
365* Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl2
366- rebuild with expat-2.0.1
367
368* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.3-0vl1
369- new upstream release
370- add Patch10 to build with neon.
371  1.3.2-0vl5 does not support neon..
372
373* Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl4
374- rebuild with new neon
375
376* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.2-0vl3
377- rebuilt with new toolchain and db4-4.3.x
378
379* Sat Mar 31 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.2-0vl2
380- modified %%files section for lib64 architecture
381
382* Tue Aug 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl1
383- new upstream release
384- rebuild with new openldap-2.3.24
385
386* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.1-0vl1
387- new upstream release
388- change Group to Develoment/Tools
389- build with apr-1.2.7/apr-util-1.2.7
390  - require apr/apr-util instead of apache2-apr
391- build with swig-1.3.29
392- split {perl,python,ruby} related files to subpackage.
393
394* Tue Oct 18 2005 IWAI, Masaharu <iwai@alib.jp> 1.2.3-0vl1
395- new upstream release
396- add noreplace option for config file
397
398* Sun Jan 30 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl3
399- fix Requires and BuildPreReq.
400
401* Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl2
402- new upstream release.
403- add swig-runtime to 'BuildPreReq:'.
404- fix %%files.
405
406* Sun Oct 17 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.0.6-0vl1.1
407- require neon version 0.24.7 for ra_dav
408- add BuildPreReq: openldap-devel
409- replace BuildPreReq: httpd to BuildPreReq: apache2
410- replace tools Requires: perl(:MODULE_COMPAT_version) to perl >= 5.8.0
411
412* Wed Jul 21 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.6-0vl1
413- new upstream release
414
415* Tue Jun 22 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.5-0vl1
416- new upstream release
417
418* Fri Jun  4 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.4-0vl1
419- new upstream release
420- clean up specfile.
421
422* Tue Nov 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.32.1-0vl1
423- new upstream release
424- build with apache2-2.0.47
425
426* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.20.0-0vl1
427- build Vine Linux
428
429* Sat Mar 01 2003 David Summers <david@summersoft.fay.ar.us> 0.18.1-5173
430- Enabled RA_DAV checking.
431  Now requires httpd package to build because of RA_DAV tests.
432
433* Sat Jan 18 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4433
434- Created tools package to hold the tools.
435
436* Thu Jan 16 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4405
437- Now requires httpd >= 2.0.44-0.1 (APACHE_2_0_BRANCH) which contains the new
438  version of APR/APR-UTILS as of 2003.01.15.
439- Added svnversion command.
440
441* Tue Dec 31 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4218
442- Create a svnadmin.static which is copied to svnadmin-version-release
443  when the package is erased, so users can still dump/load their repositories
444  even after they have upgraded the RPM package.
445
446* Sat Dec 14 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4128
447- SWIG now builds so we can use cvs2svn.
448
449* Fri Oct 04 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3280
450- Made cvs2svn conditional (at least until we can get it to build consistently
451  and work).
452
453* Sat Sep 21 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3205
454- Added SWIG dependencies to add cvs2svn capabilities.
455
456* Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2984
457- Now requires neon-0.22.0.
458
459* Thu Aug 15 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2978
460- Took out loading mod_dav_svn from subversion.spec file and put it in
461  subversion.conf file which goes into the apache conf directory.
462- Simplify what gets put into httpd.conf to only the include for the
463  subversion.conf file.
464  (Thanks to Scott Harrison <sharrison@users.sourceforge.net> for prompting
465  me to do this).
466
467* Thu Aug 08 2002 David Summers <david@summersoft.fay.ar.us> 0.14.0-2919
468- Updated to APR/APR-UTIL 2002-08-08.
469
470* Tue Jun 25 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2332
471- Updated to APACHE/APR/APR-UTIL 2002-06-25.
472- Previous version had a few problems because of missing apache error/ files.
473
474* Sun Jun 23 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2318
475- Updated to apache-2.0.40-0.3.
476- Updated to subversion-0.13.1-2318.
477
478* Tue Jun 18 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2277
479- Updated for RedHat 7.3 (autoconf253).
480- Added a bunch of pre-requisites I didn't know were needed because I built a
481  new machine that didn't have them already installed.
482- Fixed installation of man and info documentation pages.
483
484* Wed Mar 06 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1447
485- Back to apache-libapr* stuff, hopefully to stay.
486
487* Sun Feb 24 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1373
488- Fixed expat.patch to not have to make so many changes by writing a small
489  shell script that changes libexpat to -lexpat.
490
491* Fri Feb 22 2002 Blair Zajac <blair@orcaware.com> 0.9.0-1364
492- Updated to neon-0.19.2.
493
494* Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1250
495- Back to using apr and apr-util separately from apache.
496
497* Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1232
498- Updated to APR and APR-UTIL 2002.02.11.
499- Updated to apache-2.0.32-0.2. (Requires apache-libapr and apache-libapr-util).
500- Took out a (now non-existant) documentation file.
501- Moved SPEC file changelog to after all package definitions.
502 
503* Sun Feb 03 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1153
504- Updated to neon-0.18.5.
505- Broke up apache and apache-devel into apache-apr, apache-apr-devel,
506  apache-apr-utils, and apache-apr-utils-devel.
507- Updated apache to APR and APR-UTILS to 2002.02.03 version.
508
509* Sat Feb 02 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1147
510- Now builds without the separate APR package as it is built into and
511  "exported" from apache-2.0.31-0.3.
512
513* Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1132
514- Took out patches to install procedure now not required because of fixes
515  in rev 1130.
516
517* Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1129
518- Added requirement for APR 0.2002.01.19 rev 2 where the /usr/bin/apr-config
519  program was added.
520
521* Sun Oct 28 2001 David Summers <david@summersoft.fay.ar.us>
522- Release M5-r340: Added the subversion-server package.
523
524* Fri Oct 26 2001 David Summers <david@summersoft.fay.ar.us>
525- Release M5-r327: No longer need expat-lite. We can use the normal expat.
526
527* Thu Sep 27 2001 David Summers <david@summersoft.fay.ar.us>
528- Release M3-r117: Initial Version.
529
Note: See TracBrowser for help on using the repository browser.