source: projects/specs/branches/6/s/subversion/subversion-vl.spec @ 7830

Revision 7830, 16.5 KB checked in by iwamoto, 11 years ago (diff)

subversion : add patch for CVE-2013-4277

Line 
1%define neon_version 0.25.5
2%define swig_version 1.3.29
3%define apache_dir /usr
4
5%define db_version 4.3.29
6
7%define swigdirs swig_pydir=%{python_sitearch}/libsvn swig_pydir_extra=%{python_sitearch}/svn
8
9# set to zero to avoid running test suite
10%define make_check 0
11
12Summary: Modern Version Control System
13Summary(ja): モダンなバージョン管理システム
14Name: subversion
15Version: 1.6.23
16Release: 2%{?_dist_release}
17License: ASL 1.1
18Group: Development/Tools
19URL: http://subversion.apache.org/
20
21Packager: iwaim
22Vendor: Project Vine
23Distribution: Vine Linux
24
25SOURCE0: subversion-%{version}.tar.bz2
26SOURCE1: subversion.conf
27SOURCE2: httpd.davcheck.conf
28SOURCE3: filter-requires.sh
29Patch1: subversion-1.6.0-deplibs.patch
30Patch3: subversion-1.6.1-rpath.patch
31Patch6: subversion-1.5.0-pie.patch
32Patch10: subversion-1.5.7-update-neon-m4.patch
33
34#security
35Patch100: subversion-1.6.23_CVE-2013-4277-2.patch
36
37Requires: db4 >= %{db_version}
38Requires: expat
39Requires: neon >= %{neon_version}
40BuildRequires: apache2-devel
41BuildRequires: apr-devel, apr-util-devel
42BuildRequires: autoconf >= 2.53
43BuildRequires: db4-devel >= %{db_version}
44BuildRequires: expat-devel
45BuildRequires: gdbm-devel
46BuildRequires: libtool >= 1.4.2
47BuildRequires: neon-devel >= %{neon_version}
48BuildRequires: openssl-devel
49BuildRequires: python
50BuildRequires: python-devel
51BuildRequires: swig >= %{swig_version}
52BuildRequires: texinfo
53BuildRequires: zlib-devel
54BuildRequires: openldap-devel
55BuildRequires: ruby >= 1.8.2
56BuildRequires: ruby-devel >= 1.8.2
57BuildRequires: perl >= 5.8.0
58BuildRequires: sqlite3-devel
59BuildRequires: krb5-devel
60BuildRequires: keyutils-libs-devel
61BuildRequires: dbus-devel
62BuildRequires: libgnome-keyring-devel
63BuildRoot: %{_tmppath}/%{name}-%{version}-root
64
65%define __perl_requires %{SOURCE3}
66
67%description
68Subversion is a concurrent version control system which enables one
69or more users to collaborate in developing and maintaining a
70hierarchy of files and directories while keeping a history of all
71changes.  Subversion only stores the differences between versions,
72instead of every complete file.  Subversion is intended to be a
73compelling replacement for CVS.
74
75%package devel
76Group: Development/Libraries
77Summary: Development package for Subversion developers.
78Requires: subversion = %{version}-%{release}
79Requires: apr-devel, apr-util-devel
80%description devel
81The subversion-devel package includes the static libraries and include files
82for developers interacting with the subversion package.
83
84%package mod_dav_svn
85Group: System Environment/Daemons
86Summary: Apache server module for Subversion server.
87Requires: httpd >= %{apache_version}
88Requires: subversion = %{version}-%{release}
89%description mod_dav_svn
90The subversion-mod_dav_svn package adds the Subversion server Apache module to
91the Apache directories and configuration.
92
93%package tools
94Group: Development/Tools
95Summary: Tools for Subversion
96BuildRequires: perl >= 5.8.0
97Requires: perl >= 5.8.0
98Requires: subversion = %{version}-%{release}
99
100%description tools
101Tools for Subversion.
102
103%package perl
104Group: Development/Libraries
105Summary: Perl bindings to the Subversion libraries
106Requires: subversion = %{version}-%{release}
107Requires: perl >= 5.8.0
108Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
109
110%description perl
111This package includes the Perl bindings to the Subversion libraries.
112
113%package ruby
114Group: Development/Libraries
115Summary: Ruby bindings to the Subversion libraries
116Requires: subversion = %{version}-%{release}
117Requires: ruby >= 1.8.2
118
119%description ruby
120This package includes the Ruby bindings to the Subversion libraries.
121
122%package python
123Group: Development/Libraries
124Summary: Python bindings to the Subversion libraries
125Requires: subversion = %{version}-%{release}, python
126
127%description python
128This package includes the Python bindings to the Subversion libraries.
129
130%prep
131%setup -q
132%patch1 -p1 -b .deplibs
133%patch3 -p1 -b .rpath
134## comment out: 1.6.9-1
135#%patch6 -p1 -b .pie
136## comment out: 1.6.9-1
137#%patch10 -p1 -b .nola
138
139# security
140%patch100 -p1 -b .CVE-2013-4277
141
142rm -rf neon apr apr-util db4
143
144%build
145./autogen.sh
146
147# fix shebang lines, #111498
148perl -pi -e 's|/usr/bin/env perl -w|/usr/bin/perl -w|' tools/hook-scripts/*.pl.in
149
150# override weird -shrext from ruby
151export svn_cv_ruby_link="%{__cc} -shared"
152export svn_cv_ruby_sitedir_libsuffix=""
153export svn_cv_ruby_sitedir_archsuffix=""
154
155export CC=gcc CXX=g++ JAVA_HOME=%{jdk_path}
156export CPPFLAGS="-DSVN_NEON_0_26 -DSVN_NEON_0_25"
157%configure --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
158        --with-swig --with-neon=%{_prefix} \
159        --with-ruby-sitedir=%{rarchdir} \
160        --with-apxs=%{_bindir}/apxs \
161        --with-gnome-keyring \
162        --disable-mod-activation \
163        --disable-static \
164        --disable-neon-version-check
165# 1.3.0 tarball ships with generated swig sources
166make extraclean-swig-headers
167make %{?_smp_mflags} all
168make swig-py swig-py-lib %{swigdirs}
169make swig-pl swig-pl-lib swig-rb swig-rb-lib
170
171
172%install
173echo %{rarchdir}
174rm -rf $RPM_BUILD_ROOT
175make install \
176        install-swig-py \
177        install-swig-pl-lib \
178        install-swig-rb \
179        DESTDIR=$RPM_BUILD_ROOT %{swigdirs}
180
181make pure_vendor_install -C subversion/bindings/swig/perl/native \
182        PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
183install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/subversion
184
185# Add subversion.conf configuration file into httpd/conf.d directory.
186install -m 755 -d $RPM_BUILD_ROOT/etc/apache2/conf.d
187install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/apache2/conf.d
188
189# Set up tools package files.
190mkdir -p $RPM_BUILD_ROOT/usr/lib/subversion
191cp -r tools $RPM_BUILD_ROOT/usr/lib/subversion
192
193# Remove unpackaged files
194rm -rf $RPM_BUILD_ROOT%{_includedir}/subversion-*/*.txt \
195       $RPM_BUILD_ROOT%{python_sitearch}/*/*.{a,la} \
196       $RPM_BUILD_ROOT%{_libdir}/*.la
197       
198# remove stuff produced with Perl modules
199find $RPM_BUILD_ROOT -type f \
200     -a \( -name .packlist -o \( -name '*.bs' -a -empty \) \) \
201     -print0 | xargs -0 rm -f
202
203# make Perl modules writable so they get stripped
204find $RPM_BUILD_ROOT%{_libdir}/perl5 -type f -perm 555 -print0 |
205     xargs -0 chmod 755
206
207# unnecessary libraries for swig bindings
208rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig_*.{so,la,a}
209
210# Remove unnecessary ruby libraries
211rm -f $RPM_BUILD_ROOT%{rarchdir}/svn/ext/*.*a
212
213# Trim what goes in docdir
214rm -rf tools/*/*.in tools/test-scripts
215                       
216# Rename authz_svn INSTALL doc for docdir
217ln -f subversion/mod_authz_svn/INSTALL mod_authz_svn-INSTALL
218
219%clean
220rm -rf $RPM_BUILD_ROOT
221
222%post -p /sbin/ldconfig
223
224%postun -p /sbin/ldconfig
225
226%post tools -p /sbin/ldconfig
227
228%postun tools -p /sbin/ldconfig
229
230
231%files
232%defattr(-,root,root)
233%doc BUGS CHANGES COMMITTERS COPYING HACKING INSTALL README
234%doc subversion/LICENSE
235%{_bindir}/*
236%{_libdir}/libsvn_*.so.*
237%{_localedir}/*/*/subversion.mo
238%{_mandir}/man*/*
239%dir %{_sysconfdir}/subversion
240%exclude %{_mandir}/man*/*::*
241%exclude %{_libdir}/libsvn_swig_perl*.so.*
242%exclude %{_libdir}/libsvn_swig_py*.so.*
243%exclude %{_libdir}/libsvn_swig_ruby*.so.*
244
245%files devel
246%defattr(-,root,root)
247%{_includedir}/subversion-1
248%{_libdir}/libsvn*.so
249%exclude %{_libdir}/libsvn_swig_perl*.so.*
250%exclude %{_libdir}/libsvn_swig_py*.so.*
251%exclude %{_libdir}/libsvn_swig_ruby*.so.*
252
253%files mod_dav_svn
254%defattr(-,root,root)
255%config(noreplace) /etc/apache2/conf.d/subversion.conf
256%{apache_dir}/%{_lib}/apache2/modules/mod_*.*
257
258%files tools
259%defattr(-,root,root)
260%{_prefix}/lib/subversion/tools
261
262%files perl
263%defattr(-,root,root,-)
264%{perl_vendorarch}/auto/SVN
265%{perl_vendorarch}/SVN
266%{_libdir}/libsvn_swig_perl*
267%{_mandir}/man*/*::*
268
269%files ruby
270%defattr(-,root,root,-)
271%{_libdir}/libsvn_swig_ruby*
272%{rarchdir}/svn
273
274%files python
275%defattr(-,root,root,-)
276%{_libdir}/libsvn_swig_py*
277%{python_sitearch}/libsvn
278%{python_sitearch}/svn
279
280
281%changelog
282* Thu Sep 19 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.23-2
283- add patch100 for fix CVE-2013-4277 (pid-file option)
284
285* Sun Jun  2 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.23-1
286- new upstream release with security fixes (CVE-2013-1968,2088,2112)
287
288* Mon Apr 29 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.21-1
289- new upstream release with security fixes (CVE-2013-1845,46,47,49)
290- fix changelog typo
291
292* Fri Jun  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.17-1
293- new upstream release with security fix (CVE-2011-1752, 1783, 1921)
294- add configure option with-gnome-keyring
295- add BR: keyutils-libs-devel, dbus-devel, libgnome-keyring-devel
296- fix Packager name
297
298* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.16-2
299- build with perl 5.12.3
300- add Requires: perl(:MODULE_COMPAT_...)
301
302* Sat Mar  5 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.16-1
303- new upstream release with security fix
304- add Vendor/Distri tags
305
306* Mon Nov 29 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.15-1
307- new upstream release
308
309* Tue Mar  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-2
310- fix <BTS:VineLinux:941>
311  - using rpm macro: rarchdir
312  - export svn_cv_ruby_sitedir_libsuffix and svn_cv_ruby_sitedir_archsuffix
313- using rpm macros: perl_vendorarch and python_sitearch
314- add BuildRequires: sqlite3-devel krb5-devel
315
316* Thu Feb 18 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
317- new upstream release
318- update URL
319- update deplibs patch (Patch1) from Fedora 1.6.9-2.fc13
320- update rpath patch (Patch3) from Fedora 1.6.9-2.fc13
321- stop applying pia patch (Patch6): sync Fedora 1.6.9-2.fc13
322- stop applying update-neon-m4 patch (Patch10): sync Fedora 1.6.9-2.fc13
323
324* Wed Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.7-1
325- new upstream release
326
327* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.2-1
328- new upstream release
329
330* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.6-2vl5
331- rebuilt with python-2.5.2
332
333* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.6-1vl5
334- new upstream release
335- rebuild with neon-0.28.2
336- dropped old-Patch10 by adding --disable-neon-version-check to %%configure
337- added Patch6, 8, 9, 10 from Fedora Core
338  * Thu Feb 21 2008 Lubomir Kundrak <lkundrak@redhat.com> 1.4.6-5
339  - Correct install location of java stuff (#433295)
340  * Wed Aug  8 2007 Joe Orton <jorton@redhat.com> 1.4.4-3
341  - fix build with new glibc open()-as-macro
342  - build all swig code in %%build, not %%install
343  * Fri May 21 2004 Joe Orton <jorton@redhat.com> 1.0.3-2
344  - build /usr/bin/* as PIEs
345
346* Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl2
347- rebuild with expat-2.0.1
348
349* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.3-0vl1
350- new upstream release
351- add Patch10 to build with neon.
352  1.3.2-0vl5 does not support neon..
353
354* Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl4
355- rebuild with new neon
356
357* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.2-0vl3
358- rebuilt with new toolchain and db4-4.3.x
359
360* Sat Mar 31 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.2-0vl2
361- modified %%files section for lib64 architecture
362
363* Tue Aug 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl1
364- new upstream release
365- rebuild with new openldap-2.3.24
366
367* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.1-0vl1
368- new upstream release
369- change Group to Develoment/Tools
370- build with apr-1.2.7/apr-util-1.2.7
371  - require apr/apr-util instead of apache2-apr
372- build with swig-1.3.29
373- split {perl,python,ruby} related files to subpackage.
374
375* Tue Oct 18 2005 IWAI, Masaharu <iwai@alib.jp> 1.2.3-0vl1
376- new upstream release
377- add noreplace option for config file
378
379* Sun Jan 30 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl3
380- fix Requires and BuildPreReq.
381
382* Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl2
383- new upstream release.
384- add swig-runtime to 'BuildPreReq:'.
385- fix %%files.
386
387* Sun Oct 17 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.0.6-0vl1.1
388- require neon version 0.24.7 for ra_dav
389- add BuildPreReq: openldap-devel
390- replace BuildPreReq: httpd to BuildPreReq: apache2
391- replace tools Requires: perl(:MODULE_COMPAT_version) to perl >= 5.8.0
392
393* Wed Jul 21 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.6-0vl1
394- new upstream release
395
396* Tue Jun 22 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.5-0vl1
397- new upstream release
398
399* Fri Jun  4 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.4-0vl1
400- new upstream release
401- clean up specfile.
402
403* Tue Nov 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.32.1-0vl1
404- new upstream release
405- build with apache2-2.0.47
406
407* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.20.0-0vl1
408- build Vine Linux
409
410* Sat Mar 01 2003 David Summers <david@summersoft.fay.ar.us> 0.18.1-5173
411- Enabled RA_DAV checking.
412  Now requires httpd package to build because of RA_DAV tests.
413
414* Sat Jan 18 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4433
415- Created tools package to hold the tools.
416
417* Thu Jan 16 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4405
418- Now requires httpd >= 2.0.44-0.1 (APACHE_2_0_BRANCH) which contains the new
419  version of APR/APR-UTILS as of 2003.01.15.
420- Added svnversion command.
421
422* Tue Dec 31 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4218
423- Create a svnadmin.static which is copied to svnadmin-version-release
424  when the package is erased, so users can still dump/load their repositories
425  even after they have upgraded the RPM package.
426
427* Sat Dec 14 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4128
428- SWIG now builds so we can use cvs2svn.
429
430* Fri Oct 04 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3280
431- Made cvs2svn conditional (at least until we can get it to build consistently
432  and work).
433
434* Sat Sep 21 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3205
435- Added SWIG dependencies to add cvs2svn capabilities.
436
437* Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2984
438- Now requires neon-0.22.0.
439
440* Thu Aug 15 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2978
441- Took out loading mod_dav_svn from subversion.spec file and put it in
442  subversion.conf file which goes into the apache conf directory.
443- Simplify what gets put into httpd.conf to only the include for the
444  subversion.conf file.
445  (Thanks to Scott Harrison <sharrison@users.sourceforge.net> for prompting
446  me to do this).
447
448* Thu Aug 08 2002 David Summers <david@summersoft.fay.ar.us> 0.14.0-2919
449- Updated to APR/APR-UTIL 2002-08-08.
450
451* Tue Jun 25 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2332
452- Updated to APACHE/APR/APR-UTIL 2002-06-25.
453- Previous version had a few problems because of missing apache error/ files.
454
455* Sun Jun 23 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2318
456- Updated to apache-2.0.40-0.3.
457- Updated to subversion-0.13.1-2318.
458
459* Tue Jun 18 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2277
460- Updated for RedHat 7.3 (autoconf253).
461- Added a bunch of pre-requisites I didn't know were needed because I built a
462  new machine that didn't have them already installed.
463- Fixed installation of man and info documentation pages.
464
465* Wed Mar 06 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1447
466- Back to apache-libapr* stuff, hopefully to stay.
467
468* Sun Feb 24 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1373
469- Fixed expat.patch to not have to make so many changes by writing a small
470  shell script that changes libexpat to -lexpat.
471
472* Fri Feb 22 2002 Blair Zajac <blair@orcaware.com> 0.9.0-1364
473- Updated to neon-0.19.2.
474
475* Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1250
476- Back to using apr and apr-util separately from apache.
477
478* Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1232
479- Updated to APR and APR-UTIL 2002.02.11.
480- Updated to apache-2.0.32-0.2. (Requires apache-libapr and apache-libapr-util).
481- Took out a (now non-existant) documentation file.
482- Moved SPEC file changelog to after all package definitions.
483 
484* Sun Feb 03 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1153
485- Updated to neon-0.18.5.
486- Broke up apache and apache-devel into apache-apr, apache-apr-devel,
487  apache-apr-utils, and apache-apr-utils-devel.
488- Updated apache to APR and APR-UTILS to 2002.02.03 version.
489
490* Sat Feb 02 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1147
491- Now builds without the separate APR package as it is built into and
492  "exported" from apache-2.0.31-0.3.
493
494* Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1132
495- Took out patches to install procedure now not required because of fixes
496  in rev 1130.
497
498* Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1129
499- Added requirement for APR 0.2002.01.19 rev 2 where the /usr/bin/apr-config
500  program was added.
501
502* Sun Oct 28 2001 David Summers <david@summersoft.fay.ar.us>
503- Release M5-r340: Added the subversion-server package.
504
505* Fri Oct 26 2001 David Summers <david@summersoft.fay.ar.us>
506- Release M5-r327: No longer need expat-lite. We can use the normal expat.
507
508* Thu Sep 27 2001 David Summers <david@summersoft.fay.ar.us>
509- Release M3-r117: Initial Version.
510
Note: See TracBrowser for help on using the repository browser.