source: projects/specs/branches/6/s/sox/sox-vl.spec @ 3528

Revision 3528, 6.5 KB checked in by owa, 13 years ago (diff)

rebuilt

Line 
1##
2## disable gsm for Vine Linux
3%define nogsm 1
4## disable libmad
5%define nomad 1
6
7Summary:     A general purpose sound file conversion tool.
8Summary(ja): 汎用サウンドファイル変換ツール
9Name: sox
10Version: 12.18.1
11Release: 2%{?_dist_release}
12License: LGPL
13Group: Applications/Multimedia
14Source:  http://prdownloads.sourceforge.net/sox/sox-%{version}.tar.gz
15URL: http://sox.sourceforge.net/
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17
18BuildRequires: alsa-lib-devel
19Build%{?nomad:Conflicts}%{!?nomad:Requires}: libmad-devel
20Build%{?nogsm:Conflicts}%{!?nogsm:Requires}: gsm-devel
21
22
23%description
24SoX (Sound eXchange) is a sound file format converter for Linux, UNIX
25and DOS PCs. The 'Swiss Army knife of sound tools,' SoX can convert
26between many different digitized sound formats and perform simple
27sound manipulation functions, including sound effects.
28
29%description -l ja
30SoX (Sound eXchange) は Linux, UNIX, DOS PC 用サウンドファイルフォーマット
31変換ツールです.SoX は「サウンドツール界のスイスアーミーナイフ」で,
32様々なデジタルサウンドフォーマットを相互に変換したり,
33簡単なサウンドエフェクト等の処理も行うことが出来ます.
34
35
36%package -n  sox-devel
37Summary: The SoX sound file format converter libraries.
38Summary(ja): SoX サウンドファイル変換ライブラリ
39Group: Development/Libraries
40
41%description -n sox-devel
42This package contains the library needed for compiling applications
43which will use the SoX sound file format converter.
44
45Install sox-devel if you want to develop applications which will use
46SoX.
47
48%description -n sox-devel -l ja
49このパッケージには SoX サウンドファイルフォーマット変換ツールを
50利用するアプリケーションをコンパイルするのに必要なライブラリが
51収められています.
52
53SoX を利用するプログラムを開発する場合は sox-devel パッケージを
54インストールして下さい.
55
56
57%prep
58%setup -q
59
60%build
61%configure  --includedir=%{_includedir}/sox \
62%{!?nogsm: --with-gsm}
63make
64
65
66%install
67rm -rf $RPM_BUILD_ROOT
68
69mkdir -p $RPM_BUILD_ROOT%{_bindir}
70mkdir -p $RPM_BUILD_ROOT%{_libdir}
71mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1/
72mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3/
73
74%makeinstall install-lib MANDIR=$RPM_BUILD_ROOT/%{_mandir}
75
76echo "#!/bin/sh" > $RPM_BUILD_ROOT%{_bindir}/soxplay
77echo "" >> $RPM_BUILD_ROOT%{_bindir}/soxplay
78echo '%{_bindir}/sox $1 -t .au - > /dev/audio' >> $RPM_BUILD_ROOT%{_bindir}/soxplay
79chmod 755 $RPM_BUILD_ROOT%{_bindir}/soxplay
80
81strip $RPM_BUILD_ROOT%{_bindir}/sox
82
83ln -snf play $RPM_BUILD_ROOT%{_bindir}/rec
84rm -f $RPM_BUILD_ROOT%{_mandir}/man1/rec.1
85ln -snf play.1 $RPM_BUILD_ROOT%{_mandir}/man1/rec.1
86ln -snf sox.1 $RPM_BUILD_ROOT%{_mandir}/man1/soxmix.1
87install -m 644 play.1 $RPM_BUILD_ROOT%{_mandir}/man1/
88
89mkdir -p $RPM_BUILD_ROOT%{_includedir}/sox
90install -m 644 src/*.h $RPM_BUILD_ROOT%{_includedir}/sox
91
92mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3
93install -m 644 libst.3 $RPM_BUILD_ROOT%{_mandir}/man3
94
95
96%clean
97rm -rf $RPM_BUILD_ROOT
98
99
100%files
101%defattr(-,root,root)
102%doc Changelog README TODO INSTALL
103%{_bindir}/*
104%{_mandir}/man1/*
105
106%files -n sox-devel
107%defattr(-,root,root)
108%{_includedir}/*
109%{_libdir}/libst.a
110%{_mandir}/man3/*
111
112
113%changelog
114* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 12.18.1-2
115- rebuilt with rpm-4.8.1-3
116
117* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 12.18.1-1vl5
118- applied new versioning policy, spec in utf-8
119
120* Fri Apr 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 12.18.1-0vl3
121- fix installing play.1 man page (<BTS:510>)
122- add BuildRequires: alsa-lib-devel (alsa stuffs are now in main repo)
123
124* Mon Sep 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 12.18.1-0vl2
125- add "%%define nomad 1" to disable libmad dependency
126
127* Sun Aug 25 2006 NAKAMURA Kenta <kenta@vinelinux.org> 12.18.1-0vl1
128- new upstream release
129- dropped sox-vorberr.patch and sox-CAN-2004-0557.patch
130
131* Wed Aug 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 12.17.3-12vl2
132- add patch for buffer overflow in wav code (CAN-2004-0557, #128158)
133- fixed %files section
134
135* Thu Jul  3 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 12.17.3-12vl1
136- based on 12.17.3-12 from Rawhide
137- rebuild with new toolchains
138- to use License tag instead of Copyright
139- fix License (from distributable to LGPL)
140
141* Fri Jan 12 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
142- 12.17.1-1vl1
143- based on 12.17.1-1 from Rawhide
144- use better macros (%%{_bindir}, %%{_libdir}, %%{_includedir})
145- added Japanese summary and description
146- disable gsm stuff for Vine Linux
147
148* Tue Jan  2 2001 Bill Nottingham <notting@redhat.com>
149- re-enable gsm stuff
150- update to 12.17.1
151
152* Fri Dec 01 2000 Bill Nottingham <notting@redhat.com>
153- rebuild because of broken fileutils
154
155* Mon Nov 13 2000 Bill Nottingham <notting@redhat.com>
156- update to 12.17
157- yank out gsm stuff
158
159* Tue Aug  7 2000 Bill Nottingham <notting@redhat.com>
160- fix playing of sounds on cards that don't support mono
161
162* Sat Aug  5 2000 Bill Nottingham <notting@redhat.com>
163- fix playing of sounds on cards that don't support 8-bit
164
165* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
166- automatic rebuild
167
168* Thu Feb 03 2000 Bill Nottingham <notting@redhat.com>
169- fix manpage link the Right Way(tm)
170
171* Thu Feb 03 2000 Bernhard Rosenkraenzer <bero@redhat.com>
172- Fix rec manpage link - now that man pages are compressed, it should point to
173  play.1.gz, not play.1
174
175* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
176- fix description
177
178* Tue Sep 28 1999 Bill Nottingham <notting@redhat.com>
179- Grrr. Arrrrgh. Fix link.
180
181* Fri Sep 24 1999 Bill Nottingham <notting@redhat.com>
182- add some more files to devel
183
184* Fri Sep 17 1999 Bill Nottingham <notting@redhat.com>
185- fix link
186
187* Fri Jul 30 1999 Bill Nottingham <notting@redhat.com>
188- update to 12.16
189
190* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
191- auto rebuild in the new build environment (release 4)
192
193* Wed Jan 20 1999 Bill Nottingham <notting@redhat.com>
194- allow spaces in filenames for play/rec
195
196* Wed Dec  9 1998 Bill Nottingham <notting@redhat.com>
197- fix docs
198
199* Mon Nov 23 1998 Bill Nottingham <notting@redhat.com>
200- update to 12.15
201
202* Sat Oct 10 1998 Michael Maher <mike@redhat.com>
203- fixed broken spec file
204
205* Mon Jul 13 1998 Michael Maher <mike@redhat.com>
206- updated source from Chris Bagwell.
207
208* Wed Jun 23 1998 Michael Maher <mike@redhat.com>
209- made patch to fix the '-e' option. BUG 580
210- added buildroot
211
212* Fri May 08 1998 Prospector System <bugs@redhat.com>
213- translations modified for de, fr, tr
214
215* Thu Nov 06 1997 Erik Troan <ewt@redhat.com>
216- built against glibc
Note: See TracBrowser for help on using the repository browser.