source: projects/specs/branches/6/s/skrooge/skrooge-vl.spec @ 3885

Revision 3885, 6.4 KB checked in by Takemikaduchi, 13 years ago (diff)

add BR

Line 
1Name:           skrooge
2Summary:        Personal finances manager
3Summary(ja):    個人向け財務管理ツール
4Version:        0.8.0
5Release:        2%{?_dist_release}
6
7Group:          Applications/Productivity
8License:        GPLv3+
9URL:            http://skrooge.org
10
11Source0:        http://skrooge.org/files/%{name}-%{version}.tar.bz2
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildRequires:  qca2-devel
15BuildRequires:  libofx-devel
16BuildRequires:  sqlite3-devel
17BuildRequires:  kdelibs4-devel
18BuildRequires:  soprano-devel
19BuildRequires:  gettext
20
21Requires:       %{name}-libs = %{version}-%{release}
22
23%description   
24%{name} is a personal finances manager,
25aiming at being simple and intuitive.
26It allows you to keep track of your expenses and incomes,
27categorize them, and build reports of them.
28
29%package libs
30Summary:        Skrooge libraries
31Summary(ja):    Skrooge ライブラリ
32Group:          System Environment/Libraries
33#Requires:       %{name} = %{version}-%{release}
34Requires:       kdelibs4 >= 4.4.0
35
36%description libs
37%{name} libraries.
38
39%package devel
40Summary:        Development files for %{name}
41Summary(ja):    %{name} の開発用ファイル
42Group:          Development/Libraries
43Requires:       %{name}-libs = %{version}-%{release}
44
45%description devel
46The %{name}-devel package contains libraries for
47developing applications that use %{name}.
48
49%prep
50%setup -q
51
52## to prevent spurious-executable-perm in -debuginfo
53chmod -x skgbasegui/skglineedit.h
54chmod -x skgbasegui/skglineedit.cpp
55chmod -x skgbasegui/skglineeditdesignerplugin.h
56chmod -x skgbasegui/skgtablewidgetdesignerplugin.h
57chmod -x skgbasegui/skglineeditdesignerplugin.cpp
58chmod -x skgbasegui/skgtablewidgetdesignerplugin.cpp
59
60%build
61mkdir -p %{_target_platform}
62pushd %{_target_platform}
63unset QTDIR || : ; . /etc/profile.d/qt4.sh
64## the -DCMAKE is needed to prevent unused-direct-shlib-dependency in -libs
65## cant be fixed upstream, see: https://bugs.kde.org/show_bug.cgi?id=209912
66%{cmake} \
67    -Wno-dev \
68    -DCMAKE_BUILD_TYPE=release \
69    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
70    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
71    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
72    -DCMAKE_SHARED_LINKER_FLAGS="-Wl,--as-needed" \
73    ..
74popd
75
76make %{?_smp_mflags} -C %{_target_platform}
77
78
79%install
80rm -rf %{buildroot}
81make install/fast -C %{_target_platform} DESTDIR=%{buildroot}
82%find_lang %{name} --with-kde
83
84# hack to support non-oxygen icon users (gnome), drop when/if skrooge
85# ever provides hicolor icons (too).
86mv %{buildroot}%{_datadir}/icons/oxygen %{buildroot}%{_datadir}/icons/hicolor
87
88
89%clean
90rm -rf %{buildroot}
91
92%check
93desktop-file-validate %{buildroot}%{_datadir}/applications/kde4/skrooge.desktop
94
95%post
96touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
97
98%postun
99if [ $1 -eq 0 ] ; then
100   touch --no-create %{_datadir}/icons/hicolor &>/dev/null
101   gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
102   update-desktop-database -q &> /dev/null
103   update-mime-database %{_datadir}/mime &> /dev/null
104fi
105
106%posttrans
107gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
108update-desktop-database -q &> /dev/null
109update-mime-database %{_datadir}/mime &> /dev/null
110
111%post libs -p /sbin/ldconfig
112
113%postun libs -p /sbin/ldconfig
114
115
116%files -f %{name}.lang
117%defattr(-,root,root,-)
118%doc AUTHORS CHANGELOG COPYING README TODO
119%{_bindir}/skrooge
120%{_datadir}/applications/kde4/skrooge.desktop
121%{_datadir}/config.kcfg/*.kcfg
122%{_datadir}/icons/hicolor/*/*/*
123%{_datadir}/kde4/apps/skrooge*/
124%{_datadir}/kde4/apps/skg*
125%{_datadir}/kde4/services/*.desktop
126%{_datadir}/kde4/servicetypes/skg-plugin.desktop
127%{_datadir}/mime/packages/x-skg.xml
128%{_datadir}/doc/HTML/*/skrooge/
129
130%files libs
131%defattr(-,root,root,-)
132%{_libdir}/kde4/plugins/designer/*.so.*
133%{_libdir}/kde4/*.so
134%{_libdir}/lib*.so.*
135
136%files devel
137%defattr(-,root,root,-)
138%{_libdir}/libskg*.so
139%{_libdir}/kde4/plugins/designer/libskg*.so
140
141%changelog
142* Sun May 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-2
143- add BuildRequires:  soprano-devel
144
145* Sun Jan 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.0-1
146- Initial build for Vine Linux
147
148* Mon May 17 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.7.1-1
149- skrooge 0.7.1 bugfix release
150
151* Mon Apr 26 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.7.0-1
152- Skrooge 0.7.0
153
154* Wed Feb 10 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.6.0-1
155- New upstream source 0.6.0
156
157* Thu Jan 28 2010 Rex Dieter <rdieter@fedoraproject.org> 0.5.5-2
158- use %%{_kde4_version}, don't rely on kde4-config --version parsing
159
160* Sun Dec 27 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.5-1
161- Update to new upstream release
162- Corrects a lot of bugs and problems. See the CHANGELOG for details.
163
164* Sun Nov 30 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.4-1
165- Update to new upstream version
166- Corrects a lot of bugs and problems. See the changelog for details.
167
168* Sun Nov 01 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.3-1
169- Updated to new upstream version
170- Readded a -DCMAKE workaround (please keep it for now)
171- Useing chmod -x to prevent spurious-executable-perm. Bug filed.
172
173* Wed Oct 14 2009 Rex Dieter <rdieter@fedoraproject.org> 0.5.2-2
174- (HTML) docs patch, use %%find_lang --with-kde
175- own %%{_kde4_appsdir}/skrooge*/ dirs
176- %%check: omit extraneous desktop-file-validate's
177
178* Thu Oct 08 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.2-1
179- Changed to final 0.5.2 version
180- Bugfixes, including a nasty bug where one thinks the data is gone
181- added HTML documentation
182- added localizations
183
184* Tue Sep 22 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.2-0.1.beta
185- Changed to new upstream Version 0.5.2_beta (lots of bugfixes)
186
187* Mon Sep 21 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.1-0.5.beta
188- Added -libs Requires libofx
189
190* Mon Sep 21 2009 Rex Dieter <rdieter@fedoraproject.org> 0.5.1-0.4.beta
191- misc cosmetics
192- mime scriptlets
193- move icons to hicolor
194- -libs: drop dup'd docs, add min kdelibs4 dep
195
196* Thu Sep 17 2009 Thomas Janssen <thomasj@fedoraproject.org>  0.5.1-0.3.beta
197- Spec file corrections and Version correction
198
199* Wed Sep 16 2009 Thomas Janssen <thomasj@fedoraproject.org>  0.5.1-beta2
200- cleaned up desktop files
201
202* Tue Sep 15 2009 Thomas Janssen <thomasj@fedoraproject.org>  0.5.1-beta1
203- changed version to 0.5.1 beta with fixed rpmlint output
204
205* Sun Sep 13 2009 Thomas Janssen <thomasj@fedoraproject.org>  0.5.0-2
206- Fixed the spec and rpmlintoutput debuginfo-without-source
207
208* Fri Sep 11 2009 Thomas Janssen <thomasj@fedoraproject.org>  0.5.0-1
209- Initial Release 0.5.0
Note: See TracBrowser for help on using the repository browser.