source: projects/specs/branches/6/s/sane/sane-vl.spec @ 1443

Revision 1443, 12.6 KB checked in by Takemikaduchi, 14 years ago (diff)

pidgin: rebuild only, others: new upstream release

Line 
1# To make src.rpm
2# rpm -bs --define 'src:1'
3# To make nosrc.rpm
4# rpm -bs --define 'nosrc:1'
5
6Summary:        SANE -- Easy local and networked scanner access
7Summary(ja):    スキャナ操作ツール
8Name:           sane
9Version:        1.0.21
10Release:        1%{?_dist_release}
11URL:            http://www.sane-project.org/
12Source:         ftp://ftp.sane-project.org/pub/sane/%{name}-backends-%{version}.tar.gz
13Source10:       sane-hierarchy.png
14Patch0:         sane-1.0.21-vine.patch
15Patch1:         sane-backends-1.0.21-i18n.patch
16%{?nosrc:NoSource: 0}
17License:        GPL (programs), relaxed LGPL (libraries), and public domain (docs)
18Group:          Applications/Multimedia
19#Icon:          sane-logo.png
20Provides:       libsane.so.1 sane-backends
21
22Requires:       libjpeg, libusb
23BuildRequires:  sed
24BuildRequires:  libjpeg-devel
25BuildRequires:  libusb-devel
26BuildRequires:  libgphoto2-devel
27#BuildPrereq:    latex2html
28#BuildPrereq: emacs/or/xemacs pLaTeX2e/or/tetex-latex pTeX/or/tetex
29Buildroot:      %{_tmppath}/%{name}-%{version}-root
30
31%{?nosrc:%define src 1}
32%{?src:%define _src 1}
33%{?!src:%define _src 0}
34
35
36%description
37SANE (Scanner Access Now Easy) is a sane and simple interface
38to both local and networked scanners and other image acquisition devices
39like digital still and video cameras.  SANE currently includes modules for
40accessing a range of scanners, including models from Agfa SnapScan, Apple,
41Artec, Canon, CoolScan, Epson, HP, Microtek, Mustek, Nikon, Siemens,
42Tamarack, UMAX, Connectix, QuickCams and other SANE devices via network.
43This package also include a client program 'scanimage','sane-find-scanner',
44'xerox' and etc.
45
46For the latest information on SANE, the SANE standard definition, and
47mailing list access, see http://www.mostang.com/sane/
48%if %{_src}
49You need xemacs or emacs to build this package.
50And you need latex2html to build this package if you like html documents.
51%endif
52
53%description -l ja
54SANE (Scanner Access Now Easy) はローカル/ネットワーク・スキャナや
55デジタルカメラ、デジタルビデオカメラなど画像取り込み装置の簡単なイン
56ターフェースです。SANE は Agfa SnapScan, Apple, Artec, Canon, CoolScan,
57Epson, HP, Microtek, Mustek, Nikon, Siemens, Tamarack, UMAX, Connectix,
58QuickCams その他、いろいろなスキャナを使うことができます。
59コマンドラインで動くscanimage, sane-find-scanner, xeroxなどもこのパッケージに
60含まれています。
61%if %{_src}
62このソースパッケージからビルドするにはxemacsまたはemacsが必要です。
63またHTMLドキュメントを含めるにはlatex2htmlが必要です。
64%endif
65
66%package devel
67Summary:  SANE (Scanner Access Now Easy) development toolkit
68Summary(ja):  SANE (Scanner Access Now Easy) 開発ツールキット
69Group:    Development/Libraries
70Requires: %{name} = %{version}
71Requires: libjpeg-devel
72Requires: libgphoto2-devel
73Requires: libexif-devel
74Requires: libusb-devel
75
76%description devel
77Static libraries and header files for writing SANE modules.
78
79%description devel -l ja
80SANE のモジュールを書くための、ヘッダファイルと静的ライブラリ
81です。
82
83%prep
84%setup -q -n %{name}-backends-%{version}
85%patch0 -p1 -b .vine
86%patch1 -p1 -b .i18n
87
88%build
89%configure --with-gnu-ld --enable-static
90# don't set smp flags!
91make
92
93# dll.conf: comment out all lines
94# epson.conf: add example for usb scanner
95( cd backend
96cat dll.conf | %__sed "s/^\([^#]\)/#\1/" > dll.conf~
97%__mv -f dll.conf~ dll.conf
98echo "#usb /dev/usb/scanner0" >> epson.conf
99)
100
101( cd doc
102  %__make html
103  %__mv sane html
104  cd html
105  %__cp -f %{SOURCE10} img1.png
106  %__cat node10.html | \
107    %__sed 's/WIDTH="5.." HEIGHT="2"/WIDTH="500" HEIGHT="246"/' \
108    > node10.html~
109  %__mv -f node10.html~ node10.html
110  %__rm -f WARNINGS
111)
112[ -d doc/html ] || %__mkdir doc/html
113
114%install
115%__rm -rf $RPM_BUILD_ROOT
116%{__make} install DESTDIR=${RPM_BUILD_ROOT}
117%__mv $RPM_BUILD_ROOT%{_sbindir}/saned $RPM_BUILD_ROOT%{_sbindir}/in.saned
118%__install -m755 tools/xerox $RPM_BUILD_ROOT%{_bindir}
119%__install -m755 tools/umax_pp $RPM_BUILD_ROOT%{_bindir}
120%__cp tools/README README.tools
121%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/%{name}
122%__cp doc/*.html doc/*.png doc/*.jpg $RPM_BUILD_ROOT%{_datadir}/%{name}
123##%__mv doc/*.html doc/*.png doc/*.jpg doc/html
124
125pushd $RPM_BUILD_ROOT%{_bindir}
126%__ln_s sane-find-scanner find-scanner
127popd
128
129# clear uninstall files
130%__rm -rf $RPM_BUILD_ROOT%{_prefix}/doc
131%__rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.la
132%__rm -rf $RPM_BUILD_ROOT%{_libdir}/sane/lib*.la
133
134
135%post
136%__grep -q %{_libdir}/sane %{_sysconfdir}/ld.so.conf || \
137     echo %{_libdir}/sane >> %{_sysconfdir}/ld.so.conf
138/sbin/ldconfig
139
140[ -d /dev/usb ] || %__mkdir /dev/usb
141[ -c /dev/usb/scanner0 ] || mknod /dev/usb/scanner0 c 180 48 -m 777
142
143# network settings
144SERVICES=%{_sysconfdir}/services
145if [ -x "%__grep" -a -f "$SERVICES" ] ; then
146%__grep -q "^sane" $SERVICES || \
147echo "sane          6566/tcp       # network sccaner deamon" >> $SERVICES
148fi
149INETDCONF=%{_sysconfdir}/inetd.conf
150if [ -x "%__grep" -a -f "$INETDCONF" ] ; then
151%__grep -q "^#*sane" $INETDCONF || \
152echo "#sane    stream  tcp     nowait  root    %{_sbindir}/in.saned   %{_sbindir}/in.saned" >>   $INETDCONF
153fi
154#kill -HUP `/sbin/pidof inetd`
155
156%postun
157# process for uninstallation, not for upgrading.
158if [ $1 = 0 ]; then
159    %__mv %{_sysconfdir}/ld.so.conf %{_sysconfdir}/ld.so.conf.orig
160    %__grep -v "%{_libdir}/sane" %{_sysconfdir}/ld.so.conf.orig > %{_sysconfdir}/ld.so.conf
161    %__rm %{_sysconfdir}/ld.so.conf.orig
162fi
163/sbin/ldconfig
164
165
166%clean
167%__rm -rf $RPM_BUILD_ROOT
168
169%files
170%defattr(-,root,root)
171%doc README* AUTHORS ChangeLog* COPYING LICENSE PROBLEMS PROJECTS NEWS
172%doc doc/figs doc/icons doc/html doc/canon doc/mustek doc/mustek_usb doc/umax
173%doc doc/*.{txt,tex,sty}
174%doc tools
175%dir %{_sysconfdir}/sane.d
176%config %{_sysconfdir}/sane.d/*
177%{_sbindir}/*
178%{_bindir}/find-scanner
179%{_bindir}/gamma4scanimage
180%{_bindir}/sane-find-scanner
181%{_bindir}/scanimage
182%{_bindir}/umax_pp
183%{_bindir}/xerox
184%{_libdir}/lib*.so.*
185%{_libdir}/lib*.so
186%{_libdir}/sane/lib*.so.*
187%{_libdir}/sane/lib*.so
188%dir %{_libdir}/sane
189%{_datadir}/sane
190%{_mandir}/man1/*.1*
191%{_mandir}/man5/*.5*
192%{_mandir}/man7/*.7*
193%{_mandir}/man8/*.8*
194%{_datadir}/locale
195
196%files devel
197%defattr(-,root,root)
198%{_bindir}/sane-config
199%{_includedir}/sane
200%{_libdir}/lib*.a
201#{_libdir}/lib*.la
202%{_libdir}/sane/lib*.a
203#{_libdir}/sane/lib*.la
204
205%changelog
206* Sun Jul 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.21-1
207- new upstream release
208- change Patch (from sane-1.0.15-vine.patch to sane-1.0.21-vine.patch)
209- move sane-config to devel package
210- add Requires: libjpeg-devel, libgphoto2-devel, libexif-devel, libusb-devel (devel package)
211- add Patch1(sane-backends-1.0.21-i18n.patch)
212
213* Sun Oct 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.18-3
214- added BuildRequires: libgphoto2-devel instead of ghoto2-devel
215
216* Sat Oct 11 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.18-2
217- spec in utf-8
218
219* Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.18-1
220- applied new versioning policy
221- removed lib*.la files from devel package
222
223* Mon Dec 24 2007 Shu KONNO <owa@bg.wakwak.com> 1.0.18-0vl1
224- new upstream release
225
226* Sun Jan 09 2005 Satoshi MACHINO <machino@vinelinux.org> 1.0.15-0vl1
227- new upstream version(sane-1.0.15)
228- fixed spec file
229        -- cleaned up patches
230        -- added Requires:       libjpeg, libusb
231        -- added BuildRequires:  glibc, libjpeg-devel, libusb-devel
232
233* Fri Oct 25 2002 Tomoya TAKA <taka@vinelinux.org> 1.0.8-0vl1
234- new upstream release
235- update sane-1.0.8-vine.patch
236- add --enable-static option to %%configure
237
238* Mon May 13 2002 Masaki Shinomiya <shino@pos.to>
239- 1.0.7-0vl2: sparc.patch, ppc.patch both from Mandrake(4mdk)
240- informed by Iohara [VinePlus:01130]
241
242* Wed Apr 4 2002 Masaki Shinomiya <shino@pos.to>
243- 1.0.7-0vl1 for Vine Linux-2.x
244- 1.0.7-0.1
245- set %_sysconfdir to /etc for RedHat6.x/Vine2.x
246
247* Wed Mar 6 2002 Masaki SHINOMIYA <shino@pos.to>
248- 1.0.7-0
249- new source
250- avoid listing %{_libdir}/sane from sane-devel
251- add LEVEL2 in doc
252
253* Fri Feb 1 2002 Masaki SHINOMIYA <shino@pos.to>
254- 1.0.6-0.3
255- allow to build without latex2html
256- prereq ldconfig, buildprereq sed, provide sane-backends
257
258* Tue Dec 23 2001 Masaki SHINOMIYA <shino@pos.to>
259- 1.0.6-0.2
260- dll.conf, epson.conf, network settings
261
262* Tue Dec 18 2001 Masaki SHINOMIYA <shino@pos.to>
263- 1.0.6-0.1
264- new source
265
266* Mon Dec 17 2001 Masaki SHINOMIYA <shino@pos.to>
267- 1.0.5-1.3
268- allow to use emacs or xemacs in building
269- nosrc
270
271#* Wed Oct 3 2001 Masaki SHINOMIYA <shino@pos.to>
272#- 1.0.5-1.2
273#- surpress swapping R<-->G colors on EPSON GT-8700/Perfection1640
274#- ( information from [vine-users:037559] tyu <tyu@mbd.nifty.com> )
275#- omit doc/*.tex etc.
276
277* Tue Sep 18 2001 Masaki SHINOMIYA <shino@pos.to>
278- 1.0.5-1.1
279- use emacs instead of xemacs in building
280
281* Sat Jul 7 2001 Masaki SHINOMIYA <shino@pos.to>
282- 1.0.5-1
283
284* Thu Jun 7 2001 Masaki SHINOMIYA <shino@pos.to>
285- 1.0.4 + epson backend ver.20010519
286- sane-clients is removed from this package
287- scanimage, find-scanner and xerox are left in this package
288
289* Wed May 17 2001 Masaki SHINOMIYA <shino@pos.to>
290- 1.0.4 + epson backend ver.20010331
291- 'scanimage' is included in the binary'sane-1.0.4-1.i386.rpm'package.
292- refined script for gimp plug-in setup
293- html documents shal be installed in the directory '/usr/share/sane'
294- automatically make device the file /dev/usb/scanner0
295
296* Wed Nov 15 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
297- 1.0.3-0vl8
298- included missing "sane-config" script for sane
299
300* Tue Oct 17 2000 Jun Nishii <jun@vinelinux.org>
301- 1.0.3-0vl7
302- merge xscanimage patch
303
304* Mon Oct 16 2000 Jun Nishii <jun@vinelinux.org>
305- 1.0.3-0vl6
306- build with gimp-1.1.27
307
308* Sun Oct  1 2000 Jun Nishii <jun@vinelinux.org>
309- 1.0.3-0vl5
310- fixed group
311
312* Sat Sep 30 2000 Jun Nishii <jun@vinelinux.org>
313- 1.0.3-0vl4
314- added %defattr in clients
315
316* Tue Sep 26 2000 Jun Nishii <jun@vinelinux.org>
317- 1.0.3-0vl3
318- build with gimp-1.1.26
319
320* Mon Sep 25 2000 Jun Nishii <jun@vinelinux.org>
321- 1.0.3-0vl2
322- build with gimp-1.1.25
323
324* Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
325- 1.0.3-0vl1
326
327* Thu Jun  8 2000 Jun Nishii <jun@vinelinux.org>
328- 1.0.2-0vl1
329
330* Mon Jan 17 2000 Jun Nishii <jun@vinelinux.org>
331- build for Vine Linux 2.0
332- added find-scanner, xerox
333
334* Fri Apr 23 1999 Hugo van der Kooij <hvdkooij@caiw.nl>
335- Fixed packaging a bit.
336
337* Wed Apr 21 1999 Hugo van der Kooij <hvdkooij@caiw.nl>
338- Updated package to 1.01
339
340* Fri Apr 09 1999 Hugo van der Kooij <hvdkooij@caiw.nl>
341- Split off the clients
342- Fixed a Alpha system anomaly by removing the specific backend.
343
344* Mon Nov 23 1998 Jonathan Miller <jlm@mvhi.com>
345 [1.00-1]
346- upgraded to 1.00 (and made description less space-consuming)
347- included the post 1.00 fixed "configure" script available 22 Nov 1998.
348
349* Sat Aug 08 1998 Arne Coucheron <arneco@online.no>
350  [0.74-3]
351- added /etc/sane.d to %dir in file list
352
353* Sat Aug 01 1998 Arne Coucheron <arneco@online.no>
354  [0.74-2]
355- devel Group: reverted back to Development/Libraries
356- some changes to the %defattr and %attr usage in file list
357
358* Tue Jul 28 1998 Binaire <binaire@binaire.ml.org>
359  [0.74-1]
360
361* Fri May 22 1998 Arne Coucheron <arneco@online.no>
362  [0.73-3]
363- added use of %%{name} and %%{version} macros
364- added a %postun for running ldconfig after uninstall
365- using BuildRoot properly now
366- using %defattr and %attr macros in filelist, allows non-root build
367  this means that RPM 2.5 is required to build this spec file now!
368- devel Group: changed to X11/Libraries
369- added using RPM_OPT_FLAGS during make
370- added striping of programs and libraries
371- added Requires: gtk+ >= 0.99.13 to main package
372- added Requires: %%{name} = %%{version} to devel package
373- added a %clean section for removing the buildroot dir
374- simplified the filelist and added %config for sane-style.rc
375- moved lib*.so to %files devel and dropped the *.la files
376- added -q parameter to %setup
377- removed some older changelog entries
378- removed the "fix ldconfig brokenness..." stuff
379- removed the Packager: line; use /etc/rpmrc if you want your name in
380- if GIMP is installed, make symlink from xscanimage to plug-ins dir
381- install the find-scanner program from the tools dir
382
383* Mon May 18 1998 Hugo van der Kooij <hvdkooij@caiw.nl>
384- Version 0.73 was created: May 13 1998
385- gimp (original was build against 0.99.29)
386- gtk+ (original was build against 1.0.1)
387- dlh (original was build against 0.7d)
388- X11 development tree including xpm libraries.
389
390* Wed Apr 22 1998 Hugo van der Kooij <hvdkooij@caiw.nl>
391- Binaries are now BuildRoot proof.
392
393* Wed Apr 22 1998 Hugo van der Kooij <hvdkooij@caiw.nl>
394- Binaries are not BuildRoot proof. release 3 is done without BuildRoot!
395
396* Tue Apr 21 1998 Hugo van der Kooij <hvdkooij@caiw.nl>
397- Temp. fix for some documentations problems with BuildRoot.
398
399* Sat Apr 11 1998 Hugo van der Kooij <hvdkooij@caiw.nl>
400- Formal 0.72 now made as RPM! (Build against GTK+ 0.99.10 and GIMP 0.99.24)
401- Original package was released: Tue Apr 7 1998
Note: See TracBrowser for help on using the repository browser.