source: projects/specs/trunk/s/sane/sane-vl.spec @ 521

Revision 521, 11.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# To make src.rpm
2# rpm -bs --define 'src:1'
3# To make nosrc.rpm
4# rpm -bs --define 'nosrc:1'
5
6Summary:        SANE -- Easy local and networked scanner access
7Summary(ja):    スキャナ操作ツール
8Name:           sane
9Version:        1.0.18
10Release:        3%{?_dist_release}
11URL:            http://www.sane-project.org/
12Source:         ftp://ftp.sane-project.org/pub/sane/%{name}-backends-%{version}.tar.gz
13Source10:       sane-hierarchy.png
14Patch:          sane-1.0.15-vine.patch
15%{?nosrc:NoSource: 0}
16License:        GPL (programs), relaxed LGPL (libraries), and public domain (docs)
17Group:          Applications/Multimedia
18#Icon:          sane-logo.png
19Provides:       libsane.so.1 sane-backends
20
21Requires:       libjpeg, libusb
22BuildRequires:  sed
23BuildRequires:  libjpeg-devel
24BuildRequires:  libusb-devel
25BuildRequires:  libgphoto2-devel
26#BuildPrereq:    latex2html
27#BuildPrereq: emacs/or/xemacs pLaTeX2e/or/tetex-latex pTeX/or/tetex
28Buildroot:      %{_tmppath}/%{name}-%{version}-root
29
30%{?nosrc:%define src 1}
31%{?src:%define _src 1}
32%{?!src:%define _src 0}
33
34
35%description
36SANE (Scanner Access Now Easy) is a sane and simple interface
37to both local and networked scanners and other image acquisition devices
38like digital still and video cameras.  SANE currently includes modules for
39accessing a range of scanners, including models from Agfa SnapScan, Apple,
40Artec, Canon, CoolScan, Epson, HP, Microtek, Mustek, Nikon, Siemens,
41Tamarack, UMAX, Connectix, QuickCams and other SANE devices via network.
42This package also include a client program 'scanimage','sane-find-scanner',
43'xerox' and etc.
44
45For the latest information on SANE, the SANE standard definition, and
46mailing list access, see http://www.mostang.com/sane/
47%if %{_src}
48You need xemacs or emacs to build this package.
49And you need latex2html to build this package if you like html documents.
50%endif
51
52%description -l ja
53SANE (Scanner Access Now Easy) はローカル/ネットワーク・スキャナや
54デジタルカメラ、デジタルビデオカメラなど画像取り込み装置の簡単なイン
55ターフェースです。SANE は Agfa SnapScan, Apple, Artec, Canon, CoolScan,
56Epson, HP, Microtek, Mustek, Nikon, Siemens, Tamarack, UMAX, Connectix,
57QuickCams その他、いろいろなスキャナを使うことができます。
58コマンドラインで動くscanimage, sane-find-scanner, xeroxなどもこのパッケージに
59含まれています。
60%if %{_src}
61このソースパッケージからビルドするにはxemacsまたはemacsが必要です。
62またHTMLドキュメントを含めるにはlatex2htmlが必要です。
63%endif
64
65%package devel
66Summary:  SANE (Scanner Access Now Easy) development toolkit
67Summary(ja):  SANE (Scanner Access Now Easy) 開発ツールキット
68Group:    Development/Libraries
69Requires: %{name} = %{version}
70
71%description devel
72Static libraries and header files for writing SANE modules.
73
74%description devel -l ja
75SANE のモジュールを書くための、ヘッダファイルと静的ライブラリ
76です。
77
78%prep
79%setup -q -n %{name}-backends-%{version}
80%patch -p1
81
82%build
83%configure --with-gnu-ld --enable-static
84# don't set smp flags!
85make
86
87# dll.conf: comment out all lines
88# epson.conf: add example for usb scanner
89( cd backend
90cat dll.conf | %__sed "s/^\([^#]\)/#\1/" > dll.conf~
91%__mv -f dll.conf~ dll.conf
92echo "#usb /dev/usb/scanner0" >> epson.conf
93)
94
95( cd doc
96  %__make html
97  %__mv sane html
98  cd html
99  %__cp -f %{SOURCE10} img1.png
100  %__cat node10.html | \
101    %__sed 's/WIDTH="5.." HEIGHT="2"/WIDTH="500" HEIGHT="246"/' \
102    > node10.html~
103  %__mv -f node10.html~ node10.html
104  %__rm -f WARNINGS
105)
106[ -d doc/html ] || %__mkdir doc/html
107
108%install
109%__rm -rf $RPM_BUILD_ROOT
110%makeinstall
111%__mv $RPM_BUILD_ROOT%{_sbindir}/saned $RPM_BUILD_ROOT%{_sbindir}/in.saned
112%__install -m755 tools/xerox $RPM_BUILD_ROOT%{_bindir}
113%__install -m755 tools/umax_pp $RPM_BUILD_ROOT%{_bindir}
114%__cp tools/README README.tools
115%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/%{name}
116%__cp doc/*.html doc/*.png doc/*.jpg $RPM_BUILD_ROOT%{_datadir}/%{name}
117##%__mv doc/*.html doc/*.png doc/*.jpg doc/html
118
119pushd $RPM_BUILD_ROOT%{_bindir}
120%__ln_s sane-find-scanner find-scanner
121popd
122
123# clear uninstall files
124%__rm -rf $RPM_BUILD_ROOT%{_prefix}/doc
125%__rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.la
126%__rm -rf $RPM_BUILD_ROOT%{_libdir}/sane/lib*.la
127
128%post
129%__grep -q %{_libdir}/sane %{_sysconfdir}/ld.so.conf || \
130     echo %{_libdir}/sane >> %{_sysconfdir}/ld.so.conf
131/sbin/ldconfig
132
133[ -d /dev/usb ] || %__mkdir /dev/usb
134[ -c /dev/usb/scanner0 ] || mknod /dev/usb/scanner0 c 180 48 -m 777
135
136# network settings
137SERVICES=%{_sysconfdir}/services
138if [ -x "%__grep" -a -f "$SERVICES" ] ; then
139%__grep -q "^sane" $SERVICES || \
140echo "sane          6566/tcp       # network sccaner deamon" >> $SERVICES
141fi
142INETDCONF=%{_sysconfdir}/inetd.conf
143if [ -x "%__grep" -a -f "$INETDCONF" ] ; then
144%__grep -q "^#*sane" $INETDCONF || \
145echo "#sane    stream  tcp     nowait  root    %{_sbindir}/in.saned   %{_sbindir}/in.saned" >>   $INETDCONF
146fi
147#kill -HUP `/sbin/pidof inetd`
148
149%postun
150# process for uninstallation, not for upgrading.
151if [ $1 = 0 ]; then
152    %__mv %{_sysconfdir}/ld.so.conf %{_sysconfdir}/ld.so.conf.orig
153    %__grep -v "%{_libdir}/sane" %{_sysconfdir}/ld.so.conf.orig > %{_sysconfdir}/ld.so.conf
154    %__rm %{_sysconfdir}/ld.so.conf.orig
155fi
156/sbin/ldconfig
157
158
159%clean
160%__rm -rf $RPM_BUILD_ROOT
161
162%files
163%defattr(-,root,root)
164%doc README* AUTHORS ChangeLog* COPYING LICENSE PROBLEMS PROJECTS NEWS
165%doc doc/figs doc/icons doc/html doc/canon doc/mustek doc/mustek_usb doc/umax
166%doc doc/*.{txt,ps,tex,dvi,sty}
167%doc tools
168%dir %{_sysconfdir}/sane.d
169%config %{_sysconfdir}/sane.d/*
170%{_sbindir}/*
171%{_bindir}/*
172%{_libdir}/lib*.so.*
173%{_libdir}/lib*.so
174%{_libdir}/sane/lib*.so.*
175%{_libdir}/sane/lib*.so
176%dir %{_libdir}/sane
177%{_datadir}/sane
178%{_mandir}/man1/*.1*
179%{_mandir}/man5/*.5*
180%{_mandir}/man7/*.7*
181%{_mandir}/man8/*.8*
182%{_datadir}/locale
183
184%files devel
185%defattr(-,root,root)
186%{_includedir}/sane
187%{_libdir}/lib*.a
188#{_libdir}/lib*.la
189%{_libdir}/sane/lib*.a
190#{_libdir}/sane/lib*.la
191
192%changelog
193* Sun Oct 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.18-3
194- added BuildRequires: libgphoto2-devel instead of ghoto2-devel
195
196* Sat Oct 11 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.18-2
197- spec in utf-8
198
199* Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.18-1
200- applied new versioning policy
201- removed lib*.la files from devel package
202
203* Mon Dec 24 2007 Shu KONNO <owa@bg.wakwak.com> 1.0.18-0vl1
204- new upstream release
205
206* Sun Jan 09 2005 Satoshi MACHINO <machino@vinelinux.org> 1.0.15-0vl1
207- new upstream version(sane-1.0.15)
208- fixed spec file
209        -- cleaned up patches
210        -- added Requires:       libjpeg, libusb
211        -- added BuildRequires:  glibc, libjpeg-devel, libusb-devel
212
213* Fri Oct 25 2002 Tomoya TAKA <taka@vinelinux.org> 1.0.8-0vl1
214- new upstream release
215- update sane-1.0.8-vine.patch
216- add --enable-static option to %%configure
217
218* Mon May 13 2002 Masaki Shinomiya <shino@pos.to>
219- 1.0.7-0vl2: sparc.patch, ppc.patch both from Mandrake(4mdk)
220- informed by Iohara [VinePlus:01130]
221
222* Wed Apr 4 2002 Masaki Shinomiya <shino@pos.to>
223- 1.0.7-0vl1 for Vine Linux-2.x
224- 1.0.7-0.1
225- set %_sysconfdir to /etc for RedHat6.x/Vine2.x
226
227* Wed Mar 6 2002 Masaki SHINOMIYA <shino@pos.to>
228- 1.0.7-0
229- new source
230- avoid listing %{_libdir}/sane from sane-devel
231- add LEVEL2 in doc
232
233* Fri Feb 1 2002 Masaki SHINOMIYA <shino@pos.to>
234- 1.0.6-0.3
235- allow to build without latex2html
236- prereq ldconfig, buildprereq sed, provide sane-backends
237
238* Tue Dec 23 2001 Masaki SHINOMIYA <shino@pos.to>
239- 1.0.6-0.2
240- dll.conf, epson.conf, network settings
241
242* Tue Dec 18 2001 Masaki SHINOMIYA <shino@pos.to>
243- 1.0.6-0.1
244- new source
245
246* Mon Dec 17 2001 Masaki SHINOMIYA <shino@pos.to>
247- 1.0.5-1.3
248- allow to use emacs or xemacs in building
249- nosrc
250
251#* Wed Oct 3 2001 Masaki SHINOMIYA <shino@pos.to>
252#- 1.0.5-1.2
253#- surpress swapping R<-->G colors on EPSON GT-8700/Perfection1640
254#- ( information from [vine-users:037559] tyu <tyu@mbd.nifty.com> )
255#- omit doc/*.tex etc.
256
257* Tue Sep 18 2001 Masaki SHINOMIYA <shino@pos.to>
258- 1.0.5-1.1
259- use emacs instead of xemacs in building
260
261* Sat Jul 7 2001 Masaki SHINOMIYA <shino@pos.to>
262- 1.0.5-1
263
264* Thu Jun 7 2001 Masaki SHINOMIYA <shino@pos.to>
265- 1.0.4 + epson backend ver.20010519
266- sane-clients is removed from this package
267- scanimage, find-scanner and xerox are left in this package
268
269* Wed May 17 2001 Masaki SHINOMIYA <shino@pos.to>
270- 1.0.4 + epson backend ver.20010331
271- 'scanimage' is included in the binary'sane-1.0.4-1.i386.rpm'package.
272- refined script for gimp plug-in setup
273- html documents shal be installed in the directory '/usr/share/sane'
274- automatically make device the file /dev/usb/scanner0
275
276* Wed Nov 15 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
277- 1.0.3-0vl8
278- included missing "sane-config" script for sane
279
280* Tue Oct 17 2000 Jun Nishii <jun@vinelinux.org>
281- 1.0.3-0vl7
282- merge xscanimage patch
283
284* Mon Oct 16 2000 Jun Nishii <jun@vinelinux.org>
285- 1.0.3-0vl6
286- build with gimp-1.1.27
287
288* Sun Oct  1 2000 Jun Nishii <jun@vinelinux.org>
289- 1.0.3-0vl5
290- fixed group
291
292* Sat Sep 30 2000 Jun Nishii <jun@vinelinux.org>
293- 1.0.3-0vl4
294- added %defattr in clients
295
296* Tue Sep 26 2000 Jun Nishii <jun@vinelinux.org>
297- 1.0.3-0vl3
298- build with gimp-1.1.26
299
300* Mon Sep 25 2000 Jun Nishii <jun@vinelinux.org>
301- 1.0.3-0vl2
302- build with gimp-1.1.25
303
304* Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
305- 1.0.3-0vl1
306
307* Thu Jun  8 2000 Jun Nishii <jun@vinelinux.org>
308- 1.0.2-0vl1
309
310* Mon Jan 17 2000 Jun Nishii <jun@vinelinux.org>
311- build for Vine Linux 2.0
312- added find-scanner, xerox
313
314* Fri Apr 23 1999 Hugo van der Kooij <hvdkooij@caiw.nl>
315- Fixed packaging a bit.
316
317* Wed Apr 21 1999 Hugo van der Kooij <hvdkooij@caiw.nl>
318- Updated package to 1.01
319
320* Fri Apr 09 1999 Hugo van der Kooij <hvdkooij@caiw.nl>
321- Split off the clients
322- Fixed a Alpha system anomaly by removing the specific backend.
323
324* Mon Nov 23 1998 Jonathan Miller <jlm@mvhi.com>
325 [1.00-1]
326- upgraded to 1.00 (and made description less space-consuming)
327- included the post 1.00 fixed "configure" script available 22 Nov 1998.
328
329* Sat Aug 08 1998 Arne Coucheron <arneco@online.no>
330  [0.74-3]
331- added /etc/sane.d to %dir in file list
332
333* Sat Aug 01 1998 Arne Coucheron <arneco@online.no>
334  [0.74-2]
335- devel Group: reverted back to Development/Libraries
336- some changes to the %defattr and %attr usage in file list
337
338* Tue Jul 28 1998 Binaire <binaire@binaire.ml.org>
339  [0.74-1]
340
341* Fri May 22 1998 Arne Coucheron <arneco@online.no>
342  [0.73-3]
343- added use of %%{name} and %%{version} macros
344- added a %postun for running ldconfig after uninstall
345- using BuildRoot properly now
346- using %defattr and %attr macros in filelist, allows non-root build
347  this means that RPM 2.5 is required to build this spec file now!
348- devel Group: changed to X11/Libraries
349- added using RPM_OPT_FLAGS during make
350- added striping of programs and libraries
351- added Requires: gtk+ >= 0.99.13 to main package
352- added Requires: %%{name} = %%{version} to devel package
353- added a %clean section for removing the buildroot dir
354- simplified the filelist and added %config for sane-style.rc
355- moved lib*.so to %files devel and dropped the *.la files
356- added -q parameter to %setup
357- removed some older changelog entries
358- removed the "fix ldconfig brokenness..." stuff
359- removed the Packager: line; use /etc/rpmrc if you want your name in
360- if GIMP is installed, make symlink from xscanimage to plug-ins dir
361- install the find-scanner program from the tools dir
362
363* Mon May 18 1998 Hugo van der Kooij <hvdkooij@caiw.nl>
364- Version 0.73 was created: May 13 1998
365- gimp (original was build against 0.99.29)
366- gtk+ (original was build against 1.0.1)
367- dlh (original was build against 0.7d)
368- X11 development tree including xpm libraries.
369
370* Wed Apr 22 1998 Hugo van der Kooij <hvdkooij@caiw.nl>
371- Binaries are now BuildRoot proof.
372
373* Wed Apr 22 1998 Hugo van der Kooij <hvdkooij@caiw.nl>
374- Binaries are not BuildRoot proof. release 3 is done without BuildRoot!
375
376* Tue Apr 21 1998 Hugo van der Kooij <hvdkooij@caiw.nl>
377- Temp. fix for some documentations problems with BuildRoot.
378
379* Sat Apr 11 1998 Hugo van der Kooij <hvdkooij@caiw.nl>
380- Formal 0.72 now made as RPM! (Build against GTK+ 0.99.10 and GIMP 0.99.24)
381- Original package was released: Tue Apr 7 1998
Note: See TracBrowser for help on using the repository browser.