source: projects/specs/branches/6/r/rusers/rusers-vl.spec @ 3756

Revision 3756, 9.0 KB checked in by inagaki, 13 years ago (diff)

update: rusers, rwho

Line 
1Summary:     Displays the users logged into machines on the local network.
2Summary(ja): ローカルネットワーク上のマシンにログインしたユーザを表示する
3Name: rusers
4Version: 0.17
5Release: 48%{?_dist_release}
6
7License: BSD
8Group: Applications/Internet
9
10Source: ftp://ftp.uk.linux.org/pub/linux/Networking/netkit-devel/netkit-rusers-%{version}.tar.gz
11Source1: rusersd.init
12Source2: rstatd.tar.gz
13Source3: rstatd.init
14Patch0: rstatd-jbj.patch
15Patch1: netkit-rusers-0.15-numusers.patch
16Patch2: netkit-rusers-0.17-2.4.patch
17Patch3: netkit-rusers-0.17-includes.patch
18Patch4: netkit-rusers-0.17-truncate.patch
19Patch5: netkit-rusers-0.17-stats.patch
20Patch6: netkit-rusers-0.17-rstatd-no-static-buffer.patch
21Patch7: netkit-rusers-0.17-strip.patch
22Patch8: netkit-rusers-0.17-rup.patch
23Patch9: netkit-rusers-0.17-rup-timeout.patch
24Patch10: netkit-rusers-0.17-procps.patch
25Patch11: netkit-rusers-0.17-rup-stack.patch
26Patch12: netkit-rusers-0.17-bigendian.patch
27Patch13: netkit-rusers-0.17-return.patch
28Patch14: netkit-rusers-0.17-procdiskstats.patch
29Patch15: netkit-rusers-0.17-rusersd-droppriv.patch
30# Oracle explicitly gave permission for this relicensing on August 18, 2010.
31Patch16: netkit-rusers-0.17-new-rpc-license.patch
32
33Buildroot: %{_tmppath}/%{name}-%{version}-root
34BuildRequires: procps
35
36%description
37The rusers program allows users to find out who is logged into various
38machines on the local network.  The rusers command produces output
39similar to who, but for the specified list of hosts or for all
40machines on the local network.
41
42Install rusers if you need to keep track of who is logged into your
43local network.
44
45%description -l ja
46rusers プログラムを使うとローカルネットワーク上の様々なマシンに
47誰がログインしているかを調べることが出来ます.rusers コマンドは
48who に似た出力をしますが,引数で指定したホストあるいはローカル
49ネットワーク上の全ホストの情報を出力するところが異なります.
50
51ローカルネットワークで誰がログインしているかを調べるには
52rusers パッケージをインストールして下さい.
53
54
55%package server
56Summary: Server for the rusers protocol.
57Summary(ja): rusers プロトコルのサーバ
58Group: System Environment/Daemons
59#Prereq: /sbin/chkconfig /etc/init.d
60Requires(pre): /sbin/chkconfig
61Requires: portmap
62
63
64%description server
65The rusers program allows users to find out who is logged into various
66machines on the local network.  The rusers command produces output
67similar to who, but for the specified list of hosts or for all
68machines on the local network. The rusers-server package contains the
69server for responding to rusers requests.
70
71Install rusers-server if you want remote users to be able to see
72who is logged into your machine.
73
74%description server -l ja
75rusers プログラムを使うとローカルネットワーク上の様々なマシンに
76誰がログインしているかを調べることが出来ます.rusers コマンドは
77who に似た出力をしますが,引数で指定したホストあるいはローカル
78ネットワーク上の全ホストの情報を出力するところが異なります.
79この rusers-server パッケージには rusers のリクエストに答える
80サーバが含まれています.
81
82遠隔ユーザがあなたのマシンに誰がログインしているかを調べることが
83出来る様にするには,rusers-server パッケージをインストールして下さい.
84
85
86%prep
87%setup -q -n netkit-rusers-%{version} -a 2
88%patch0 -p1 -b .jbj
89%patch1 -p1 -b .numusers
90%patch2 -p1 -b .2.4
91%patch3 -p1 -b .includes
92%patch4 -p1 -b .truncate
93%patch5 -p1 -b .stats
94%patch6 -p1 -b .rstatd-no-static-buffer
95%patch7 -p1 -b .strip
96%patch8 -p1 -b .rup
97%patch9 -p1 -b .rup-timeout
98%patch10 -p1 -b .procps
99%patch11 -p1 -b .rup-stack
100%patch12 -p1 -b .bigendian
101%patch13 -p1 -b .return
102%patch14 -p1 -b .procdiskstats
103%patch15 -p1 -b .dropprivs
104%patch16 -p1 -b .licensefix
105
106%build
107sh configure
108perl -pi -e '
109    s,^CC=.*$,CC=cc,;
110    s,-O2,\$(RPM_OPT_FLAGS),;
111    s,^BINDIR=.*$,BINDIR=%{_bindir},;
112    s,^MANDIR=.*$,MANDIR=%{_mandir},;
113    s,^SBINDIR=.*$,SBINDIR=%{_sbindir},;
114    ' MCONFIG
115
116make
117make -C rpc.rstatd
118
119
120%install
121rm -rf ${RPM_BUILD_ROOT}
122mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
123mkdir -p ${RPM_BUILD_ROOT}%{_sbindir}
124mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man{1,8}
125mkdir -p ${RPM_BUILD_ROOT}%{_initdir}
126
127make INSTALLROOT=${RPM_BUILD_ROOT} install
128make INSTALLROOT=${RPM_BUILD_ROOT} install -C rpc.rstatd
129
130install -m 755 $RPM_SOURCE_DIR/rusersd.init ${RPM_BUILD_ROOT}%{_initdir}/rusersd
131install -m 755 $RPM_SOURCE_DIR/rstatd.init ${RPM_BUILD_ROOT}%{_initdir}/rstatd
132
133
134%clean
135rm -rf ${RPM_BUILD_ROOT}
136
137
138%post server
139/sbin/chkconfig --add rusersd
140/sbin/chkconfig --add rstatd
141
142
143%preun server
144if [ $1 = 0 ]; then
145    /sbin/chkconfig --del rusersd
146    /sbin/chkconfig --del rstatd
147fi
148
149
150%files
151%defattr(-,root,root)
152%doc README
153%{_bindir}/rup
154%{_bindir}/rusers
155%{_mandir}/man1/*
156
157%files server
158%defattr(-,root,root)
159%{_mandir}/man8/*
160%{_sbindir}/rpc.rstatd
161%{_sbindir}/rpc.rusersd
162%config %{_initdir}/rusersd
163%config %{_initdir}/rstatd
164
165
166%changelog
167* Sun May  1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-48
168- rebuilt with current VineSeed
169- added Patch 14, 15 and 16 from FC
170  * Thu Aug 26 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 0.17-60
171  - replace SunRPC license with BSD (thanks to Oracle)
172  * Sat Sep 15 2007 Steve Dickson <steved@redaht.com> 0.17-51
173  - Removed portmap dependency and re-worked when the user
174    privilege are drop; allowing port registration with
175    rpcbind. (#247985)
176  * Wed Aug 09 2006 Phil Knirsch <pknirsch@redhat.com> 0.17-47
177  - Modified the RHEL3 procpartitions patch to work on recent 2.6
178    kernels (#201839)
179
180* Fri Oct 10 2008 Shu KONNO <owa@bg.wakwak.com> 0.17-47vl5
181- applied new versioning policy, spec in utf-8
182
183* Sun Jun 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-46vl1
184- added Patch 10, 11, 12 and 13 from Fedora 0.17-46
185  * Tue Mar 21 2006 Phil Knirsch <pknirsch@redhat.com> - 0.17-46
186  - Included fix for correct return values for rup (#177419)
187  * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.17-45.2.1
188  - bump again for double-long bug on ppc(64)
189  * Wed Sep 07 2005 Phil Knirsch <pknirsch@redhat.com> 0.17-45
190  - Fixed 64bit bigendian problem in rpc.rstatd (#130286)
191  * Wed May 04 2005 Phil Knirsch <pknirsch@redhat.com> 0.17-44
192  - Fixed rup stack problem (#154396)
193  * Mon Jul 12 2004 Phil Knirsch <pknirsch@redhat.com> 0.17-40
194  - Made patch to make rpc.rstatd independant of procps (#127512)
195- changed Group to Applications/Internet
196
197* Mon Jul 16 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-30vl1
198- based on Redhat Rawhide 0.17-30
199- rebuild with new toolchains
200- to use License instead of Copyright
201
202* Wed Jan 10 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
203- 0.17-6vl1
204- based on 0.17-6 from Rawhide
205- use better macros (%%{_initdir})
206- added Japanese summary and description
207
208* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
209- condrestart fixes
210
211* Thu Jul 20 2000 Bill Nottingham <notting@redhat.com>
212- move initscript back
213
214* Sun Jul 16 2000 Matt Wilson <msw@redhat.com>
215- rebuilt against new procps
216
217* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
218- automatic rebuild
219
220* Mon Jul 10 2000 Preston Brown <pbrown@redhat.com>
221- move initscripts
222
223* Sun Jun 18 2000 Jeff Johnson <jbj@redhat.com>
224- FHS packaging.
225- update to 0.17.
226
227* Wed Feb  9 2000 Jeff Johnson <jbj@redhat.com>
228- compress man pages (again).
229
230* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
231- fix description and summary
232- man pages are compressed
233
234* Tue Jan  4 2000 Bill Nottingham <notting@redhat.com>
235- split client and server
236
237* Tue Dec 21 1999 Jeff Johnson <jbj@redhat.com>
238- update to 0.16.
239
240* Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
241- rebuild against new procps
242
243* Wed Sep 22 1999 Jeff Johnson <jbj@redhat.com>
244- rusers init script started rstatd.
245
246* Mon Sep 20 1999 Jeff Johnson <jbj@redhat.com>
247- (re-)initialize number of users (#5244).
248
249* Fri Aug 27 1999 Preston Brown <pbrown@redhat.com>
250- initscripts check for portmapper running before starting (#2615)
251
252* Fri Aug 27 1999 Jeff Johnson <jbj@redhat.com>
253- return monitoring statistics like solaris does (#4237).
254
255* Thu Aug 26 1999 Jeff Johnson <jbj@redhat.com>
256- update to netkit-0.15.
257- on startup, rpc.rstatd needs to read information twice (#3994).
258
259* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
260- initscript munging
261
262* Tue Apr  6 1999 Jeff Johnson <jbj@redhat.com>
263- add rpc.rstatd (#2000)
264
265* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
266- auto rebuild in the new build environment (release 22)
267
268* Mon Mar 15 1999 Jeff Johnson <jbj@redhat.com>
269- compile for 6.0.
270
271* Tue May 05 1998 Cristian Gafton <gafton@redhat.com>
272- added /etc/rc.d/init.d/functions to the init script
273
274* Tue May 05 1998 Prospector System <bugs@redhat.com>
275- translations modified for de, fr, tr
276
277* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
278- enhanced initscript
279
280* Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
281- added init script
282- users %attr
283- supports chkconfig
284
285* Tue Jul 15 1997 Erik Troan <ewt@redhat.com>
286- initial build
Note: See TracBrowser for help on using the repository browser.