source: projects/specs/trunk/r/rusers/rusers-vl.spec @ 521

Revision 521, 8.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:     Displays the users logged into machines on the local network.
2Summary(ja): ローカルネットワーク上のマシンにログインしたユーザを表示する
3Name: rusers
4Version: 0.17
5Release: 47%{?_dist_release}
6License: BSD
7Group: Applications/Internet
8Source: ftp://ftp.uk.linux.org/pub/linux/Networking/netkit-devel/netkit-rusers-%{version}.tar.gz
9Source1: rusersd.init
10Source2: rstatd.tar.gz
11Source3: rstatd.init
12Patch0: rstatd-jbj.patch
13Patch1: netkit-rusers-0.15-numusers.patch
14Patch2: netkit-rusers-0.17-2.4.patch
15Patch3: netkit-rusers-0.17-includes.patch
16Patch4: netkit-rusers-0.17-truncate.patch
17Patch5: netkit-rusers-0.17-stats.patch
18Patch6: netkit-rusers-0.17-rstatd-no-static-buffer.patch
19Patch7: netkit-rusers-0.17-strip.patch
20Patch8: netkit-rusers-0.17-rup.patch
21Patch9: netkit-rusers-0.17-rup-timeout.patch
22Patch10: netkit-rusers-0.17-procps.patch
23Patch11: netkit-rusers-0.17-rup-stack.patch
24Patch12: netkit-rusers-0.17-bigendian.patch
25Patch13: netkit-rusers-0.17-return.patch
26Buildroot: %{_tmppath}/%{name}-%{version}-root
27BuildRequires: procps
28
29%description
30The rusers program allows users to find out who is logged into various
31machines on the local network.  The rusers command produces output
32similar to who, but for the specified list of hosts or for all
33machines on the local network.
34
35Install rusers if you need to keep track of who is logged into your
36local network.
37
38%description -l ja
39rusers プログラムを使うとローカルネットワーク上の様々なマシンに
40誰がログインしているかを調べることが出来ます.rusers コマンドは
41who に似た出力をしますが,引数で指定したホストあるいはローカル
42ネットワーク上の全ホストの情報を出力するところが異なります.
43
44ローカルネットワークで誰がログインしているかを調べるには
45rusers パッケージをインストールして下さい.
46
47
48%package server
49Summary: Server for the rusers protocol.
50Summary(ja): rusers プロトコルのサーバ
51Group: System Environment/Daemons
52#Prereq: /sbin/chkconfig /etc/init.d
53Prereq: /sbin/chkconfig
54Requires: portmap
55
56
57%description server
58The rusers program allows users to find out who is logged into various
59machines on the local network.  The rusers command produces output
60similar to who, but for the specified list of hosts or for all
61machines on the local network. The rusers-server package contains the
62server for responding to rusers requests.
63
64Install rusers-server if you want remote users to be able to see
65who is logged into your machine.
66
67%description server -l ja
68rusers プログラムを使うとローカルネットワーク上の様々なマシンに
69誰がログインしているかを調べることが出来ます.rusers コマンドは
70who に似た出力をしますが,引数で指定したホストあるいはローカル
71ネットワーク上の全ホストの情報を出力するところが異なります.
72この rusers-server パッケージには rusers のリクエストに答える
73サーバが含まれています.
74
75遠隔ユーザがあなたのマシンに誰がログインしているかを調べることが
76出来る様にするには,rusers-server パッケージをインストールして下さい.
77
78
79%prep
80%setup -q -n netkit-rusers-%{version} -a 2
81%patch0 -p1 -b .jbj
82%patch1 -p1 -b .numusers
83%patch2 -p1 -b .2.4
84%patch3 -p1 -b .includes
85%patch4 -p1 -b .truncate
86%patch5 -p1 -b .stats
87%patch6 -p1 -b .rstatd-no-static-buffer
88%patch7 -p1 -b .strip
89%patch8 -p1 -b .rup
90%patch9 -p1 -b .rup-timeout
91%patch10 -p1 -b .procps
92%patch11 -p1 -b .rup-stack
93%patch12 -p1 -b .bigendian
94%patch13 -p1 -b .return
95
96%build
97sh configure
98perl -pi -e '
99    s,^CC=.*$,CC=cc,;
100    s,-O2,\$(RPM_OPT_FLAGS),;
101    s,^BINDIR=.*$,BINDIR=%{_bindir},;
102    s,^MANDIR=.*$,MANDIR=%{_mandir},;
103    s,^SBINDIR=.*$,SBINDIR=%{_sbindir},;
104    ' MCONFIG
105
106make
107make -C rpc.rstatd
108
109
110%install
111rm -rf ${RPM_BUILD_ROOT}
112mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
113mkdir -p ${RPM_BUILD_ROOT}%{_sbindir}
114mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man{1,8}
115mkdir -p ${RPM_BUILD_ROOT}%{_initdir}
116
117make INSTALLROOT=${RPM_BUILD_ROOT} install
118make INSTALLROOT=${RPM_BUILD_ROOT} install -C rpc.rstatd
119
120install -m 755 $RPM_SOURCE_DIR/rusersd.init ${RPM_BUILD_ROOT}%{_initdir}/rusersd
121install -m 755 $RPM_SOURCE_DIR/rstatd.init ${RPM_BUILD_ROOT}%{_initdir}/rstatd
122
123
124%clean
125rm -rf ${RPM_BUILD_ROOT}
126
127
128%post server
129/sbin/chkconfig --add rusersd
130/sbin/chkconfig --add rstatd
131
132
133%preun server
134if [ $1 = 0 ]; then
135    /sbin/chkconfig --del rusersd
136    /sbin/chkconfig --del rstatd
137fi
138
139
140%files
141%defattr(-,root,root)
142%{_bindir}/rup
143%{_bindir}/rusers
144%{_mandir}/man1/*
145
146%files server
147%defattr(-,root,root)
148%{_mandir}/man8/*
149%{_sbindir}/rpc.rstatd
150%{_sbindir}/rpc.rusersd
151%config %{_initdir}/rusersd
152%config %{_initdir}/rstatd
153
154
155%changelog
156* Fri Oct 10 2008 Shu KONNO <owa@bg.wakwak.com> 0.17-47vl5
157- applied new versioning policy, spec in utf-8
158
159* Sun Jun 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-46vl1
160- added Patch 10, 11, 12 and 13 from Fedora 0.17-46
161  * Tue Mar 21 2006 Phil Knirsch <pknirsch@redhat.com> - 0.17-46
162  - Included fix for correct return values for rup (#177419)
163  * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.17-45.2.1
164  - bump again for double-long bug on ppc(64)
165  * Wed Sep 07 2005 Phil Knirsch <pknirsch@redhat.com> 0.17-45
166  - Fixed 64bit bigendian problem in rpc.rstatd (#130286)
167  * Wed May 04 2005 Phil Knirsch <pknirsch@redhat.com> 0.17-44
168  - Fixed rup stack problem (#154396)
169  * Mon Jul 12 2004 Phil Knirsch <pknirsch@redhat.com> 0.17-40
170  - Made patch to make rpc.rstatd independant of procps (#127512)
171- changed Group to Applications/Internet
172
173* Mon Jul 16 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-30vl1
174- based on Redhat Rawhide 0.17-30
175- rebuild with new toolchains
176- to use License instead of Copyright
177
178* Wed Jan 10 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
179- 0.17-6vl1
180- based on 0.17-6 from Rawhide
181- use better macros (%%{_initdir})
182- added Japanese summary and description
183
184* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
185- condrestart fixes
186
187* Thu Jul 20 2000 Bill Nottingham <notting@redhat.com>
188- move initscript back
189
190* Sun Jul 16 2000 Matt Wilson <msw@redhat.com>
191- rebuilt against new procps
192
193* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
194- automatic rebuild
195
196* Mon Jul 10 2000 Preston Brown <pbrown@redhat.com>
197- move initscripts
198
199* Sun Jun 18 2000 Jeff Johnson <jbj@redhat.com>
200- FHS packaging.
201- update to 0.17.
202
203* Wed Feb  9 2000 Jeff Johnson <jbj@redhat.com>
204- compress man pages (again).
205
206* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
207- fix description and summary
208- man pages are compressed
209
210* Tue Jan  4 2000 Bill Nottingham <notting@redhat.com>
211- split client and server
212
213* Tue Dec 21 1999 Jeff Johnson <jbj@redhat.com>
214- update to 0.16.
215
216* Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
217- rebuild against new procps
218
219* Wed Sep 22 1999 Jeff Johnson <jbj@redhat.com>
220- rusers init script started rstatd.
221
222* Mon Sep 20 1999 Jeff Johnson <jbj@redhat.com>
223- (re-)initialize number of users (#5244).
224
225* Fri Aug 27 1999 Preston Brown <pbrown@redhat.com>
226- initscripts check for portmapper running before starting (#2615)
227
228* Fri Aug 27 1999 Jeff Johnson <jbj@redhat.com>
229- return monitoring statistics like solaris does (#4237).
230
231* Thu Aug 26 1999 Jeff Johnson <jbj@redhat.com>
232- update to netkit-0.15.
233- on startup, rpc.rstatd needs to read information twice (#3994).
234
235* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
236- initscript munging
237
238* Tue Apr  6 1999 Jeff Johnson <jbj@redhat.com>
239- add rpc.rstatd (#2000)
240
241* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
242- auto rebuild in the new build environment (release 22)
243
244* Mon Mar 15 1999 Jeff Johnson <jbj@redhat.com>
245- compile for 6.0.
246
247* Tue May 05 1998 Cristian Gafton <gafton@redhat.com>
248- added /etc/rc.d/init.d/functions to the init script
249
250* Tue May 05 1998 Prospector System <bugs@redhat.com>
251- translations modified for de, fr, tr
252
253* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
254- enhanced initscript
255
256* Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
257- added init script
258- users %attr
259- supports chkconfig
260
261* Tue Jul 15 1997 Erik Troan <ewt@redhat.com>
262- initial build
Note: See TracBrowser for help on using the repository browser.