source: projects/specs/branches/6/r/rhythmbox/rhythmbox-vl.spec @ 4590

Revision 4590, 19.3 KB checked in by Takemikaduchi, 13 years ago (diff)

fix BTS:1193,1195

Line 
1# -*- coding: utf-8-unix -*-
2%define desktop_file_utils_version 0.9
3
4%define enable_DLNA_UPnP 0
5
6Summary: Music Management Application
7Summary(ja): 音楽管理アプリケーション
8Name: rhythmbox
9Version: 0.13.3
10Release: 2%{?_dist_release}
11License: GPL2+ with exceptions and GFDL
12Group: Applications/Multimedia
13URL: http://projects.gnome.org/rhythmbox/
14Source: http://download.gnome.org/sources/rhythmbox/0.13/%{name}-%{version}.tar.bz2
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: avahi-glib-devel >= 0.6
18BuildRequires: brasero-devel >= 2.32.0
19BuildRequires: dbus-devel >= 1.0
20BuildRequires: dbus-glib-devel
21BuildRequires: gnome-media-devel
22BuildRequires: gnome-vfs2-devel >= 2.18.0
23BuildRequires: gstreamer-plugins-base-devel >= 0.10
24BuildRequires: gstreamer-python-devel
25BuildRequires: json-glib-devel
26BuildRequires: libSM-devel
27BuildRequires: libffi-devel
28BuildRequires: libgnome-keyring-devel >= 2.30.0
29BuildRequires: libgnomeui-devel >= 2.18.0
30BuildRequires: libgpod-devel
31BuildRequires: libgudev1-devel
32BuildRequires: libmusicbrainz-devel >= 2.1.0
33BuildRequires: libnotify-devel
34BuildRequires: libsexy-devel
35BuildRequires: libsoup-devel
36BuildRequires: popt-devel
37BuildRequires: python-devel, pygtk2-devel
38BuildRequires: sqlite3-devel
39BuildRequires: totem-pl-parser-devel
40BuildRequires: check >= 0.8.2
41BuildRequires: gettext, rarian-compat
42BuildRequires: gnome-doc-utils >= 0.3.2
43BuildRequires: intltool >= 0.35.0
44BuildRequires: libmtp-devel
45BuildRequires: lirc
46Requires: libgpod
47Requires: libnotify
48Requires: libsexy
49Requires: lirc
50Requires: libmtp
51Requires: libgnomeui
52Requires: brasero
53Requires: gnome-python gnome-vfs2
54Requires: gnome-themes
55Requires: libgnome-keyring
56Requires: gstreamer-python
57%if %{enable_DLNA_UPnP}
58Requires: python-Coherence
59%endif
60Requires: desktop-file-utils >= %{desktop_file_utils_version}
61Requires: scrollkeeper GConf2
62
63# # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
64# # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
65# # respectively.
66# Requires: self-build-gstreamer-plugins-ffmpeg
67# Requires: self-build-gstreamer-plugins-ugly
68
69
70%description
71Rhythmbox is an integrated music management application based on the powerful
72GStreamer media framework. It has a number of features, including an easy to
73use music browser, searching and sorting, comprehensive audio format support
74through GStreamer, Internet Radio support, playlists and more.
75
76Rhythmbox is extensible through a plugin system.
77
78%description -l ja
79Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
80統合音楽管理アプリケーションです。
81見やすいユーザインターフェースを備え、検索や整列ができ、
82GStreamer により数多くの音声フォーマットをサポート、
83インターネットラジオをサポート、プレイリスト管理などの
84数多くの特徴を持ちます。
85
86%package devel
87Summary: Development tools for rhythmbox applications.
88Summary(ja): rhythmbox アプリケーションの開発用ファイル
89Group: Development/Libraries
90Requires: %{name} = %{version}-%{release}
91Requires: pkgconfig
92Requires: glib2-devel
93Requires: gtk2-devel
94Requires: libsoup-devel
95Requires: gnome-media-devel
96Requires: totem-pl-parser-devel
97Requires: gstreamer-devel
98
99%description devel
100Header files and libraries for building a extension library for the rhythmbox.
101
102%description devel -l ja
103
104%prep
105%setup -q
106# autoreconf -i
107
108# Use the installed louie, not the one in Coherence
109find plugins/coherence/upnp_coherence/ -type f \
110    -exec %__sed -i 's/coherence.extern.louie as louie/louie/' '{}' ';'
111
112%build
113# work around a gstreamer bug
114/usr/bin/gst-inspect-0.10 --print-all >& /dev/null || :
115
116%configure --with-ipod \
117    --with-mtp \
118    --with-mdns=avahi \
119    --with-libnautilus-burn \
120    --enable-lirc \
121    --enable-python \
122    --disable-vala \
123    --disable-browser-plugin \
124    --disable-static \
125    --disable-scrollkeeper \
126    --disable-schemas-install \
127    --without-hal
128%__make %{?_smp_mflags}
129
130%install
131%__rm -rf $RPM_BUILD_ROOT
132export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
133%__make install DESTDIR=$RPM_BUILD_ROOT
134unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
135
136%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
137%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
138%__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
139%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
140%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
141%__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
142%__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
143
144## Don't package DLNA/UPnP plugin
145%if !%{enable_DLNA_UPnP}
146%__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
147%endif
148
149%find_lang %{name}
150
151
152# Don't package api docs
153%__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
154
155# Don't package scrollkeeper catalogs
156%__rm -rf $RPM_BUILD_ROOT%{_localstatedir}
157
158# And don't package vala
159%__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
160        %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
161
162# save space by linking identical images in translated docs
163helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
164for f in $helpdir/C/figures/*.png; do
165  b="$(basename $f)"
166  for d in $helpdir/*; do
167    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
168      g="$d/figures/$b"
169      if [ -f "$g" ]; then
170        if cmp -s $f $g; then
171          %__rm "$g"; ln -s "../../C/figures/$b" "$g"
172        fi
173      fi
174    fi
175  done
176done
177
178
179%clean
180%__rm -rf $RPM_BUILD_ROOT
181
182%post
183/sbin/ldconfig
184export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
185gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/rhythmbox.schemas >/dev/null
186update-desktop-database -q
187scrollkeeper-update -q
188touch --no-create %{_datadir}/icons/hicolor
189if [ -x /usr/bin/gtk-update-icon-cache ]; then
190  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
191fi
192
193%preun
194if [ "$1" -eq 0 ]; then
195    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
196    gconftool-2 --makefile-uninstall-rule \
197      %{_sysconfdir}/gconf/schemas/rhythmbox.schemas > /dev/null || :
198fi
199
200%postun
201/sbin/ldconfig
202update-desktop-database -q
203scrollkeeper-update -q
204touch --no-create %{_datadir}/icons/hicolor
205if [ -x /usr/bin/gtk-update-icon-cache ]; then
206  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
207fi
208
209
210%files -f %{name}.lang
211%defattr(-, root, root)
212%doc AUTHORS COPYING ChangeLog README NEWS
213%{_sysconfdir}/gconf/schemas/rhythmbox.schemas
214%{_bindir}/*
215%{_libdir}/lib*.so.*
216%{_libdir}/rhythmbox/plugins
217%{_datadir}/applications/rhythmbox.desktop
218%{_datadir}/applications/rhythmbox-device.desktop
219%{_datadir}/dbus-1/services/org.gnome.Rhythmbox.service
220%{_datadir}/gnome/help/rhythmbox
221%{_datadir}/icons/*
222%{_datadir}/omf/rhythmbox
223%{_datadir}/rhythmbox
224%{_mandir}/man1/*
225%{_libexecdir}/rhythmbox-metadata
226
227%files devel
228%defattr(-, root, root)
229%{_includedir}/%{name}/*
230%{_libdir}/*.so
231%{_libdir}/pkgconfig/*.pc
232
233
234%changelog
235* Fri Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-2
236- add BuildRequires: json-glib-devel
237- remove unrecognized configure option (--with-dbus, --with-cd-burning, --with-metadata-helper)
238
239* Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-1
240- new upstream release
241- change BuildRequires: gstreamer-python-devel instead of gstreamer-python
242
243* Sat Nov 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.2-1
244- new upstream release
245
246* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-3
247- rebuild with brasero-2.32.0
248
249* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-2
250- rebuild with rpm-4.8.1 for pkg-config file
251
252* Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
253- new upstream release
254- fix %files (add rhythmbox-device.desktop)
255
256* Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
257- new upstream release
258- change BuildRequires: gnome-media-devel instead of gnome-media
259- add devel package
260- drop Patch0
261
262* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
263- new upstream release
264- drop Patch1, Patch2, Patch3
265- change BuildRequires: nautilus-cd-burner -> brasero-devel
266- change Requires: nautilus-cd-burner -> brasero
267- change BuildRequires: hal-devel -> libgudev1-devel
268- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
269- change Requires: gnome-keyring -> libgnome-keyring
270- add configure option (--without-hal)
271
272* Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
273- rebuilt with new environment
274
275* Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
276- new upstream release
277  - dropped upstreamed/obsolete patches
278  - added patches applied Fedora development
279
280* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
281- new upstream release
282- added configure options:
283  --disable-vala
284  --disable-browser-plugin
285
286* Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
287- added Japanese description
288
289* Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
290- new upstream release
291  - dropped rb-disable-power-plugin-by-default.patch
292- added BuildRequires:
293  - libSM-devel
294  - gnome-media
295
296* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
297- rebuild with libgpod-0.7.2
298
299* Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
300- new upstream release
301- corrected License tag
302- dropped rhythmbox-0.11.6-libmtp.patch
303- added BuildRequires:
304  - sqlite3-devel
305  - libffi-devel
306
307* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
308- defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
309- applied rhythmbox-0.11.6-libmtp.patch
310- added Requires:
311  - libgpod
312  - libnotify
313  - libsexy
314  - lirc
315  - libmtp
316  - libgnomeui
317  - nautilus-cd-burner
318  - gstreamer-python
319  - gnome-vfs2
320  - gnome-themes
321  - gnome-keyring
322  - python-Coherence, if enable_DLNA_UPnP = 1
323- added BuildRequires:
324  - libnotify-devel
325  - libsexy-devel
326  - lirc
327  - libmtp-devel
328  - gnome-vfs2-devel, instead of gnome-vfs2
329  - gnome-keyring-devel
330- dropped --with-internal-libsexy in configure options
331- added in configure options:
332  --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
333- added %%preun to remove the schema
334
335* Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
336- new upstream release
337- changed to --with-metadata-helper in configure options
338- added BuildRequires:
339  - gstreamer-python
340  - intltool >= 0.35.0
341  - popt-devel
342
343* Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
344- added BuildRequires: totem-pl-parser-devel, instead of totem-devel
345- rebuilt with python-2.5.2
346- applied new versioning policy
347- spec in utf-8
348
349* Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
350- rebuilt with libgpod-0.6.0
351
352* Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
353- new upstream release
354
355* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
356- new upstream release
357
358* Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
359- rebuilt with new toolchain and libgpod-0.4.2
360- add BuildRequires: dbus-glib-devel
361
362* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
363- new upstream release
364
365* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
366- rebuilt for VineSeed
367
368* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
369- new upstream release
370- added --enable-python option to %%configure
371- added Requires: gnome-python
372
373* Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
374- new upstream release
375- built with libsoup 2.2.99
376
377* Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
378- added --with-cd-burner to configure
379- added BuildRequires: libsexy-devel hal-devel libsoup-devel
380
381* Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
382- add BuildRequires:
383  - gnome-doc-utils >= 0.3.2
384  - python-devel
385  - pygtk2-devel
386  - check >= 0.8.2
387
388* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
389- rebuild with gnutls-1.4.1
390
391* Sun Oct  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
392- new upstream release
393
394* Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
395- new upstream release
396- run scrollkeeper-update at %post and %postun
397- added BuildRequires: libnotify-devel
398
399* Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
400- new upstream release (dropped patch0)
401- added --without-metadata-helper at configure
402
403* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
404- Initial build for Vine Linux based on FC pacakge
405
406* Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
407- add patch from James "Doc" Livingston to stop a hang
408  for new users (bug 183883)
409
410* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
411- bump again for double-long bug on ppc(64)
412
413* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
414- rebuilt for new gcc4.1 snapshot and glibc changes
415
416* Sat Feb  4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
417- Update to 0.9.3.1
418- Use gstreamer (0.10)
419
420* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
421- Remove hack for 173869, as its no longer needed.
422
423* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
424- 0.9.3
425
426* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
427- Newer CVS snapshot
428
429* Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
430- Update to latest CVS
431- Add hack to workaround bug #173869
432
433* Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
434- Rebuild, now that gstreamer08-plugins has been fixed
435
436* Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
437- bonobo multilib issue (bug 156982)
438
439* Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
440- rebuild with ipod support
441
442* Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
443- rebuilt again
444
445* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
446- rebuilt
447
448* Mon Dec  5 2005 Matthias Clasen <mclasen@redhat.com>
449- rebuild
450
451* Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
452- rebuild for new dbus
453
454* Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
455- Update to 0.9.2
456
457* Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
458- Update to 0.9.1
459
460* Fri Sep 02 2005 Colin Walters <walters@redhat.com>
461- Add configure flags --with-bonobo --with-dbus
462- BR nautilus-cd-burner-devel
463- New upstream CVS snapshot for testing
464- Drop IDL file and ui .xml
465- Add dbus service file
466- Drop upstreamed rhythmbox-bluecurve.tar.gz
467- Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
468
469* Fri Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
470- Add Bluecurve-ized icons from Jeff Schroeder (157716)
471- Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
472  cell renderer for playback icon (no longer necessary) and
473  changes the rating renderer to work with non-b&w icons
474
475* Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
476- Rebuild for GCC4
477
478* Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
479- New upstream version
480- Remove librb-nautilus-context-menu.so, killed upstream
481
482* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
483- PreReq desktop-file-utils >= 0.9
484
485* Sat Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
486- New upstream version
487
488* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
489- Fix postun to use correct syntax, thanks Nils Philippsen
490
491* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
492- New upstream version
493- Call update-desktop-database in post and postun
494
495* Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
496- New upstream version
497
498* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
499- rebuilt
500
501* Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
502- New upstream version
503- Remove backported patches
504- Gratuitiously bump various BuildRequires versions
505
506* Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
507- Remove code to unregister GConf schema for now (Closes: #122532)
508
509* Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
510- Apply tiny patch from 0.8 arch to fix GConf key used
511  for initial sorting
512
513* Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
514- Apply patch from 0.8 arch tree to fix a number of memleaks
515
516* Thu May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
517- Update to 0.8.3: fixes showstopper bug with internet radio
518
519* Thu Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
520- Update to 0.8.2
521- Fix Source url
522- Add smp_mflags
523- Bump BuildRequires on gstreamer to 0.8.1
524
525* Tue Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
526- Uninstall GConf schemas on removal
527
528* Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
529- Update to 0.8.1
530
531* Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
532- Update to 0.8.0
533
534* Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
535- Update to 0.7.2
536
537* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
538- Remove BuildRequires on autoconf and libvorbis-devel
539
540* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
541- New major version - I know we are past major version slush, but
542  this should have been done two weeks ago along with the GNOME 2.6
543  upload.  As upstream author as well, I believe this version is
544  good enough for FC2.
545- Remove --disable-mp3
546- Remove id3, flac variables
547- Remove GStreamer major version patch
548- Fix typo in description
549
550* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
551- rebuild for new gstreamer
552
553* Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
554- update to 0.6.8
555
556* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
557- rebuilt
558
559* Mon Mar  1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
560- update to 0.6.7
561
562* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
563- rebuilt
564
565* Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
566- New upstream version
567- Don't re-run the autotools; upstream incorporates newer versions.
568* Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
569- new version
570- remove smp_flags
571
572* Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
573- remove the initial iradio channels as they all are mp3 based.
574
575* Wed Oct  8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
576- Fix category from Development/Libraries to Applications/Multimedia.
577- Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
578- Fix SCHEMES vs. SCHEMAS in the post scriplet.
579- Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
580- Removed unnecessary date expansion define.
581- Updated description, including mp3 reference removal.
582- Added libid3tag and flac optional support for convenient rebuild.
583- Removed obsolete omf.make and xmldocs.make (included ones are the same now).
584
585* Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
586- new version
587- use %{_sysconfdir} instead of /etc
588
589* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
590- rebuilt
591
592* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
593- gave up on other archs for the Beta
594- new version
595- remove werror and add missing files
596
597* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
598- update to newer cvs snap
599
600* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
601- update to cvs snap
602
603* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
604- use %%(lang)
605
606* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
607- fix post to actually install the schema
608
609* Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
610- Added gconf file
611- Added i18n directory
612
613* Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
614- Updated for new rewrite of rhythmbox, thanks to Jeroen
615
616* Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
617- removed bonobo dependency
618* Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
619- created new spec file
Note: See TracBrowser for help on using the repository browser.