source: projects/specs/branches/6/r/rhythmbox/rhythmbox-vl.spec @ 10619

Revision 10619, 19.4 KB checked in by tomop, 8 years ago (diff)

rhythmbox-0.13.3-3

Line 
1# -*- coding: utf-8-unix -*-
2%define desktop_file_utils_version 0.9
3
4%define enable_DLNA_UPnP 0
5
6Summary: Music Management Application
7Summary(ja): 音楽管理アプリケーション
8Name: rhythmbox
9Version: 0.13.3
10Release: 3%{?_dist_release}
11License: GPL2+ with exceptions and GFDL
12Group: Applications/Multimedia
13URL: http://projects.gnome.org/rhythmbox/
14Source: http://download.gnome.org/sources/rhythmbox/0.13/%{name}-%{version}.tar.bz2
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: avahi-glib-devel >= 0.6
18BuildRequires: brasero-devel >= 2.32.0
19BuildRequires: dbus-devel >= 1.0
20BuildRequires: dbus-glib-devel
21BuildRequires: gnome-media-devel
22BuildRequires: gnome-vfs2-devel >= 2.18.0
23BuildRequires: gstreamer-plugins-base-devel >= 0.10
24BuildRequires: gstreamer-python-devel
25BuildRequires: json-glib-devel
26BuildRequires: libSM-devel
27BuildRequires: libffi-devel
28BuildRequires: libgnome-keyring-devel >= 2.30.0
29BuildRequires: libgnomeui-devel >= 2.18.0
30BuildRequires: libgpod-devel
31BuildRequires: libgudev1-devel
32BuildRequires: libmusicbrainz-devel >= 2.1.0
33BuildRequires: libnotify-devel
34BuildRequires: libsexy-devel
35BuildRequires: libsoup-devel
36BuildRequires: popt-devel
37BuildRequires: python-devel, pygtk2-devel
38BuildRequires: sqlite3-devel
39BuildRequires: totem-pl-parser-devel
40BuildRequires: check >= 0.8.2
41BuildRequires: gettext, rarian-compat
42BuildRequires: gnome-doc-utils >= 0.3.2
43BuildRequires: intltool >= 0.35.0
44BuildRequires: libmtp-devel
45BuildRequires: lirc
46Requires: libgpod
47Requires: libnotify
48Requires: libsexy
49Requires: lirc
50Requires: libmtp
51Requires: libgnomeui
52Requires: brasero
53Requires: gnome-python gnome-vfs2
54Requires: gnome-themes
55Requires: libgnome-keyring
56Requires: gstreamer-python
57%if %{enable_DLNA_UPnP}
58Requires: python-Coherence
59%endif
60Requires: desktop-file-utils >= %{desktop_file_utils_version}
61Requires: scrollkeeper GConf2
62
63# # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
64# # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
65# # respectively.
66# Requires: self-build-gstreamer-plugins-ffmpeg
67# Requires: self-build-gstreamer-plugins-ugly
68
69
70%description
71Rhythmbox is an integrated music management application based on the powerful
72GStreamer media framework. It has a number of features, including an easy to
73use music browser, searching and sorting, comprehensive audio format support
74through GStreamer, Internet Radio support, playlists and more.
75
76Rhythmbox is extensible through a plugin system.
77
78%description -l ja
79Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
80統合音楽管理アプリケーションです。
81見やすいユーザインターフェースを備え、検索や整列ができ、
82GStreamer により数多くの音声フォーマットをサポート、
83インターネットラジオをサポート、プレイリスト管理などの
84数多くの特徴を持ちます。
85
86%package devel
87Summary: Development tools for rhythmbox applications.
88Summary(ja): rhythmbox アプリケーションの開発用ファイル
89Group: Development/Libraries
90Requires: %{name} = %{version}-%{release}
91Requires: pkgconfig
92Requires: glib2-devel
93Requires: gtk2-devel
94Requires: libsoup-devel
95Requires: gnome-media-devel
96Requires: totem-pl-parser-devel
97Requires: gstreamer-devel
98
99%description devel
100Header files and libraries for building a extension library for the rhythmbox.
101
102%description devel -l ja
103
104%prep
105%setup -q
106# autoreconf -i
107
108# Use the installed louie, not the one in Coherence
109find plugins/coherence/upnp_coherence/ -type f \
110    -exec %__sed -i 's/coherence.extern.louie as louie/louie/' '{}' ';'
111
112%build
113# work around a gstreamer bug
114/usr/bin/gst-inspect-0.10 --print-all >& /dev/null || :
115
116%configure --with-ipod \
117    --with-mtp \
118    --with-mdns=avahi \
119    --with-libnautilus-burn \
120    --enable-lirc \
121    --enable-python \
122    --disable-vala \
123    --disable-browser-plugin \
124    --disable-static \
125    --disable-scrollkeeper \
126    --disable-schemas-install \
127    --without-hal
128%__make %{?_smp_mflags}
129
130%install
131%__rm -rf $RPM_BUILD_ROOT
132export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
133%__make install DESTDIR=$RPM_BUILD_ROOT
134unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
135
136%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
137%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
138%__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
139%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
140%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
141%__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
142%__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
143
144## Don't package DLNA/UPnP plugin
145%if !%{enable_DLNA_UPnP}
146%__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
147%endif
148
149%find_lang %{name}
150
151
152# Don't package api docs
153%__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
154
155# Don't package scrollkeeper catalogs
156%__rm -rf $RPM_BUILD_ROOT%{_localstatedir}
157
158# And don't package vala
159%__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
160        %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
161
162# save space by linking identical images in translated docs
163helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
164for f in $helpdir/C/figures/*.png; do
165  b="$(basename $f)"
166  for d in $helpdir/*; do
167    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
168      g="$d/figures/$b"
169      if [ -f "$g" ]; then
170        if cmp -s $f $g; then
171          %__rm "$g"; ln -s "../../C/figures/$b" "$g"
172        fi
173      fi
174    fi
175  done
176done
177
178
179%clean
180%__rm -rf $RPM_BUILD_ROOT
181
182%post
183/sbin/ldconfig
184export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
185gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/rhythmbox.schemas >/dev/null
186update-desktop-database -q
187scrollkeeper-update -q
188touch --no-create %{_datadir}/icons/hicolor
189if [ -x /usr/bin/gtk-update-icon-cache ]; then
190  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
191fi
192
193%preun
194if [ "$1" -eq 0 ]; then
195    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
196    gconftool-2 --makefile-uninstall-rule \
197      %{_sysconfdir}/gconf/schemas/rhythmbox.schemas > /dev/null || :
198fi
199
200%postun
201/sbin/ldconfig
202update-desktop-database -q
203scrollkeeper-update -q
204touch --no-create %{_datadir}/icons/hicolor
205if [ -x /usr/bin/gtk-update-icon-cache ]; then
206  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
207fi
208
209
210%files -f %{name}.lang
211%defattr(-, root, root)
212%doc AUTHORS COPYING ChangeLog README NEWS
213%{_sysconfdir}/gconf/schemas/rhythmbox.schemas
214%{_bindir}/*
215%{_libdir}/lib*.so.*
216%{_libdir}/rhythmbox/plugins
217%{_datadir}/applications/rhythmbox.desktop
218%{_datadir}/applications/rhythmbox-device.desktop
219%{_datadir}/dbus-1/services/org.gnome.Rhythmbox.service
220%{_datadir}/gnome/help/rhythmbox
221%{_datadir}/icons/*
222%{_datadir}/omf/rhythmbox
223%{_datadir}/rhythmbox
224%{_mandir}/man1/*
225%{_libexecdir}/rhythmbox-metadata
226
227%files devel
228%defattr(-, root, root)
229%{_includedir}/%{name}/*
230%{_libdir}/*.so
231%{_libdir}/pkgconfig/*.pc
232
233
234%changelog
235* Fri Jul 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.13.3-3
236- rebuilt with libmtp-1.1.11.
237
238* Fri Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-2
239- add BuildRequires: json-glib-devel
240- remove unrecognized configure option (--with-dbus, --with-cd-burning, --with-metadata-helper)
241
242* Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-1
243- new upstream release
244- change BuildRequires: gstreamer-python-devel instead of gstreamer-python
245
246* Sat Nov 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.2-1
247- new upstream release
248
249* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-3
250- rebuild with brasero-2.32.0
251
252* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-2
253- rebuild with rpm-4.8.1 for pkg-config file
254
255* Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
256- new upstream release
257- fix %files (add rhythmbox-device.desktop)
258
259* Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
260- new upstream release
261- change BuildRequires: gnome-media-devel instead of gnome-media
262- add devel package
263- drop Patch0
264
265* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
266- new upstream release
267- drop Patch1, Patch2, Patch3
268- change BuildRequires: nautilus-cd-burner -> brasero-devel
269- change Requires: nautilus-cd-burner -> brasero
270- change BuildRequires: hal-devel -> libgudev1-devel
271- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
272- change Requires: gnome-keyring -> libgnome-keyring
273- add configure option (--without-hal)
274
275* Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
276- rebuilt with new environment
277
278* Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
279- new upstream release
280  - dropped upstreamed/obsolete patches
281  - added patches applied Fedora development
282
283* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
284- new upstream release
285- added configure options:
286  --disable-vala
287  --disable-browser-plugin
288
289* Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
290- added Japanese description
291
292* Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
293- new upstream release
294  - dropped rb-disable-power-plugin-by-default.patch
295- added BuildRequires:
296  - libSM-devel
297  - gnome-media
298
299* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
300- rebuild with libgpod-0.7.2
301
302* Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
303- new upstream release
304- corrected License tag
305- dropped rhythmbox-0.11.6-libmtp.patch
306- added BuildRequires:
307  - sqlite3-devel
308  - libffi-devel
309
310* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
311- defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
312- applied rhythmbox-0.11.6-libmtp.patch
313- added Requires:
314  - libgpod
315  - libnotify
316  - libsexy
317  - lirc
318  - libmtp
319  - libgnomeui
320  - nautilus-cd-burner
321  - gstreamer-python
322  - gnome-vfs2
323  - gnome-themes
324  - gnome-keyring
325  - python-Coherence, if enable_DLNA_UPnP = 1
326- added BuildRequires:
327  - libnotify-devel
328  - libsexy-devel
329  - lirc
330  - libmtp-devel
331  - gnome-vfs2-devel, instead of gnome-vfs2
332  - gnome-keyring-devel
333- dropped --with-internal-libsexy in configure options
334- added in configure options:
335  --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
336- added %%preun to remove the schema
337
338* Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
339- new upstream release
340- changed to --with-metadata-helper in configure options
341- added BuildRequires:
342  - gstreamer-python
343  - intltool >= 0.35.0
344  - popt-devel
345
346* Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
347- added BuildRequires: totem-pl-parser-devel, instead of totem-devel
348- rebuilt with python-2.5.2
349- applied new versioning policy
350- spec in utf-8
351
352* Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
353- rebuilt with libgpod-0.6.0
354
355* Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
356- new upstream release
357
358* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
359- new upstream release
360
361* Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
362- rebuilt with new toolchain and libgpod-0.4.2
363- add BuildRequires: dbus-glib-devel
364
365* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
366- new upstream release
367
368* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
369- rebuilt for VineSeed
370
371* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
372- new upstream release
373- added --enable-python option to %%configure
374- added Requires: gnome-python
375
376* Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
377- new upstream release
378- built with libsoup 2.2.99
379
380* Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
381- added --with-cd-burner to configure
382- added BuildRequires: libsexy-devel hal-devel libsoup-devel
383
384* Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
385- add BuildRequires:
386  - gnome-doc-utils >= 0.3.2
387  - python-devel
388  - pygtk2-devel
389  - check >= 0.8.2
390
391* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
392- rebuild with gnutls-1.4.1
393
394* Sun Oct  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
395- new upstream release
396
397* Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
398- new upstream release
399- run scrollkeeper-update at %post and %postun
400- added BuildRequires: libnotify-devel
401
402* Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
403- new upstream release (dropped patch0)
404- added --without-metadata-helper at configure
405
406* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
407- Initial build for Vine Linux based on FC pacakge
408
409* Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
410- add patch from James "Doc" Livingston to stop a hang
411  for new users (bug 183883)
412
413* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
414- bump again for double-long bug on ppc(64)
415
416* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
417- rebuilt for new gcc4.1 snapshot and glibc changes
418
419* Sat Feb  4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
420- Update to 0.9.3.1
421- Use gstreamer (0.10)
422
423* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
424- Remove hack for 173869, as its no longer needed.
425
426* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
427- 0.9.3
428
429* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
430- Newer CVS snapshot
431
432* Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
433- Update to latest CVS
434- Add hack to workaround bug #173869
435
436* Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
437- Rebuild, now that gstreamer08-plugins has been fixed
438
439* Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
440- bonobo multilib issue (bug 156982)
441
442* Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
443- rebuild with ipod support
444
445* Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
446- rebuilt again
447
448* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
449- rebuilt
450
451* Mon Dec  5 2005 Matthias Clasen <mclasen@redhat.com>
452- rebuild
453
454* Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
455- rebuild for new dbus
456
457* Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
458- Update to 0.9.2
459
460* Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
461- Update to 0.9.1
462
463* Fri Sep 02 2005 Colin Walters <walters@redhat.com>
464- Add configure flags --with-bonobo --with-dbus
465- BR nautilus-cd-burner-devel
466- New upstream CVS snapshot for testing
467- Drop IDL file and ui .xml
468- Add dbus service file
469- Drop upstreamed rhythmbox-bluecurve.tar.gz
470- Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
471
472* Fri Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
473- Add Bluecurve-ized icons from Jeff Schroeder (157716)
474- Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
475  cell renderer for playback icon (no longer necessary) and
476  changes the rating renderer to work with non-b&w icons
477
478* Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
479- Rebuild for GCC4
480
481* Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
482- New upstream version
483- Remove librb-nautilus-context-menu.so, killed upstream
484
485* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
486- PreReq desktop-file-utils >= 0.9
487
488* Sat Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
489- New upstream version
490
491* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
492- Fix postun to use correct syntax, thanks Nils Philippsen
493
494* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
495- New upstream version
496- Call update-desktop-database in post and postun
497
498* Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
499- New upstream version
500
501* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
502- rebuilt
503
504* Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
505- New upstream version
506- Remove backported patches
507- Gratuitiously bump various BuildRequires versions
508
509* Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
510- Remove code to unregister GConf schema for now (Closes: #122532)
511
512* Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
513- Apply tiny patch from 0.8 arch to fix GConf key used
514  for initial sorting
515
516* Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
517- Apply patch from 0.8 arch tree to fix a number of memleaks
518
519* Thu May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
520- Update to 0.8.3: fixes showstopper bug with internet radio
521
522* Thu Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
523- Update to 0.8.2
524- Fix Source url
525- Add smp_mflags
526- Bump BuildRequires on gstreamer to 0.8.1
527
528* Tue Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
529- Uninstall GConf schemas on removal
530
531* Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
532- Update to 0.8.1
533
534* Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
535- Update to 0.8.0
536
537* Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
538- Update to 0.7.2
539
540* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
541- Remove BuildRequires on autoconf and libvorbis-devel
542
543* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
544- New major version - I know we are past major version slush, but
545  this should have been done two weeks ago along with the GNOME 2.6
546  upload.  As upstream author as well, I believe this version is
547  good enough for FC2.
548- Remove --disable-mp3
549- Remove id3, flac variables
550- Remove GStreamer major version patch
551- Fix typo in description
552
553* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
554- rebuild for new gstreamer
555
556* Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
557- update to 0.6.8
558
559* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
560- rebuilt
561
562* Mon Mar  1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
563- update to 0.6.7
564
565* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
566- rebuilt
567
568* Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
569- New upstream version
570- Don't re-run the autotools; upstream incorporates newer versions.
571* Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
572- new version
573- remove smp_flags
574
575* Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
576- remove the initial iradio channels as they all are mp3 based.
577
578* Wed Oct  8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
579- Fix category from Development/Libraries to Applications/Multimedia.
580- Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
581- Fix SCHEMES vs. SCHEMAS in the post scriplet.
582- Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
583- Removed unnecessary date expansion define.
584- Updated description, including mp3 reference removal.
585- Added libid3tag and flac optional support for convenient rebuild.
586- Removed obsolete omf.make and xmldocs.make (included ones are the same now).
587
588* Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
589- new version
590- use %{_sysconfdir} instead of /etc
591
592* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
593- rebuilt
594
595* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
596- gave up on other archs for the Beta
597- new version
598- remove werror and add missing files
599
600* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
601- update to newer cvs snap
602
603* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
604- update to cvs snap
605
606* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
607- use %%(lang)
608
609* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
610- fix post to actually install the schema
611
612* Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
613- Added gconf file
614- Added i18n directory
615
616* Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
617- Updated for new rewrite of rhythmbox, thanks to Jeroen
618
619* Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
620- removed bonobo dependency
621* Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
622- created new spec file
Note: See TracBrowser for help on using the repository browser.