source: projects/specs/branches/6/r/resource-agents/resource-agents-vl.spec @ 1321

Revision 1321, 18.8 KB checked in by daisuke, 14 years ago (diff)

ewsource-agents: new package, Cluster-Resource-Agents-3.0.13

Line 
1###############################################################################
2###############################################################################
3##
4##  Copyright (C) 2004-2010 Red Hat, Inc.  All rights reserved.
5##
6##  This copyrighted material is made available to anyone wishing to use,
7##  modify, copy, or redistribute it subject to the terms and conditions
8##  of the GNU General Public License v.2.
9##
10###############################################################################
11###############################################################################
12
13# keep around ready for later user
14## global alphatag rc4
15
16# When downloading directly from Mercurial, it will automatically add this prefix
17# Invoking 'hg archive' wont but you can add one with:
18#  hg archive -t tgz -p "Cluster-Resource-Agents-" -r $altversion $altversion.tar.gz
19%global altprefix Cluster-Resource-Agents-
20%global altversion a7c0f35916bf
21
22Name: resource-agents
23Summary: Open Source HA Resource Agents
24Summary(ja): Open Source HA Resource Agents
25Version: 3.0.13
26Release: 1%{?_dist_release}
27License: GPLv2+ and LGPLv2+
28Group: System Environment/Base
29URL: http://sources.redhat.com/cluster/wiki/
30Source0: https://fedorahosted.org/releases/c/l/cluster/%{name}-%{version}.tar.bz2
31Source1: http://hg.linux-ha.org/agents/archive/%{altversion}.tar.bz2
32
33## Runtime deps
34# system tools shared by several agents
35Requires: bash grep sed gawk
36Requires: procps net-tools
37Requires: psmisc
38Requires: util-linux-ng
39
40# fs.sh
41Requires: quota
42Requires: util-linux-ng
43Requires: e2fsprogs
44Requires: xfsprogs
45
46# ip.sh
47Requires: iproute ethtool
48Requires: iputils
49
50# lvm.sh
51Requires: lvm2
52
53# netfs.sh
54Requires: nfs-utils samba-client
55
56## Setup/build bits
57BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
58
59# Build dependencies
60BuildRequires: cluster-glue-libs-devel glib2-devel
61BuildRequires: automake autoconf pkgconfig
62BuildRequires: libxslt docbook-style-xsl
63BuildRequires: python perl
64BuildRequires: libnet-devel
65
66%description
67A set of scripts to interface with several services to operate in a
68High Availability environment for both Pacemaker and rgmanager
69service managers.
70
71%package -n ldirectord
72Summary:          Monitor daemon for maintaining high availability resources
73Summary(ja):          Monitor daemon for maintaining high availability resources
74Group:            System Environment/Daemons
75Requires:         ipvsadm
76Requires(post):   /sbin/chkconfig
77Requires(preun):  /sbin/chkconfig
78
79# We were originally ldirectord, then renamed with a heartbeat- prefix.
80# Upstream maintainer wishes to use no prefix, which is consistent with
81# how it is packaged for other distributions
82Provides:  ldirectord = 3.0.0-15
83Obsoletes: ldirectord < 3.0.0-15
84Provides:  heartbeat-ldirectord = 3.0.0-15
85Obsoletes: heartbeat-ldirectord < 3.0.0-15
86
87# removed for now until it's in Fedora
88#Requires:  perl(Net::IMAP::Simple::SSL)
89
90%description -n ldirectord
91ldirectord is a stand-alone daemon to monitor services of real
92for virtual services provided by The Linux Virtual Server
93(http://www.linuxvirtualserver.org/). It is simple to install
94and works with the heartbeat code (http://www.linux-ha.org/).
95
96# we inherit configure from cluster project. Configure it for vars we need.
97# building from source directly without those parameters will NOT work.
98# See http://www.redhat.com/archives/cluster-devel/2009-February/msg00003.html
99%prep
100%setup -q -n %{name}-%{version} -a 1
101
102# prepare rgmanager RAs
103%{_configure} \
104  --sbindir=%{_sbindir} \
105  --initddir=%{_sysconfdir}/rc.d/init.d \
106  --libdir=%{_libdir} \
107  --without_fence_agents \
108  --disable_kernel_check
109
110# prepare pacemaker RAs
111cd %{altprefix}%{altversion}
112./autogen.sh
113%{configure} --enable-fatal-warnings=no --with-rsctmpdir=%{_var}/run/heartbeat/rsctmp
114
115%build
116##CFLAGS="$(echo '%{optflags}')" make %{_smp_mflags}
117# %{_smp_mflags} is broken from upstream and unrequired for this project.
118CFLAGS="$(echo '%{optflags}')" make -C rgmanager/src/resources
119make -C %{altprefix}%{altversion} %{_smp_mflags}
120
121%install
122rm -rf %{buildroot}
123make -C rgmanager/src/resources install DESTDIR=%{buildroot}
124make -C %{altprefix}%{altversion} install DESTDIR=%{buildroot}
125
126# tree fixup
127rm %{buildroot}/%{_libdir}/heartbeat/ocf-*
128find %{buildroot} -type f -name '.ocf-*' -exec chmod 644 {} \;
129find %{buildroot} -type f -name 'ocf-*' -exec chmod 644 {} \;
130find %{buildroot} -type f -name '*.dtd' -exec chmod 644 {} \;
131chmod 755 %{buildroot}/%{_sbindir}/ocf-tester
132chmod 755 %{buildroot}/%{_datadir}/cluster/ocf-shellfuncs
133
134# Strange location, remove until we can confirm
135rm -f %{buildroot}%{_libdir}/heartbeat/tickle_tcp
136
137# Test harness, worth creating a devel package for?
138rm -rf %{buildroot}%{_datadir}/resource-agents/ocft
139rm -f  %{buildroot}%{_sbindir}/ocft
140
141# symlink to allow pacemaker to use rgmanager RAs
142cd %{buildroot}/usr/lib/ocf/resource.d/ && \
143 ln -sf %{_datadir}/cluster/ vine
144
145%clean
146rm -rf %{buildroot}
147
148%post -n ldirectord
149/sbin/chkconfig --add ldirectord
150
151%postun -n ldirectord -p /sbin/ldconfig
152
153%preun -n ldirectord
154/sbin/chkconfig --del ldirectord
155
156%files
157%defattr(-,root,root,-)
158%doc doc/COPYING.* doc/COPYRIGHT doc/README.licence
159%doc %{altprefix}%{altversion}/AUTHORS
160%{_datadir}/cluster
161
162%dir /usr/lib/ocf
163%dir /usr/lib/ocf/resource.d
164/usr/lib/ocf/resource.d/heartbeat
165/usr/lib/ocf/resource.d/vine
166%{_sbindir}/ocf-tester
167%{_sbindir}/sfex_init
168
169%dir %{_datadir}/resource-agents
170%doc %{_datadir}/resource-agents/ra-api-1.dtd
171%{_mandir}/man7/*.7*
172
173%dir %{_sysconfdir}/ha.d
174%{_sysconfdir}/ha.d/shellfuncs
175
176%dir %{_libdir}/heartbeat
177%{_libdir}/heartbeat/findif
178%{_libdir}/heartbeat/send_arp 
179%{_libdir}/heartbeat/sfex_daemon
180%{_includedir}/heartbeat/agent_config.h
181
182%files -n ldirectord
183%defattr(-,root,root,-)
184%doc %{altprefix}%{altversion}/COPYING
185%doc %{altprefix}%{altversion}/ldirectord/ldirectord.cf
186%{_sbindir}/ldirectord
187%config(noreplace) %{_sysconfdir}/logrotate.d/ldirectord
188%{_sysconfdir}/init.d/ldirectord
189%{_sysconfdir}/ha.d/resource.d/ldirectord
190%{_mandir}/man8/ldirectord.8*
191/usr/lib/ocf/resource.d/heartbeat/ldirectord
192
193%changelog
194* Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.13-1
195- initial build for Vine Linux
196
197* Mon Jun  7 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.13-1
198- new upstream release
199  Resolves: rhbz#592103, rhbz#593108, rhbz#578617, rhbz#594626
200  Resolves: rhbz#594511, rhbz#596046, rhbz#594111, rhbz#597002
201  Resolves: rhbz#599643
202
203* Tue May 18 2010 Andrew Beekhof <andrew@beekhof.net> - 3.0.12-2
204- libnet is not available on RHEL
205- Do not package ldirectord on RHEL
206  Resolves: rhbz#577264
207
208* Mon May 10 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.12-1
209- new upstream release
210  Resolves: rhbz#585217, rhbz#586100, rhbz#581533, rhbz#582753
211  Resolves: rhbz#582754, rhbz#585083, rhbz#587079, rhbz#588890
212  Resolves: rhbz#588925, rhbz#583789, rhbz#589131, rhbz#588010
213  Resolves: rhbz#576871, rhbz#576871, rhbz#590000, rhbz#589823
214
215* Mon May 10 2010 Andrew Beekhof <andrew@beekhof.net> - 3.0.12-1
216- New pacemaker agents upstream release: a7c0f35916bf
217  + High: pgsql: properly implement pghost parameter
218  + High: RA: mysql: fix syntax error
219  + High: SAPInstance RA: do not rely on op target rc when monitoring clones (lf#2371)
220  + High: set the HA_RSCTMP directory to /var/run/resource-agents (lf#2378)
221  + Medium: IPaddr/IPaddr2: add a description of the assumption in meta-data
222  + Medium: IPaddr: return the correct code if interface delete failed
223  + Medium: nfsserver: rpc.statd as the notify cmd does not work with -v (thanks to Carl Lewis)
224  + Medium: oracle: reduce output from sqlplus to the last line for queries (bnc#567815)
225  + Medium: pgsql: implement "config" parameter
226  + Medium: RA: iSCSITarget: follow changed IET access policy
227
228* Wed Apr 21 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.11-1
229- new upstream release
230  Resolves: rhbz#583945, rhbz#581047, rhbz#576330, rhbz#583017
231  Resolves: rhbz#583019, rhbz#583948, rhbz#584003, rhbz#582017
232  Resolves: rhbz#555901, rhbz#582754, rhbz#582573, rhbz#581533
233- Switch to file based Requires.
234  Also address several other problems related to missing runtime
235  components in different agents.
236  With the current Requires: set, we guarantee all basic functionalities
237  out of the box for lvm/fs/clusterfs/netfs/networking.
238  Resolves: rhbz#570008
239
240* Sat Apr 17 2010 Andrew Beekhof <andrew@beekhof.net> - 3.0.10-2
241- New pacemaker agents upstream release
242  + High: RA: vmware: fix set_environment() invocation (LF 2342)
243  + High: RA: vmware: update to version 0.2
244  + Medium: Filesystem: prefer /proc/mounts to /etc/mtab for non-bind mounts (lf#2388)
245  + Medium: IPaddr2: don't bring the interface down on stop (thanks to Lars Ellenberg)
246  + Medium: IPsrcaddr: modify the interface route (lf#2367)
247  + Medium: ldirectord: Allow multiple email addresses (LF 2168)
248  + Medium: ldirectord: fix setting defaults for configfile and ldirectord (lf#2328)
249  + Medium: meta-data: improve timeouts in most resource agents
250  + Medium: nfsserver: use default values (lf#2321)
251  + Medium: ocf-shellfuncs: don't log but print to stderr if connected to a terminal
252  + Medium: ocf-shellfuncs: don't output to stderr if using syslog
253  + Medium: oracle/oralsnr: improve exit codes if the environment isn't valid
254  + Medium: RA: iSCSILogicalUnit: fix monitor for STGT
255  + Medium: RA: make sure that OCF_RESKEY_CRM_meta_interval is always defined (LF 2284)
256  + Medium: RA: ManageRAID: require bash
257  + Medium: RA: ManageRAID: require bash
258  + Medium: RA: VirtualDomain: bail out early if config file can't be read during probe (Novell 593988)
259  + Medium: RA: VirtualDomain: fix incorrect use of __OCF_ACTION
260  + Medium: RA: VirtualDomain: improve error messages
261  + Medium: RA: VirtualDomain: spin on define until we definitely have a domain name
262  + Medium: Route: add route table parameter (lf#2335)
263  + Medium: sfex: don't use pid file (lf#2363,bnc#585416)
264  + Medium: sfex: exit with success on stop if sfex has never been started (bnc#585416)
265
266* Fri Apr  9 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.10-1
267- New rgmanager resource agents upstream release
268  Resolves: rhbz#519491, rhbz#570525, rhbz#571806, rhbz#574027
269  Resolves: rhbz#574215, rhbz#574886, rhbz#576322, rhbz#576335
270  Resolves: rhbz#575103, rhbz#577856, rhbz#577874, rhbz#578249
271  Resolves: rhbz#578625, rhbz#578626, rhbz#578628, rhbz#578626
272  Resolves: rhbz#579621, rhbz#579623, rhbz#579625, rhbz#579626
273  Resolves: rhbz#579059
274
275* Wed Mar 24 2010 Andrew Beekhof <andrew@beekhof.net> - 3.0.9-2
276- Resolves: rhbz#572993 - Patched build process to correctly generate ldirectord man page
277- Resolves: rhbz#574732 - Add libnet-devel as a dependancy to ensure IPaddrv6 is built
278
279* Mon Mar  1 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.9-1
280- New rgmanager resource agents upstream release
281  Resolves: rhbz#455300, rhbz#568446, rhbz#561862, rhbz#536902
282  Resolves: rhbz#512171, rhbz#519491
283
284* Mon Feb 22 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.8-1
285- New rgmanager resource agents upstream release
286  Resolves: rhbz#548133, rhbz#565907, rhbz#545602, rhbz#555901
287  Resolves: rhbz#564471, rhbz#515717, rhbz#557128, rhbz#536157
288  Resolves: rhbz#455300, rhbz#561416, rhbz#562237, rhbz#537201
289  Resolves: rhbz#536962, rhbz#553383, rhbz#556961, rhbz#555363
290  Resolves: rhbz#557128, rhbz#455300, rhbz#557167, rhbz#459630
291  Resolves: rhbz#532808, rhbz#556603, rhbz#554968, rhbz#555047
292  Resolves: rhbz#554968, rhbz#555047
293- spec file update:
294  * update spec file copyright date
295  * use bz2 tarball
296
297* Fri Jan 15 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.7-2
298- Add python as BuildRequires
299
300* Mon Jan 11 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.7-1
301- New rgmanager resource agents upstream release
302  Resolves: rhbz#526286, rhbz#533461
303
304* Mon Jan 11 2010 Andrew Beekhof <andrew@beekhof.net> - 3.0.6-2
305- Update Pacameker agents to upstream version: c76b4a6eb576
306  + High: RA: VirtualDomain: fix forceful stop (LF 2283)
307  + High: apache: monitor operation of depth 10 for web applications (LF 2234)
308  + Medium: IPaddr2: CLUSTERIP/iptables rule not always inserted on failed monitor (LF 2281)
309  + Medium: RA: Route: improve validate (LF 2232)
310  + Medium: mark obsolete RAs as deprecated (LF 2244)
311  + Medium: mysql: escalate stop to KILL if regular shutdown doesn't work
312
313* Mon Dec 7 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.6-1
314- New rgmanager resource agents upstream release
315- spec file update:
316  * use global instead of define
317  * use new Source0 url
318  * use %name macro more aggressively
319
320* Mon Dec 7 2009 Andrew Beekhof <andrew@beekhof.net> - 3.0.5-2
321- Update Pacameker agents to upstream version: bc00c0b065d9
322  + High: RA: introduce OCF_FUNCTIONS_DIR, allow it to be overridden (LF2239)
323  + High: doc: add man pages for all RAs (LF2237)
324  + High: syslog-ng: new RA
325  + High: vmware: make meta-data work and several cleanups (LF 2212)
326  + Medium: .ocf-shellfuncs: add ocf_is_probe function
327  + Medium: Dev: make RAs executable (LF2239)
328  + Medium: IPv6addr: ifdef out the ip offset hack for libnet v1.1.4 (LF 2034)
329  + Medium: add mercurial repository version information to .ocf-shellfuncs
330  + Medium: build: add perl-MailTools runtime dependency to ldirectord package (LF 1469)
331  + Medium: iSCSITarget, iSCSILogicalUnit: support LIO
332  + Medium: nfsserver: use check_binary properly in validate (LF 2211)
333  + Medium: nfsserver: validate should not check if nfs_shared_infodir exists (thanks to eelco@procolix.com) (LF 2219)
334  + Medium: oracle/oralsnr: export variables properly
335  + Medium: pgsql: remove the previous backup_label if it exists
336  + Medium: postfix: fix double stop (thanks to Dinh N. Quoc)
337  + RA: LVM: Make monitor operation quiet in logs (bnc#546353)
338  + RA: Xen: Remove instance_attribute "allow_migrate" (bnc#539968)
339  + ldirectord: OCF agent: overhaul
340
341* Fri Nov 20 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.5-1
342- New rgmanager resource agents upstream release
343- Allow pacemaker to use rgmanager resource agents
344
345* Wed Oct 28 2009 Andrew Beekhof <andrew@beekhof.net> - 3.0.4-2
346- Update Pacameker agents to upstream version: e2338892f59f
347  + High: send_arp - turn on unsolicited mode for compatibilty with the libnet version's exit codes
348  + High: Trap sigterm for compatibility with the libnet version of send_arp
349  + Medium: Bug - lf#2147: IPaddr2: behave if the interface is down
350  + Medium: IPv6addr: recognize network masks properly
351  + Medium: RA: VirtualDomain: avoid needlessly invoking "virsh define"
352
353* Wed Oct 21 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.4-1
354- New rgmanager resource agents upstream release
355
356* Mon Oct 12 2009 Andrew Beekhof <andrew@beekhof.net> - 3.0.3-3
357- Update Pacameker agents to upstream version: 099c0e5d80db
358  + Add the ha_parameter function back into .ocf-shellfuncs.
359  + Bug bnc#534803 - Provide a default for MAILCMD
360  + Fix use of undefined macro @HA_NOARCHDATAHBDIR@
361  + High (LF 2138): IPsrcaddr: replace 0/0 with proper ip prefix (thanks to Michael Ricordeau and Michael Schwartzkopff)
362  + Import shellfuncs from heartbeat as badly written RAs use it
363  + Medium (LF 2173): nfsserver: exit properly in nfsserver_validate
364  + Medium: RA: Filesystem: implement monitor operation
365  + Medium: RA: VirtualDomain: loop on status if libvirtd is unreachable
366  + Medium: RA: VirtualDomain: loop on status if libvirtd is unreachable (addendum)
367  + Medium: RA: iSCSILogicalUnit: use a 16-byte default SCSI ID
368  + Medium: RA: iSCSITarget: be more persistent deleting targets on stop
369  + Medium: RA: portblock: add per-IP filtering capability
370  + Medium: mysql-proxy: log_level and keepalive parameters
371  + Medium: oracle: drop spurious output from sqlplus
372  + RA: Filesystem: allow configuring smbfs mounts as clones
373
374* Wed Sep 23 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.3-1
375- New rgmanager resource agents upstream release
376
377* Thu Aug 20 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.1-1
378- New rgmanager resource agents upstream release
379
380* Tue Aug 18 2009 Andrew Beekhof <andrew@beekhof.net> - 3.0.0-16
381- Create an ldirectord package
382- Update Pacameker agents to upstream version: 2198dc90bec4
383  + Build: Import ldirectord.
384  + Ensure HA_VARRUNDIR has a value to substitute
385  + High: Add findif tool (mandatory for IPaddr/IPaddr2)
386  + High: IPv6addr: new nic and cidr_netmask parameters
387  + High: postfix: new resource agent
388  + Include license information
389  + Low (LF 2159): Squid: make the regexp match more precisely output of netstat
390  + Low: configure: Fix package name.
391  + Low: ldirectord: add dependency on $remote_fs.
392  + Low: ldirectord: add mandatory required header to init script.
393  + Medium (LF 2165): IPaddr2: remove all colons from the mac address before passing it to send_arp
394  + Medium: VirtualDomain: destroy domain shortly before timeout expiry
395  + Medium: shellfuncs: Make the mktemp wrappers work.
396  + Remove references to Echo function
397  + Remove references to heartbeat shellfuncs.
398  + Remove useless path lookups
399  + findif: actually include the right header. Simplify configure.
400  + ldirectord: Remove superfluous configure artifact.
401  + ocf-tester: Fix package reference and path to DTD.
402
403* Tue Aug 11 2009 Ville Skyttä <ville.skytta@iki.fi> - 3.0.0-15
404- Use bzipped upstream hg tarball.
405
406* Wed Jul 29 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-14
407- Merge Pacemaker cluster resource agents:
408  * Add Source1.
409  * Drop noarch. We have real binaries now.
410  * Update BuildRequires.
411  * Update all relevant prep/build/install/files/description sections.
412
413* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.0-13
414- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
415
416* Wed Jul  8 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-12
417- spec file updates:
418  * Update copyright header
419  * final release.. undefine alphatag
420
421* Thu Jul  2 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-11.rc4
422- New upstream release.
423
424* Sat Jun 20 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-10.rc3
425- New upstream release.
426
427* Wed Jun 10 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-9.rc2
428- New upstream release + git94df30ca63e49afb1e8aeede65df8a3e5bcd0970
429
430* Tue Mar 24 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-8.rc1
431- New upstream release.
432- Update BuildRoot usage to preferred versions/names
433
434* Mon Mar  9 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-7.beta1
435- New upstream release.
436
437* Fri Mar  6 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-6.alpha7
438- New upstream release.
439
440* Tue Mar  3 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-5.alpha6
441- New upstream release.
442
443* Tue Feb 24 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-4.alpha5
444- Drop Conflicts with rgmanager.
445
446* Mon Feb 23 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-3.alpha5
447- New upstream release.
448
449* Thu Feb 19 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-2.alpha4
450- Add comments on how to build this package.
451
452* Thu Feb  5 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-1.alpha4
453- New upstream release.
454- Fix datadir/cluster directory ownership.
455
456* Tue Jan 27 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-1.alpha3
457  - Initial packaging
Note: See TracBrowser for help on using the repository browser.