source: projects/specs/trunk/r/resource-agents/resource-agents-vl.spec @ 9394

Revision 9394, 18.1 KB checked in by inagaki, 9 years ago (diff)

2015-02-28 Ryoichi INAGAKI <ryo1@…>

  • corosync, pacemaker, resoure-agents: updated
  • libqb, perl-Net-IAMP-Simple-SSL: new


Line 
1# determine the ras-set to process based on configure invokation
2%bcond_with    rgmanager
3%bcond_without linuxha
4
5Name:           resource-agents
6Summary:        Open Source HA Reusable Cluster Resource Scripts
7Version:        3.9.6
8Release:        1%{?_dist_release}
9License:        GPLv3+ and LGPLv2+
10Group:          System Environment/Base
11URL:            https://github.com/ClusterLabs/resource-agents
12
13Source0:        https://github.com/ClusterLabs/%{name}/archive/v%{version}.tar.gz
14
15## Setup/build bits
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
17# Build dependencies
18BuildRequires:  automake autoconf pkgconfig
19BuildRequires:  perl python-devel
20BuildRequires:  libxslt glib2-devel
21BuildRequires:  which
22#BuildRequires: cluster-glue-libs-devel
23BuildRequires:  docbook-style-xsl docbook-dtds
24BuildRequires:  libnet-devel
25
26## Runtime deps
27# system tools shared by several agents
28## These apply to rgmanager agents only to guarantee agents
29## are functional
30%if %{with rgmanager}
31# system tools shared by several agents
32Requires: bash grep sed gawk
33Requires: procps net-tools
34Requires: psmisc
35Requires: util-linux
36
37# fs.sh
38Requires: quota
39Requires: util-linux-ng
40Requires: e2fsprogs
41Requires: xfsprogs
42
43# ip.sh
44Requires: iproute ethtool
45Requires: iputils
46
47# lvm.sh
48Requires: lvm2
49
50# netfs.sh
51Requires: nfs-utils samba-client
52%endif
53
54Obsoletes:      heartbeat-resources <= %{version}
55Provides:       heartbeat-resources = %{version}
56
57%description
58A set of scripts to interface with several services to operate in a
59High Availability environment for both Pacemaker and rgmanager
60service managers.
61
62%if %{with linuxha}
63%package -n ldirectord
64Summary:        Monitor daemon for maintaining high availability resources
65Group:          System Environment/Daemons
66License:        GPLv2+
67Requires:       perl-Net-SSLeay perl-libwww-perl perl-MailTools
68Requires:       perl-Net-IMAP-Simple-SSL
69Requires:       ipvsadm logrotate
70Requires(post): /sbin/chkconfig
71Requires(preun):/sbin/chkconfig
72Obsoletes:      heartbeat-ldirectord <= %{version}
73Provides:       heartbeat-ldirectord = %{version}
74
75%description -n ldirectord
76The Linux Director Daemon (ldirectord) was written by Jacob Rief.
77<jacob.rief@tiscover.com>
78
79ldirectord is a stand alone daemon for monitoring the services on real
80servers. Currently, HTTP, HTTPS, and FTP services are supported.
81lditrecord is simple to install and works with the heartbeat code
82(http://www.linux-ha.org/).
83
84See 'ldirectord -h' and linux-ha/doc/ldirectord for more information.
85%endif
86
87%prep
88%setup -q -n %{name}-%{version}
89
90# prepare rgmanager RAs
91#configure \
92#  --sbindir=%{_sbindir} \
93#  --initddir=%{_sysconfdir}/rc.d/init.d \
94#  --libdir=%{_libdir} \
95#  --without_fence_agents \
96#  --disable_kernel_check
97
98# prepare pacemaker RAs
99#cd %{altprefix}%{altversion}
100#./autogen.sh
101#configure --enable-fatal-warnings=no --with-rsctmpdir=%{_var}/run/heartbeat/rsctmp
102
103%build
104if [ ! -f configure ]; then
105        ./autogen.sh
106fi
107
108%if %{with rgmanager}
109%global rasset rgmanager
110%endif
111%if %{with linuxha}
112%global rasset linux-ha
113%endif
114%if %{with rgmanager} && %{with linuxha}
115%global rasset all
116%endif
117
118%configure \
119    --enable-fatal-warnings=no \
120    --with-version=%{version} \
121    --with-pkg-name=%{name} \
122    --with-initdir=%{_initdir} \
123    --with-ras-set=%{rasset}
124
125make %{?_smp_mflags}
126
127%install
128rm -rf %{buildroot}
129make install DESTDIR=%{buildroot}
130
131# tree fixup
132# remove docs (there is only one and they should come from doc sections in files)
133rm -rf %{buildroot}/usr/share/doc/resource-agents
134
135%if %{with rgmanager}
136# symlink to allow pacemaker to use rgmanager RAs
137cd %{buildroot}/usr/lib/ocf/resource.d/ && \
138    ln -sf %{_datadir}/cluster/ vine
139
140# remove symlink named redhat
141rm -f %{buildroot}/usr/lib/ocf/resource.d/redhat
142%endif
143
144%clean
145rm -rf %{buildroot}
146
147
148%if %{with rgmanager}
149%post -n resource-agents
150ccs_update_schema > /dev/null 2>&1 ||:
151%endif
152
153%if %{with linuxha}
154%post -n ldirectord
155/sbin/chkconfig --add ldirectord
156
157%postun -n ldirectord -p /sbin/ldconfig
158
159%preun -n ldirectord
160/sbin/chkconfig --del ldirectord
161%endif
162
163%files
164%defattr(-,root,root,-)
165%doc AUTHORS COPYING COPYING.GPLv3 ChangeLog
166%if %{with linuxha}
167%doc doc/README.webapps
168%doc %{_datadir}/%{name}/ra-api-1.dtd
169%endif
170
171%if %{with rgmanager}
172%{_datadir}/cluster
173%{_sbindir}/rhev-check.sh
174%endif
175
176%if %{with linuxha}
177%dir /usr/lib/ocf
178%dir /usr/lib/ocf/resource.d
179%dir /usr/lib/ocf/lib
180/usr/lib/ocf/lib/heartbeat
181/usr/lib/ocf/resource.d/heartbeat
182%if %{with rgmanager}
183/usr/lib/ocf/resource.d/vine
184%endif
185%dir %{_datadir}/%{name}
186%dir %{_datadir}/%{name}/ocft
187%{_datadir}/%{name}/ocft/configs
188%{_datadir}/%{name}/ocft/caselib
189%{_datadir}/%{name}/ocft/README
190%{_datadir}/%{name}/ocft/README.zh_CN
191%{_sbindir}/ocf-tester
192%{_sbindir}/ocft
193%{_includedir}/heartbeat
194%dir %attr (1755, root, root)   %{_var}/run/resource-agents
195%{_mandir}/man7/*.7*
196%{_mandir}/man8/ocf-tester.8*
197# For compatability with pre-existing agents
198%dir %{_sysconfdir}/ha.d
199%{_sysconfdir}/ha.d/shellfuncs
200%{_libexecdir}/heartbeat
201%endif
202
203%if %{with linuxha}
204%files -n ldirectord
205%defattr(-,root,root,-)
206%{_sbindir}/ldirectord
207%doc ldirectord/ldirectord.cf COPYING
208%config(noreplace) %{_sysconfdir}/logrotate.d/ldirectord
209%dir %{_sysconfdir}/ha.d
210%dir %{_sysconfdir}/ha.d/resource.d
211%{_sysconfdir}/ha.d/resource.d/ldirectord
212%{_initdir}/ldirectord
213/usr/lib/ocf/resource.d/heartbeat/ldirectord
214%{_mandir}/man8/ldirectord.8*
215%endif
216
217
218%changelog
219* Thu Feb 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.9.6-1
220- updated to 3.9.6
221- added R: perl-Net-IMAP-Simple-SSL to ldirectord
222
223* Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.13-1
224- initial build for Vine Linux
225
226* Mon Jun  7 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.13-1
227- new upstream release
228  Resolves: rhbz#592103, rhbz#593108, rhbz#578617, rhbz#594626
229  Resolves: rhbz#594511, rhbz#596046, rhbz#594111, rhbz#597002
230  Resolves: rhbz#599643
231
232* Tue May 18 2010 Andrew Beekhof <andrew@beekhof.net> - 3.0.12-2
233- libnet is not available on RHEL
234- Do not package ldirectord on RHEL
235  Resolves: rhbz#577264
236
237* Mon May 10 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.12-1
238- new upstream release
239  Resolves: rhbz#585217, rhbz#586100, rhbz#581533, rhbz#582753
240  Resolves: rhbz#582754, rhbz#585083, rhbz#587079, rhbz#588890
241  Resolves: rhbz#588925, rhbz#583789, rhbz#589131, rhbz#588010
242  Resolves: rhbz#576871, rhbz#576871, rhbz#590000, rhbz#589823
243
244* Mon May 10 2010 Andrew Beekhof <andrew@beekhof.net> - 3.0.12-1
245- New pacemaker agents upstream release: a7c0f35916bf
246  + High: pgsql: properly implement pghost parameter
247  + High: RA: mysql: fix syntax error
248  + High: SAPInstance RA: do not rely on op target rc when monitoring clones (lf#2371)
249  + High: set the HA_RSCTMP directory to /var/run/resource-agents (lf#2378)
250  + Medium: IPaddr/IPaddr2: add a description of the assumption in meta-data
251  + Medium: IPaddr: return the correct code if interface delete failed
252  + Medium: nfsserver: rpc.statd as the notify cmd does not work with -v (thanks to Carl Lewis)
253  + Medium: oracle: reduce output from sqlplus to the last line for queries (bnc#567815)
254  + Medium: pgsql: implement "config" parameter
255  + Medium: RA: iSCSITarget: follow changed IET access policy
256
257* Wed Apr 21 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.11-1
258- new upstream release
259  Resolves: rhbz#583945, rhbz#581047, rhbz#576330, rhbz#583017
260  Resolves: rhbz#583019, rhbz#583948, rhbz#584003, rhbz#582017
261  Resolves: rhbz#555901, rhbz#582754, rhbz#582573, rhbz#581533
262- Switch to file based Requires.
263  Also address several other problems related to missing runtime
264  components in different agents.
265  With the current Requires: set, we guarantee all basic functionalities
266  out of the box for lvm/fs/clusterfs/netfs/networking.
267  Resolves: rhbz#570008
268
269* Sat Apr 17 2010 Andrew Beekhof <andrew@beekhof.net> - 3.0.10-2
270- New pacemaker agents upstream release
271  + High: RA: vmware: fix set_environment() invocation (LF 2342)
272  + High: RA: vmware: update to version 0.2
273  + Medium: Filesystem: prefer /proc/mounts to /etc/mtab for non-bind mounts (lf#2388)
274  + Medium: IPaddr2: don't bring the interface down on stop (thanks to Lars Ellenberg)
275  + Medium: IPsrcaddr: modify the interface route (lf#2367)
276  + Medium: ldirectord: Allow multiple email addresses (LF 2168)
277  + Medium: ldirectord: fix setting defaults for configfile and ldirectord (lf#2328)
278  + Medium: meta-data: improve timeouts in most resource agents
279  + Medium: nfsserver: use default values (lf#2321)
280  + Medium: ocf-shellfuncs: don't log but print to stderr if connected to a terminal
281  + Medium: ocf-shellfuncs: don't output to stderr if using syslog
282  + Medium: oracle/oralsnr: improve exit codes if the environment isn't valid
283  + Medium: RA: iSCSILogicalUnit: fix monitor for STGT
284  + Medium: RA: make sure that OCF_RESKEY_CRM_meta_interval is always defined (LF 2284)
285  + Medium: RA: ManageRAID: require bash
286  + Medium: RA: ManageRAID: require bash
287  + Medium: RA: VirtualDomain: bail out early if config file can't be read during probe (Novell 593988)
288  + Medium: RA: VirtualDomain: fix incorrect use of __OCF_ACTION
289  + Medium: RA: VirtualDomain: improve error messages
290  + Medium: RA: VirtualDomain: spin on define until we definitely have a domain name
291  + Medium: Route: add route table parameter (lf#2335)
292  + Medium: sfex: don't use pid file (lf#2363,bnc#585416)
293  + Medium: sfex: exit with success on stop if sfex has never been started (bnc#585416)
294
295* Fri Apr  9 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.10-1
296- New rgmanager resource agents upstream release
297  Resolves: rhbz#519491, rhbz#570525, rhbz#571806, rhbz#574027
298  Resolves: rhbz#574215, rhbz#574886, rhbz#576322, rhbz#576335
299  Resolves: rhbz#575103, rhbz#577856, rhbz#577874, rhbz#578249
300  Resolves: rhbz#578625, rhbz#578626, rhbz#578628, rhbz#578626
301  Resolves: rhbz#579621, rhbz#579623, rhbz#579625, rhbz#579626
302  Resolves: rhbz#579059
303
304* Wed Mar 24 2010 Andrew Beekhof <andrew@beekhof.net> - 3.0.9-2
305- Resolves: rhbz#572993 - Patched build process to correctly generate ldirectord man page
306- Resolves: rhbz#574732 - Add libnet-devel as a dependancy to ensure IPaddrv6 is built
307
308* Mon Mar  1 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.9-1
309- New rgmanager resource agents upstream release
310  Resolves: rhbz#455300, rhbz#568446, rhbz#561862, rhbz#536902
311  Resolves: rhbz#512171, rhbz#519491
312
313* Mon Feb 22 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.8-1
314- New rgmanager resource agents upstream release
315  Resolves: rhbz#548133, rhbz#565907, rhbz#545602, rhbz#555901
316  Resolves: rhbz#564471, rhbz#515717, rhbz#557128, rhbz#536157
317  Resolves: rhbz#455300, rhbz#561416, rhbz#562237, rhbz#537201
318  Resolves: rhbz#536962, rhbz#553383, rhbz#556961, rhbz#555363
319  Resolves: rhbz#557128, rhbz#455300, rhbz#557167, rhbz#459630
320  Resolves: rhbz#532808, rhbz#556603, rhbz#554968, rhbz#555047
321  Resolves: rhbz#554968, rhbz#555047
322- spec file update:
323  * update spec file copyright date
324  * use bz2 tarball
325
326* Fri Jan 15 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.7-2
327- Add python as BuildRequires
328
329* Mon Jan 11 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.7-1
330- New rgmanager resource agents upstream release
331  Resolves: rhbz#526286, rhbz#533461
332
333* Mon Jan 11 2010 Andrew Beekhof <andrew@beekhof.net> - 3.0.6-2
334- Update Pacameker agents to upstream version: c76b4a6eb576
335  + High: RA: VirtualDomain: fix forceful stop (LF 2283)
336  + High: apache: monitor operation of depth 10 for web applications (LF 2234)
337  + Medium: IPaddr2: CLUSTERIP/iptables rule not always inserted on failed monitor (LF 2281)
338  + Medium: RA: Route: improve validate (LF 2232)
339  + Medium: mark obsolete RAs as deprecated (LF 2244)
340  + Medium: mysql: escalate stop to KILL if regular shutdown doesn't work
341
342* Mon Dec 7 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.6-1
343- New rgmanager resource agents upstream release
344- spec file update:
345  * use global instead of define
346  * use new Source0 url
347  * use %name macro more aggressively
348
349* Mon Dec 7 2009 Andrew Beekhof <andrew@beekhof.net> - 3.0.5-2
350- Update Pacameker agents to upstream version: bc00c0b065d9
351  + High: RA: introduce OCF_FUNCTIONS_DIR, allow it to be overridden (LF2239)
352  + High: doc: add man pages for all RAs (LF2237)
353  + High: syslog-ng: new RA
354  + High: vmware: make meta-data work and several cleanups (LF 2212)
355  + Medium: .ocf-shellfuncs: add ocf_is_probe function
356  + Medium: Dev: make RAs executable (LF2239)
357  + Medium: IPv6addr: ifdef out the ip offset hack for libnet v1.1.4 (LF 2034)
358  + Medium: add mercurial repository version information to .ocf-shellfuncs
359  + Medium: build: add perl-MailTools runtime dependency to ldirectord package (LF 1469)
360  + Medium: iSCSITarget, iSCSILogicalUnit: support LIO
361  + Medium: nfsserver: use check_binary properly in validate (LF 2211)
362  + Medium: nfsserver: validate should not check if nfs_shared_infodir exists (thanks to eelco@procolix.com) (LF 2219)
363  + Medium: oracle/oralsnr: export variables properly
364  + Medium: pgsql: remove the previous backup_label if it exists
365  + Medium: postfix: fix double stop (thanks to Dinh N. Quoc)
366  + RA: LVM: Make monitor operation quiet in logs (bnc#546353)
367  + RA: Xen: Remove instance_attribute "allow_migrate" (bnc#539968)
368  + ldirectord: OCF agent: overhaul
369
370* Fri Nov 20 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.5-1
371- New rgmanager resource agents upstream release
372- Allow pacemaker to use rgmanager resource agents
373
374* Wed Oct 28 2009 Andrew Beekhof <andrew@beekhof.net> - 3.0.4-2
375- Update Pacameker agents to upstream version: e2338892f59f
376  + High: send_arp - turn on unsolicited mode for compatibilty with the libnet version's exit codes
377  + High: Trap sigterm for compatibility with the libnet version of send_arp
378  + Medium: Bug - lf#2147: IPaddr2: behave if the interface is down
379  + Medium: IPv6addr: recognize network masks properly
380  + Medium: RA: VirtualDomain: avoid needlessly invoking "virsh define"
381
382* Wed Oct 21 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.4-1
383- New rgmanager resource agents upstream release
384
385* Mon Oct 12 2009 Andrew Beekhof <andrew@beekhof.net> - 3.0.3-3
386- Update Pacameker agents to upstream version: 099c0e5d80db
387  + Add the ha_parameter function back into .ocf-shellfuncs.
388  + Bug bnc#534803 - Provide a default for MAILCMD
389  + Fix use of undefined macro @HA_NOARCHDATAHBDIR@
390  + High (LF 2138): IPsrcaddr: replace 0/0 with proper ip prefix (thanks to Michael Ricordeau and Michael Schwartzkopff)
391  + Import shellfuncs from heartbeat as badly written RAs use it
392  + Medium (LF 2173): nfsserver: exit properly in nfsserver_validate
393  + Medium: RA: Filesystem: implement monitor operation
394  + Medium: RA: VirtualDomain: loop on status if libvirtd is unreachable
395  + Medium: RA: VirtualDomain: loop on status if libvirtd is unreachable (addendum)
396  + Medium: RA: iSCSILogicalUnit: use a 16-byte default SCSI ID
397  + Medium: RA: iSCSITarget: be more persistent deleting targets on stop
398  + Medium: RA: portblock: add per-IP filtering capability
399  + Medium: mysql-proxy: log_level and keepalive parameters
400  + Medium: oracle: drop spurious output from sqlplus
401  + RA: Filesystem: allow configuring smbfs mounts as clones
402
403* Wed Sep 23 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.3-1
404- New rgmanager resource agents upstream release
405
406* Thu Aug 20 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.1-1
407- New rgmanager resource agents upstream release
408
409* Tue Aug 18 2009 Andrew Beekhof <andrew@beekhof.net> - 3.0.0-16
410- Create an ldirectord package
411- Update Pacameker agents to upstream version: 2198dc90bec4
412  + Build: Import ldirectord.
413  + Ensure HA_VARRUNDIR has a value to substitute
414  + High: Add findif tool (mandatory for IPaddr/IPaddr2)
415  + High: IPv6addr: new nic and cidr_netmask parameters
416  + High: postfix: new resource agent
417  + Include license information
418  + Low (LF 2159): Squid: make the regexp match more precisely output of netstat
419  + Low: configure: Fix package name.
420  + Low: ldirectord: add dependency on $remote_fs.
421  + Low: ldirectord: add mandatory required header to init script.
422  + Medium (LF 2165): IPaddr2: remove all colons from the mac address before passing it to send_arp
423  + Medium: VirtualDomain: destroy domain shortly before timeout expiry
424  + Medium: shellfuncs: Make the mktemp wrappers work.
425  + Remove references to Echo function
426  + Remove references to heartbeat shellfuncs.
427  + Remove useless path lookups
428  + findif: actually include the right header. Simplify configure.
429  + ldirectord: Remove superfluous configure artifact.
430  + ocf-tester: Fix package reference and path to DTD.
431
432* Tue Aug 11 2009 Ville Skyttä <ville.skytta@iki.fi> - 3.0.0-15
433- Use bzipped upstream hg tarball.
434
435* Wed Jul 29 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-14
436- Merge Pacemaker cluster resource agents:
437  * Add Source1.
438  * Drop noarch. We have real binaries now.
439  * Update BuildRequires.
440  * Update all relevant prep/build/install/files/description sections.
441
442* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.0-13
443- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
444
445* Wed Jul  8 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-12
446- spec file updates:
447  * Update copyright header
448  * final release.. undefine alphatag
449
450* Thu Jul  2 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-11.rc4
451- New upstream release.
452
453* Sat Jun 20 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-10.rc3
454- New upstream release.
455
456* Wed Jun 10 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-9.rc2
457- New upstream release + git94df30ca63e49afb1e8aeede65df8a3e5bcd0970
458
459* Tue Mar 24 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-8.rc1
460- New upstream release.
461- Update BuildRoot usage to preferred versions/names
462
463* Mon Mar  9 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-7.beta1
464- New upstream release.
465
466* Fri Mar  6 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-6.alpha7
467- New upstream release.
468
469* Tue Mar  3 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-5.alpha6
470- New upstream release.
471
472* Tue Feb 24 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-4.alpha5
473- Drop Conflicts with rgmanager.
474
475* Mon Feb 23 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-3.alpha5
476- New upstream release.
477
478* Thu Feb 19 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-2.alpha4
479- Add comments on how to build this package.
480
481* Thu Feb  5 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-1.alpha4
482- New upstream release.
483- Fix datadir/cluster directory ownership.
484
485* Tue Jan 27 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-1.alpha3
486  - Initial packaging
Note: See TracBrowser for help on using the repository browser.