source: projects/specs/branches/6/p/python-virtualenv/python-virtualenv-vl.spec @ 2228

Revision 2228, 4.5 KB checked in by owa, 13 years ago (diff)

new upstream

Line 
1%global oname virtualenv
2
3Summary:        Tool to create isolated Python environments
4Summary(ja):    隔離されたPython環境を構築するためのツール
5Name:           python-%{oname}
6Version:        1.5.1
7Release:        1%{?_dist_release}
8
9Group:          Development/Languages
10License:        MIT
11URL:            http://pypi.python.org/pypi/%{oname}
12Source0:        http://pypi.python.org/packages/source/v/%{oname}/%{oname}-%{version}.tar.gz
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
14
15BuildArch:      noarch
16BuildRequires:  python-devel
17Requires:       python-setuptools, python-devel
18
19BuildRequires:  python-setuptools
20Requires:       python-setuptools
21
22
23%description
24virtualenv is a tool to create isolated Python environments. virtualenv
25is a successor to workingenv, and an extension of virtual-python. It is
26written by Ian Bicking, and sponsored by the Open Planning Project. It is
27licensed under an MIT-style permissive license.
28
29
30%prep
31%setup -q -n %{oname}-%{version}
32%{__sed} -i -e "1s|#!/usr/bin/env python||" virtualenv.py
33
34
35%build
36%{__python} setup.py build
37
38
39%install
40rm -rf $RPM_BUILD_ROOT
41%{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
42
43 
44%clean
45rm -rf $RPM_BUILD_ROOT
46
47
48%files
49%defattr(-,root,root,-)
50%doc docs/index.txt docs/license.txt docs/news.txt PKG-INFO
51# For noarch packages: sitelib
52%{python_sitelib}/*
53%attr(755,root,root) %{_bindir}/virtualenv
54
55
56%changelog
57* Mon Nov 22 2010 Shu KONNO <owa@bg.wakwak.com> 1.5.1-1
58- updated virtualenv to 1.5.1
59
60* Sat Sep 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.8-1
61- initial build for Vine Linux
62
63* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.4.8-4
64- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
65
66* Tue Jul  7 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.8-3
67- Fixed EPEL installation issue from BZ#611536
68
69* Tue Jun  8 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.8-2
70- Only replace the python shebang on the first line (Robert Buchholz)
71
72* Fri Apr 28 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.8-1
73- update pip to 0.7
74- move regen-docs into bin/
75- Fix #31, make activate_this.py work on Windows (use Lib/site-packages)
76unset PYTHONHOME envioronment variable -- first step towards fixing the PYTHONHOME issue; see e.g. https://bugs.launchpad.net/virtualenv/+bug/290844
77- unset PYTHONHOME in the (Unix) activate script (and reset it in deactivate())
78- use the activate.sh in virtualenv.py via running bin/rebuild-script.py
79- add warning message if PYTHONHOME is set
80
81* Fri Apr 2 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.6-1
82- allow script creation without setuptools
83- fix problem with --relocate when bin/ has subdirs (fixes #12)
84- Allow more flexible .pth file fixup
85- make nt a required module, along with posix. it may not be a builtin module on jython
86- don't mess with PEP 302-supplied __file__, from CPython, and merge in a small startup optimization for Jython, from Jython
87
88* Tue Dec 22 2009 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.3-1
89- Updated for upstream release.
90
91* Thu Nov 12 2009 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.2-1
92- Updated for upstream release.
93
94* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.3-2
95- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
96
97* Tue Apr 28 2009 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.3-1
98- Updated for upstream release.
99
100* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.2-2
101- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
102
103* Thu Dec 25 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.2-1
104- Updated for upstream release.
105
106* Thu Dec 04 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.3.1-4
107- Rebuild for Python 2.6
108
109* Mon Dec  1 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.1-3
110- Added missing dependencies.
111
112* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.3.1-2
113- Rebuild for Python 2.6
114
115* Fri Nov 28 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.1-1
116- Updated for upstream release
117
118* Sun Sep 28 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3-1
119- Updated for upstream release
120
121* Sat Aug 30 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.2-1
122- Updated for upstream release
123
124* Fri Aug 29 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.1-3
125- Updated from review notes
126
127* Thu Aug 28 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.1-2
128- Updated from review notes
129
130* Tue Aug 26 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.1-1
131- Initial Version
Note: See TracBrowser for help on using the repository browser.