source: projects/specs/branches/6/p/python-sphinx/python-sphinx-vl.spec @ 3795

Revision 3795, 8.1 KB checked in by iwaim, 13 years ago (diff)

python-sphinx-1.0.7-1

Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
2
3%global upstream_name Sphinx
4
5Name:       python-sphinx
6Version:    1.0.7
7Release:    1%{?_dist_release}
8Summary:    Python documentation generator
9
10Group:      Development/Tools
11
12# Unless otherwise noted, the license for code is BSD
13# sphinx/util/stemmer.py Public Domain
14# sphinx/pycode/pgen2 Python
15# jquery (MIT or GPLv2)
16License: BSD and Public Domain and Python and (MIT or GPLv2)
17URL:        http://sphinx.pocoo.org/
18Source0:    http://pypi.python.org/packages/source/S/%{upstream_name}/%{upstream_name}-%{version}.tar.gz
19
20BuildRoot:     %{_tmppath}/%{name}-%{version}-%{release}-root
21BuildArch:     noarch
22BuildRequires: python-devel >= 2.4
23BuildRequires: python-setuptools
24%if %{?_dist_release} == "vl5"
25BuildRequires: python-simplejson
26BuildRequires: docutils
27%else
28BuildRequires: python-docutils
29%endif
30BuildRequires: python-jinja2
31BuildRequires: python-nose
32%if %{?_dist_release} == "vl5"
33Requires:      docutils
34%else
35Requires:      python-docutils
36%endif
37Requires:      python-jinja2
38Requires:      python-pygments
39
40Vendor: Project Vine
41Distribution: Vine Linux
42
43%description
44Sphinx is a tool that makes it easy to create intelligent and
45beautiful documentation for Python projects (or other documents
46consisting of multiple reStructuredText sources), written by Georg
47Brandl. It was originally created to translate the new Python
48documentation, but has now been cleaned up in the hope that it will be
49useful to many other projects.
50
51Sphinx uses reStructuredText as its markup language, and many of its
52strengths come from the power and straightforwardness of
53reStructuredText and its parsing and translating suite, the Docutils.
54
55Although it is still under constant development, the following
56features are already present, work fine and can be seen "in action" in
57the Python docs:
58
59    * Output formats: HTML (including Windows HTML Help) and LaTeX,
60      for printable PDF versions
61    * Extensive cross-references: semantic markup and automatic links
62      for functions, classes, glossary terms and similar pieces of
63      information
64    * Hierarchical structure: easy definition of a document tree, with
65      automatic links to siblings, parents and children
66    * Automatic indices: general index as well as a module index
67    * Code handling: automatic highlighting using the Pygments highlighter
68    * Various extensions are available, e.g. for automatic testing of
69      snippets and inclusion of appropriately formatted docstrings.
70
71
72%package doc
73Summary:    Documentation for %{name}
74Group:      Documentation
75License:    BSD
76Requires:   %{name} = %{version}-%{release}
77
78
79%description doc
80Sphinx is a tool that makes it easy to create intelligent and
81beautiful documentation for Python projects (or other documents
82consisting of multiple reStructuredText sources), written by Georg
83Brandl. It was originally created to translate the new Python
84documentation, but has now been cleaned up in the hope that it will be
85useful to many other projects.
86
87This package contains documentation in reST and HTML formats.
88
89
90%prep
91%setup -q -n %{upstream_name}-%{version}
92%__sed '1d' -i sphinx/pycode/pgen2/token.py
93
94%build
95%{__python} setup.py build
96pushd doc
97%__make html
98%__rm -rf _build/html/.buildinfo
99%__mv _build/html ..
100%__rm -rf _*
101popd
102
103
104%install
105%__rm -rf %{buildroot}
106
107%{__python} setup.py install --skip-build --root %{buildroot}
108
109
110# Manpages not in beta release yet
111#pushd doc
112# Deliver man pages
113#install -d %{buildroot}%{_mandir}/man1
114#mv sphinx-*.1 %{buildroot}%{_mandir}/man1/
115#popd
116
117# Deliver rst files
118%__mv doc reST
119
120# Move language files to /usr/share in association with %patch1
121pushd %{buildroot}%{python_sitelib}
122
123for lang in `find sphinx/locale -maxdepth 1 -mindepth 1 -type d -printf "%f "`;
124do
125  install -d %{buildroot}%{_datadir}/sphinx/locale/$lang
126  install -d %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES
127  %__mv sphinx/locale/$lang/LC_MESSAGES/sphinx.js \
128     %{buildroot}%{_datadir}/sphinx/locale/$lang/
129  %__mv sphinx/locale/$lang/LC_MESSAGES/sphinx.mo \
130    %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/
131  %__rm -rf sphinx/locale/$lang
132done
133popd
134%find_lang sphinx
135
136# Language files; Since these are javascript, it's not immediately obvious to
137# find_lang that they need to be marked with a language.
138(cd %{buildroot} && find . -name 'sphinx.js') | %__sed -e 's|^.||' | %__sed -e \
139  's:\(.*/locale/\)\([^/_]\+\)\(.*\.js$\):%lang(\2) \1\2\3:' \
140  >> sphinx.lang
141
142
143%clean
144%__rm -rf %{buildroot}
145
146
147%check
148%__make test
149
150
151%files -f sphinx.lang
152%defattr(-,root,root,-)
153%doc AUTHORS CHANGES EXAMPLES LICENSE README TODO
154%{_bindir}/sphinx-*
155%{python_sitelib}/*
156%{_datadir}/sphinx/
157%exclude %{_datadir}/sphinx/locale/*/sphinx.js
158#%{_mandir}/man1/*
159
160%files doc
161%defattr(-,root,root,-)
162%doc html reST
163
164
165%changelog
166* Thu May  5 2011 IWAI, Masaharu <iwai@alib.jp> 1.0.7-1
167- new upstream release
168- add BuildRequires: python-simplejson for Vine5
169- add Vendor and Distribution tags
170
171* Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.0.5-1
172- update sphinx to 1.0.5
173
174* Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-1.b2
175- initial build based on Fedora development
176
177* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.0-0.1.b2.1
178- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
179
180* Mon May 31 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 1.0-0.2.b2
181- Update to 1.0 beta 2
182- Fixes problem building html documentation in non-English locales
183
184* Wed May 26 2010 Michel Salim <salimma@fedoraproject.org> - 1.0-0.1.b1
185- Update to 1.0 beta 1
186
187* Tue May 25 2010 Michel Salim <salimma@fedoraproject.org> - 0.6.6-1
188- Update to 0.6.6
189
190* Fri May 21 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.5-2
191- Few minor tweaks to Gareth's spec file update
192
193* Mon May 10 2010 Gareth Armstrong <gareth.armstrong@hp.com> - 0.6.5-1.hp
194- Update to 0.6.5
195- Initial import of python-sphinx from Fedora Rawhide for use in HP CMS
196- Enforce that Sphinx requires Python 2.4 or later via an explicit BR
197- Minor tweaks to spec file
198- Move language files to %%{_datadir}, idea borrowed from Debian's sphinx
199  package
200- Deliver man pages for sphinx-build & sphinx-quickstart
201- Deliver rst documentation files to reST directory in doc sub-package
202- Add %%check section for Python2 and add BR on python-nose
203
204* Wed Jan 13 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.4-1
205- Update to 0.6.4
206- Fixes a problem using autodoc with pylons projects.
207
208* Fri Sep  4 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.3-1
209- Update to 0.6.3
210
211* Mon Aug 17 2009 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.2-1
212- Update to 0.6.2 -- upstream bugfix requested inside bz#512438
213
214* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.1-3
215- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
216
217* Fri Jun 05 2009 Luke Macken <lmacken@redhat.com> - 0.6.1-2
218- Add a patch to use our own setuptools package
219
220* Fri Apr 17 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1-1
221- Update to 0.6.1
222
223* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.1-2
224- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
225
226* Fri Jan  2 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.1-1
227- Update to 0.5.1
228
229* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.5-2
230- Rebuild for Python 2.6
231
232* Mon Nov 24 2008 Michel Salim <salimma@fedoraproject.org> - 0.5-1
233- Update to 0.5
234
235* Fri Oct 10 2008 Michel Salim <salimma@fedoraproject.org> - 0.4.3-1
236- Update to 0.4.3
237
238* Wed Aug 27 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 0.4.2-1.1
239- Fix for EL-5 build.
240
241* Mon Aug 25 2008 Michel Salim <salimma@fedoraproject.org> - 0.4.2-1
242- Update to 0.4.2
243
244* Mon May 26 2008 Michel Salim <salimma@fedoraproject.org> - 0.3-1
245- Update to 0.3
246
247* Fri May  2 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.61950-3
248- Split documentation into subpackage
249- Exclude C files (not built by default anyway)
250
251* Wed Apr 16 2008 José Matos <jamatos@fc.up.pt> - 0.1.61950-2
252- Build html documentation, include it and include the rst
253  documentation.
254
255* Thu Mar 27 2008 Michel Salim <michel.sylvan@gmail.com> 0.1.61950-1
256- Initial package
Note: See TracBrowser for help on using the repository browser.