source: projects/specs/branches/6/p/proftpd/proftpd-vl.spec @ 7422

Revision 7422, 14.0 KB checked in by iwamoto, 11 years ago (diff)

perl, proftpd, gnupg, freetype2, net-snmp update @ vine6

Line 
1%define _prefix         /usr
2%define _localstatedir  /var/run
3%define _sysconfdir     /etc
4%define _rundir         /var/run/proftpd
5%define tarballversion  1.3.3e
6%define origversion     1.3.3e
7
8Summary: ProFTPd -- Professional FTP Server.
9Summary(ja): ProFTPd -- プロフェッショナル FTP サーバ
10Name: proftpd
11Epoch: 1
12Version: %{origversion}
13Release: 3%{?_dist_release}
14License: GPL
15Group: System Environment/Daemons
16URL: http://www.proftpd.org/
17
18Source0: ftp://ftp.proftpd.org/distrib/%{name}-%{origversion}.tar.bz2
19Source1: proftpd.vine.conf
20Source2: ftpusers.vine
21Source3: proftpd.init
22Source5: welcome.msg
23
24# upstream bug fixes & security fixes
25
26# auth
27Patch201: proftpd-1.3.1-use-system-auth-instead-of-pam_pwdb.patch
28
29# iconv patch (CharsetLocal/CharsetRemote)
30# Patch300: http://www.hakusan.tsg.ne.jp/tjkawa/software/misc/proftpd-iconv/pack/proftpd-1.3.0-iconv.patch.gz
31Patch300: proftpd-1.3.3e-iconv.patch
32
33# fix build on recent kernel headers
34# Patch400: proftpd-1.3.1-umode.patch
35
36# security fix
37Patch1001: proftpd-1.3.3e-CVE-2011-4130.patch
38Patch1010: proftpd-1.3.3e_CVE-2012-6095.patch
39
40BuildRoot: %{_tmppath}/%{name}-%{version}-root
41BuildRequires: pam-devel, openldap-devel, openssl-devel
42BuildRequires: ncurses-devel, libcap-devel, libacl-devel
43BuildRequires: e2fsprogs-devel
44Requires: pam > 0.59
45Obsoletes: wu-ftpd, anonftp
46Provides: ftpserver
47
48Vendor: Project Vine
49Distribution: Vine Linux
50
51%description
52ProFTPd is an enhanced FTP server with a focus toward simplicity,
53security, and ease of configuration.  It features a very Apache-like
54configuration syntax, and a highly customizable server infrastructure,
55including support for multiple 'virtual' FTP servers, anonymous FTP,
56and permission-based directory visibility.
57
58%description -l ja
59ProFTPd は シンプルさ, セキュリティ, 設定の容易さに焦点をあてた 優れた
60FTP サーバです。Apache に似た構文による設定や、複数の仮想 FTP サーバ、
61anonymous FTP, パーミッションベースのディレクトリ可視性のサポートを含む、
62高度にカスタマイズ可能なサーバ・インターフェイスを特徴としています。
63
64%prep
65%setup -q -n %{name}-%{tarballversion}
66find . -type d -name CVS | xargs -r rm -frv
67
68# upstream fixes
69
70## patches from mdk
71# use system-auth instaed of pam_pwdb
72%patch201 -p1
73
74# iconv patch (CharsetLocal/CharsetRemote)
75%patch300 -p1
76
77# fix build on recent kernel headers
78# %patch400 -p0
79
80# security fixes
81%patch1001 -p1
82%patch1010 -p1 -b .CVE-2012-6095
83
84%build
85# Disable stripping in order to get useful debuginfo packages
86%{__perl} -pi -e 's|"-s"|""|g' configure
87
88%configure \
89    --libexecdir="%{_libexecdir}/proftpd" \
90    --localstatedir="%{_var}/run/proftpd" \
91    --enable-ctrls \
92    --enable-facl \
93    --enable-dso \
94    --enable-ipv6 \
95    --with-modules=mod_readme:mod_auth_pam:mod_tls:mod_codeconv:mod_df:\
96mod_ban:mod_dynmasq:mod_load:mod_ratio:mod_rewrite \
97    --with-shared=mod_ldap:mod_quotatab:mod_quotatab_file:mod_quotatab_ldap
98
99# It seems that with _smp_mflags -lsupp tries to get linked before being built
100# (as of 1.3.0a-4 F7/devel with koji, happened on F8 x86_64 and F7 ppc64)
101%{__make}
102
103
104%install
105%{__rm} -rf %{buildroot}
106%{__make} install DESTDIR=%{buildroot} \
107    rundir="%{_var}/run/proftpd" \
108    INSTALL_USER=`id -un` \
109    INSTALL_GROUP=`id -gn`
110
111# auth
112mkdir -p %{buildroot}%{_sysconfdir}/pam.d
113%{__install} -m 644 contrib/dist/rpm/ftp.pamd %{buildroot}%{_sysconfdir}/pam.d/ftp
114
115# logrotate
116mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d
117%{__install} -m 644 contrib/dist/rpm/proftpd.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/proftpd
118
119# init.d
120%{__install} -D -p -m 0755 %{SOURCE3} \
121    %{buildroot}%{_sysconfdir}/rc.d/init.d/proftpd
122
123%{__install} -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/proftpd.conf
124%{__install} -m 644 %{SOURCE2} %{buildroot}%{_sysconfdir}/ftpusers
125%{__install} -D -p -m 0644 %{SOURCE5} %{buildroot}/%{_var}/ftp/welcome.msg
126
127touch %{buildroot}%{_sysconfdir}/ftpusers
128
129rm contrib/README.* || :
130# eliminate executable bit in %doc
131find doc/ sample-configurations/ -type f -perm +111 | xargs -r chmod -x
132
133# remove .{la,a}
134rm -f %{buildroot}%{_libexecdir}/proftpd/*.{la,a}
135
136# remove development files (headers and pkgconfig file)
137# who need these files?
138rm -rf %{buildroot}%{_includedir}/proftpd
139rm -rf %{buildroot}%{_libdir}/pkgconfig
140
141%preun
142if [ -d %{_rundir} ] ; then
143        rm -rf %{_rundir}/*
144fi
145
146if [ $1 = 0 ] ; then
147        /sbin/chkconfig --del proftpd
148fi
149
150%postun
151if [ $1 -ge 1 ]; then
152    /sbin/service proftpd condrestart
153fi
154
155%post
156/sbin/chkconfig --add proftpd
157
158
159%clean
160rm -rf %{buildroot}
161
162%files
163%defattr(-,root,root)
164%doc COPYING CREDITS ChangeLog INSTALL NEWS
165%doc README.{LDAP,PAM,modules} doc/*
166%doc contrib/README contrib/xferstats.holger-preiss
167%doc sample-configurations/
168%{_sbindir}/*
169%{_bindir}/*
170%{_mandir}/*/*
171%{_var}/ftp/welcome.msg
172%dir %{_libexecdir}/proftpd/
173%{_libexecdir}/proftpd/mod_*
174%dir %{_rundir}
175%dir %{_var}/ftp
176%config %{_sysconfdir}/rc.d/init.d/proftpd
177%config(noreplace) %{_sysconfdir}/pam.d/ftp
178%config(noreplace) %{_sysconfdir}/proftpd.conf
179%config(noreplace) %{_sysconfdir}/ftpusers
180%config(noreplace) %{_sysconfdir}/logrotate.d/proftpd
181
182
183%changelog
184* Wed Jan 16 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.3e-3
185- add patch1010 for fix CVE-2012-6095 (MKD/XMKD) from deb.
186
187* Wed Dec 19 2012 IWAI, Masaharu <iwai@alib.jp> 1.3.3e-2
188- SECURITY FIX: CVE-2011-4130
189 - add CVE-2011-4130 patch (Patch1001): from Debian 1.3.3a-6squeeze4
190
191* Sun Apr 24 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.3e-1
192- new upstream release
193- update patch300 to fit new version
194- drop patch1000 (is included in new release)
195- add BR: e2fsprogs-devel
196
197* Wed Jan 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.2e-2
198- rebuild with openssl-1.0.0c
199
200* Fri Nov  5 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2e-1
201- new upstream release
202- add patch1000 for CVE-2010-4221 (TELNET_IAC)
203- add BRs: ncurses-devel, libcap-devel, libacl-devel
204
205* Mon Dec 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2c-1
206- new upstream release with security fix (CVE-2009-3555)
207
208* Wed Oct 21 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2b-1
209- new upstream release with security fix (NULL char in X.509 certificate)
210- add chkconfig --add in post script
211
212* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2a-3
213- remove .{la,a}
214- remove headers and pkgconfig file
215
216* Mon Jul  6 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2a-2
217- update Source1 (sample config file for vine)
218  set default char set to UTF-8
219
220* Fri Jul  3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2a-1
221- new upstream release
222
223* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-3
224- rebuild with openldap-2.4.11
225
226* Tue Mar 31 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2-2
227- built with openssl-0.9.8k
228
229* Sat Feb 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2-1
230- new upstream release
231- add configure option to activate new modules
232- drop patch400
233
234* Wed Jan 14 2009 Shu KONNO <owa@bg.wakwak.com> 1.3.1-6
235- built with openssl-0.9.8j
236
237* Mon Sep 22 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.1-5
238- built with openssl-0.9.8i
239
240* Sun Aug 10 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.1-4
241- add Patch400 to fix build failure at least on i386
242- spec in UTF-8
243
244* Tue Jul 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.1-3
245- built with openssl-0.9.8h
246
247* Sun Mar 23 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.1-2
248- update proftpd.vine.conf (use DisplayChdir instead of DisplayFirstChdir)
249
250* Sun Mar 23 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.1-1
251- new upstream release
252- drop old patches which are included in new release
253- update patch201, 300
254- build under new versioning policy
255
256* Mon Sep 10 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.0a-0vl1
257- new upstream release
258- built with openssl098
259- drop old (for 1.2.10) patches
260- Patch100-150 from FC8 package
261- Patch160-170 from upstream CVS (maybe will be fixed in 1.3.1)
262- update patch300 for 1.3.0
263- change configure option refer to FC8
264- add process reboot with message output when package is upgraded
265- docfiles list update
266- fix changelog ver number typo
267
268* Sun Sep 09 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.10-0vl6
269- add patch202 for fix timestamp (backport from 1.3.0rc1 #2798)
270  (<WISHES:15>)
271- add Vendor/Distribution tag
272- add patch104 for fix pr_ctrls_recv_request issue
273- add patch103 for fix CVE-2006-6170
274- add patch102 for fix CVE-2006-5815
275- add patch101 for fix CVE-2006-6171
276
277* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.10-0vl5
278- rebuilt with openldap-2.3.27-0vl
279
280* Sun Jul 02 2006 Satoshi MACHINO <machino@vinelinux.org> 1.2.10-0vl4
281- rebuilt with openldap-2.3.24-0vl1
282
283* Sun May 14 2006 Shoji Matsumoto <shom@vinelinux.org> 1.2.10-0vl3
284- add patch300 for iconv patch
285
286* Thu Mar 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl2
287- enable mod_ldap
288- add BuildRequires: openldap-devel, openssl-devel
289- add Patch200 from MDK to support ldap
290- add Patch201 from MDK to use system-auth instead of pam_pwdb
291  (pam_pwdb is now obsolete, and will be removed in the future pam version)
292
293* Fri Sep 09 2005 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
294- 1.2.10-0vl1.1
295- add patch100 for fix CAN-2005-2390
296
297* Sun Sep 05 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl1
298- new upstream release
299
300* Tue Aug 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl0.3
301- new upstream release (1.2.10rc3)
302- build for Vine Linux 3.0
303
304* Fri May 21 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.2.10-0vl0.1
305- new upstream release
306- fix security issue: http://secunia.com/advisories/11527/
307
308* Tue Apr 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.9-0vl1
309- new upstream release
310
311* Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8p-0vl1
312- new upstream release
313- fix security issue: http://xforce.iss.net/xforce/alerts/id/154
314
315* Sun Mar  9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl1
316- new upstream release
317
318* Fri Dec  6 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
319- new upstream release 1.2.7
320- add logrotate config file.
321- move ftp home directory from /home/ftp to /var/ftp
322
323* Mon Jun 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl1
324- new upstream release 1.2.6
325
326* Mon Jun 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl4
327- new upstream release 1.2.5 (stable release version)
328
329* Mon Jun 03 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl3
330- new upstream release 1.2.5-rc3
331
332* Mon Jan 28 2002 Toru Sagami <sagami@vinelinux.org> 1.2.5-0vl2
333- eliminate executable bit in %doc (requierment for /usr/bin/perl)
334- put files in sample-configurations/ to the according directory
335- remove unnecessary README.* files
336
337* Thu Dec 20 2001 Toru Sagami <sagami@vinelinux.org> 1.2.5-0vl1
338- updated to 1.2.5rc1 for problems in file globbing
339
340* Sun Oct 21 2001 Toru Sagami <sagami@vinelinux.org>
341- 1.2.4-0vl1
342
343* Fri Oct 19 2001 Toru Sagami <sagami@vinelinux.org>
344- 1.2.3-0vl1
345
346* Sat Aug 18 2001 Toru Sagami <sagami@vinelinux.org>
347- 1.2.2-0vl1: update to 1.2.2 release
348- added more documents
349
350* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl0.rc3
351- update to 1.2.2rc3
352- use macros
353
354* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
355- 1.2.1-0vl3
356- rebuilt for VineSeed
357
358* Tue Feb 27 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.1-0vl2]
359- update to 1.2.1
360
361* Tue Feb 27 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0-0vl2]
362- build for VineSeed
363
364* Tue Feb 27 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0-0vl1]
365- update to 1.2.0
366- set Epoch 1 to update from pre* and rc* version
367 
368* Tue Feb 20 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
369- 1.2.0rc3-0vl3
370- removed PreReq and postun about /etc/ftpusers stuff
371
372* Mon Feb 19 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc3-0vl3]
373- remove setup of /etc/ftpusers in %%pre script
374- add ftpusers.vine insted of the %%pre script
375- remove contrib/README.* frpm %%files
376- add BuildRequires: pam-devel
377
378* Mon Feb 19 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc3-0vl2]
379- rebuild for VineSeed
380
381* Wed Feb 07 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc3-0vl1]
382- update to 1.2.0rc3
383- add 'TimesGMT FALSE' in default configuration file
384- build on Vine 2.1
385
386* Mon Feb 05 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
387- modified pre script to make it run by bash2 and added PreReq
388- remove /etc/ftpusers after uninstall
389
390* Thu Feb 01 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
391- 1.2.0rc2-0vl8
392- rebuilt on VineSeed
393
394* Thu Feb 01 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc2-0vl7]
395- remove patch from CVS to avoid 'after 5min data brake'
396- add passive patch insted of abobe CVS patch
397- revival contribute's proftpd.init.d
398
399* Tue Jan 23 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc2-0vl6]
400- fixed %pre script and remove /etc/ftpusers from files
401- modify Japanese summary and descriptions
402
403* Sun Dec 03 2000 Toru Sagami <czs14350@mb.infoweb.ne.jp>
404- actually fixed to make the package relocatable.
405- non-root build failure by broken %prein, which should be %pre.
406- dont include CVS directory in doc
407- add %config /etc/rc.d/init.d/proftpd
408
409* Tue Nov 14 2000 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc2-0vl4]
410- correct config directive of the init.d script
411
412* Wed Oct 18 2000 Yoshihiro Kajiki <kajiki@ylug.org> [1.2.0rc2-0vl3]
413- adopt current patch from CVS to avoid the 'put on passive mode' probrem
414
415* Sun Jul 30 2000 Jun Nishii <jun@vinelinux.org>
416- 1.2.0rc2-0vl1
417- obsoletes anonftp
418- do not chkconfig --add in %post
419- requires: pam
420- added proftpd.vine.conf
421
422* Fri Jul 28 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
423- libtoolize for alpha
424
425* Sat Jul 15 2000 Kazuhisa TAKEI<takei@vinelinux.org>
426- [1.2.0rc2]
427
428* Wed Jun 28 2000 Kazuhisa TAKEI<takei@vinelinux.org>
429- repackaging for VineLinux
430
431* Thu Oct 3 1999 O.Elliyasa <osman@Cable.EU.org>
432- Multi package creation.
433  Created core, standalone, inetd (&doc) package creations.
434  Added startup script for init.d
435  Need to make the "standalone & inetd" packages being created as "noarch"
436- Added URL.
437- Added prefix to make the package relocatable.
438
439* Wed Sep 8 1999 O.Elliyasa <osman@Cable.EU.org>
440- Corrected inetd.conf line addition/change logic.
441
442* Sat Jul 24 1999 MacGyver <macgyver@tos.net>
443- Initial import of spec.
444
Note: See TracBrowser for help on using the repository browser.