source: projects/specs/branches/6/p/proftpd/proftpd-vl.spec @ 7259

Revision 7259, 13.8 KB checked in by iwaim, 12 years ago (diff)

proftpd-1.3.3e-2vl6

Line 
1%define _prefix         /usr
2%define _localstatedir  /var/run
3%define _sysconfdir     /etc
4%define _rundir         /var/run/proftpd
5%define tarballversion  1.3.3e
6%define origversion     1.3.3e
7
8Summary: ProFTPd -- Professional FTP Server.
9Summary(ja): ProFTPd -- プロフェッショナル FTP サーバ
10Name: proftpd
11Epoch: 1
12Version: %{origversion}
13Release: 2%{?_dist_release}
14License: GPL
15Group: System Environment/Daemons
16URL: http://www.proftpd.org/
17
18Source0: ftp://ftp.proftpd.org/distrib/%{name}-%{origversion}.tar.bz2
19Source1: proftpd.vine.conf
20Source2: ftpusers.vine
21Source3: proftpd.init
22Source5: welcome.msg
23
24# upstream bug fixes & security fixes
25
26# auth
27Patch201: proftpd-1.3.1-use-system-auth-instead-of-pam_pwdb.patch
28
29# iconv patch (CharsetLocal/CharsetRemote)
30# Patch300: http://www.hakusan.tsg.ne.jp/tjkawa/software/misc/proftpd-iconv/pack/proftpd-1.3.0-iconv.patch.gz
31Patch300: proftpd-1.3.3e-iconv.patch
32
33# fix build on recent kernel headers
34# Patch400: proftpd-1.3.1-umode.patch
35
36# security fix
37Patch1001: proftpd-1.3.3e-CVE-2011-4130.patch
38
39BuildRoot: %{_tmppath}/%{name}-%{version}-root
40BuildRequires: pam-devel, openldap-devel, openssl-devel
41BuildRequires: ncurses-devel, libcap-devel, libacl-devel
42BuildRequires: e2fsprogs-devel
43Requires: pam > 0.59
44Obsoletes: wu-ftpd, anonftp
45Provides: ftpserver
46
47Vendor: Project Vine
48Distribution: Vine Linux
49
50%description
51ProFTPd is an enhanced FTP server with a focus toward simplicity,
52security, and ease of configuration.  It features a very Apache-like
53configuration syntax, and a highly customizable server infrastructure,
54including support for multiple 'virtual' FTP servers, anonymous FTP,
55and permission-based directory visibility.
56
57%description -l ja
58ProFTPd は シンプルさ, セキュリティ, 設定の容易さに焦点をあてた 優れた
59FTP サーバです。Apache に似た構文による設定や、複数の仮想 FTP サーバ、
60anonymous FTP, パーミッションベースのディレクトリ可視性のサポートを含む、
61高度にカスタマイズ可能なサーバ・インターフェイスを特徴としています。
62
63%prep
64%setup -q -n %{name}-%{tarballversion}
65find . -type d -name CVS | xargs -r rm -frv
66
67# upstream fixes
68
69## patches from mdk
70# use system-auth instaed of pam_pwdb
71%patch201 -p1
72
73# iconv patch (CharsetLocal/CharsetRemote)
74%patch300 -p1
75
76# fix build on recent kernel headers
77# %patch400 -p0
78
79# security fixes
80%patch1001 -p1
81
82%build
83# Disable stripping in order to get useful debuginfo packages
84%{__perl} -pi -e 's|"-s"|""|g' configure
85
86%configure \
87    --libexecdir="%{_libexecdir}/proftpd" \
88    --localstatedir="%{_var}/run/proftpd" \
89    --enable-ctrls \
90    --enable-facl \
91    --enable-dso \
92    --enable-ipv6 \
93    --with-modules=mod_readme:mod_auth_pam:mod_tls:mod_codeconv:mod_df:\
94mod_ban:mod_dynmasq:mod_load:mod_ratio:mod_rewrite \
95    --with-shared=mod_ldap:mod_quotatab:mod_quotatab_file:mod_quotatab_ldap
96
97# It seems that with _smp_mflags -lsupp tries to get linked before being built
98# (as of 1.3.0a-4 F7/devel with koji, happened on F8 x86_64 and F7 ppc64)
99%{__make}
100
101
102%install
103%{__rm} -rf %{buildroot}
104%{__make} install DESTDIR=%{buildroot} \
105    rundir="%{_var}/run/proftpd" \
106    INSTALL_USER=`id -un` \
107    INSTALL_GROUP=`id -gn`
108
109# auth
110mkdir -p %{buildroot}%{_sysconfdir}/pam.d
111%{__install} -m 644 contrib/dist/rpm/ftp.pamd %{buildroot}%{_sysconfdir}/pam.d/ftp
112
113# logrotate
114mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d
115%{__install} -m 644 contrib/dist/rpm/proftpd.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/proftpd
116
117# init.d
118%{__install} -D -p -m 0755 %{SOURCE3} \
119    %{buildroot}%{_sysconfdir}/rc.d/init.d/proftpd
120
121%{__install} -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/proftpd.conf
122%{__install} -m 644 %{SOURCE2} %{buildroot}%{_sysconfdir}/ftpusers
123%{__install} -D -p -m 0644 %{SOURCE5} %{buildroot}/%{_var}/ftp/welcome.msg
124
125touch %{buildroot}%{_sysconfdir}/ftpusers
126
127rm contrib/README.* || :
128# eliminate executable bit in %doc
129find doc/ sample-configurations/ -type f -perm +111 | xargs -r chmod -x
130
131# remove .{la,a}
132rm -f %{buildroot}%{_libexecdir}/proftpd/*.{la,a}
133
134# remove development files (headers and pkgconfig file)
135# who need these files?
136rm -rf %{buildroot}%{_includedir}/proftpd
137rm -rf %{buildroot}%{_libdir}/pkgconfig
138
139%preun
140if [ -d %{_rundir} ] ; then
141        rm -rf %{_rundir}/*
142fi
143
144if [ $1 = 0 ] ; then
145        /sbin/chkconfig --del proftpd
146fi
147
148%postun
149if [ $1 -ge 1 ]; then
150    /sbin/service proftpd condrestart
151fi
152
153%post
154/sbin/chkconfig --add proftpd
155
156
157%clean
158rm -rf %{buildroot}
159
160%files
161%defattr(-,root,root)
162%doc COPYING CREDITS ChangeLog INSTALL NEWS
163%doc README.{LDAP,PAM,modules} doc/*
164%doc contrib/README contrib/xferstats.holger-preiss
165%doc sample-configurations/
166%{_sbindir}/*
167%{_bindir}/*
168%{_mandir}/*/*
169%{_var}/ftp/welcome.msg
170%dir %{_libexecdir}/proftpd/
171%{_libexecdir}/proftpd/mod_*
172%dir %{_rundir}
173%dir %{_var}/ftp
174%config %{_sysconfdir}/rc.d/init.d/proftpd
175%config(noreplace) %{_sysconfdir}/pam.d/ftp
176%config(noreplace) %{_sysconfdir}/proftpd.conf
177%config(noreplace) %{_sysconfdir}/ftpusers
178%config(noreplace) %{_sysconfdir}/logrotate.d/proftpd
179
180
181%changelog
182* Wed Dec 19 2012 IWAI, Masaharu <iwai@alib.jp> 1.3.3e-2
183- SECURITY FIX: CVE-2011-4130
184 - add CVE-2011-4130 patch (Patch1001): from Debian 1.3.3a-6squeeze4
185
186* Sun Apr 24 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.3e-1
187- new upstream release
188- update patch300 to fit new version
189- drop patch1000 (is included in new release)
190- add BR: e2fsprogs-devel
191
192* Wed Jan 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.2e-2
193- rebuild with openssl-1.0.0c
194
195* Fri Nov  5 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2e-1
196- new upstream release
197- add patch1000 for CVE-2010-4221 (TELNET_IAC)
198- add BRs: ncurses-devel, libcap-devel, libacl-devel
199
200* Mon Dec 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2c-1
201- new upstream release with security fix (CVE-2009-3555)
202
203* Wed Oct 21 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2b-1
204- new upstream release with security fix (NULL char in X.509 certificate)
205- add chkconfig --add in post script
206
207* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2a-3
208- remove .{la,a}
209- remove headers and pkgconfig file
210
211* Mon Jul  6 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2a-2
212- update Source1 (sample config file for vine)
213  set default char set to UTF-8
214
215* Fri Jul  3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2a-1
216- new upstream release
217
218* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-3
219- rebuild with openldap-2.4.11
220
221* Tue Mar 31 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2-2
222- built with openssl-0.9.8k
223
224* Sat Feb 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2-1
225- new upstream release
226- add configure option to activate new modules
227- drop patch400
228
229* Wed Jan 14 2009 Shu KONNO <owa@bg.wakwak.com> 1.3.1-6
230- built with openssl-0.9.8j
231
232* Mon Sep 22 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.1-5
233- built with openssl-0.9.8i
234
235* Sun Aug 10 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.1-4
236- add Patch400 to fix build failure at least on i386
237- spec in UTF-8
238
239* Tue Jul 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.1-3
240- built with openssl-0.9.8h
241
242* Sun Mar 23 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.1-2
243- update proftpd.vine.conf (use DisplayChdir instead of DisplayFirstChdir)
244
245* Sun Mar 23 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.1-1
246- new upstream release
247- drop old patches which are included in new release
248- update patch201, 300
249- build under new versioning policy
250
251* Mon Sep 10 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.0a-0vl1
252- new upstream release
253- built with openssl098
254- drop old (for 1.2.10) patches
255- Patch100-150 from FC8 package
256- Patch160-170 from upstream CVS (maybe will be fixed in 1.3.1)
257- update patch300 for 1.3.0
258- change configure option refer to FC8
259- add process reboot with message output when package is upgraded
260- docfiles list update
261- fix changelog ver number typo
262
263* Sun Sep 09 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.10-0vl6
264- add patch202 for fix timestamp (backport from 1.3.0rc1 #2798)
265  (<WISHES:15>)
266- add Vendor/Distribution tag
267- add patch104 for fix pr_ctrls_recv_request issue
268- add patch103 for fix CVE-2006-6170
269- add patch102 for fix CVE-2006-5815
270- add patch101 for fix CVE-2006-6171
271
272* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.10-0vl5
273- rebuilt with openldap-2.3.27-0vl
274
275* Sun Jul 02 2006 Satoshi MACHINO <machino@vinelinux.org> 1.2.10-0vl4
276- rebuilt with openldap-2.3.24-0vl1
277
278* Sun May 14 2006 Shoji Matsumoto <shom@vinelinux.org> 1.2.10-0vl3
279- add patch300 for iconv patch
280
281* Thu Mar 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl2
282- enable mod_ldap
283- add BuildRequires: openldap-devel, openssl-devel
284- add Patch200 from MDK to support ldap
285- add Patch201 from MDK to use system-auth instead of pam_pwdb
286  (pam_pwdb is now obsolete, and will be removed in the future pam version)
287
288* Fri Sep 09 2005 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
289- 1.2.10-0vl1.1
290- add patch100 for fix CAN-2005-2390
291
292* Sun Sep 05 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl1
293- new upstream release
294
295* Tue Aug 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl0.3
296- new upstream release (1.2.10rc3)
297- build for Vine Linux 3.0
298
299* Fri May 21 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.2.10-0vl0.1
300- new upstream release
301- fix security issue: http://secunia.com/advisories/11527/
302
303* Tue Apr 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.9-0vl1
304- new upstream release
305
306* Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8p-0vl1
307- new upstream release
308- fix security issue: http://xforce.iss.net/xforce/alerts/id/154
309
310* Sun Mar  9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl1
311- new upstream release
312
313* Fri Dec  6 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
314- new upstream release 1.2.7
315- add logrotate config file.
316- move ftp home directory from /home/ftp to /var/ftp
317
318* Mon Jun 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl1
319- new upstream release 1.2.6
320
321* Mon Jun 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl4
322- new upstream release 1.2.5 (stable release version)
323
324* Mon Jun 03 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl3
325- new upstream release 1.2.5-rc3
326
327* Mon Jan 28 2002 Toru Sagami <sagami@vinelinux.org> 1.2.5-0vl2
328- eliminate executable bit in %doc (requierment for /usr/bin/perl)
329- put files in sample-configurations/ to the according directory
330- remove unnecessary README.* files
331
332* Thu Dec 20 2001 Toru Sagami <sagami@vinelinux.org> 1.2.5-0vl1
333- updated to 1.2.5rc1 for problems in file globbing
334
335* Sun Oct 21 2001 Toru Sagami <sagami@vinelinux.org>
336- 1.2.4-0vl1
337
338* Fri Oct 19 2001 Toru Sagami <sagami@vinelinux.org>
339- 1.2.3-0vl1
340
341* Sat Aug 18 2001 Toru Sagami <sagami@vinelinux.org>
342- 1.2.2-0vl1: update to 1.2.2 release
343- added more documents
344
345* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl0.rc3
346- update to 1.2.2rc3
347- use macros
348
349* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
350- 1.2.1-0vl3
351- rebuilt for VineSeed
352
353* Tue Feb 27 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.1-0vl2]
354- update to 1.2.1
355
356* Tue Feb 27 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0-0vl2]
357- build for VineSeed
358
359* Tue Feb 27 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0-0vl1]
360- update to 1.2.0
361- set Epoch 1 to update from pre* and rc* version
362 
363* Tue Feb 20 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
364- 1.2.0rc3-0vl3
365- removed PreReq and postun about /etc/ftpusers stuff
366
367* Mon Feb 19 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc3-0vl3]
368- remove setup of /etc/ftpusers in %%pre script
369- add ftpusers.vine insted of the %%pre script
370- remove contrib/README.* frpm %%files
371- add BuildRequires: pam-devel
372
373* Mon Feb 19 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc3-0vl2]
374- rebuild for VineSeed
375
376* Wed Feb 07 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc3-0vl1]
377- update to 1.2.0rc3
378- add 'TimesGMT FALSE' in default configuration file
379- build on Vine 2.1
380
381* Mon Feb 05 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
382- modified pre script to make it run by bash2 and added PreReq
383- remove /etc/ftpusers after uninstall
384
385* Thu Feb 01 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
386- 1.2.0rc2-0vl8
387- rebuilt on VineSeed
388
389* Thu Feb 01 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc2-0vl7]
390- remove patch from CVS to avoid 'after 5min data brake'
391- add passive patch insted of abobe CVS patch
392- revival contribute's proftpd.init.d
393
394* Tue Jan 23 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc2-0vl6]
395- fixed %pre script and remove /etc/ftpusers from files
396- modify Japanese summary and descriptions
397
398* Sun Dec 03 2000 Toru Sagami <czs14350@mb.infoweb.ne.jp>
399- actually fixed to make the package relocatable.
400- non-root build failure by broken %prein, which should be %pre.
401- dont include CVS directory in doc
402- add %config /etc/rc.d/init.d/proftpd
403
404* Tue Nov 14 2000 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc2-0vl4]
405- correct config directive of the init.d script
406
407* Wed Oct 18 2000 Yoshihiro Kajiki <kajiki@ylug.org> [1.2.0rc2-0vl3]
408- adopt current patch from CVS to avoid the 'put on passive mode' probrem
409
410* Sun Jul 30 2000 Jun Nishii <jun@vinelinux.org>
411- 1.2.0rc2-0vl1
412- obsoletes anonftp
413- do not chkconfig --add in %post
414- requires: pam
415- added proftpd.vine.conf
416
417* Fri Jul 28 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
418- libtoolize for alpha
419
420* Sat Jul 15 2000 Kazuhisa TAKEI<takei@vinelinux.org>
421- [1.2.0rc2]
422
423* Wed Jun 28 2000 Kazuhisa TAKEI<takei@vinelinux.org>
424- repackaging for VineLinux
425
426* Thu Oct 3 1999 O.Elliyasa <osman@Cable.EU.org>
427- Multi package creation.
428  Created core, standalone, inetd (&doc) package creations.
429  Added startup script for init.d
430  Need to make the "standalone & inetd" packages being created as "noarch"
431- Added URL.
432- Added prefix to make the package relocatable.
433
434* Wed Sep 8 1999 O.Elliyasa <osman@Cable.EU.org>
435- Corrected inetd.conf line addition/change logic.
436
437* Sat Jul 24 1999 MacGyver <macgyver@tos.net>
438- Initial import of spec.
439
Note: See TracBrowser for help on using the repository browser.