source: projects/specs/branches/6/p/ppp/ppp-vl.spec @ 9025

Revision 9025, 10.3 KB checked in by iwamoto, 10 years ago (diff)

ppp: fix CVE-2014-3158

Line 
1Summary: The PPP (Point-to-Point Protocol) daemon.
2Summary(ja): PPP (Point-to-Point Protocol) デーモン
3Name: ppp
4Version: 2.4.5
5Release: 5%{?_dist_release}
6License: BSD and LGPLv2+ and GPLv2+ and Public Domain
7Group: System Environment/Daemons
8URL: http://www.samba.org/ppp
9
10Source0: ftp://ftp.samba.org/pub/ppp/ppp-%{version}.tar.gz
11Source1: ppp-2.4.4-pamd.conf
12Patch0: ppp-2.4.3-make.patch
13Patch1: ppp-2.3.6-sample.patch
14Patch2: ppp-2.4.2-libutil.patch
15Patch3: ppp-2.4.1-varargs.patch
16Patch4: ppp-2.4.4-lib64.patch
17Patch7: ppp-2.4.2-pie.patch
18Patch8: ppp-2.4.3-fix.patch
19Patch9: ppp-2.4.3-fix64.patch
20Patch11: ppp-2.4.2-change_resolv_conf.patch
21Patch13: ppp-2.4.4-no_strip.patch
22Patch17: ppp-2.4.2-pppoatm-make.patch
23Patch19: ppp-2.4.3-local.patch
24Patch20: ppp-2.4.3-ipv6-accept-remote.patch
25Patch21: ppp-2.4.3-usepeerdns-var_run_ppp_resolv.conf.patch
26Patch22: ppp-2.4.4-cbcp.patch
27Patch23: ppp-2.4.2-dontwriteetc.patch
28Patch24: ppp-2.4.4-fd_leak.patch
29Patch25: ppp-2.4.5-var_run_ppp.patch
30
31# security fix
32Patch100: ppp-2.4.x-CVE-2014-3158.patch
33
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35BuildRequires: libpcap >= 0.8.3, pam-devel
36#Requires: glibc >= 2.0.6, /etc/pam.d/system-auth
37Requires: glibc >= 2.0.6, pam >= 1.0
38
39Vendor: Project Vine
40Distribution: Vine Linux
41Packager: daisuke
42
43%description
44The ppp package contains the PPP (Point-to-Point Protocol) daemon and
45documentation for PPP support.  The PPP protocol provides a method for
46transmitting datagrams over serial point-to-point links. PPP is
47usually used to dial in to an ISP (Internet Service Provider) or other
48organization over a modem and phone line.
49
50%description -l ja
51ppp パッケージには PPP (Point-to-Point Protocol) デーモンと
52PPP を使う為のドキュメントが収められています.PPP プロトコルを
53使うとシリアルな point-to-point 接続上でデータグラムを転送する
54事が出来ます.この PPP は一般的には ISP (Internet Service Provider) 等に
55モデムを介した電話回線で接続する際に使われます.
56
57
58%package devel
59Summary: Headers for ppp plugin development
60SUmmary(ja): ppp プラグイン開発用ヘッダファイル
61Group: Development/Libraries
62
63%description devel
64This package contains the header files for building plugins for ppp.
65
66%description -l ja devel
67このパッケージには ppp のプラグインを開発するためのヘッダファイルが
68含まれています。
69
70%prep
71%setup  -q
72
73%patch0 -p1 -b .make
74%patch1 -p1 -b .sample
75%patch2 -p1 -b .libutil
76%patch3 -p1 -b .varargs
77%patch4 -p1 -b .lib64
78%patch7 -p1 -b .pie
79%patch8 -p1 -b .fix
80%patch9 -p1 -b .fix64
81%patch11 -p1 -b .change_resolv_conf
82%patch13 -p1 -b .no_strip
83%patch17 -p1 -b .atm-make
84%patch19 -p1 -b .local
85%patch20 -p1 -b .ipv6cp
86%patch21 -p1 -b .usepeerdns-var_run_ppp_resolv
87%patch22 -p1 -b .cbcp
88%patch23 -p1 -b .dontwriteetc
89%patch24 -p1 -b .fd_leak
90%patch25 -p1 -b .var_run_ppp
91
92# security fix
93%patch100 -p1 -b .CVE-2014-3158
94
95rm -f scripts/*.local
96rm -f scripts/*.change_resolv_conf
97rm -f scripts/*.usepeerdns-var_run_ppp_resolv
98rm -f scripts/*.ppp_resolv
99
100find . -type f -name "*.sample" | xargs rm -f
101
102rm -f include/linux/if_pppol2tp.h
103
104%build
105RPM_OPT_FLAGS="$RPM_OPT_FLAGS -fPIC -Wall"
106./configure
107make RPM_OPT_FLAGS="$RPM_OPT_FLAGS"
108
109
110%install
111[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
112export INSTROOT=$RPM_BUILD_ROOT
113%ifarch x86_64
114make install install-etcppp LIBDIR=$RPM_BUILD_ROOT%{_libdir}/pppd/%{version}
115%else
116make install install-etcppp
117%endif
118
119mv %{buildroot}/usr/var %{buildroot}/
120
121## it shouldn't be SUID root be default
122#chmod 755 %{buildroot}/usr/sbin/pppd
123
124chmod go+r scripts/*
125mkdir -p %{buildroot}/etc/pam.d
126install -m 644 %{SOURCE1} %{buildroot}/etc/pam.d/ppp
127
128mkdir -p %{buildroot}/etc/ppp
129cp etc.ppp/* %{buildroot}/etc/ppp
130chmod 600 %{buildroot}/etc/ppp/*-secrets
131
132mkdir -p %{buildroot}/etc/radiusclient
133cp pppd/plugins/radius/etc/* %{buildroot}/etc/radiusclient
134mv %{buildroot}/etc/radiusclient/radiusclient.conf %{buildroot}/etc/
135perl -pi -e 's|/usr/local||g' %{buildroot}/etc/radiusclient/radiusclient.conf
136
137find scripts -type f | xargs chmod 644
138
139%clean
140rm -rf %{buildroot}
141
142
143%files
144%defattr(-,root,root)
145%{_sbindir}/*
146%{_libdir}/pppd
147%{_mandir}/man8/chat.8*
148%{_mandir}/man8/pppd.8*
149%{_mandir}/man8/pppdump.8*
150%{_mandir}/man8/pppstats.8*
151%{_mandir}/man8/pppd-radattr.8*
152%{_mandir}/man8/pppd-radius.8*
153%dir /etc/ppp
154%config(noreplace) /etc/ppp/*
155%config(noreplace) /etc/pam.d/ppp
156%config(noreplace) /etc/radiusclient/*
157%config(noreplace) /etc/radiusclient.conf
158%doc README README.linux scripts sample
159%dir %{_localstatedir}/run/ppp
160%dir %{_localstatedir}/log/ppp
161
162%files devel
163%defattr(-,root,root)
164%{_includedir}/pppd
165%doc PLUGINS
166
167
168%changelog
169* Sun Oct 26 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.5-5
170- add patch100 for fix CVE-2014-3158
171
172* Tue Sep 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.5-4
173- added /var/run/ppp to %%files. (BTS:1215)
174- added /var/log/ppp to %%files.
175
176* Mon Apr 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-3
177- remove include/linux/if_pppol2tp.h to build pppoe plugin
178- update License tag
179
180* Fri Apr 08 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.5-2
181- rebuilt with new toolchain.
182
183* Mon Mar 08 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.5-1
184- new upstream release.
185- replaced all patches with Fedora's.
186- replaced 'BuildPreReq:' with 'BuildRequires:'.
187
188* Sun Aug 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-4
189- update pam.d/ppp to fix pam-1.0
190
191* Thu Aug 14 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.4-3
192- added option LIBDIR at makeinstall for x86_64
193
194* Thu Jul 31 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-2
195- add -devel subpackage to develop ppp plugins
196
197* Wed Jun 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.4-1
198- update Source1 for pam-1.0.1
199- import several patches from Fedora 2.4.4-7
200
201* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.4-0vl1
202- new upstream release
203- rebuilt with new toolchain and environment
204- added URL (also URL of Source0)
205
206* Fri Nov 17 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.4.3-0vl2
207- use License: instead of Copyright:
208
209* Mon Jan 24 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.4.3-0vl1
210- new upstream release.
211- replace patch0.
212
213* Wed Aug 11 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.4.2-0vl0
214- new upstream release.
215- remove patch 2-4 (no longer needed).
216
217* Sat Mar 15 2003 <ryo1@bc.wakwak.com> 2.4.1-0vl2
218- rebuild with new toolchains
219
220* Sun Jun 10 2001 <sagami@vinelinux.org>
221- 2.4.1-0vl1: update to 2.4.1
222
223* Thu Jan 25 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
224- 2.4.0-2vl1
225- based on 2.4.0-2 from Rawhide
226- added Japanese summary and description
227- Requires: /etc/pam.d/system-auth -> pam >= 0.72
228  (for better compatibility with apt for rpm)
229
230* Fri Dec  1 2000 Nalin Dahyabhai <nalin@redhat.com>
231- rebuild in new environment
232
233* Thu Nov  9 2000 Nalin Dahyabhai <nalin@redhat.com>
234- update to 2.4.0
235
236* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
237- automatic rebuild
238
239* Mon Jun  5 2000 Nalin Dahyabhai <nalin@redhat.com>
240- move man pages to %{_mandir}
241
242* Thu Jun  1 2000 Nalin Dahyabhai <nalin@redhat.com>
243- change perms using defattr
244- modify PAM setup to use system-auth
245
246* Sun Mar 26 2000 Florian La Roche <Florian.La Roche@redhat.com>
247- change to root:root perms
248
249* Mon Mar 06 2000 Nalin Dahyabhai <nalin@redhat.com>
250- reaper bugs verified as fixed
251- check pam_open_session result code (bug #9966)
252
253* Mon Feb 07 2000 Nalin Dahyabhai <nalin@redhat.com>
254- take a shot at the wrong reaper bugs (#8153, #5290)
255
256* Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
257- free ride through the build system (release 2)
258
259* Tue Jan 18 2000 Nalin Dahyabhai <nalin@redhat.com>
260- Update to 2.3.11
261
262* Sat Nov 06 1999 Michael K. Johnson <johnsonm@redhat.com>
263- Better fix for both problems
264
265* Fri Nov 05 1999 Michael K. Johnson <johnsonm@redhat.com>
266- fix for double-dial problem
267- fix for requiring a controlling terminal problem
268
269* Sun Sep 19 1999 Preston Brown <pbrown@redhat.com>
270- 2.3.10 bugfix release
271
272* Fri Aug 13 1999 Michael K. Johnson <johnsonm@redhat.com>
273- New version 2.3.9 required for kernel 2.3.13 and will be required
274  for new initscripts.  auth patch removed; 2.3.9 does the same thing
275  more readably than the previous patch.
276
277* Thu Jun 24 1999 Cristian Gafton <gafton@redhat.com>
278- add pppdump
279
280* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
281- force pppd use the glibc's logwtmp instead of implementing its own
282
283* Wed Apr 01 1999 Preston Brown <pbrown@redhat.com>
284- version 2.3.7 bugfix release
285
286* Tue Mar 23 1999 Cristian Gafton <gafton@redhat.com>
287- version 2.3.6
288
289* Mon Mar 22 1999 Michael Johnson <johnsonm@redhat.com>
290- auth patch
291
292* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
293- auto rebuild in the new build environment (release 3)
294
295* Thu Jan 07 1999 Cristian Gafton <gafton@redhat.com>
296- build for glibc 2.1
297
298* Fri Jun  5 1998 Jeff Johnson <jbj@redhat.com>
299- updated to 2.3.5.
300
301* Tue May 19 1998 Prospector System <bugs@redhat.com>
302- translations modified for de
303
304* Fri May  8 1998 Jakub Jelinek <jj@ultra.linux.cz>
305- make it run with kernels 2.1.100 and above.
306
307* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
308- translations modified for de, fr, tr
309
310* Wed Mar 18 1998 Cristian Gafton <gafton@redhat.com>
311- requires glibc 2.0.6 or later
312
313* Wed Mar 18 1998 Michael K. Johnson <johnsonm@redhat.com>
314- updated PAM patch to not turn off wtmp/utmp/syslog logging.
315
316* Wed Jan  7 1998 Cristian Gafton <gafton@redhat.com>
317- added the /etc/pam.d config file
318- updated PAM patch to include session support
319
320* Tue Jan  6 1998 Cristian Gafton <gafton@redhat.com>
321- updated to ppp-2.3.3, build against glibc-2.0.6 - previous patches not
322  required any more.
323- added buildroot
324- fixed the PAM support, which was really, completely broken and against any
325  standards (session support is still not here... :-( )
326- we build against running kernel and pray that it will work
327- added a samples patch; updated glibc patch
328
329* Thu Dec 18 1997 Erik Troan <ewt@redhat.com>
330- added a patch to use our own route.h, rather then glibc's (which has
331  alignment problems on Alpha's) -- I only applied this patch on the Alpha,
332  though it should be safe everywhere
333
334* Fri Oct 10 1997 Erik Troan <ewt@redhat.com>
335- turned off the execute bit for scripts in /usr/doc
336
337* Fri Jul 18 1997 Erik Troan <ewt@redhat.com>
338- built against glibc
339
340* Tue Mar 25 1997 Erik Troan <ewt@redhat.com>
341- Integrated new patch from David Mosberger
342- Improved description
343
Note: See TracBrowser for help on using the repository browser.