source: projects/specs/branches/6/p/ppp/ppp-vl.spec @ 9524

Revision 9524, 10.5 KB checked in by iwamoto, 9 years ago (diff)

ppp: fix CVE-2015-3310

Line 
1Summary: The PPP (Point-to-Point Protocol) daemon.
2Summary(ja): PPP (Point-to-Point Protocol) デーモン
3Name: ppp
4Version: 2.4.5
5Release: 6%{?_dist_release}
6License: BSD and LGPLv2+ and GPLv2+ and Public Domain
7Group: System Environment/Daemons
8URL: http://www.samba.org/ppp
9
10Source0: ftp://ftp.samba.org/pub/ppp/ppp-%{version}.tar.gz
11Source1: ppp-2.4.4-pamd.conf
12Patch0: ppp-2.4.3-make.patch
13Patch1: ppp-2.3.6-sample.patch
14Patch2: ppp-2.4.2-libutil.patch
15Patch3: ppp-2.4.1-varargs.patch
16Patch4: ppp-2.4.4-lib64.patch
17Patch7: ppp-2.4.2-pie.patch
18Patch8: ppp-2.4.3-fix.patch
19Patch9: ppp-2.4.3-fix64.patch
20Patch11: ppp-2.4.2-change_resolv_conf.patch
21Patch13: ppp-2.4.4-no_strip.patch
22Patch17: ppp-2.4.2-pppoatm-make.patch
23Patch19: ppp-2.4.3-local.patch
24Patch20: ppp-2.4.3-ipv6-accept-remote.patch
25Patch21: ppp-2.4.3-usepeerdns-var_run_ppp_resolv.conf.patch
26Patch22: ppp-2.4.4-cbcp.patch
27Patch23: ppp-2.4.2-dontwriteetc.patch
28Patch24: ppp-2.4.4-fd_leak.patch
29Patch25: ppp-2.4.5-var_run_ppp.patch
30
31# security fix
32Patch100: ppp-2.4.x-CVE-2014-3158.patch
33Patch110: ppp-2.4.5_CVE-2015-3310.patch
34
35BuildRoot: %{_tmppath}/%{name}-%{version}-root
36BuildRequires: libpcap >= 0.8.3, pam-devel
37#Requires: glibc >= 2.0.6, /etc/pam.d/system-auth
38Requires: glibc >= 2.0.6, pam >= 1.0
39
40Vendor: Project Vine
41Distribution: Vine Linux
42Packager: daisuke
43
44%description
45The ppp package contains the PPP (Point-to-Point Protocol) daemon and
46documentation for PPP support.  The PPP protocol provides a method for
47transmitting datagrams over serial point-to-point links. PPP is
48usually used to dial in to an ISP (Internet Service Provider) or other
49organization over a modem and phone line.
50
51%description -l ja
52ppp パッケージには PPP (Point-to-Point Protocol) デーモンと
53PPP を使う為のドキュメントが収められています.PPP プロトコルを
54使うとシリアルな point-to-point 接続上でデータグラムを転送する
55事が出来ます.この PPP は一般的には ISP (Internet Service Provider) 等に
56モデムを介した電話回線で接続する際に使われます.
57
58
59%package devel
60Summary: Headers for ppp plugin development
61SUmmary(ja): ppp プラグイン開発用ヘッダファイル
62Group: Development/Libraries
63
64%description devel
65This package contains the header files for building plugins for ppp.
66
67%description -l ja devel
68このパッケージには ppp のプラグインを開発するためのヘッダファイルが
69含まれています。
70
71%prep
72%setup  -q
73
74%patch0 -p1 -b .make
75%patch1 -p1 -b .sample
76%patch2 -p1 -b .libutil
77%patch3 -p1 -b .varargs
78%patch4 -p1 -b .lib64
79%patch7 -p1 -b .pie
80%patch8 -p1 -b .fix
81%patch9 -p1 -b .fix64
82%patch11 -p1 -b .change_resolv_conf
83%patch13 -p1 -b .no_strip
84%patch17 -p1 -b .atm-make
85%patch19 -p1 -b .local
86%patch20 -p1 -b .ipv6cp
87%patch21 -p1 -b .usepeerdns-var_run_ppp_resolv
88%patch22 -p1 -b .cbcp
89%patch23 -p1 -b .dontwriteetc
90%patch24 -p1 -b .fd_leak
91%patch25 -p1 -b .var_run_ppp
92
93# security fix
94%patch100 -p1 -b .CVE-2014-3158
95%patch110 -p1 -b .CVE-2015-3310
96
97rm -f scripts/*.local
98rm -f scripts/*.change_resolv_conf
99rm -f scripts/*.usepeerdns-var_run_ppp_resolv
100rm -f scripts/*.ppp_resolv
101
102find . -type f -name "*.sample" | xargs rm -f
103
104rm -f include/linux/if_pppol2tp.h
105
106%build
107RPM_OPT_FLAGS="$RPM_OPT_FLAGS -fPIC -Wall"
108./configure
109make RPM_OPT_FLAGS="$RPM_OPT_FLAGS"
110
111
112%install
113[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
114export INSTROOT=$RPM_BUILD_ROOT
115%ifarch x86_64
116make install install-etcppp LIBDIR=$RPM_BUILD_ROOT%{_libdir}/pppd/%{version}
117%else
118make install install-etcppp
119%endif
120
121mv %{buildroot}/usr/var %{buildroot}/
122
123## it shouldn't be SUID root be default
124#chmod 755 %{buildroot}/usr/sbin/pppd
125
126chmod go+r scripts/*
127mkdir -p %{buildroot}/etc/pam.d
128install -m 644 %{SOURCE1} %{buildroot}/etc/pam.d/ppp
129
130mkdir -p %{buildroot}/etc/ppp
131cp etc.ppp/* %{buildroot}/etc/ppp
132chmod 600 %{buildroot}/etc/ppp/*-secrets
133
134mkdir -p %{buildroot}/etc/radiusclient
135cp pppd/plugins/radius/etc/* %{buildroot}/etc/radiusclient
136mv %{buildroot}/etc/radiusclient/radiusclient.conf %{buildroot}/etc/
137perl -pi -e 's|/usr/local||g' %{buildroot}/etc/radiusclient/radiusclient.conf
138
139find scripts -type f | xargs chmod 644
140
141%clean
142rm -rf %{buildroot}
143
144
145%files
146%defattr(-,root,root)
147%{_sbindir}/*
148%{_libdir}/pppd
149%{_mandir}/man8/chat.8*
150%{_mandir}/man8/pppd.8*
151%{_mandir}/man8/pppdump.8*
152%{_mandir}/man8/pppstats.8*
153%{_mandir}/man8/pppd-radattr.8*
154%{_mandir}/man8/pppd-radius.8*
155%dir /etc/ppp
156%config(noreplace) /etc/ppp/*
157%config(noreplace) /etc/pam.d/ppp
158%config(noreplace) /etc/radiusclient/*
159%config(noreplace) /etc/radiusclient.conf
160%doc README README.linux scripts sample
161%dir %{_localstatedir}/run/ppp
162%dir %{_localstatedir}/log/ppp
163
164%files devel
165%defattr(-,root,root)
166%{_includedir}/pppd
167%doc PLUGINS
168
169
170%changelog
171* Fri Apr 17 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.5-6
172- add patch110 for fix CVE-2015-3310 (radius DoS)
173
174* Sun Oct 26 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.5-5
175- add patch100 for fix CVE-2014-3158
176
177* Tue Sep 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.5-4
178- added /var/run/ppp to %%files. (BTS:1215)
179- added /var/log/ppp to %%files.
180
181* Mon Apr 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-3
182- remove include/linux/if_pppol2tp.h to build pppoe plugin
183- update License tag
184
185* Fri Apr 08 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.5-2
186- rebuilt with new toolchain.
187
188* Mon Mar 08 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.5-1
189- new upstream release.
190- replaced all patches with Fedora's.
191- replaced 'BuildPreReq:' with 'BuildRequires:'.
192
193* Sun Aug 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-4
194- update pam.d/ppp to fix pam-1.0
195
196* Thu Aug 14 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.4-3
197- added option LIBDIR at makeinstall for x86_64
198
199* Thu Jul 31 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-2
200- add -devel subpackage to develop ppp plugins
201
202* Wed Jun 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.4-1
203- update Source1 for pam-1.0.1
204- import several patches from Fedora 2.4.4-7
205
206* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.4-0vl1
207- new upstream release
208- rebuilt with new toolchain and environment
209- added URL (also URL of Source0)
210
211* Fri Nov 17 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.4.3-0vl2
212- use License: instead of Copyright:
213
214* Mon Jan 24 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.4.3-0vl1
215- new upstream release.
216- replace patch0.
217
218* Wed Aug 11 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.4.2-0vl0
219- new upstream release.
220- remove patch 2-4 (no longer needed).
221
222* Sat Mar 15 2003 <ryo1@bc.wakwak.com> 2.4.1-0vl2
223- rebuild with new toolchains
224
225* Sun Jun 10 2001 <sagami@vinelinux.org>
226- 2.4.1-0vl1: update to 2.4.1
227
228* Thu Jan 25 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
229- 2.4.0-2vl1
230- based on 2.4.0-2 from Rawhide
231- added Japanese summary and description
232- Requires: /etc/pam.d/system-auth -> pam >= 0.72
233  (for better compatibility with apt for rpm)
234
235* Fri Dec  1 2000 Nalin Dahyabhai <nalin@redhat.com>
236- rebuild in new environment
237
238* Thu Nov  9 2000 Nalin Dahyabhai <nalin@redhat.com>
239- update to 2.4.0
240
241* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
242- automatic rebuild
243
244* Mon Jun  5 2000 Nalin Dahyabhai <nalin@redhat.com>
245- move man pages to %{_mandir}
246
247* Thu Jun  1 2000 Nalin Dahyabhai <nalin@redhat.com>
248- change perms using defattr
249- modify PAM setup to use system-auth
250
251* Sun Mar 26 2000 Florian La Roche <Florian.La Roche@redhat.com>
252- change to root:root perms
253
254* Mon Mar 06 2000 Nalin Dahyabhai <nalin@redhat.com>
255- reaper bugs verified as fixed
256- check pam_open_session result code (bug #9966)
257
258* Mon Feb 07 2000 Nalin Dahyabhai <nalin@redhat.com>
259- take a shot at the wrong reaper bugs (#8153, #5290)
260
261* Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
262- free ride through the build system (release 2)
263
264* Tue Jan 18 2000 Nalin Dahyabhai <nalin@redhat.com>
265- Update to 2.3.11
266
267* Sat Nov 06 1999 Michael K. Johnson <johnsonm@redhat.com>
268- Better fix for both problems
269
270* Fri Nov 05 1999 Michael K. Johnson <johnsonm@redhat.com>
271- fix for double-dial problem
272- fix for requiring a controlling terminal problem
273
274* Sun Sep 19 1999 Preston Brown <pbrown@redhat.com>
275- 2.3.10 bugfix release
276
277* Fri Aug 13 1999 Michael K. Johnson <johnsonm@redhat.com>
278- New version 2.3.9 required for kernel 2.3.13 and will be required
279  for new initscripts.  auth patch removed; 2.3.9 does the same thing
280  more readably than the previous patch.
281
282* Thu Jun 24 1999 Cristian Gafton <gafton@redhat.com>
283- add pppdump
284
285* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
286- force pppd use the glibc's logwtmp instead of implementing its own
287
288* Wed Apr 01 1999 Preston Brown <pbrown@redhat.com>
289- version 2.3.7 bugfix release
290
291* Tue Mar 23 1999 Cristian Gafton <gafton@redhat.com>
292- version 2.3.6
293
294* Mon Mar 22 1999 Michael Johnson <johnsonm@redhat.com>
295- auth patch
296
297* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
298- auto rebuild in the new build environment (release 3)
299
300* Thu Jan 07 1999 Cristian Gafton <gafton@redhat.com>
301- build for glibc 2.1
302
303* Fri Jun  5 1998 Jeff Johnson <jbj@redhat.com>
304- updated to 2.3.5.
305
306* Tue May 19 1998 Prospector System <bugs@redhat.com>
307- translations modified for de
308
309* Fri May  8 1998 Jakub Jelinek <jj@ultra.linux.cz>
310- make it run with kernels 2.1.100 and above.
311
312* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
313- translations modified for de, fr, tr
314
315* Wed Mar 18 1998 Cristian Gafton <gafton@redhat.com>
316- requires glibc 2.0.6 or later
317
318* Wed Mar 18 1998 Michael K. Johnson <johnsonm@redhat.com>
319- updated PAM patch to not turn off wtmp/utmp/syslog logging.
320
321* Wed Jan  7 1998 Cristian Gafton <gafton@redhat.com>
322- added the /etc/pam.d config file
323- updated PAM patch to include session support
324
325* Tue Jan  6 1998 Cristian Gafton <gafton@redhat.com>
326- updated to ppp-2.3.3, build against glibc-2.0.6 - previous patches not
327  required any more.
328- added buildroot
329- fixed the PAM support, which was really, completely broken and against any
330  standards (session support is still not here... :-( )
331- we build against running kernel and pray that it will work
332- added a samples patch; updated glibc patch
333
334* Thu Dec 18 1997 Erik Troan <ewt@redhat.com>
335- added a patch to use our own route.h, rather then glibc's (which has
336  alignment problems on Alpha's) -- I only applied this patch on the Alpha,
337  though it should be safe everywhere
338
339* Fri Oct 10 1997 Erik Troan <ewt@redhat.com>
340- turned off the execute bit for scripts in /usr/doc
341
342* Fri Jul 18 1997 Erik Troan <ewt@redhat.com>
343- built against glibc
344
345* Tue Mar 25 1997 Erik Troan <ewt@redhat.com>
346- Integrated new patch from David Mosberger
347- Improved description
348
Note: See TracBrowser for help on using the repository browser.