source: projects/specs/branches/6/p/popt/popt-vl.spec @ 3528

Revision 3528, 7.4 KB checked in by owa, 13 years ago (diff)

rebuilt

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2Summary:        C library for parsing command line parameters
3Summary(ja):    コマンドラインパラメータを文法解析するためのCライブラリ
4Name:           popt
5Version:        1.14
6Release:        5%{?_dist_release}
7License:        MIT
8Group:          System Environment/Libraries
9URL:            http://www.rpm5.org/
10Source0:        http://www.rpm5.org/files/%{name}/%{name}-%{version}.tar.gz
11BuildRequires:  gettext, doxygen, graphviz
12BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
13
14%description
15Popt is a C library for parsing command line parameters. Popt was
16heavily influenced by the getopt() and getopt_long() functions, but
17it improves on them by allowing more powerful argument expansion.
18Popt can parse arbitrary argv[] style arrays and automatically set
19variables based on command line arguments. Popt allows command line
20arguments to be aliased via configuration files and includes utility
21functions for parsing arbitrary strings into argv[] arrays using
22shell-like rules.
23
24%description -l ja
25Poptはコマンドパラメータを文法解析するためのCライブラリです。
26Poptは getopt()やgetopt_long()関数の影響を強く受けていますが、
27もっと強力な引数の拡張を施すことによって、それらをもっと進化
28させています。Poptは 任意の argv[]形式配列を解析して、コマンド
29ライン引数に基づいて変数を自動的に設定します。
30Poptは、コマンドライン引数を設定ファイルによってエイリアス化を
31許可したり、シェルライクな方針を用いた任意の文字列を文法解析し
32てargv[]配列に変換したりするユーティリティ関数を含んでいます。
33
34%package devel
35Summary:        Development files for the popt library
36Summary(ja):    popt ライブラリの開発ファイル
37Group:          Development/Libraries
38Requires:       %{name} = %{version}-%{release}
39
40%description devel
41The popt-devel package includes header files and libraries necessary
42for developing programs which use the popt C library. It contains the
43API documentation of the popt library, too.
44
45%package -n compat32-%{name}
46Summary: A C library for parsing command line parameters.
47Summary(ja): コマンドラインパラメータを文法解析するためのCライブラリ
48Group: Development/Libraries
49Requires: %{name} = %{version}-%{release}
50
51%description -n compat32-%{name}
52Popt is a C library for parsing command line parameters. Popt was
53heavily influenced by the getopt() and getopt_long() functions, but it
54improves on them by allowing more powerful argument expansion. Popt
55can parse arbitrary argv[] style arrays and automatically set
56variables based on command line arguments. Popt allows command line
57arguments to be aliased via configuration files and includes utility
58functions for parsing arbitrary strings into argv[] arrays using
59shell-like rules.
60
61%description -n compat32-%{name} -l ja
62Poptはコマンドパラメータを文法解析するためのCライブラリです。
63Poptは getopt()やgetopt_long()関数の影響を強く受けていますが、
64もっと強力な引数の拡張を施すことによって、それらをもっと進化
65させています。Poptは 任意の argv[]形式配列を解析して、コマンド
66ライン引数に基づいて変数を自動的に設定します。
67Poptは、コマンドライン引数を設定ファイルによってエイリアス化を
68許可したり、シェルライクな方針を用いた任意の文字列を文法解析し
69てargv[]配列に変換したりするユーティリティ関数を含んでいます。
70
71%package -n compat32-%{name}-devel
72Summary:        Development files for the popt library
73Summary(ja):    popt ライブラリの開発ファイル
74Group:          Development/Libraries
75Requires:       compat32-%{name} = %{version}-%{release}
76Requires:       %{name}-devel = %{version}-%{release}
77
78%description -n compat32-%{name}-devel
79The popt-devel package includes header files and libraries necessary
80for developing programs which use the popt C library. It contains the
81API documentation of the popt library, too.
82
83%prep
84%setup -q
85
86%build
87%configure --libdir=/%{_lib}
88make %{?_smp_mflags}
89doxygen
90
91%install
92rm -rf $RPM_BUILD_ROOT
93make DESTDIR=$RPM_BUILD_ROOT install
94
95# Move libpopt.{so,a} to %{_libdir}
96rm -f $RPM_BUILD_ROOT/%{_lib}/libpopt.{la,so}
97pushd $RPM_BUILD_ROOT/%{_lib}
98mkdir -p $RPM_BUILD_ROOT%{_libdir}
99ln -sf ../../%{_lib}/$(ls libpopt.so.?.?.?) $RPM_BUILD_ROOT%{_libdir}/libpopt.so
100popd
101mv -f $RPM_BUILD_ROOT/%{_lib}/libpopt.a $RPM_BUILD_ROOT%{_libdir}/libpopt.a
102
103# Multiple popt configurations are possible
104mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/popt.d
105
106%find_lang %{name}
107
108%clean
109rm -rf $RPM_BUILD_ROOT
110
111%post -p /sbin/ldconfig
112
113%postun -p /sbin/ldconfig
114
115%post -n compat32-%{name} -p /sbin/ldconfig
116
117%postun -n compat32-%{name} -p /sbin/ldconfig
118
119%files -f %{name}.lang
120%defattr(-,root,root)
121%doc CHANGES COPYING
122%{_sysconfdir}/popt.d
123/%{_lib}/libpopt.so.*
124
125%files devel
126%defattr(-,root,root)
127%doc README doxygen/html
128%{_libdir}/libpopt.so
129%{_libdir}/libpopt.a
130%{_includedir}/popt.h
131%{_mandir}/man3/popt.3*
132
133%if %{build_compat32}
134%files -n compat32-%{name}
135%defattr(-,root,root)
136/%{_lib}/libpopt.so.*
137
138%files -n compat32-%{name}-devel
139%defattr(-,root,root)
140%{_libdir}/libpopt.so
141%{_libdir}/libpopt.a
142%endif
143
144
145%changelog
146* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 1.14-5
147- rebuilt with rpm-4.8.1-3
148
149* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.14-4
150- rebuilt with new toolchain
151
152* Sun Jun 28 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.14-3
153- updated Requires: and %%files section on compat32 subpackages
154
155* Mon Jun 08 2009 Shu KONNO <owa@bg.wakwak.com> 1.14-2
156- added %%define build_compat32
157- fixed compat32 directories
158
159* Mon Aug 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14-1
160- initial build for Vine Linux
161  - splitted out from rpm, based on rpm5.org source.
162- move libpopt to /lib[64] from /usr/lib[64]
163  - initscripts-8 uses libpopt.
164
165* Sun May 25 2008 Robert Scheck <robert@fedoraproject.org> 1.13-4
166- Solved multilib problems at doxygen generated files (#342921)
167
168* Wed Feb 20 2008 Robert Scheck <robert@fedoraproject.org> 1.13-3
169- Revert the broken bind_textdomain_codeset() patch (#433324)
170
171* Thu Feb 14 2008 Robert Scheck <robert@fedoraproject.org> 1.13-2
172- Added patch to work around missing bind_textdomain_codeset()
173
174* Sun Dec 30 2007 Robert Scheck <robert@fedoraproject.org> 1.13-1
175- Upgrade to 1.13 (#290531, #332201, #425803)
176- Solved multilib problems at doxygen generated files (#342921)
177
178* Thu Aug 23 2007 Robert Scheck <robert@fedoraproject.org> 1.12-3
179- Added buildrequirement to graphviz (#249352)
180- Backported bugfixes from CVS (#102254, #135428 and #178413)
181
182* Sun Aug 12 2007 Robert Scheck <robert@fedoraproject.org> 1.12-2
183- Move libpopt to /lib[64] (#249814)
184- Generate API documentation, added buildrequirement to doxygen
185
186* Mon Jul 23 2007 Robert Scheck <robert@fedoraproject.org> 1.12-1
187- Changes to match with Fedora Packaging Guidelines (#249352)
188
189* Tue Jul 10 2007 Jeff Johnson <jbj@rpm5.org>
190- release popt-1.12 through rpm5.org.
191
192* Sat Jun  9 2007 Jeff Johnson <jbj@rpm5.org>
193- release popt-1.11 through rpm5.org.
194
195* Thu Dec 10 1998 Michael Johnson <johnsonm@redhat.com>
196- released 1.2.2; see CHANGES
197
198* Tue Nov 17 1998 Michael K. Johnson <johnsonm@redhat.com>
199- added man page to default install
200
201* Thu Oct 22 1998 Erik Troan <ewt@redhat.com>
202- see CHANGES file for 1.2
203
204* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
205- added ./configure step to spec file
Note: See TracBrowser for help on using the repository browser.