source: projects/specs/branches/6/p/podofo/podofo-vl.spec @ 1741

Revision 1741, 3.4 KB checked in by munepi, 14 years ago (diff)

NEW calibre: updated/added calibre's dependencies

Line 
1Name:           podofo
2Version:        0.8.1
3Release:        1%{?_dist_release}
4Summary:        Tools and libraries to work with the PDF file format
5
6Group:          Applications/Publishing
7License:        GPLv2+
8URL:            http://podofo.sourceforge.net
9Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
10Patch0:         %{name}-0.8.1-casts.patch
11BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
12
13BuildRequires:  cmake
14BuildRequires:  zlib-devel
15BuildRequires:  libjpeg-devel
16BuildRequires:  libtiff-devel
17BuildRequires:  libpng-devel
18BuildRequires:  freetype2-devel
19BuildRequires:  fontconfig-devel
20BuildRequires:  cppunit-devel
21BuildRequires:  lua-devel
22BuildRequires:  doxygen
23
24
25%description
26PoDoFo is a library to work with the PDF file format. The name comes from
27the first letter of PDF (Portable Document Format). A few tools to work
28with PDF files are already included in the PoDoFo package.
29
30The PoDoFo library is a free, portable C++ library which includes classes
31to parse PDF files and modify their contents into memory. The changes can be
32written back to disk easily. The parser can also be used to extract
33information from a PDF file (for example the parser could be used in a PDF
34viewer). Besides parsing PoDoFo includes also very simple classes to create
35your own PDF files. All classes are documented so it is easy to start writing
36your own application using PoDoFo.
37
38
39%package libs
40Summary:        Runtime library for %{name}
41Group:          System Environment/Libraries
42License:        LGPLv2+
43
44%description libs
45Runtime library for %{name}.
46
47
48%package devel
49Summary:        Development files for %{name} library
50Group:          Development/Libraries
51License:        LGPLv2+
52Requires:       %{name}-libs = %{version}-%{release}
53
54%description devel
55Development files and documentation for the %{name} library.
56
57
58%prep
59%setup -q
60%patch0 -p1 -b .casts
61
62
63%build
64%cmake -DPODOFO_BUILD_SHARED=1 \
65%ifarch x86_64 ppc64 s390x sparc64
66-DWANT_LIB64=1 \
67%endif
68.
69%__make %{?_smp_mflags}
70
71# build the docs
72doxygen
73
74# set timestamps on generated files to some constant
75find doc/html -exec touch -r %{SOURCE0} {} \;
76
77
78%install
79%__rm -rf $RPM_BUILD_ROOT
80%__make install DESTDIR=$RPM_BUILD_ROOT
81
82
83%clean
84%__rm -rf $RPM_BUILD_ROOT
85
86%post libs -p /sbin/ldconfig
87
88%postun libs -p /sbin/ldconfig
89
90
91%files
92%defattr(-,root,root,-)
93%doc COPYING
94%{_bindir}/%{name}*
95
96%files libs
97%defattr(-,root,root,-)
98%doc AUTHORS COPYING.LIB ChangeLog FAQ.html README.html TODO
99%{_libdir}/*.so.*
100
101%files devel
102%defattr(-,root,root,-)
103%doc doc/html
104%{_includedir}/%{name}
105%{_libdir}/*.so
106
107
108%changelog
109* Tue Aug 24 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.1-1
110- initial build based on Fedora development
111
112* Tue Jun  8 2010 Dan Horák <dan[at]danny.cz> 0.8.1-2
113- fix building tests
114
115* Mon Jun  7 2010 Dan Horák <dan[at]danny.cz> 0.8.1-1
116- updated to 0.8.1
117
118* Thu Apr 29 2010 Dan Horák <dan[at]danny.cz> 0.8.0-1
119- updated to 0.8.0
120
121* Tue Feb 16 2010 Dan Horák <dan[at]danny.cz> 0.7.0-4
122- set timestamp on generated docs (#565683)
123
124* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.0-3
125- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
126
127* Thu Apr 30 2009 Dan Horák <dan[at]danny.cz> 0.7.0-2
128- remove BR: openssl-devel, it could be required in the future (but then
129    an exception clause will be added to the licenses)
130- add missing doc files
131
132* Sun Mar 29 2009 Dan Horák <dan[at]danny.cz> 0.7.0-1
133- initial Fedora package
Note: See TracBrowser for help on using the repository browser.