source: projects/specs/trunk/p/podofo/podofo-vl.spec @ 12281

Revision 12281, 5.6 KB checked in by tomop, 5 years ago (diff)

updated 4 packages

hunspell-1.7.0-1

libtiff-4.0.10-2

msgpack-3.2.0-1

podofo-0.9.6-1

Line 
1Name:           podofo
2Version:        0.9.6
3Release:        1%{?_dist_release}
4Summary:        Tools and libraries to work with the PDF file format
5
6Group:          Applications/Publishing
7
8Vendor:         Project Vine
9Distribution:   Vine Linux
10
11License:        GPLv2+
12URL:            http://podofo.sourceforge.net
13Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
14
15# Fix failure to detect FreeType
16Patch0:         podofo-0.9.4-freetype.patch
17# Don't attempt to copy non-existing testdata dir
18Patch1:         podofo_tests.patch
19# Fix pkg-config file
20Patch2:         podofo_pkgconfig.patch
21
22# Backport patch for CVE-2018-5783
23# https://sourceforge.net/p/podofo/code/1949
24Patch10:        podofo_CVE-2018-5783.patch
25# Backport patch for CVE-2018-11254
26# https://sourceforge.net/p/podofo/code/1941
27Patch11:        podofo_CVE-2018-11254.patch
28# Backport patch for CVE-2018-11255
29# https://sourceforge.net/p/podofo/code/1952
30Patch12:        podofo_CVE-2018-11255.patch
31# Backport patch for CVE-2018-11256
32# https://sourceforge.net/p/podofo/code/1938
33Patch13:        podofo_CVE-2018-11256.patch
34# Backport patch for CVE-2018-12982
35# https://sourceforge.net/p/podofo/code/1948
36Patch14:        podofo_CVE-2018-12982.patch
37# Backport patch for CVE-2018-14320
38# https://sourceforge.net/p/podofo/code/1953
39Patch15:        podofo_CVE-2018-14320.patch
40# Backport patch for CVE-2018-19532
41# https://sourceforge.net/p/podofo/code/1950
42Patch16:        podofo_CVE-2018-19532.patch
43# Backport patch for CVE-2018-20751
44# https://sourceforge.net/p/podofo/code/1954
45Patch17:        podofo_CVE-2018-20751.patch
46# Backport patch for CVE-2019-9199
47# https://sourceforge.net/p/podofo/code/1971/
48Patch18:        podofo_CVE-2019-9199.patch
49# Backport patch for CVE-2019-9687
50# https://sourceforge.net/p/podofo/code/1969
51Patch19:        podofo_CVE-2019-9687.patch
52
53BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
54
55BuildRequires:  cmake
56BuildRequires:  zlib-devel
57BuildRequires:  libjpeg-turbo-devel
58BuildRequires:  libtiff-devel
59BuildRequires:  libpng-devel
60BuildRequires:  freetype2-devel
61BuildRequires:  fontconfig-devel
62BuildRequires:  cppunit-devel
63BuildRequires:  lua-devel
64BuildRequires:  doxygen
65
66
67%description
68PoDoFo is a library to work with the PDF file format. The name comes from
69the first letter of PDF (Portable Document Format). A few tools to work
70with PDF files are already included in the PoDoFo package.
71
72The PoDoFo library is a free, portable C++ library which includes classes
73to parse PDF files and modify their contents into memory. The changes can be
74written back to disk easily. The parser can also be used to extract
75information from a PDF file (for example the parser could be used in a PDF
76viewer). Besides parsing PoDoFo includes also very simple classes to create
77your own PDF files. All classes are documented so it is easy to start writing
78your own application using PoDoFo.
79
80
81%package libs
82Summary:        Runtime library for %{name}
83Group:          System Environment/Libraries
84License:        LGPLv2+
85
86%description libs
87Runtime library for %{name}.
88
89
90%package devel
91Summary:        Development files for %{name} library
92Group:          Development/Libraries
93License:        LGPLv2+
94Requires:       %{name}-libs = %{version}-%{release}
95
96%description devel
97Development files and documentation for the %{name} library.
98
99
100%prep
101%autosetup -p1
102
103# disable timestamps in docs
104echo "HTML_TIMESTAMP = NO" >> Doxyfile
105
106%build
107%cmake -DPODOFO_BUILD_SHARED=1 \
108%ifarch x86_64 ppc64 s390x sparc64
109-DWANT_LIB64=1 \
110%endif
111.
112%__make %{?_smp_mflags}
113
114# build the docs
115doxygen
116
117# set timestamps on generated files to some constant
118find doc/html -exec touch -r %{SOURCE0} {} \;
119
120
121%install
122%__rm -rf $RPM_BUILD_ROOT
123%__make install DESTDIR=$RPM_BUILD_ROOT
124
125
126%clean
127%__rm -rf $RPM_BUILD_ROOT
128
129%post libs -p /sbin/ldconfig
130
131%postun libs -p /sbin/ldconfig
132
133
134%files
135%defattr(-,root,root,-)
136%license COPYING
137%{_bindir}/%{name}*
138%{_mandir}/man1/%{name}*.1*
139
140%files libs
141%defattr(-,root,root,-)
142%license COPYING.LIB COPYING.exception
143%doc AUTHORS ChangeLog FAQ.html README.html TODO
144%{_libdir}/*.so.*
145
146%files devel
147%defattr(-,root,root,-)
148%doc doc/html examples
149%{_includedir}/%{name}
150%{_libdir}/*.so
151%{_libdir}/pkgconfig/*
152
153
154%changelog
155* Tue Oct 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.6-1
156- new upstream release.
157- dropped Patch0: fixed in upstream.
158- dropped Patch1.
159- imported Patch0-19 from rawhide.
160
161* Sat Jul 02 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.1-3
162- rebuild with gcc-5.4.0
163
164* Sat Sep 13 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.1-2
165- rebuilt with libpng-1.6.12
166- changed BuildRequires: libjpeg-devel to libjpeg-turbo-devel
167- added Patch1 from Fedora rawhide
168
169* Sun Mar 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
170- updated to 0.9.1
171
172* Tue Aug 24 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.1-1
173- initial build based on Fedora development
174
175* Tue Jun  8 2010 Dan Horák <dan[at]danny.cz> 0.8.1-2
176- fix building tests
177
178* Mon Jun  7 2010 Dan Horák <dan[at]danny.cz> 0.8.1-1
179- updated to 0.8.1
180
181* Thu Apr 29 2010 Dan Horák <dan[at]danny.cz> 0.8.0-1
182- updated to 0.8.0
183
184* Tue Feb 16 2010 Dan Horák <dan[at]danny.cz> 0.7.0-4
185- set timestamp on generated docs (#565683)
186
187* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.0-3
188- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
189
190* Thu Apr 30 2009 Dan Horák <dan[at]danny.cz> 0.7.0-2
191- remove BR: openssl-devel, it could be required in the future (but then
192    an exception clause will be added to the licenses)
193- add missing doc files
194
195* Sun Mar 29 2009 Dan Horák <dan[at]danny.cz> 0.7.0-1
196- initial Fedora package
Note: See TracBrowser for help on using the repository browser.