source: projects/specs/branches/6/p/perl-CGI-Application/perl-CGI-Application-vl.spec @ 3920

Revision 3920, 2.2 KB checked in by iwaim, 13 years ago (diff)

perl-CGI-Application-4.31-2

Line 
1Summary: Framework for building reusable web-applications
2Name: perl-CGI-Application
3Version: 4.31
4Release: 2%{?_dist_release}
5Group: Development/Libraries
6License: GPL or Artistic
7URL: http://search.cpan.org/~markstos/CGI-Application/
8Source0: http://search.cpan.org/CPAN/authors/id/M/MA/MARKSTOS/CGI-Application-%{version}.tar.gz
9
10BuildRoot: %{_tmppath}/%{name}-%{version}-root
11BuildArch: noarch
12BuildRequires: perl-HTML-Template
13Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
14
15Vendor: Project Vine
16Distribution: Vine Linux
17
18%description
19CGI::Application is intended to make it easier to create sophisticated,
20reusable web-based applications. This module implements a methodology which,
21if followed, will make your web software easier to design, easier to
22document, easier to write, and easier to evolve.
23
24%prep
25%setup -q -n CGI-Application-%{version}
26perldoc -t perlartistic > Artistic
27perldoc -t perlgpl > COPYING
28
29%build
30%{__perl} Makefile.PL INSTALLDIRS=vendor
31make
32
33%install
34rm -rf $RPM_BUILD_ROOT
35mkdir -p $RPM_BUILD_ROOT%{_prefix}
36make DESTDIR=$RPM_BUILD_ROOT install
37
38find $RPM_BUILD_ROOT%{_prefix} -type f -print |
39        sed "s@^$RPM_BUILD_ROOT@@g" |
40        grep -v ^%{_mandir} |
41        grep -v perllocal.pod |
42        grep -v "\.packlist" > %{name}.files
43if [ "$(cat %{name}.files)X" = "X" ] ; then
44    echo "ERROR: EMPTY FILE LIST"
45    exit -1
46fi
47
48perllocalfile=`find %{buildroot} -name perllocal.pod`
49echo "mv $perllocalfile ."
50mv $perllocalfile .
51
52%check
53make test
54
55%clean
56rm -rf $RPM_BUILD_ROOT
57
58%files -f %{name}.files
59%defattr(-,root,root,-)
60%doc Artistic COPYING Changes README perllocal.pod
61%dir %{perl_vendorlib}/CGI
62%dir %{perl_vendorlib}/CGI/Application
63%{_mandir}/man3/*.3*
64
65%changelog
66* Sun May 22 2011 IWAI, Masaharu <iwai@alib.jp> 4.31-2
67- build with perl 5.12.3
68- add Vendor and Distribution tags
69
70* Thu Nov 12 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.31-1
71- new upstream release
72
73* Mon Apr 28 2008 IWAI, Masaharu <iwaim@cc.mbn.or.jp> 4.06-1
74- rebuild with perl-5.10.0-1
75
76* Fri Feb 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.06-0vl1
77- updated to 4.06
78- changed Group to Development/Libraries
79
80* Fri Sep  9 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.03-0vl1
81- Initial package for Vine Linux (VineSeed Plus)
Note: See TracBrowser for help on using the repository browser.