source: projects/specs/trunk/p/perl-CGI-Application/perl-CGI-Application-vl.spec @ 521

Revision 521, 2.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Framework for building reusable web-applications
2Name: perl-CGI-Application
3Version: 4.31
4Release: 1%{?_dist_release}
5Group: Development/Libraries
6License: GPL or Artistic
7URL: http://search.cpan.org/~markstos/CGI-Application/
8Source0: http://search.cpan.org/CPAN/authors/id/M/MA/MARKSTOS/CGI-Application-%{version}.tar.gz
9
10BuildRoot: %{_tmppath}/%{name}-%{version}-root
11BuildArch: noarch
12BuildRequires: perl-HTML-Template
13Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
14
15%description
16CGI::Application is intended to make it easier to create sophisticated,
17reusable web-based applications. This module implements a methodology which,
18if followed, will make your web software easier to design, easier to
19document, easier to write, and easier to evolve.
20
21%prep
22%setup -q -n CGI-Application-%{version}
23perldoc -t perlartistic > Artistic
24perldoc -t perlgpl > COPYING
25
26%build
27%{__perl} Makefile.PL INSTALLDIRS=vendor
28make
29
30%install
31rm -rf $RPM_BUILD_ROOT
32mkdir -p $RPM_BUILD_ROOT%{_prefix}
33make DESTDIR=$RPM_BUILD_ROOT install
34
35find $RPM_BUILD_ROOT%{_prefix} -type f -print |
36        sed "s@^$RPM_BUILD_ROOT@@g" |
37        grep -v ^%{_mandir} |
38        grep -v perllocal.pod |
39        grep -v "\.packlist" > %{name}.files
40if [ "$(cat %{name}.files)X" = "X" ] ; then
41    echo "ERROR: EMPTY FILE LIST"
42    exit -1
43fi
44
45perllocalfile=`find %{buildroot} -name perllocal.pod`
46echo "mv $perllocalfile ."
47mv $perllocalfile .
48
49%check
50make test
51
52%clean
53rm -rf $RPM_BUILD_ROOT
54
55%files -f %{name}.files
56%defattr(-,root,root,-)
57%doc Artistic COPYING Changes README perllocal.pod
58%dir %{perl_vendorlib}/CGI
59%dir %{perl_vendorlib}/CGI/Application
60%{_mandir}/man3/*.3*
61
62%changelog
63* Thu Nov 12 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.31-1
64- new upstream release
65
66* Mon Apr 28 2008 IWAI, Masaharu <iwaim@cc.mbn.or.jp> 4.06-1
67- rebuild with perl-5.10.0-1
68
69* Fri Feb 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.06-0vl1
70- updated to 4.06
71- changed Group to Development/Libraries
72
73* Fri Sep  9 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.03-0vl1
74- Initial package for Vine Linux (VineSeed Plus)
Note: See TracBrowser for help on using the repository browser.