source: projects/specs/branches/6/o/openssl098/openssl098-vl.spec @ 9237

Revision 9237, 20.6 KB checked in by iwamoto, 9 years ago (diff)

openssl098: update to 0.9.8zd

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define soversion 6
3%define version 0.9.8zd
4%define release 1%{_dist_release}
5
6Summary: Secure Sockets Layer Toolkit
7Name: openssl098
8Version: %{version}
9Release: %{release}
10Source: openssl-%{version}.tar.gz
11Source2: Makefile.certificate
12Source3: ca-bundle.crt
13Source5: make-dummy-cert
14# Source6: openssl-%{version}.pc
15Patch0: openssl-0.9.8b-soversion.patch
16Patch2: openssl-0.9.8e-rpm_opt.patch
17Patch4: openssl-0.9.8p-enginesdir.patch
18
19# security fix
20# nothing ;-)
21
22License: BSDish
23Group: System Environment/Libraries
24URL: http://www.openssl.org/
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26BuildRequires: perl, sed
27Requires: mktemp
28Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
29Vendor: Project Vine
30Distribution: Vine Linux
31
32%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
33
34%description
35The OpenSSL certificate management tool and the shared libraries that
36provide various cryptographic algorithms and protocols.
37
38## to build compat32 for x86_64 architecture support
39%package -n compat32-%{name}
40Summary: Secure Sockets Layer Toolkit
41Group: System Environment/Libraries
42Requires: %{name} = %{version}-%{release}
43%description -n compat32-%{name}
44The OpenSSL certificate management tool and the shared libraries that
45provide various cryptographic algorithms and protocols.
46
47%prep
48%setup -q -n openssl-%{version}
49%patch0 -p1 -b .soversion
50%patch2 -p1 -b .rpm_opt
51%patch4 -p1 -b .enginesdir
52
53# security fix
54# nothing ;-)
55
56chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
57chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
58chmod 644 doc/openssl_button.html doc/openssl_button.gif
59chmod 644 doc/ssleay.txt
60
61# Link the configuration header to the one we're going to make.
62ln -sf ../../crypto/opensslconf.h include/openssl/
63
64%build
65PATH=${PATH}:${PWD}/bin
66TOPDIR=${PWD}
67LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
68
69# Figure out which flags we want to use.  Can't use assembler because it's
70# not lowest-common-denominator in most cases.
71perl util/perlpath.pl `dirname %{__perl}`
72%ifarch %ix86
73sslarch=linux-elf
74sslflags="no-asm 386"
75%endif
76%ifarch ppc
77sslarch=linux-ppc
78sslflags=no-asm
79%endif
80%ifarch sparc
81sslarch=linux-sparcv9
82sslflags=no-asm
83%endif
84%ifarch ia64
85sslarch=linux-ia64
86sslflags=no-asm
87%endif
88%ifarch alpha
89sslarch=linux-alpha-gcc
90sslflags=no-asm
91%endif
92%ifarch s390
93sslarch=linux-s390
94%endif
95%ifarch s390x
96sslarch=linux-s390x
97%endif
98%ifarch mipsel
99sslarch=linux-mips
100sslflags=no-asm
101%endif
102## to build for x86_64 architecture support
103%ifarch x86_64
104sslarch=linux-x86_64
105sslflags=no-asm
106%endif
107
108# Configure the build tree.  Override OpenSSL defaults with known-good defaults
109# usable on all platforms.  The Configure script already knows to use -fPIC and
110# RPM_OPT_FLAGS, so we can skip specifiying them here.
111./Configure  \
112         --prefix=%{_prefix} --openssldir=%{_datadir}/ssl ${sslflags} \
113         --enginesdir=%{_libdir}/openssl/engines \
114         shared ${sslarch}
115
116# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
117# marked as not requiring an executable stack.
118RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
119make depend
120make all build-shared
121
122# Generate hashes for the included certs.
123LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
124export LD_LIBRARY_PATH
125make rehash build-shared
126
127# Verify that what was compiled actually works.
128make -C test apps tests
129
130# Relink the main binary to get it dynamically linked.
131rm apps/openssl
132make all build-shared
133
134%install
135[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
136# Install OpenSSL.
137install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
138make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
139install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
140# added for lib64
141mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
142mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
143mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
144mv $RPM_BUILD_ROOT%{_datadir}/ssl/man/* $RPM_BUILD_ROOT%{_mandir}
145rmdir $RPM_BUILD_ROOT%{_datadir}/ssl/man
146rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
147for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
148        chmod 755 ${lib}
149        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
150        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
151done
152# install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
153
154# Install a makefile for generating keys and self-signed certs, and a script
155# for generating them on the fly.
156mkdir -p $RPM_BUILD_ROOT%{_datadir}/ssl/certs
157install -m644 $RPM_SOURCE_DIR/Makefile.certificate $RPM_BUILD_ROOT%{_datadir}/ssl/certs/Makefile
158install -m644 $RPM_SOURCE_DIR/make-dummy-cert      $RPM_BUILD_ROOT%{_datadir}/ssl/certs/make-dummy-cert
159
160# Make sure we actually include the headers we built against.
161for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
162        if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
163                install -m644 include/openssl/`basename ${header}` ${header}
164        fi
165done
166
167# Rename man pages so that they don't conflict with system man pages.  We used
168# to change the file extensions, but that only prevents file conflicts.  The
169# man viewer still can't select either of the two unless we physically change
170# the directory.
171for section in 1 2 3 4 5 6 7 8 ; do
172        if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
173                mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
174                   $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
175        fi
176done
177
178# Pick a CA script.
179pushd  $RPM_BUILD_ROOT%{_datadir}/ssl/misc
180mv CA.sh CA
181popd
182
183# Install root CA stuffs.
184cat %{SOURCE3} > ca-bundle.crt
185install -m644 ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/certs/
186ln -s certs/ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/cert.pem
187
188# Fix libdir.
189#sed 's,^libdir=${exec_prefix}/lib,libdir=${exec_prefix}/%{_lib},g' \
190# sed 's,^libdir=/usr/lib,libdir=%{_libdir},g' \
191#         $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc > \
192#         $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp && \
193# cat $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp > \
194#         $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc && \
195# rm -f $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp
196
197%clean
198[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
199
200%files
201%defattr(-,root,root)
202%doc FAQ LICENSE CHANGES NEWS INSTALL README
203%doc doc/README doc/c-indentation.el doc/openssl.txt
204%doc doc/openssl_button.html doc/openssl_button.gif
205%doc doc/ssleay.txt
206# %dir %{_datadir}/ssl
207# %{_datadir}/ssl/certs
208# %{_datadir}/ssl/cert.pem
209# %{_datadir}/ssl/misc/CA
210# %{_datadir}/ssl/misc/c_*
211# %{_datadir}/ssl/private
212# %config(noreplace) %{_datadir}/ssl/openssl.cnf
213
214# %attr(0755,root,root) %{_bindir}/openssl
215%attr(0755,root,root) /%{_lib}/*.so.*
216# %attr(0755,root,root) %{_libdir}/openssl/engines/*.so
217# %attr(0755,root,root) %dir %{_mandir}/man1*
218# %attr(0644,root,root) %{_mandir}/man1*/*
219# %attr(0755,root,root) %dir %{_mandir}/man5*
220# %attr(0644,root,root) %{_mandir}/man5*/*
221# %attr(0755,root,root) %dir %{_mandir}/man7*
222# %attr(0644,root,root) %{_mandir}/man7*/*
223
224## to build compat32 for x86_64 architecture support
225%if %{build_compat32}
226%files -n compat32-%{name}
227%defattr(-,root,root)
228%attr(0755,root,root) /%{_lib}/*.so.*
229%endif
230
231%post -p /sbin/ldconfig
232
233%postun -p /sbin/ldconfig
234
235%post -n compat32-%{name} -p /sbin/ldconfig
236
237%postun -n compat32-%{name} -p /sbin/ldconfig
238
239%changelog
240* Sat Jan 10 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8zd-1
241- new upstream release with security fix
242
243* Thu Oct 23 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8zc-1
244- new upstream release with security fix
245
246* Thu Aug  7 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8zb-1
247- new upstream release with security fix   
248
249* Sat Jun  7 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8za-1
250- new upstream release with security fix 
251
252* Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8r-1
253- new upstream release with security fix
254
255* Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
256- new upstream release with security fix
257- update patch4
258
259* Wed Mar 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8n-2
260- fix files list (unneeded files were included in package)
261
262* Tue Mar 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8n-1
263- new compatible package openssl 0.9.8n for upgrade openssl 1.0.0
264
265* Thu Mar 18 2010 IWAI, Masaharu <iwai@alib.jp> 0.9.8m-1
266- new upstream release
267- update enginsdir patch (Patch4)
268- drop unnecessary patch: upstream fixed
269  - dtls dos patch (Patch10)
270  - CVE-2009-4355 (memory leak) patch (Patch11)
271  - CVE-2009-3555 (renegotiation) patch (Patch12)
272- update SOURCE6 for pkgconfig
273- replace BuildPreReq to BuildRequires
274
275* Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
276- add patch12 for fix CVE-2009-3555 (renegotiation)
277
278* Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
279- add patch11 for fix CVE-2009-4355 (memory leak)
280
281* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
282- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
283
284* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
285- removed unnecessary %%if %{build_compat32} statements
286- removed lib*.a from devel package
287
288* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
289- new upstream release with security fix (CVE-2000-0590,0591,0789)
290
291* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
292- new upstream release with security fix (CVE-2008-5077)
293
294* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
295- new upstream release
296
297* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
298- new upstream release
299- new versioning policy
300
301* Fri Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
302- new upstream release
303- drop patch10,20 which is merged in upstream
304
305* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
306- add security patch in advance for CVE-2007-5135
307  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
308  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
309
310* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
311- add security patch for CVE-2007-3108
312  (http://openssl.org/news/patch-CVE-2007-3108.txt)
313
314* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
315- new upstream release
316
317* Sat Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
318- update (fix) openssl.pc <BTS:437>
319
320* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
321- new upstream release (with security fix)
322
323* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
324- new upstream release
325- add patch2 to use RPM_OPT macro
326
327* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
328- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
329
330* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
331- added compat32-* packages for x86_64 architecture support
332- added openssl-0.9.7i.Configure-compat32.patch
333- changed '/lib' to '/%{_lib}'
334
335* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
336- new upstream release
337
338* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
339- rebuild on VineSeed
340
341* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
342- added a security patch from Gentoo.
343  - Patch1: openssl-0.9.7c-tempfile.patch
344
345* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
346- sslarch for ppc was missing... added.
347
348* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
349- use sslarch=linux-alpha-gcc instead of alpha-gcc
350
351* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
352- new upstream version
353- clean up of spec file
354        -- removed old patches
355
356* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
357- new upstream release
358- SECURITY fix.
359  - http://www.openssl.org/news/secadv_20040317.txt
360
361* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
362- new upstream release
363- [Security fix]
364  - Vulnerabilities in ASN.1 parsing
365    http://www.openssl.org/news/secadv_20030930.txt
366- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
367
368* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
369- add openssl.pc for pkgconfig
370
371* Fri Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
372- New upstream version
373- dropped patch10, 11
374        -- merged upstream version
375
376* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
377- rebuild for VineSeed
378
379* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
380- [Security Fix]
381  - Timing-based attacks on RSA keys
382    http://www.openssl.org/news/secadv_20030317.txt
383  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
384    http://www.openssl.org/news/secadv_20030317.txt
385
386* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
387- new upstream release 0.9.6i
388- [Security Fix]
389- build for Vine Linux 2.6 errata
390
391* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
392- new upstream release 0.9.6h
393
394* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
395- new upstream release 0.9.6g
396
397* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
398- SECURITY: CAN-2002-0659 fixed
399  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
400    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
401    - update asn patch to fix accidental reversal of a logic check
402    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
403    - update asn patch to reduce chance that compiler optimization will remove
404      one of the added tests
405    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
406    - rebuild
407    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
408    - add patch to fix ASN.1 vulnerabilities
409
410* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
411- rename spec file name
412- SECURITY: CA-2002-23 fixed
413  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
414    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
415    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
416
417* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
418- added ${PATH} in LD_LIBRARY_PATH
419- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
420 
421* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
422- remove --no-<cipher>
423
424* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
425- add Patch10 for mipsel shared ( Configure )
426
427* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
428- build for Vine Linux
429- use openssl-engine-0.9.6b.tar.gz
430
431* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
432- update to 0.9.6b
433
434* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
435- move .so symlinks back to %%{_libdir}
436
437* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
438- move shared libraries to /lib (#38410)
439
440* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
441- switch to engine code base
442
443* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
444- add a script for creating dummy certificates
445- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
446
447* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
448- add s390x support
449
450* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
451- change two memcpy() calls to memmove()
452- don't define L_ENDIAN on alpha
453
454* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
455- make subpackages depend on the main package
456
457* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
458- adjust the hobble script to not disturb symlinks in include/ (fix from
459  Joe Orton)
460
461* Fri Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
462- drop the m2crypo patch we weren't using
463
464* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
465- configure using "shared" as well
466
467* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
468- update to 0.9.6a
469- use the build-shared target to build shared libraries
470- bump the soversion to 2 because we're no longer compatible with
471  our 0.9.5a packages or our 0.9.6 packages
472- drop the patch for making rsatest a no-op when rsa null support is used
473- put all man pages into <section>ssl instead of <section>
474- break the m2crypto modules into a separate package
475
476* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
477- use BN_LLONG on s390
478
479* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
480- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
481
482* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
483- move c_rehash to the perl subpackage, because it's a perl script now
484
485* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
486- update to 0.9.6
487- enable MD2
488- use the libcrypto.so and libssl.so targets to build shared libs with
489- bump the soversion to 1 because we're no longer compatible with any of
490  the various 0.9.5a packages circulating around, which provide lib*.so.0
491
492* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
493- change hobble-openssl for disabling MD2 again
494
495* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
496- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
497  bytes or so, causing EVP_DigestInit() to zero out stack variables in
498  apps built against a version of the library without it
499
500* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
501- disable some inline assembly, which on x86 is Pentium-specific
502- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
503
504* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
505- fix s390 patch
506
507* Fri Dec 8 2000 Than Ngo <than@redhat.com>
508- added support s390
509
510* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
511- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
512- add the CA.pl man page to the perl subpackage
513
514* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
515- always build with -mcpu=ev5 on alpha
516
517* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
518- add a symlink from cert.pem to ca-bundle.crt
519
520* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
521- add a ca-bundle file for packages like Samba to reference for CA certificates
522
523* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
524- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
525
526* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
527- add unzip as a buildprereq (#17662)
528- update m2crypto to 0.05-snap4
529
530* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
531- fix some issues in building when it's not installed
532
533* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
534- make sure the headers we include are the ones we built with (aaaaarrgh!)
535
536* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
537- add Richard Henderson's patch for BN on ia64
538- clean up the changelog
539
540* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
541- fix the building of python modules without openssl-devel already installed
542
543* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
544- byte-compile python extensions without the build-root
545- adjust the makefile to not remove temporary files (like .key files when
546  building .csr files) by marking them as .PRECIOUS
547
548* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
549- break out python extensions into a subpackage
550
551* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
552- tweak the makefile some more
553
554* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
555- disable MD2 support
556
557* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
558- disable MDC2 support
559
560* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
561- tweak the disabling of RC5, IDEA support
562- tweak the makefile
563
564* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
565- strip binaries and libraries
566- rework certificate makefile to have the right parts for Apache
567
568* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
569- use %%{_perl} instead of /usr/bin/perl
570- disable alpha until it passes its own test suite
571
572* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
573- move the passwd.1 man page out of the passwd package's way
574
575* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
576- update to 0.9.5a, modified for U.S.
577- add perl as a build-time requirement
578- move certificate makefile to another package
579- disable RC5, IDEA, RSA support
580- remove optimizations for now
581
582* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
583- Bero told me to move the Makefile into this package
584
585* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
586- add lib*.so symlinks to link dynamically against shared libs
587
588* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
589- update to 0.9.5
590- run ldconfig directly in post/postun
591- add FAQ
592
593* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
594- Fix build on non-x86 platforms
595
596* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
597- move /usr/share/ssl/* from -devel to main package
598
599* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
600- inital packaging
601- changes from base:
602  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
603  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.