source: projects/specs/branches/6/o/openssl098/openssl098-vl.spec @ 9863

Revision 9863, 20.9 KB checked in by iwamoto, 8 years ago (diff)

openssl098: update to 0.9.8zh

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define soversion 6
3%define version 0.9.8zh
4%define release 1%{_dist_release}
5
6Summary: Secure Sockets Layer Toolkit
7Name: openssl098
8Version: %{version}
9Release: %{release}
10Source: openssl-%{version}.tar.gz
11Source2: Makefile.certificate
12Source3: ca-bundle.crt
13Source5: make-dummy-cert
14# Source6: openssl-%{version}.pc
15Patch0: openssl-0.9.8b-soversion.patch
16Patch2: openssl-0.9.8e-rpm_opt.patch
17Patch4: openssl-0.9.8p-enginesdir.patch
18
19# security fix
20# nothing ;-)
21
22License: BSDish
23Group: System Environment/Libraries
24URL: http://www.openssl.org/
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26BuildRequires: perl, sed
27Requires: mktemp
28Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
29Vendor: Project Vine
30Distribution: Vine Linux
31
32%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
33
34%description
35The OpenSSL certificate management tool and the shared libraries that
36provide various cryptographic algorithms and protocols.
37
38## to build compat32 for x86_64 architecture support
39%package -n compat32-%{name}
40Summary: Secure Sockets Layer Toolkit
41Group: System Environment/Libraries
42Requires: %{name} = %{version}-%{release}
43%description -n compat32-%{name}
44The OpenSSL certificate management tool and the shared libraries that
45provide various cryptographic algorithms and protocols.
46
47%prep
48%setup -q -n openssl-%{version}
49%patch0 -p1 -b .soversion
50%patch2 -p1 -b .rpm_opt
51%patch4 -p1 -b .enginesdir
52
53# security fix
54# nothing ;-)
55
56chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
57chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
58chmod 644 doc/openssl_button.html doc/openssl_button.gif
59chmod 644 doc/ssleay.txt
60
61# Link the configuration header to the one we're going to make.
62# ln -sf ../../crypto/opensslconf.h include/openssl/
63
64%build
65PATH=${PATH}:${PWD}/bin
66TOPDIR=${PWD}
67LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
68
69# Figure out which flags we want to use.  Can't use assembler because it's
70# not lowest-common-denominator in most cases.
71perl util/perlpath.pl `dirname %{__perl}`
72%ifarch %ix86
73sslarch=linux-elf
74sslflags="no-asm 386"
75%endif
76%ifarch ppc
77sslarch=linux-ppc
78sslflags=no-asm
79%endif
80%ifarch sparc
81sslarch=linux-sparcv9
82sslflags=no-asm
83%endif
84%ifarch ia64
85sslarch=linux-ia64
86sslflags=no-asm
87%endif
88%ifarch alpha
89sslarch=linux-alpha-gcc
90sslflags=no-asm
91%endif
92%ifarch s390
93sslarch=linux-s390
94%endif
95%ifarch s390x
96sslarch=linux-s390x
97%endif
98%ifarch mipsel
99sslarch=linux-mips
100sslflags=no-asm
101%endif
102## to build for x86_64 architecture support
103%ifarch x86_64
104sslarch=linux-x86_64
105sslflags=no-asm
106%endif
107
108# Configure the build tree.  Override OpenSSL defaults with known-good defaults
109# usable on all platforms.  The Configure script already knows to use -fPIC and
110# RPM_OPT_FLAGS, so we can skip specifiying them here.
111./Configure  \
112         --prefix=%{_prefix} --openssldir=%{_datadir}/ssl ${sslflags} \
113         --enginesdir=%{_libdir}/openssl/engines \
114         shared ${sslarch}
115
116# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
117# marked as not requiring an executable stack.
118RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
119make depend
120make all build-shared
121
122# Generate hashes for the included certs.
123LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
124export LD_LIBRARY_PATH
125make rehash build-shared
126
127# Verify that what was compiled actually works.
128make -C test apps tests
129
130# Relink the main binary to get it dynamically linked.
131rm apps/openssl
132make all build-shared
133
134%install
135[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
136# Install OpenSSL.
137install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
138make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
139install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
140# added for lib64
141mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
142mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
143mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
144mv $RPM_BUILD_ROOT%{_datadir}/ssl/man/* $RPM_BUILD_ROOT%{_mandir}
145rmdir $RPM_BUILD_ROOT%{_datadir}/ssl/man
146rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
147for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
148        chmod 755 ${lib}
149        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
150        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
151done
152# install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
153
154# Install a makefile for generating keys and self-signed certs, and a script
155# for generating them on the fly.
156mkdir -p $RPM_BUILD_ROOT%{_datadir}/ssl/certs
157install -m644 $RPM_SOURCE_DIR/Makefile.certificate $RPM_BUILD_ROOT%{_datadir}/ssl/certs/Makefile
158install -m644 $RPM_SOURCE_DIR/make-dummy-cert      $RPM_BUILD_ROOT%{_datadir}/ssl/certs/make-dummy-cert
159
160# Make sure we actually include the headers we built against.
161for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
162        if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
163                install -m644 include/openssl/`basename ${header}` ${header}
164        fi
165done
166
167# Rename man pages so that they don't conflict with system man pages.  We used
168# to change the file extensions, but that only prevents file conflicts.  The
169# man viewer still can't select either of the two unless we physically change
170# the directory.
171for section in 1 2 3 4 5 6 7 8 ; do
172        if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
173                mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
174                   $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
175        fi
176done
177
178# Pick a CA script.
179pushd  $RPM_BUILD_ROOT%{_datadir}/ssl/misc
180mv CA.sh CA
181popd
182
183# Install root CA stuffs.
184cat %{SOURCE3} > ca-bundle.crt
185install -m644 ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/certs/
186ln -s certs/ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/cert.pem
187
188# Fix libdir.
189#sed 's,^libdir=${exec_prefix}/lib,libdir=${exec_prefix}/%{_lib},g' \
190# sed 's,^libdir=/usr/lib,libdir=%{_libdir},g' \
191#         $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc > \
192#         $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp && \
193# cat $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp > \
194#         $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc && \
195# rm -f $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp
196
197%clean
198[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
199
200%files
201%defattr(-,root,root)
202%doc FAQ LICENSE CHANGES NEWS INSTALL README
203%doc doc/README doc/c-indentation.el doc/openssl.txt
204%doc doc/openssl_button.html doc/openssl_button.gif
205%doc doc/ssleay.txt
206# %dir %{_datadir}/ssl
207# %{_datadir}/ssl/certs
208# %{_datadir}/ssl/cert.pem
209# %{_datadir}/ssl/misc/CA
210# %{_datadir}/ssl/misc/c_*
211# %{_datadir}/ssl/private
212# %config(noreplace) %{_datadir}/ssl/openssl.cnf
213
214# %attr(0755,root,root) %{_bindir}/openssl
215%attr(0755,root,root) /%{_lib}/*.so.*
216# %attr(0755,root,root) %{_libdir}/openssl/engines/*.so
217# %attr(0755,root,root) %dir %{_mandir}/man1*
218# %attr(0644,root,root) %{_mandir}/man1*/*
219# %attr(0755,root,root) %dir %{_mandir}/man5*
220# %attr(0644,root,root) %{_mandir}/man5*/*
221# %attr(0755,root,root) %dir %{_mandir}/man7*
222# %attr(0644,root,root) %{_mandir}/man7*/*
223
224## to build compat32 for x86_64 architecture support
225%if %{build_compat32}
226%files -n compat32-%{name}
227%defattr(-,root,root)
228%attr(0755,root,root) /%{_lib}/*.so.*
229%endif
230
231%post -p /sbin/ldconfig
232
233%postun -p /sbin/ldconfig
234
235%post -n compat32-%{name} -p /sbin/ldconfig
236
237%postun -n compat32-%{name} -p /sbin/ldconfig
238
239%changelog
240* Sun Dec  6 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8zh-1
241- new upstream release with security fix   
242
243* Mon Jun 15 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8zg-1
244- new upstream release with security fix 
245
246* Fri Mar 20 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8zf-1
247- new upstream release with security fix
248
249* Sat Jan 10 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8zd-1
250- new upstream release with security fix
251
252* Thu Oct 23 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8zc-1
253- new upstream release with security fix
254
255* Thu Aug  7 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8zb-1
256- new upstream release with security fix   
257
258* Sat Jun  7 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8za-1
259- new upstream release with security fix 
260
261* Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8r-1
262- new upstream release with security fix
263
264* Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
265- new upstream release with security fix
266- update patch4
267
268* Wed Mar 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8n-2
269- fix files list (unneeded files were included in package)
270
271* Tue Mar 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8n-1
272- new compatible package openssl 0.9.8n for upgrade openssl 1.0.0
273
274* Thu Mar 18 2010 IWAI, Masaharu <iwai@alib.jp> 0.9.8m-1
275- new upstream release
276- update enginsdir patch (Patch4)
277- drop unnecessary patch: upstream fixed
278  - dtls dos patch (Patch10)
279  - CVE-2009-4355 (memory leak) patch (Patch11)
280  - CVE-2009-3555 (renegotiation) patch (Patch12)
281- update SOURCE6 for pkgconfig
282- replace BuildPreReq to BuildRequires
283
284* Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
285- add patch12 for fix CVE-2009-3555 (renegotiation)
286
287* Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
288- add patch11 for fix CVE-2009-4355 (memory leak)
289
290* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
291- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
292
293* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
294- removed unnecessary %%if %{build_compat32} statements
295- removed lib*.a from devel package
296
297* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
298- new upstream release with security fix (CVE-2000-0590,0591,0789)
299
300* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
301- new upstream release with security fix (CVE-2008-5077)
302
303* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
304- new upstream release
305
306* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
307- new upstream release
308- new versioning policy
309
310* Fri Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
311- new upstream release
312- drop patch10,20 which is merged in upstream
313
314* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
315- add security patch in advance for CVE-2007-5135
316  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
317  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
318
319* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
320- add security patch for CVE-2007-3108
321  (http://openssl.org/news/patch-CVE-2007-3108.txt)
322
323* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
324- new upstream release
325
326* Sat Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
327- update (fix) openssl.pc <BTS:437>
328
329* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
330- new upstream release (with security fix)
331
332* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
333- new upstream release
334- add patch2 to use RPM_OPT macro
335
336* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
337- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
338
339* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
340- added compat32-* packages for x86_64 architecture support
341- added openssl-0.9.7i.Configure-compat32.patch
342- changed '/lib' to '/%{_lib}'
343
344* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
345- new upstream release
346
347* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
348- rebuild on VineSeed
349
350* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
351- added a security patch from Gentoo.
352  - Patch1: openssl-0.9.7c-tempfile.patch
353
354* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
355- sslarch for ppc was missing... added.
356
357* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
358- use sslarch=linux-alpha-gcc instead of alpha-gcc
359
360* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
361- new upstream version
362- clean up of spec file
363        -- removed old patches
364
365* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
366- new upstream release
367- SECURITY fix.
368  - http://www.openssl.org/news/secadv_20040317.txt
369
370* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
371- new upstream release
372- [Security fix]
373  - Vulnerabilities in ASN.1 parsing
374    http://www.openssl.org/news/secadv_20030930.txt
375- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
376
377* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
378- add openssl.pc for pkgconfig
379
380* Fri Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
381- New upstream version
382- dropped patch10, 11
383        -- merged upstream version
384
385* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
386- rebuild for VineSeed
387
388* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
389- [Security Fix]
390  - Timing-based attacks on RSA keys
391    http://www.openssl.org/news/secadv_20030317.txt
392  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
393    http://www.openssl.org/news/secadv_20030317.txt
394
395* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
396- new upstream release 0.9.6i
397- [Security Fix]
398- build for Vine Linux 2.6 errata
399
400* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
401- new upstream release 0.9.6h
402
403* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
404- new upstream release 0.9.6g
405
406* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
407- SECURITY: CAN-2002-0659 fixed
408  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
409    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
410    - update asn patch to fix accidental reversal of a logic check
411    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
412    - update asn patch to reduce chance that compiler optimization will remove
413      one of the added tests
414    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
415    - rebuild
416    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
417    - add patch to fix ASN.1 vulnerabilities
418
419* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
420- rename spec file name
421- SECURITY: CA-2002-23 fixed
422  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
423    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
424    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
425
426* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
427- added ${PATH} in LD_LIBRARY_PATH
428- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
429 
430* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
431- remove --no-<cipher>
432
433* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
434- add Patch10 for mipsel shared ( Configure )
435
436* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
437- build for Vine Linux
438- use openssl-engine-0.9.6b.tar.gz
439
440* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
441- update to 0.9.6b
442
443* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
444- move .so symlinks back to %%{_libdir}
445
446* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
447- move shared libraries to /lib (#38410)
448
449* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
450- switch to engine code base
451
452* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
453- add a script for creating dummy certificates
454- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
455
456* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
457- add s390x support
458
459* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
460- change two memcpy() calls to memmove()
461- don't define L_ENDIAN on alpha
462
463* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
464- make subpackages depend on the main package
465
466* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
467- adjust the hobble script to not disturb symlinks in include/ (fix from
468  Joe Orton)
469
470* Fri Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
471- drop the m2crypo patch we weren't using
472
473* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
474- configure using "shared" as well
475
476* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
477- update to 0.9.6a
478- use the build-shared target to build shared libraries
479- bump the soversion to 2 because we're no longer compatible with
480  our 0.9.5a packages or our 0.9.6 packages
481- drop the patch for making rsatest a no-op when rsa null support is used
482- put all man pages into <section>ssl instead of <section>
483- break the m2crypto modules into a separate package
484
485* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
486- use BN_LLONG on s390
487
488* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
489- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
490
491* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
492- move c_rehash to the perl subpackage, because it's a perl script now
493
494* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
495- update to 0.9.6
496- enable MD2
497- use the libcrypto.so and libssl.so targets to build shared libs with
498- bump the soversion to 1 because we're no longer compatible with any of
499  the various 0.9.5a packages circulating around, which provide lib*.so.0
500
501* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
502- change hobble-openssl for disabling MD2 again
503
504* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
505- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
506  bytes or so, causing EVP_DigestInit() to zero out stack variables in
507  apps built against a version of the library without it
508
509* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
510- disable some inline assembly, which on x86 is Pentium-specific
511- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
512
513* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
514- fix s390 patch
515
516* Fri Dec 8 2000 Than Ngo <than@redhat.com>
517- added support s390
518
519* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
520- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
521- add the CA.pl man page to the perl subpackage
522
523* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
524- always build with -mcpu=ev5 on alpha
525
526* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
527- add a symlink from cert.pem to ca-bundle.crt
528
529* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
530- add a ca-bundle file for packages like Samba to reference for CA certificates
531
532* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
533- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
534
535* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
536- add unzip as a buildprereq (#17662)
537- update m2crypto to 0.05-snap4
538
539* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
540- fix some issues in building when it's not installed
541
542* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
543- make sure the headers we include are the ones we built with (aaaaarrgh!)
544
545* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
546- add Richard Henderson's patch for BN on ia64
547- clean up the changelog
548
549* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
550- fix the building of python modules without openssl-devel already installed
551
552* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
553- byte-compile python extensions without the build-root
554- adjust the makefile to not remove temporary files (like .key files when
555  building .csr files) by marking them as .PRECIOUS
556
557* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
558- break out python extensions into a subpackage
559
560* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
561- tweak the makefile some more
562
563* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
564- disable MD2 support
565
566* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
567- disable MDC2 support
568
569* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
570- tweak the disabling of RC5, IDEA support
571- tweak the makefile
572
573* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
574- strip binaries and libraries
575- rework certificate makefile to have the right parts for Apache
576
577* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
578- use %%{_perl} instead of /usr/bin/perl
579- disable alpha until it passes its own test suite
580
581* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
582- move the passwd.1 man page out of the passwd package's way
583
584* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
585- update to 0.9.5a, modified for U.S.
586- add perl as a build-time requirement
587- move certificate makefile to another package
588- disable RC5, IDEA, RSA support
589- remove optimizations for now
590
591* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
592- Bero told me to move the Makefile into this package
593
594* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
595- add lib*.so symlinks to link dynamically against shared libs
596
597* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
598- update to 0.9.5
599- run ldconfig directly in post/postun
600- add FAQ
601
602* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
603- Fix build on non-x86 platforms
604
605* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
606- move /usr/share/ssl/* from -devel to main package
607
608* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
609- inital packaging
610- changes from base:
611  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
612  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.